14:01:45 <Sam-I-Am> #startmeeting docteam
14:01:46 <openstack> Meeting started Wed Jun 11 14:01:45 2014 UTC and is due to finish in 60 minutes.  The chair is Sam-I-Am. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:50 <openstack> The meeting name has been set to 'docteam'
14:01:55 <annegentle> thanks
14:02:06 <annegentle> Sam-I-Am started so I can leave early, my apologies but an appt. I can't miss.
14:02:09 <annegentle> Here's the agenda
14:02:19 <annegentle> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
14:02:20 <Sam-I-Am> i have it up...
14:02:36 <Sam-I-Am> #topic action items from last meeting
14:02:46 <annegentle> Let's review the action items
14:02:53 <dianefleming> good morning
14:02:53 <annegentle> both were Andreas's and he's out this week and next
14:02:57 <annegentle> morning dianefleming!
14:03:07 <annegentle> Andreas will streamline the Documentation/HowTo page
14:03:08 <Sam-I-Am> the last apac meeting mostly didnt happen, so this goes back to 5/21
14:03:18 <annegentle> and we're abandoning the separate writers guide
14:03:24 <annegentle> that's it for actions
14:03:44 <Sam-I-Am> #topic training team migration
14:03:46 <annegentle> Let's discus the Training team move to separate repo; looking for core reviewers
14:04:11 <annegentle> The repo is now set up since https://review.openstack.org/#/c/96334/8 merged
14:04:29 <annegentle> Next I'll propose the change to the governance repo to point to it under the Documentation Program
14:04:42 <berendt> i can support with reviewing the training guide
14:04:53 <annegentle> berendt: great!
14:04:57 <Sam-I-Am> sarob approched me about reviewing the training guide since it does/will reference parts of the installation guide
14:05:02 <annegentle> the repo is openstack/training-guides
14:05:18 <annegentle> Sam-I-Am: I'm encouraging them to use as much of it as possible
14:05:23 <Sam-I-Am> it makes sense
14:05:36 <annegentle> Phil and I are looking at scripted labs -- I like the idea very much
14:06:09 <annegentle> Sean (sarob) and I talked yesterday and I want to give the team time to get ramped up, but also ensure quality, by the Juno-2 milestone release
14:06:15 <annegentle> That's July 24th
14:06:19 <annegentle> (juno-1 is tomorrow)
14:06:27 <phil_h> I believe they are the way to go
14:06:28 <Sam-I-Am> wow, sosoon
14:06:40 <Sam-I-Am> feels like we just released!
14:06:41 <annegentle> the TC gives teams 2 milestone releases, so the July 24th date is simply a check in
14:06:55 <annegentle> I'd prefer that the training group focus on training deliverables -- the lab is a great example
14:07:13 <annegentle> my general sense is that the guides have quality issues but they are working towards our conventions and so on
14:07:21 <annegentle> I think they will also track their bugs separately
14:07:25 <annegentle> any questions?
14:08:03 <annegentle> The mailing list thread has the most indepth info
14:08:19 <annegentle> #link http://lists.openstack.org/pipermail/openstack-docs/2014-June/004572.html
14:08:28 <annegentle> Ok, next topic, Style questions: IBM Style Guide for core reviewers
14:08:39 <Sam-I-Am> #topic ibm style guide for core reviewers
14:08:57 <annegentle> I've sent emails to our current core except for Lorin who's not working on OpenStack anymore, boo hoo
14:09:04 <annegentle> You can either get a Kindle version or a paperbook
14:09:21 <annegentle> thing is, there are only 6 copies paperback available right now, so I'm working through the preferences and shipping
14:09:26 <annegentle> Will probably take me the rest of this week
14:09:34 <dianefleming> cool
14:09:42 <annegentle> The idea is, while reviewing, use the IBM Style Guide for anything that isn't covered in our Conventions page
14:09:47 <berendt> is it possible to get the kindle version for non-core reviewers?
14:09:55 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/Conventions
14:10:20 <annegentle> berendt: I couldn't find a way to "lend" but I can probably just get Rackspace to buy you one if you want
14:10:46 <annegentle> Seems useful for people who review often
14:11:07 <berendt> at least I try this so I think it would be useful to increase the quality of my reviews
14:11:38 <annegentle> Sam-I-Am: one thing I wondered is if the IBM style guide answered your last two questions to the mailing list?
14:11:40 <phil_h> Wish there was and easy way to get more copies
14:11:56 <annegentle> phil_h: it's not hard - if you want one I'll find you one
14:12:03 <Sam-I-Am> annegentle: i hadn't looked... i can do that.
14:12:09 <Sam-I-Am> the key is finding stuff
14:12:12 <phil_h> thanks
14:12:13 <annegentle> I've let the Rackspace editor know we won't need the Rackspace one
14:12:28 <annegentle> #action Anne to send IBM Style Guide Kindle to berendt
14:12:35 <annegentle> phil_h: do you want paperback or kindle version?
14:12:54 <dianefleming> @annegentle can you add a link on the conventions page to the kindle version?
14:13:00 <dianefleming> so anyone can get it?
14:13:09 <phil_h> kindle would be fine if I can use my android
14:13:19 <Sam-I-Am> i think there's a kindle reader app for most platforms
14:13:24 <phil_h> yes
14:13:26 <annegentle> #action Anne to send IBM Style Guide Kindle to phil_h
14:13:28 <annegentle> Yep
14:13:42 <annegentle> Ok, I'll keep working that list
14:13:44 <berendt> phil_h: https://play.google.com/store/apps/details?hl=en&id=com.amazon.kindle
14:13:49 <annegentle> Irony moment: buying from amazon. :)
14:13:53 <Sam-I-Am> lol
14:14:14 <annegentle> Ok, wanted to make sure everyone knows about the decisions on Debian install guide reviews
14:14:31 <Sam-I-Am> #topic debian install guide reviews
14:14:41 <Sam-I-Am> that was a fun thread
14:14:42 <annegentle> Oh and one other thing about IBM Style Guides, many RedHat writers already have it
14:15:09 <annegentle> Sounds like it's all resolved, I appreciate everyone's discussion on the list (and that I didn't have to break out of vacay mode) :)
14:15:11 <Sam-I-Am> i was thankfully away looking for housing for most of it... but i tried to sum it up with a happy conclusion
14:15:24 <annegentle> It seems like the reviews are going oka
14:15:25 <annegentle> okay
14:15:31 <Sam-I-Am> tom agreed with the two resolutions
14:15:34 <annegentle> and I guess he keeps the screenshots?
14:15:46 <annegentle> I was just trying to make sure I know how to review, also
14:15:58 <annegentle> seems like we add zaro (Thomas Goirand) to those patches as reviewer
14:15:59 <dianefleming> screenshots = no good!
14:16:02 <Sam-I-Am> for now, yes... but there will be more 'translatable' information surrounding the screen shots
14:16:19 <Sam-I-Am> annegentle: yes, he gets tagged in debian-affecting patches (like most of the install guide improvements)
14:16:33 <Sam-I-Am> whether or not he wants to do his stuff as separate patches is his choice
14:16:43 <Sam-I-Am> right now i'm trying to leave the debian stuff as-is as much as possible
14:17:09 <annegentle> Okay
14:18:05 <annegentle> The Mailing List thread crossed the May/June boundary, but I think it's all wrapped up here
14:18:07 <annegentle> #link http://lists.openstack.org/pipermail/openstack-docs/2014-June/004563.html
14:18:22 <annegentle> Any questions?
14:18:41 <gpocentek> just a correction, Thomas'  nick is zigo ;)
14:18:49 <annegentle> gpocentek: ha! Thanks!
14:18:58 <Sam-I-Am> somewhere in that is the conclusion of the thread
14:19:02 <zigo> gpocentek: And I'm around! :)
14:19:06 <annegentle> That's right, zaro is... now I forget!
14:19:10 <annegentle> zigo: hiya!
14:19:17 <zigo> annegentle: Hello! :)
14:19:26 <Sam-I-Am> #link http://lists.openstack.org/pipermail/openstack-docs/2014-June/004579.html
14:19:28 <annegentle> zigo: Any remaining concerns about Debian and install?
14:19:30 <Sam-I-Am> thats the summary
14:19:45 <zigo> annegentle: Well, I still got some remaining patch review not done.
14:19:53 <annegentle> thanks Sam-I-Am
14:20:16 <annegentle> zigo: ok yep
14:20:18 <annegentle> #link https://review.openstack.org/#/c/98329/
14:20:23 <annegentle> That one needs review
14:20:32 <zigo> https://review.openstack.org/97158, https://review.openstack.org/96687, https://review.openstack.org/98329
14:20:34 <annegentle> Ah, and a rebase
14:20:41 <Sam-I-Am> yeah, a rebase...
14:20:46 <Sam-I-Am> the qm/mq thing
14:20:46 <zigo> Yeah, will work on that.
14:20:52 <annegentle> Ok, I'll also add those links to this week's What's Up Doc so people can take a look
14:21:02 <zigo> Plus I need to explicitely write what some debconf screen do in the directives, but that's going to be later on.
14:21:04 <annegentle> zigo: anything else you can think of? Thanks for the discussion
14:21:27 <zigo> That's going to be within each service chapters...
14:21:41 <zigo> Like for example, the core_plugin directive in Neutron, etc.
14:21:56 <Sam-I-Am> zigo: to avoid patch collisions, for the larger 'install guide updates' patches... do you want to edit the big patch, or upload another patch after approval to handle the debian stuff?
14:22:20 <zigo> I'm trying to get my patches as small and incremental as possible, yeah.
14:22:32 <Sam-I-Am> ok, so sounds like a separate patch later then
14:22:36 <Sam-I-Am> can you tag me in your patches
14:22:49 <zigo> You mean add you for the review? I will, thanks.
14:22:52 <Sam-I-Am> yeah
14:22:58 <annegentle> sounds good
14:22:59 <zigo> https://review.openstack.org/97158 <--- For that one, I'm not sure how to handle it.
14:23:19 <zigo> No, not that one, hang on.
14:23:22 <Sam-I-Am> and we'll tag you in the 'big' install guide update patches, but mainly just to make sure we didn't completely break the debian stuff. you'll do your improvements in a later patch.
14:23:30 <annegentle> zigo: ah we might need to ask sgordon to look again?
14:24:10 <zigo> That one: https://review.openstack.org/#/c/96687/
14:24:23 <zigo> Andreas wrote (rightfully) that there was some redundancy.
14:24:30 <zigo> And that I wrote 3 times the same thing.
14:24:40 <annegentle> zigo: he's good at spotting inefficiency :)
14:24:43 <Sam-I-Am> i think 97158 is pre-conclusion of that e-mail thread
14:24:44 <zigo> I agree, though it was like that previously, it just shows more now ...
14:24:47 <zigo> So I wonder how to fix.
14:25:00 <zigo> Probably first remove the redundancy everywhere first?
14:25:24 <annegentle> Sam-I-Am: agreed on 97158
14:25:27 <Sam-I-Am> i'd need to look closer at the patch
14:25:51 <annegentle> zigo: for the redundant, is it really just the screenshot that's unique to debian?
14:25:53 <Sam-I-Am> zigo: my suggestion is, for the most common debian stuff, provide a 'flagship' patch that sets the tone for all other patches
14:26:15 <Sam-I-Am> then you can use it as a template for the other patches
14:26:16 <zigo> annegentle: That's my point, I replaced something redundant by something else (redundant screenshots).
14:26:23 <annegentle> zigo: ah :)
14:27:06 <zigo> And I'm really not sure how to remove the redundancy then ...
14:27:25 <zigo> Create another section, and refer to it at the 3 places?
14:27:28 <zigo> (with a link)
14:27:51 <berendt> why not working with includes for the moment?
14:28:11 <annegentle> zigo: I'll comment in the patch itself
14:28:22 <zigo> Thanks! :)
14:28:32 <zigo> I don't need an answer right now...
14:28:40 <annegentle> berendt: zigo: includes might work, but basically you do the same thing on all three nodes?
14:29:03 <annegentle> (thing=same configuration of networking)
14:29:10 <annegentle> ah precision with language
14:29:15 <Sam-I-Am> the nodes are mostly the same
14:29:27 <annegentle> Ok maybe we can get to one more topic before I have to leave? Do comment in reviews.
14:29:34 <Sam-I-Am> at least for neutron.conf
14:29:37 <Sam-I-Am> sure
14:29:45 <annegentle> I think it was berendt who asked about how to make the Glossary alphabet headers list in a TOC?
14:29:53 <Sam-I-Am> oh, there was one thing before that
14:29:56 <Sam-I-Am> but we can hit that topic
14:29:58 <annegentle> oh yes
14:30:22 <Sam-I-Am> #topic how to make glossary alphabet headers list in a toc
14:30:23 <annegentle> Just going to say, I talked to David Cramer and yes it can be changed in the XSLT
14:30:51 <annegentle> berendt: I asked him to write back on the list, it's either webhelp.xsl or docbook.xsl that has the logic
14:31:01 <annegentle> and... I'd better go so I'm not late to the eye doc... thanks Sam-I-Am!
14:31:07 <annegentle> and thanks all for joining!
14:31:09 <Sam-I-Am> have fun!
14:31:16 <berendt> I had a short look but not yet the time to work on the glossary
14:31:19 <Sam-I-Am> we'll hit the last topic here...
14:31:53 <Sam-I-Am> #topic review change options automation
14:31:59 <Sam-I-Am> #link https://review.openstack.org/#/c/97621/
14:32:39 <gpocentek> more eyes of this patch would be nice
14:32:41 <Sam-I-Am> i suspect we should take a look at that patch
14:33:21 <gpocentek> Andreas suggested another way to deal with changed options but it will be more tricky to handle
14:33:23 <berendt> https://review.openstack.org/#/c/97620/ is not yet merged
14:34:09 <gpocentek> berendt: reviews on the output will help fix/modify the code
14:35:56 <Sam-I-Am> anything else here?
14:36:22 <Sam-I-Am> #topic open discussion
14:36:49 <Sam-I-Am> a few things going on here. i completed a havana-to-icehouse upgrade on rhel yesterday, so will be working on a patch to the ops guide
14:37:10 <Sam-I-Am> also, i'm moving and starting a new job so i might go dark for a bit starting in a couple of days
14:37:42 <phil_h> I have both linuxbrige working with OVS on different nodes and I see a couple of doc bugs that I need to file
14:37:44 <gpocentek> congrats on the new job :)
14:37:56 <phil_h> We are happy to get him
14:38:09 <gpocentek> oh, new job at rackspace?
14:38:11 <Sam-I-Am> yup
14:38:16 <gpocentek> awesome!
14:38:40 <Sam-I-Am> gonna try to get these few install guide patches through before i disappear for a bit
14:38:45 <dianefleming> @Sam-I-Am CONGRATS!!
14:38:54 <Sam-I-Am> the ops guide patch... maybe.
14:39:50 <Sam-I-Am> aight, anything else?
14:41:02 <Sam-I-Am> guess we're done here
14:41:06 <Sam-I-Am> thanks everyone
14:41:11 <Sam-I-Am> #endmeeting