14:02:54 <annegentle> #startmeeting docteam
14:02:54 <openstack> Meeting started Thu Sep 25 14:02:54 2014 UTC and is due to finish in 60 minutes. The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:58 <openstack> The meeting name has been set to 'docteam'
14:03:11 <annegentle> I know that Lana's here in the states but they had a big release today
14:03:26 <annegentle> So it has been a while since we met last, let me pull up the old action items
14:03:28 <annegentle> see how stale they are
14:03:37 <annegentle> #topic Action items from the last meeting
14:03:54 <annegentle> no action items!
14:03:56 <annegentle> it's a good day
14:04:04 <nickchase> hey, that's all good. :)
14:04:06 <annegentle> #topic Networking Guide status
14:04:12 <annegentle> cool, we'll keep moving
14:04:24 <annegentle> I think (but need to check) everything from the swarm has landed
14:05:01 <nickchase> I was under the impression that there were a couple of patches hanging out there, but yes, we nee dot check.
14:05:53 <annegentle> I think there's still plenty of lorem ipsum
14:06:14 <annegentle> but there's no remaining reviews
14:06:17 <nickchase> yes
14:06:28 <nickchase> well, Elke will be here momentarily
14:06:33 <annegentle> Elke is starting on that, nickchase? Cool
14:06:36 <nickchase> yes.
14:06:57 <annegentle> nickchase: you're taking care of onboarding and all, right? Anything you need me to do for the networking guide specifically?
14:07:19 <nickchase> yes I ma, and no, I don't think so.
14:07:26 <annegentle> cool
14:07:44 <annegentle> I think we just need a minimum viable book to publish
14:08:15 <annegentle> #link http://specs.openstack.org/openstack/docs-specs/specs/juno/create-networking-guide.html
14:08:43 <nickchase> right, I agree.
14:08:48 <annegentle> Looking at the spec, I think it is bare minimum already, so that's our goal.
14:09:03 <nickchase> yes, so that's good.
14:09:07 <annegentle> (maybe not "bare" minimum, but I just want to point out the goal)
14:09:13 <nickchase> :) Yes.
14:09:22 <nickchase> We'll have something reasonable to publish.
14:09:32 <annegentle> yeah
14:09:35 <annegentle> Oct. 16th looms
14:09:36 <annegentle> :)
14:09:51 <annegentle> anything else on networking guide? Matt and Phil are both neck-deep in release too
14:09:59 <annegentle> I know Matt wants to circle back to it
14:09:59 <nickchase> No
14:10:06 <annegentle> #topic High Availability Guide - core team, repo move, move of resource agents
14:10:20 <annegentle> So we have four core reviewers on that guide now
14:10:35 <annegentle> (I think I wrote that on the mailing list, checking_
14:10:58 <berendt> but looks like they are not reviewing. there are 9 pending requests at the moment.
14:11:08 <annegentle> wow 9
14:11:12 <berendt> https://review.openstack.org/#/q/status:open+project:openstack/ha-guide,n,z
14:11:17 <nickchase> maybe we need to ping them and remind them that's what they need to be doing?
14:11:29 <annegentle> #link http://lists.openstack.org/pipermail/openstack-docs/2014-September/005227.html
14:11:32 <annegentle> yep I will!
14:11:46 <annegentle> I need to change the doc review dashboard too
14:11:56 <berendt> annegentle: already done
14:11:58 <annegentle> #action Annegentle change the doc review dashboard to include the ha-guide
14:12:00 <annegentle> berendt: nice
14:12:14 <annegentle> #udno
14:12:16 <annegentle> #undo
14:12:16 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x270ed10>
14:13:04 <annegentle> #info Need reviews on the ha-guide
14:13:07 <annegentle> #link https://review.openstack.org/#/q/project:openstack/ha-guide,n,z
14:13:37 <annegentle> #action Anne to email David Medberry, Emilien Macchi, Matt Griffin, and Sriram Subramanian
14:14:25 <annegentle> nice work berendt I'll do some reviews today
14:15:01 <annegentle> Anything else on High Availability? I'm meeting with the Foundation content group this afternoon and I'll make sure they know the progrss
14:15:10 <nickchase> not from me
14:15:18 <berendt> yes. the move of the resource agents.
14:15:23 <nickchase> Elka has arrived, btw. Welcome, #elkevorheis
14:15:30 <annegentle> the HA Guide is one of those "enterprise" deliverables that the enterprise working group wants
14:15:38 <annegentle> welcome elkevorheis! So glad to have you here!
14:15:39 <berendt> I can take care, but I need support. I have never moved a repository or added a new repository to openstack/
14:15:45 <nickchase> MAN my typing is bad this morning. sorry.
14:15:58 <annegentle> no worries :)
14:16:26 <annegentle> berendt: yeah I hadn't done the git move with history... and failed :) Sadly I had a repo that built correctly but the history was gone so I had to leave it be.
14:16:41 <annegentle> berendt: but seems like it's building right?
14:16:56 <annegentle> #topic Website design status
14:17:07 <annegentle> So since June I've been working on getting a new web design
14:17:39 <annegentle> Next week I'm meeting with a web designer that the Foundation identified and the description of the project is linked for us to take a look at by next Wed.
14:17:48 <annegentle> #link https://docs.google.com/document/d/1GGKTKHDMc8A0jerdv-K3ql0udnxMr-j4DlhL2Cj6kcw/edit?usp=sharing
14:17:49 <nickchase> awesome.
14:17:52 <berendt> annegentle: I'm talking about the integration of https://github.com/madkiss/openstack-resource-agents/ into openstack/, not the ha-guide repository itself
14:17:59 <annegentle> berendt: oh yeah!
14:18:15 <annegentle> berendt: sorry, that's the move of resource agents part, which is a GREAT idea
14:19:04 <annegentle> berendt: we definitely want the official docs to have supported agents
14:19:30 <annegentle> #action review the link above for the Design Project and leave comments in the document itself
14:19:35 <nickchase> So I was reading the design brief and I'm wondering whether we need to break out the "book" and "non-book" content. I mean, they should ALL be readable in a responsive way.
14:20:00 <annegentle> nickchase: yeah that's definitely debatable. I want some things to remain books though, I really see the value
14:20:14 <annegentle> nickchase: and, the responsiveness of a book layout could come in a second phase
14:20:31 <annegentle> nickchase: I feel the pain we need to prioritize is the sprawl
14:21:12 <nickchase> annegentle: I agree, just saying that the content itself shouldn't affect what layout it goes into. But ...
14:21:16 <nickchase> you're right, it's a secondary issue.
14:21:40 <nickchase> That said, we're really only talking about the need for a new format for the output
14:21:41 <annegentle> nickchase: I think it's a chicken-egg problem... until we have more page-friendly layouts, people will still write book-ish...
14:21:42 <annegentle> maybe
14:21:58 <annegentle> it's interesting, as I went through it, I thought, well, we really only need one additional page layout
14:22:01 <nickchase> When you say "page friendly" what do you mean, though.
14:22:04 <annegentle> I mean, I was suprised
14:22:19 <nickchase> Yes, it's true; because it's all generated by the same tool.
14:22:27 <annegentle> The User Guide, Admin User Guide, Cloud Administrator Guide, High Availability Guide, Installation Guides, API Quick Start Guide, and Virtual Machine Image Guide can all go to a page-based layout.
14:22:36 <annegentle> but they could "not" be generated in teh same tool
14:22:48 <nickchase> But what I'm saying is, "what does 'page-based' mean?"
14:23:07 <annegentle> nickchase: oh I want the designer to tell me :)
14:23:11 <nickchase> True that they don't HAVE to be generated by the same tool.
14:23:15 <annegentle> nickchase: from any page, you can get to any other page, etc.
14:23:40 <annegentle> Search for "These are page features that can be enhanced in a page-based design" and look at the bullets
14:23:45 <annegentle> see if there's anything to be added
14:23:53 <nickchase> annegentle: Ah... that's kind of what we have now, though.
14:24:14 <nickchase> Actually, elkevorheis, you've got a lot of experience with large documentation sets
14:24:14 <annegentle> nickchase: yep, we do have the 3 bullets above that list, we do not have the bullets below that list
14:24:18 <nickchase> do you have any thoughts?
14:24:30 <annegentle> yes, input welcomed! Before next We.d
14:24:33 <annegentle> er Wed.
14:24:55 <nickchase> k, we'll talk about it, then.
14:25:14 <annegentle> the trick is, scope it well enough to actually get something done. By the summit with any luck... not holding my breath
14:25:29 <nickchase> Yeah, don't.
14:25:35 <annegentle> heh
14:25:38 * annegentle takes deep breath
14:25:46 <nickchase> :)
14:25:47 <annegentle> any questions?
14:26:11 <annegentle> #topic HOT Template Guide status
14:26:27 <annegentle> I heard from Gauvain this week, we're pleased with the contributions to the RST
14:26:29 <annegentle> so that's nice
14:26:38 <annegentle> as an experiment, I think we're winning
14:28:05 <nickchase> always good.
14:28:14 <annegentle> thanks to Steve Baker and Angus Salkeld for their technical knowledge
14:28:52 <annegentle> And thanks to Gauvain for hanging in there with the discussion about putting in the version
14:29:28 <annegentle> #topic API docs status
14:29:39 <annegentle> I really really wish I was further along with deleting the old content
14:29:50 <annegentle> so that I can get rid of the <service>-api repos
14:30:04 <annegentle> Nearly there, just need to take a day and do the work uninterrupted :)
14:30:18 <annegentle> and get over my fear of deleting old files :)
14:30:47 <nickchase> that's what git history is for. :)
14:30:52 <annegentle> :)
14:31:01 <annegentle> Google scares me. There I said it :)
14:31:11 <annegentle> #topic Doc tools status
14:31:22 <annegentle> Whoohoo, released 2.1.3 clouddocs-maven-plugin
14:31:35 <annegentle> #info 2.1.3 clouddocs-maven-plugin now available
14:31:51 <annegentle> #link https://github.com/stackforge/clouddocs-maven-plugin/blob/master/RELEASE_NOTES.rst
14:32:07 <annegentle> to me, the biggest change is here:
14:32:09 <annegentle> #link http://developer.openstack.org/api-ref-compute-v2.html
14:32:20 <annegentle> now there are short names for each API call
14:34:18 <annegentle> there are still lots of API doc bugs
14:34:37 <annegentle> but I think getting rid of the "spec" repos helps draw down technical debt there
14:34:48 <annegentle> we just need more people in the community to get jazzed about api docs :)
14:34:53 <annegentle> Ok, that's it for the agenda
14:34:56 <annegentle> #Open discussion
14:34:59 <annegentle> er
14:35:04 <annegentle> #topic Open discussion
14:35:09 <annegentle> typing, it's required
14:36:13 <annegentle> I am willing to continue to serve as Docs PTL but would love to identify people who want to learn the role. We definitely already share the management - thanks Nick and Lana.
14:37:59 <annegentle> anyone else have anything?
14:38:32 <annegentle> For the Summit, I think docs track for the design summit will be in the cross-project session track
14:38:54 <annegentle> We'll have a project pod
14:39:04 <annegentle> It looks like that's Tuesday
14:39:16 <annegentle> Wed/Thurs. will be the "old school" scheduled slots
14:39:33 <annegentle> and Fri. are separate contributors meetups. Each day of course there are many other things going on.
14:40:43 <annegentle> I haven't put any etherpad links on https://wiki.openstack.org/wiki/Summit/Planning yet but we'll need to determine what we need to talk about at the summit in the next meeting or two
14:40:46 <annegentle> that's all I've got!
14:40:51 <annegentle> Thanks everyone
14:41:07 <annegentle> #endmeeting