14:01:16 <annegentle> #startmeeting docteam
14:01:17 <openstack> Meeting started Wed Oct 22 14:01:16 2014 UTC and is due to finish in 60 minutes. The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:18 * Sam-I-Am looks at coffee cup
14:01:19 * AJaeger is here and sings happy birthday, anne!
14:01:21 <openstack> The meeting name has been set to 'docteam'
14:01:22 <annegentle> you're up late sld :)
14:01:31 <annegentle> #topic Action items from the last meeting
14:01:31 <nickchase> any chance of doing the networking guide first?
14:01:33 <Sam-I-Am> i might be interrupted by a fedup delivery
14:01:38 <nickchase> (well, besides that)
14:01:42 * annegentle looks
14:01:55 <annegentle> oh yeah, meetbot was down
14:02:00 <Sam-I-Am> annegentle: rumor says you're birthdaying?
14:02:06 <Sam-I-Am> yeah, that meeting was a mess
14:02:09 <annegentle> hee hee yes
14:02:14 <AJaeger> annegentle, happy birthday to you!
14:02:18 <annegentle> thanks!
14:02:21 <Sam-I-Am> well happy birthday
14:02:23 <nickchase> happy birthday
14:02:29 <sld> annegentle: Happy bday
14:02:32 * annegentle wonders why she doesn't take her birthday off
14:02:37 <sld> (mine isn't til next month. lol)
14:02:41 <KLevenstein> happy birthday annegentle!
14:02:46 <sld> annegentle: i am doing that, and the day before as well. ;)
14:02:48 <nickchase> mine's next week. :)
14:02:48 <annegentle> thanks y'all!
14:03:03 <annegentle> cool, October's the best. Not like November at all. :P
14:03:05 <Zemeio> Happy birthday annegentle : ) (from the whole UFSCar team)
14:03:07 <annegentle> #topic Summit schedule
14:03:08 <sld> lol
14:03:16 <annegentle> hee thanks Zemeio and team!
14:03:31 <annegentle> So I thought we'd have the schedule by yesterday but looks like it'll be another week
14:03:39 <annegentle> there are about 32 topics for 18 slots but we'll get one for docs
14:03:47 <annegentle> cross-project topics for 18 slots
14:03:50 <annegentle> that'll be Tuesday
14:04:09 <annegentle> #link https://etherpad.openstack.org/p/docstopicsparissummit
14:04:18 <annegentle> I've started marking some topics for "pod" in that etherpad ^^
14:04:34 <annegentle> I think the API specs/docs discussion will be in cross=project for sure
14:04:45 <sld> was just about to ask - what is 'pod'?
14:04:48 <annegentle> then I also want to know if you want to talk about scaling across projects?
14:04:59 <annegentle> a pod is just a table where team members can gather
14:05:04 <sld> ah
14:05:15 <Sam-I-Am> annegentle: you need a VC version for those of us not there :)
14:05:45 <annegentle> mailing list to pod interfeace it is then
14:06:33 <annegentle> I think the cross project discussion will mostly be about ensuring we have liaisons
14:06:58 <AJaeger> annegentle, scaling is important.
14:07:22 <AJaeger> With Trove, Ceilometer and Heat we made some good steps forward but we need more
14:07:42 <annegentle> yep AJaeger -- I feel it's the one topic we should pick, sound good?
14:07:46 <annegentle> #link https://openstacksummitnovember2014paris.sched.org/event/4a1f709ce0318c973ac87f815f92734e#.VEe6GIt4r_w
14:08:04 <AJaeger> +1
14:08:05 <annegentle> that talk is one Lana and I are giving about how to work on upstream docs when you have a product based on OpenStack
14:08:34 <sld> cool
14:08:36 * AJaeger looks forward to the linked talk!
14:08:46 <annegentle> #link https://openstacksummitnovember2014paris.sched.org/event/792d87161d517ca27ce1b212c06d695d
14:08:47 <sld> yeah, was just about to ask if it would be recorded (video). ;)
14:08:56 <annegentle> sld: yes, those two will be
14:09:15 <annegentle> that one is about developer support, and part of the data collection is the Disqus comments on API docs
14:09:21 <sld> cool
14:09:25 <annegentle> so that might be interesting to docs folks as well, please spread the word
14:09:30 <annegentle> ok, anything else on the Summit?
14:09:45 <annegentle> #topic Networking Guide status
14:09:50 <Sam-I-Am> hi
14:09:51 <annegentle> Their meeting has moved to today
14:10:02 <annegentle> Sam-I-Am: nick had to step out, what time is that meeting?
14:10:02 <Sam-I-Am> nick left, so i can update
14:10:18 <Sam-I-Am> the meeting is at 11 us/central (under 2 hours)
14:10:38 <Sam-I-Am> we discussed the issues with existing network content in the admin guide
14:10:59 <Sam-I-Am> determined that re-using content from admin guide in networking guide would be a mess
14:11:04 <Sam-I-Am> so we'll do it the other way
14:11:14 <Sam-I-Am> add new content to networking guide, and include it in other books as needed.
14:11:19 <annegentle> ah ok
14:11:47 <Sam-I-Am> we have a contributor for the provider-type network scenario
14:11:59 <Sam-I-Am> i'm assigned to work on the intro parts and diagrams
14:12:02 <AJaeger> Sam-I-Am, Elke raised a question on the mailing list regarding includes. That whole thread confused me a bit. Could you describe it again for me, please?
14:12:12 <Sam-I-Am> now that the install guide is done, i might have more time for it
14:12:34 <Sam-I-Am> AJaeger: sure. the original plan for the guide (and the existing code) uses a lot of includes from other material.
14:13:14 <Sam-I-Am> after she sent that e-mail, we realized we need to work the other way around... that is, include new content from the networking guide.
14:13:19 <Sam-I-Am> so its sort of moot now
14:13:56 <AJaeger> Thanks, now I understand
14:13:58 <annegentle> heh might want to repost to that thread :)
14:14:19 <Sam-I-Am> i have to find it
14:14:51 <annegentle> just to make sure people know the change
14:14:58 <annegentle> ok anyting else on Networking?
14:14:59 <Sam-I-Am> http://lists.openstack.org/pipermail/openstack-docs/2014-October/005353.html
14:15:04 <Sam-I-Am> er
14:15:06 <Sam-I-Am> #link http://lists.openstack.org/pipermail/openstack-docs/2014-October/005353.html
14:15:35 <Sam-I-Am> nothing else
14:15:35 <annegentle> oh related to Networking (but not the guide) I will put in an api spec to their repo
14:15:43 <annegentle> but that comes later
14:15:45 <annegentle> ok
14:15:50 <annegentle> #topic Installation Guides status
14:15:58 <annegentle> Sam-I-Am: sounds like it's as done as docs can do
14:16:05 <AJaeger> annegentle, tell me once I can retire the compute-api etc. I can do those changes
14:16:06 <Sam-I-Am> ubuntu seems to mostly work with release packages
14:16:18 <Sam-I-Am> rdo has not provided release packages yet
14:16:18 <annegentle> AJaeger: awesome, thank you
14:16:23 <Sam-I-Am> i'll test when they come out
14:16:28 <annegentle> oh I thought it was the other way round, Sam-I-Am.
14:16:37 <annegentle> That rdo was released but not cloud-archive
14:16:47 <Sam-I-Am> we have one bug report about glance in the rdo packages which i think it causes by non-sane defaults (rdo does not seem to update config files)
14:16:59 <annegentle> there are trove install fixes
14:17:01 <annegentle> #link https://review.openstack.org/#/c/129573/
14:17:12 <Sam-I-Am> annegentle: ubuntu is cloud-archive and they havent published a cloud-archive:juno link yet for some reason
14:17:23 <Sam-I-Am> but the underlying repo works and i have installed using it
14:17:43 <annegentle> ok cool
14:17:51 <Sam-I-Am> i think christian has tested most of suse, but has not updated the wiki page
14:17:51 <annegentle> I don't see other patches in review
14:18:05 <Sam-I-Am> #link https://wiki.openstack.org/wiki/JunoDocTesting
14:18:06 <AJaeger> Yeah, berendt tested SUSE heavily and send patches
14:18:07 <annegentle> ok, he said he couldn't make it to this meeting
14:18:18 <annegentle> so we'll talk about him while he's gone :)
14:18:18 <Sam-I-Am> AJaeger: if you could update that wiki
14:18:20 <annegentle> I kid!
14:18:47 <AJaeger> Sam-I-Am, let's ping berendt since he did the testing...
14:18:50 <Sam-I-Am> i still have some changes i would like to make to the guide before we officially move it to stable
14:19:05 <Sam-I-Am> mostly waiting on bug reports, but some other things need attention
14:19:26 <annegentle> okay, shall we make it a goal of Oct 31st? Or is that too soon? Trying to think if before or after Summit is better.
14:19:30 <AJaeger> Should we make a date when we create the Juno branch - or wait?
14:19:39 <annegentle> AJaeger: my thinking also :)
14:19:47 <annegentle> AJaeger: it'd be nice to have it done by Summit time
14:19:56 <annegentle> But Sam-I-Am is that do-able?
14:19:59 <AJaeger> annegentle, not on the 31st - that's too close to the summit
14:20:10 <annegentle> AJaeger: yeah I'll be on a plane
14:20:12 <Sam-I-Am> i can always backport
14:20:13 <AJaeger> 29th would work for me.
14:20:23 <AJaeger> This time I have a short plane ride ;)
14:20:25 <annegentle> Sam-I-Am: you good with 29th as a goal?
14:20:28 <annegentle> AJaeger: nice! :)
14:20:33 <annegentle> a week from today
14:20:42 <Sam-I-Am> sure. the guide hopefully wont have major changes for a while, so backports would be easy-ish
14:21:00 <Sam-I-Am> i really need to test swift, but... time.
14:21:10 <Sam-I-Am> ceilometer and trove also need testing
14:21:11 <annegentle> yeah, okay.
14:21:27 <Sam-I-Am> but at least the more popular/core services work
14:21:28 <annegentle> #info Goal to cut stable/juno branch for openstack-manuals is Oct 29 2014
14:21:42 <annegentle> Okay anything else on install?
14:21:46 <Sam-I-Am> nope
14:21:49 <annegentle> #topic HA Guide status
14:21:55 <annegentle> did we manage to entice any HA-ers?
14:22:02 <annegentle> to join our oh-so-exciting meeting?
14:22:20 <annegentle> #link https://review.openstack.org/#/q/project:openstack/ha-guide+status:open,n,z
14:22:29 <annegentle> looks like the reviews cleared out, nice
14:23:07 <annegentle> There are still only 7 bugs against the ha guide
14:23:29 <annegentle> they aren't small though, such as L3 agent revisions
14:23:57 <AJaeger> the ha guide needs one large review and update for Juno and updated packages...
14:24:13 <annegentle> #info ha guide needs one large review and update for Juno and updated packages
14:24:22 <annegentle> needs testing during that review
14:24:45 <annegentle> Hopefully the interested parties have what they need to both test and doc
14:25:34 <annegentle> I'm not sure what else to do to enable that subteam, ideas welcome!
14:25:55 <annegentle> #topic Website design status
14:26:20 <sld> website design = all of the guides, the reworking of it all?
14:26:23 <annegentle> They've got photoshopping done, basically flat designs for both the landing page and a subpage
14:26:28 <annegentle> and the search results page
14:26:43 <annegentle> sld: you want to read the next link thoroughly to understand scope
14:26:51 <annegentle> #link https://docs.google.com/document/d/1GGKTKHDMc8A0jerdv-K3ql0udnxMr-j4DlhL2Cj6kcw/edit
14:27:04 <annegentle> you may have noticed our docs header no longer matches www
14:27:05 <sld> oooooooo awesome. thx :)
14:27:09 <annegentle> so the design will help with that
14:27:36 <sld> right on!
14:27:58 <annegentle> I'm still holding to "For content that we want to remain as a book primarily, this layout would not apply. Examples include the Install Guides, the Operations Guide, the Security Guide, and the Architecture Design Guide."
14:28:05 <annegentle> (that's a pull out from the brief)
14:28:13 <annegentle> as is this:
14:28:14 <annegentle> "The User Guide, Admin User Guide, Cloud Administrator Guide, High Availability Guide, Installation Guides, API Quick Start Guide, and Virtual Machine Image Guide can all go to a page-based layout."
14:28:35 <annegentle> so we'll see, there is progress. They're putting into html/css now
14:29:01 <annegentle> In a related bit of work, there's a dev team at Rackspace taking on the work of splitting out the Rackspace branding from the OpenStack branding for clouddocs-maven-plugin
14:29:02 <AJaeger> annegentle, let's sit together in Paris and get some common understanding what page based design could mean.
14:29:15 <annegentle> AJaeger: for the writing? building? all of it?
14:29:27 <annegentle> #link https://bugs.launchpad.net/openstack-manuals/+bug/1177698
14:29:28 <Sam-I-Am> annegentle: installation guide mentioned in both places?
14:29:30 * AJaeger has some basic ideas but many questions
14:29:30 <uvirtbot> Launchpad bug 1177698 in openstack-manuals "Implement outside the plugin a branding (dup-of: 1271685)" [Wishlist,Confirmed]
14:29:36 <annegentle> #link https://bugs.launchpad.net/openstack-manuals/+bug/1271685
14:29:37 <uvirtbot> Launchpad bug 1271685 in openstack-manuals "Refactor Docs toolchain to separate Transforms from Templates" [Wishlist,Confirmed]
14:29:45 <annegentle> those are the bugs addressed by the split
14:29:50 <AJaeger> annegentle, first just defining what it really is.
14:30:07 <annegentle> AJaeger: what pages are? nav? what does the brief not answer?
14:30:12 <Sam-I-Am> AJaeger: you should read the book 'every page is page one'
14:30:30 <sld> annegentle: is there anywhere I can see a mockup of the new design?
14:30:44 <AJaeger> Sam-I-Am, and discuss whether we understand it the same
14:30:45 <annegentle> sld: not yet, I don't want them distracted with much input right now
14:30:57 <sld> awwwww ok. :(
14:31:10 <annegentle> sld: it looks a lot more like what www.openstack.org looks like
14:31:22 <annegentle> if that helps
14:31:39 <sld> a tiny bit? ;)
14:32:12 <annegentle> we'll need html css before we can see much, believe me
14:32:23 <annegentle> anything else on the redesign?
14:33:05 <annegentle> #topic HOT Template Guide
14:33:34 <annegentle> what will it take to publish it on the docs.openstack.org landing page?
14:34:12 <Sam-I-Am> i think we're missing the main contributor...
14:34:29 <annegentle> yeah guess he'll be the judge
14:34:29 <Sam-I-Am> gpocentek: ping
14:34:42 <annegentle> They are publishing so there's that
14:35:38 <annegentle> ah well
14:36:43 <annegentle> #action annegentle to ask Gauvain when he wants to publish the HOT guides
14:37:01 <annegentle> #topic API docs status
14:37:27 <annegentle> I've got four patches in review for api specs in the <project>-specs repos, to get rid of the <project>-api repos
14:37:33 <annegentle> Keystone finished theirs for v3 today
14:37:41 <annegentle> I still need to do neutron and keystone v2
14:37:55 <annegentle> so far, so good
14:38:02 <morganfainberg> annegentle, let me know what I can do to help w/ V2 Keystone.
14:38:05 <annegentle> even had to code some Python to get the patches done
14:38:15 <annegentle> morganfainberg: I think I have the content, just need to make the patch, thanks!
14:38:50 <annegentle> morganfainberg: I have yet to see how much to chunk, meaning, how many rst files to create for the patch
14:39:09 <morganfainberg> annegentle, ack
14:39:25 <annegentle> thank you AJaeger for offering to help with deletion
14:39:46 <annegentle> Also want to be sure you all know there are 20 REST API definitions in integrated and incubating projects
14:39:52 <AJaeger> annegentle, if we should declare a soft-freeze on the repos, please tell everybody!
14:39:58 <annegentle> so this is one way to offload docs maintenance
14:40:11 <annegentle> AJaeger: good point. No one really patches those though :)
14:40:57 <annegentle> still
14:41:15 <annegentle> #action annegentle to add a soft-freeze declaration to this week's What's Up Doc
14:41:21 <annegentle> #topic Doc tools status
14:41:45 <annegentle> So I mentioned this earlier, that the split of transforms from build will happen soon
14:41:56 <annegentle> I'm taking on the testing tasks but will welcome assistance of course :)
14:42:06 <annegentle> we'll be able to see it in the reviews
14:42:25 <annegentle> timing wise, there's no predictability for which will happen first, the redesign or the split
14:42:47 <annegentle> so I'm kind of just being zen about it, otherwise it's crazy-making trying to coordinate/aline
14:42:50 <annegentle> align
14:43:09 <annegentle> we did have an increment on openstack-doc-tools
14:43:10 <AJaeger> :)
14:43:28 <annegentle> for the sitemap
14:43:32 <annegentle> and I deleted all of /grizzly
14:43:41 <annegentle> I think that's it for doc tools -- anything else AJaeger?
14:43:43 * AJaeger regenerated the sitmeap
14:43:54 <AJaeger> everything green on tools ;)
14:44:15 <annegentle> AJaeger: cool. Any news from the -infra work? I saw their meeting notes yesterday saying they hadn't gotten the swift idea working yet?
14:44:35 <AJaeger> annegentle, correct - so no progress on docs.o.o move
14:44:44 <annegentle> okay
14:44:55 <annegentle> heh it could also be in there with the redesign :)
14:44:57 <annegentle> ok
14:45:01 <annegentle> #topic Open discussion
14:45:03 <annegentle> anything else?
14:45:04 <AJaeger> annegentle, but it's on their weekly agenda ;)
14:45:13 <annegentle> AJaeger: yeah they are being diligent!
14:45:22 <Sam-I-Am> yeah...
14:45:24 <Sam-I-Am> i have a few things
14:45:35 <Sam-I-Am> i put 'upgrades' in the agenda but i guess it was overlooked
14:45:36 <annegentle> I would like to hear discussion on the project liaisons and scaling
14:45:41 <annegentle> sorry didn't see it Sam-I-Am
14:46:07 <annegentle> ah, had to refresh
14:46:08 <Sam-I-Am> as per the usual, we move from install to upgrade post-release. it goes into the ops guide for now.
14:46:14 <annegentle> ready to move it out?
14:46:19 <annegentle> separate guide or with install guide?
14:46:54 <Sam-I-Am> people seem to be looking at the install guide for how to upgrade, but they're completely different operations
14:47:24 <Sam-I-Am> not a fan of guide proliferation
14:47:36 <AJaeger> Do we need to add a paragraph pointing to the ops guide?
14:48:15 <Sam-I-Am> we could do that too. however, if upgrade stick in the ops guide, i would like to use better markup.
14:48:22 <Sam-I-Am> the stuff we did for the print book is messy and gross
14:48:35 <Sam-I-Am> and if we dont plan to publish it again...
14:48:46 <Sam-I-Am> dead tree makes no sense for something with a 6 month release cycle
14:49:38 <Sam-I-Am> so...
14:49:42 <annegentle> Sam-I-Am: disagree on the last point but agree we can move upgrades out. I'd prefer its own guide. Sounds like you think so too?
14:50:01 <Sam-I-Am> that or the admin guide.
14:50:16 <Sam-I-Am> it just needs to go somewhere :)
14:50:30 <annegentle> ah, could be admin guide
14:50:31 <annegentle> sure
14:50:40 <annegentle> is this a blueprint for next release then?
14:50:49 <AJaeger> Upgrades sounds like something for a page design ;)
14:50:59 <annegentle> heh overload overload!
14:51:13 <Sam-I-Am> AJaeger: its sort of both.
14:51:38 <AJaeger> now I'm confused - let's solve in Paris...
14:51:52 <Sam-I-Am> haha, sure i wont be there
14:52:27 <Sam-I-Am> annegentle: for now, where do you want me to stash the content?
14:52:33 <Sam-I-Am> since it'll probably happen sooner than later
14:53:26 <AJaeger> Not? I'll miss you, Sam-I-Am !
14:53:45 <Sam-I-Am> i can always join irc or something if there's a meeting i need to be in
14:53:59 <Sam-I-Am> etherpads, etc
14:54:39 <AJaeger> drinking a beer via irc or etherpad might be difficult ;)
14:54:54 <annegentle> Sam-I-Am: thinking
14:56:17 <Sam-I-Am> heh
14:56:34 <Sam-I-Am> this stuff shouldnt be hard...
14:57:04 <annegentle> Sam-I-Am: I think: 1 patch to move upgrade chapter to install guide
14:57:09 <annegentle> Sam-I-Am: then do your cleanup patch
14:57:19 <annegentle> Sam-I-Am: and I can even take on those two if you want
14:57:30 <annegentle> Sam-I-Am: then patch for the actual steps
14:57:33 <annegentle> Sam-I-Am: does that work?
14:57:39 <Sam-I-Am> annegentle: so move the havana-icehouse content to icehouse install guide?
14:57:48 <annegentle> Augh versions
14:57:52 <Sam-I-Am> and then make a new place for icehouse-juno in the juno guide?
14:57:57 <annegentle> This is why it should be an unversioined separate guide
14:57:57 <AJaeger> and Juno install guide would contain only icehouse-juno?
14:57:58 <Sam-I-Am> yeah :/
14:58:05 <Sam-I-Am> yes it would
14:58:06 <AJaeger> yeah, as Sam-I-Am said.
14:58:07 <annegentle> unversioned separate guide I think is better.
14:58:26 <Sam-I-Am> people would need to follow each incremental upgrade
14:58:29 <annegentle> then we just delete chapters as the version EOLs
14:58:33 <Sam-I-Am> i'm not about to test all permutations
14:58:37 <annegentle> nope
14:58:50 <annegentle> want me to do the patch for seprate guide?
14:58:53 <Sam-I-Am> yes, eoling make sense. do we keep the last eol'd version?
14:59:03 <Sam-I-Am> so right now we'd still have havana->icehouse
14:59:12 <Sam-I-Am> but grizzly goes bye
14:59:35 <annegentle> right
14:59:54 <annegentle> is that better for maintenance and people finding it?
14:59:55 <Sam-I-Am> annegentle: feel free to create the guide... and perhaps copy/move the havana-icehouse content from the ops guide?
15:00:06 <Sam-I-Am> i think so. we can always consolidate later.
15:00:09 <annegentle> right
15:00:19 <Sam-I-Am> right now its more about content than the organizational stuffs
15:00:23 <annegentle> AJaeger: does that work? see any problems with standing up another guide?
15:00:30 <Sam-I-Am> its not super obvious in the ops guide
15:00:40 <AJaeger> annegentle, I just need to add it to transifex - no problem at all...
15:01:08 <annegentle> okie doke
15:01:11 <AJaeger> annegentle, just go ahead - and please let me approve the patch to setup transifex first.
15:01:18 <annegentle> #action annegentle to pull upgrade info from ops guide
15:01:21 <annegentle> sure
15:01:29 <annegentle> ok anything else? gotta give up the room
15:01:31 <AJaeger> but no problem if somebody approves it.
15:01:39 <AJaeger> annegentle, go party!
15:01:41 <annegentle> continue in #openstack-doc
15:01:44 <annegentle> #endmeeting