15:01:37 <annegentle> #startmeeting docteam
15:01:37 <openstack> Meeting started Wed Jan 28 15:01:37 2015 UTC and is due to finish in 60 minutes.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:40 <openstack> The meeting name has been set to 'docteam'
15:01:47 <annegentle> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting
15:01:54 <annegentle> agenda has been updated since I emailed, so let's get started
15:02:00 <annegentle> #topic Action items from last meeting
15:02:55 <annegentle> I met with alexadamov and reported back to the mailing list.
15:03:08 <annegentle> So we now have Install Guide backing for Debian, he's setting up a test bed.
15:03:32 <annegentle> Looks like Alex isn't here, so I'll try to get an update from him on how that's going offline. (It's a bit late for his timezone I think).
15:03:38 <annegentle> that's it for action items
15:03:53 <annegentle> #topic Specialty team reports
15:04:11 <annegentle> Anyone here from training? too early for Sean R for sure :)
15:04:35 <annegentle> I know that the stable/juno branch is now done for the training-guides repo
15:04:52 <annegentle> woops I mean stable/icehouse
15:04:58 <annegentle> #link https://github.com/openstack/training-guides/tree/stable/icehouse
15:05:28 <annegentle> How about ha-guide, anything to report?
15:06:02 <annegentle> #info HA Guide team meeting Thursdays at 21:00 UTC, #openstack-meeting-3
15:06:06 <annegentle> join them if you're interested
15:06:57 <annegentle> Anyone from the Security team?
15:07:41 <annegentle> #link https://review.openstack.org/#/c/149056/
15:07:50 <annegentle> one outstanding review that handles six bugs
15:07:56 <annegentle> for the security guide
15:08:09 <annegentle> Okay, anyone from the Networking team?
15:08:22 <annegentle> I know Matt (Sam-I-Am) is stuck on a bus
15:08:40 <klevenstein> We just arrived at the castle
15:08:48 <annegentle> ok cool
15:09:13 <annegentle> The Networking team will meet again this week
15:09:53 <annegentle> #link https://wiki.openstack.org/wiki/Meetings#Networking_Guide_Update_Meeting
15:10:49 <annegentle> Another note for subteams, I am talking to Lana (loquacities) and the SUSE team (Tanja) about starting a User Guide specialty team
15:10:58 <annegentle> Okay, which easily moves us to the next topic
15:11:08 <annegentle> #topic User guide migrations
15:11:42 <annegentle> I'm working as fast as I can on the Sphinx template, and hope to be done in the next week or so. Fingers crossed.
15:11:55 <annegentle> We do need to migrate the content, and I wondered if signing up on the wiki page for chapters is a good way to do that?
15:12:05 <annegentle> When I did the migration for the dev guides, I used this process:
15:12:28 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/Migrate
15:12:50 <annegentle> So I'm thinking we can have people sign up for the migration and cleanup.
15:13:08 <annegentle> Andreas got a good start here: https://review.openstack.org/#/c/142437/
15:13:27 <annegentle> so really, it seems either method would work
15:13:37 <annegentle> the main thing to do is to carefully clean up the source after it's migrated
15:13:43 <annegentle> is a wiki page signup the way to go?
15:14:03 <klevenstein> sounds good to me
15:14:16 <annegentle> klevenstein: cool, I think Robb was also interested
15:14:31 <annegentle> honestly, I don't think we care how it's done as long as the files look good
15:15:54 <klevenstein> Brb, switching devices.
15:16:57 <annegentle> #info Add your Name and a Chapter to https://wiki.openstack.org/wiki/Documentation/Migrate#End_User_Guide_Migration to sign up for migrating content
15:17:41 <annegentle> #info Either use Andreas's script in doc/playground-user-guide/source or the one in the Documentation/Migrate wiki page
15:17:55 <annegentle> That should do it, spread the word please. And I'll keep working on the theme.
15:18:08 <annegentle> #link https://github.com/annegentle/openstack-docs-theme
15:18:38 <annegentle> I met with Doug ( dhellmann) this week and have revised the plan to create an extension named openstackdocstheme
15:18:50 <annegentle> Updating the spec with that info so that's the plan of record
15:19:10 <annegentle> Then, people can build locally and automatically, and we'll have the ability to add more features as we go.
15:19:25 <annegentle> the CSS and other changes will be reviewed by the docs team and the repo will live in the Docs project.
15:19:32 <annegentle> But Doug is definitely willing to help.
15:19:38 <annegentle> That's it for the migration
15:19:53 <annegentle> Oh I combined two topics :)
15:19:54 <annegentle> #topic Doc tools latest: Sphinx new theme
15:20:04 <annegentle> So yeah what I just said is the latest on the new theme.
15:20:27 <annegentle> I finally got the divs working like they need to, now I just have to map styles within Sphinx to match ..note:: with what we want output, for example.
15:20:35 <annegentle> Any questins?
15:20:39 <annegentle> questions even?
15:21:11 <annegentle> Okay, next topic
15:21:19 <annegentle> #topic Installation guide: Change trunk to Kilo, potential changes for Kilo
15:21:23 <Sam-I-Am> yep
15:21:24 <annegentle> Sam-I-Am: go ahead, the floor is yours
15:21:39 <Sam-I-Am> so, kilo-2 is coming out soon, and i wondered when we should move feature work to kilo
15:21:49 <Sam-I-Am> in other words, only bug fix the juno branch
15:22:30 <annegentle> I'll be honest -- I would like us to not focus on the install guide until 6 weeks from release date.
15:22:39 <annegentle> what are the risks with leaving it alone for a while?
15:22:51 <Sam-I-Am> depends on what we want to accomplish for kilo
15:23:14 <annegentle> Sam-I-Am: ah, what are you thinking of?
15:23:26 <Sam-I-Am> keystone v3 comes to mind, but that requires moving to 'python-openstackclient' for everything
15:23:41 <Sam-I-Am> there's also nova v3, removing deprecated cinder v1, perhaps glance v2, etc.
15:24:07 <annegentle> honestly, I don't sense we can decide that for another milestone or 2
15:24:28 <annegentle> what do others think? Esp. about keystone v3?
15:24:45 <Sam-I-Am> thats fine. i figured i would bring it up. the key with this release was trying to get people to use the actual release docs vs. always going to trunk (because historically, thats the only place bugs were fixed)
15:24:56 <annegentle> right.
15:25:03 <Sam-I-Am> my goals are to slowly make the install guide more practical
15:25:25 <annegentle> oh it's definitely a good time to bring it up, just was hoping to delay another milestone if possible. I don't have good spidey sense on any decisions but that might be just me.
15:25:33 <Sam-I-Am> i have a good source (rpc) of practical things
15:25:42 <Sam-I-Am> sure -3 is fine
15:26:06 <Sam-I-Am> trying to make the process a bit better each release.
15:26:22 <annegentle> absolutely
15:26:22 <Sam-I-Am> get the big stuff done early, fix the packaging bugs later
15:26:45 <annegentle> yeah, keystone v3 and/or nova v2.1 would be big changes
15:27:02 <annegentle> is there anyone else we can get a gut check on keystone v3?
15:27:09 <Sam-I-Am> rpc uses it
15:27:11 <annegentle> (more people more betta)
15:27:17 <annegentle> how about Mirantis or RDO?
15:27:22 <annegentle> or Trystack?
15:27:37 <Sam-I-Am> not sure. i can ask dolph what we knows.
15:27:38 <Sam-I-Am> he
15:27:57 <annegentle> Sam-I-Am: can you ask on the mailing list -- Steve Gordon and Nick Chase would be good references for RDO (which is Trystack) and Mirantis
15:28:08 <Sam-I-Am> sure
15:28:12 <annegentle> Cool, thanks
15:28:29 <annegentle> #action Sam-I-Am to ask about keystone v3 uptake for major ref architectures
15:28:37 <annegentle> #undo
15:28:38 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x326a510>
15:28:53 <annegentle> #action Sam-I-Am to ask about keystone v3 uptake for major ref architectures like RDO, Mirantis (Rackspace is going to v3)
15:28:59 <annegentle> is that more accurate? Anyway.
15:29:04 <Sam-I-Am> pretty much
15:29:42 <annegentle> Okay, next topic
15:29:44 <annegentle> #topic Image source files
15:29:47 <annegentle> Go ahead
15:30:06 <Sam-I-Am> there's a patch waiting to remove all of the omnigraffle source files
15:30:15 <Sam-I-Am> yet we never really came up with a workaround
15:30:38 <Sam-I-Am> the last shot was the wiki, which only takes a few file types (like jpg and gif)
15:30:42 <annegentle> ha, I thought this was a glance thing :)
15:30:48 <Sam-I-Am> hahaha nope
15:30:51 <annegentle> Sam-I-Am: have you seen the thread on the ops list about diagrams?
15:30:53 <Sam-I-Am> that would be too easy
15:30:59 <annegentle> Sam-I-Am: there were some decent alternatives there, let me dig it up
15:31:01 <Sam-I-Am> i'm not on the ops list
15:31:55 <annegentle> Ah, there were two relevant threads
15:31:57 <annegentle> Okay, first one
15:32:25 <annegentle> #link http://lists.openstack.org/pipermail/openstack-operators/2015-January/006011.html
15:32:52 <annegentle> And then the other relevant thread is the one on the Rally docs on openstack-dev
15:33:12 <annegentle> they used https://www.lucidchart.com to make omnigraffle looking diagrams
15:34:13 <Sam-I-Am> lucidchart is not free?
15:34:29 <Sam-I-Am> i remember looking at it at some point
15:34:30 <annegentle> #link http://lists.openstack.org/pipermail/openstack-operators/2015-January/005980.html
15:34:34 <Sam-I-Am> it just moves the problem
15:34:55 <annegentle> it's another data point
15:35:09 <Sam-I-Am> sure
15:35:16 <annegentle> where the source files aren't stored in a repo
15:35:44 <Sam-I-Am> so, in the meantime, i have these files...
15:36:23 <annegentle> I think it's fine to put them on your own repo, then.
15:36:32 <annegentle> similar to your drafts for the networking guide
15:36:43 <annegentle> ensure the readme and license make it clear they're meant for people to use
15:36:49 <annegentle> but I don't want them in the openstack namespace
15:36:51 <Sam-I-Am> sure, but i wanted to make them accessible to anyone. there's quite a few people who secretly use omnigraffle. :)
15:36:56 <annegentle> does that help?
15:37:06 <annegentle> github is accessible to anyone
15:37:22 <Sam-I-Am> i mean... if you're working on openstack docs
15:37:29 <annegentle> while protecting the openstack docs governance
15:37:45 <annegentle> I'm not willing to govern omnigraffle files in the Docs program
15:37:48 <Sam-I-Am> can i put a link to them in the docs?
15:38:06 <annegentle> we already link to Google Drive so go ahead, see what reviewers say
15:38:24 <Sam-I-Am> ok, i'll give that a shot
15:38:31 <annegentle> let's try it and see if it sticks
15:38:42 <annegentle> okay, thanks!
15:38:46 <annegentle> #topic Open discussion
15:38:53 <annegentle> I've got a few items
15:39:26 <annegentle> one is summit planning, Lana had asked about a "docs track" for the design summit side and doesn't have an answer yet, but I just don't think that "tracks" are how we're thinking of the design summit this time.
15:39:53 <annegentle> There are two types of setups for design summit: fishbowl, where discussions occur, and working groups, where tight collaborative groups get together
15:40:03 <annegentle> I think we'll need both, anyone have thoughts?
15:40:06 <KLevenstein> +1
15:41:16 <Sam-I-Am> makes sense
15:41:56 <annegentle> I don't have "a few items" just that one now that I think about it.
15:42:04 <annegentle> Anything else going on or interesting lately?
15:42:17 <annegentle> Oh, one other item, was the governance
15:42:21 <annegentle> er
15:42:24 <annegentle> governance changes coming
15:42:37 <annegentle> The TC is working on "tagging" for projects/repos in the openstack namespace
15:43:03 <annegentle> I've got a patch to keep the "service names" in the programs.yaml (which is being renamed to projects.yaml)
15:43:10 <annegentle> And in it, I change the capitalization to be more consistent.
15:43:26 <annegentle> Please look at https://review.openstack.org/#/c/150030/
15:43:52 <annegentle> For example, DNS service or Domain Name Servers service?
15:44:05 <Sam-I-Am> isnt it just domain name service?
15:44:54 <annegentle> ah, IBM style guide says Domain Name System
15:45:02 <Sam-I-Am> or system... but not server
15:45:02 <annegentle> so, DNS service or Domain Name System service?
15:45:13 <annegentle> or Domain Name System (DNS) service?
15:45:45 <KLevenstein> is there anything else that DNS stands for, or is this one of those things everyone knows?
15:45:45 <Sam-I-Am> DNSaaS :)
15:46:10 <Sam-I-Am> i only know of one dns, but its probably overloaded somewhere.
15:46:16 <annegentle> KLevenstein: we'd just go with IBM's definition
15:46:27 <annegentle> but yes, system, service, and servers get used
15:46:36 <Sam-I-Am> wikipedia says 'domain name system' too
15:47:00 <annegentle> vote your preferences on the review
15:47:06 <KLevenstein> I’ll take a look at the patch and see if anything else catches my eye
15:47:08 <annegentle> It does mean Image Service becomes Image service
15:47:13 <annegentle> so there's that.
15:47:16 <Sam-I-Am> that would be nice
15:47:30 <annegentle> okay, feel free to take back your dozen minutes and do something AWESOME with it.
15:47:37 <Sam-I-Am> like getting coffee?
15:47:42 <Sam-I-Am> i ran here from the bus lol
15:47:47 <annegentle> 'zactly  Sam-I-Am :)
15:47:47 <KLevenstein> start paying attention to this other meeting I’m in. :)
15:47:48 <Sam-I-Am> almost 10 with no coffee...
15:47:51 <annegentle> lol
15:47:53 * Sam-I-Am shudder
15:47:56 <Sam-I-Am> shake
15:47:58 <annegentle> #endmeeting