00:30:27 <loquacities> #startmeeting docteam
00:30:28 <openstack> Meeting started Wed May 27 00:30:27 2015 UTC and is due to finish in 60 minutes.  The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:30:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:30:32 <openstack> The meeting name has been set to 'docteam'
00:30:41 <loquacities> who's here?
00:30:47 <JRobinson__> Checking in
00:30:51 <berndbausch> good morning
00:30:58 <darrenc> me
00:31:49 <loquacities> hi berndbausch good to see you :)
00:31:51 <loquacities> adahms: here?
00:32:17 <berndbausch> I am afraid I will just lurk
00:32:25 <loquacities> lurking is just fine :)
00:32:47 <katomo> Hi
00:32:51 <asettle> yo
00:32:52 <loquacities> hi katomo!
00:33:04 <loquacities> we don't seem to have any of the apac red hatters ...
00:33:30 <asettle> dmacpher you around friend? :)
00:34:02 <dmacpher> asettle, hi
00:34:59 <loquacities> ok, looks like there might be a conflict for those guys again
00:35:05 <loquacities> let's get started
00:35:08 <loquacities> oh, hi dmacpher :)
00:35:18 <dmacpher> loquacities, hi there
00:35:26 <loquacities> #topic Action items from the last meeting
00:35:38 <loquacities> i don't think we had anything there, since we've missed a couple of weeks
00:35:59 <JRobinson__> One item - I was going to check on who was running US docs meeting
00:36:04 <loquacities> oh, it's shilla
00:36:20 <JRobinson__> So mark that one itme as completed :)
00:36:25 <loquacities> \o/
00:36:35 <loquacities> #topic Notes from Design Summit
00:36:43 <loquacities> #info RST conversion: Install Guide, Cloud Admin Guide, HA Guide
00:36:56 <loquacities> these are the books that we determined to be next in line for conversion
00:37:06 <JRobinson__> Good to hear
00:37:11 <darrenc> great
00:37:18 <loquacities> install guide will be the defcore projects only, and we'll start the conversion once we've branched for kilo
00:37:21 <loquacities> which should be soon
00:37:39 <loquacities> karin is going to be the point person for that book, as the install guide speciality team lead
00:38:02 <loquacities> cloud admin guide will be the other main conversion project
00:38:09 <loquacities> the user guide speciality team will be handling that one
00:38:29 <darrenc> cool
00:38:33 <JRobinson__> Is there any etherpad notes to look over for this one?
00:38:36 <loquacities> the HA guide has already been started, meg mcroberts had a sprint on that at the summit
00:38:49 <loquacities> JRobinson__: yep
00:39:06 <loquacities> #link https://etherpad.openstack.org/p/Documentation__Info_Architecture_1
00:39:12 <loquacities> #link https://etherpad.openstack.org/p/Documentation__Blueprint_Work_Session
00:39:13 <JRobinson__> Thanks loquacities
00:39:43 <loquacities> #info all the etherpads can be found here: https://wiki.openstack.org/wiki/Design_Summit/Liberty/Etherpads#Documentation
00:40:00 <loquacities> #info Lana will send out a summary of those to the ML Real Soon Now
00:40:29 <loquacities> #info Much discussion about IA. User Guides will be rejiggered for Liberty.
00:40:41 <loquacities> no major changes on IA at this point, other than the user guides
00:41:09 <loquacities> but we did have a lot of really productive discussion about how we move to an EPPO-style layout, and organising guides by service instead of audience
00:41:21 <loquacities> we want to try and move away from audience-based organisation as much as possible
00:41:39 <loquacities> #info Lana to spend time on blueprints/old bugs this week and next
00:41:50 <loquacities> so be aware that things will be moving around a bit for a little while
00:41:56 <loquacities> also: help gladly received :)
00:42:03 <loquacities> #info Plan for helping out devs with docs in their repo
00:42:18 <loquacities> this was sparked by the ironic dev team
00:42:21 <JRobinson__> Okay, older bug hunting time
00:42:47 <loquacities> the general idea being that we can provide assistance (through the speciality teams) to devs groups to clean up docs in the dev repos
00:43:15 <loquacities> this way, the devs get the help they need to clean up their own docs, but the maintenance burden remains with them, and not us
00:43:45 <loquacities> there's also discussion about tweaking the toolchain so that they can publish stuff in their dev repos to look like formal openstack documentation (with our theme, etc)
00:43:58 <loquacities> any questions on any of that before we move on?
00:44:31 <berndbausch> what does "assistance" mean_?
00:44:47 <JRobinson__> Are the docs in the developer repos in separate files or added with #comments in the coding?
00:44:59 <loquacities> in theory, what would happen is the PTL of the dev project would approach us, and we would then ask the appropriate speciality team to take on the project
00:45:12 <berndbausch> tx
00:45:17 <loquacities> how much work is involved, etc, would be on a case-by-case basis
00:45:33 <loquacities> JRobinson__: these are the docs on doc.openstack/developer
00:45:49 <loquacities> #link http://docs.openstack.org/developer/openstack-projects.html
00:46:06 <loquacities> they're usually RST, but they live in the dev repo, not openstack-manuals
00:46:39 <JRobinson__> loquacities, thank you!
00:46:43 <loquacities> np
00:46:54 <loquacities> ok, shall we move on?
00:46:58 <JRobinson__> that all makes sense :)
00:47:05 <loquacities> great!
00:47:11 <loquacities> we can discuss this more as we go on, anyway
00:47:15 <loquacities> for now it's all in theory :)
00:47:22 <loquacities> #topic Liberty specs in review
00:47:28 <loquacities> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
00:47:39 <loquacities> the only two in flight right now are these ones:
00:47:39 <adahms> Hello, hello - sorry loquacities
00:47:46 <loquacities> #link https://review.openstack.org/183138 (Install Guide RST conversion)
00:47:49 <loquacities> hi adahms!
00:47:50 <adahms> Meeting heavy day today
00:47:57 <loquacities> yeah, it happens :)
00:48:10 <loquacities> so this blueprint is the one karin drafted during summit
00:48:22 <loquacities> be sure to check that out, it covers the install guide changes and RST conversion
00:48:33 <loquacities> #link https://review.openstack.org/#/c/177934/ (API work)
00:48:40 <loquacities> this is anne's one for the API work
00:48:49 <loquacities> there's some interesting changes coming there, too
00:49:07 <loquacities> the other outstanding specs right now are training guides
00:49:30 <loquacities> but bear in mind that now that we have a liberty plan, all the specs will be starting to push through
00:49:37 <loquacities> any questions on specs?
00:50:45 <JRobinson__> Seems to be clear
00:50:59 <loquacities> ok
00:51:07 <loquacities> #topic Specialty teams
00:51:21 <loquacities> not a lot of action from the speciality teams because summit
00:51:26 <loquacities> but here's the current state of play:
00:51:35 <loquacities> #info HA Guide - Sprint during design summit. RST outline now available.
00:51:46 <loquacities> #info Install Guides - Preparing blueprint/spec for RST conversion
00:51:55 <loquacities> #info User Guides - Preparing for RST conversion of the Cloud Admin Guide
00:52:04 <loquacities> #info Security Guide - No update, but needs love. Lana to touch base with Nathaniel.
00:52:12 <loquacities> #info API docs - Please look at the new spec
00:52:20 <loquacities> #info Networking Guide - Test & review. Blueprint/spec to be created for Liberty work.
00:52:41 <loquacities> anything i missed on speciality teams?
00:54:21 <katomo> Ops Guide?
00:54:35 <loquacities> ah, good point
00:54:44 <JRobinson__> I think that's all for the user guide team. Moving to RST cloud admin is the next step
00:54:45 <loquacities> i don't have an update, but it needs some love
00:55:24 <loquacities> it also doesn't currently fall into a specific speciality team, so that probably requires some thought
00:55:33 <loquacities> ideally, all books would have a speciality team dedicated to them
00:56:07 <loquacities> there was also some discussion about removing the upgrades section from the ops guide and putting it somewhere else (TBD where)
00:56:52 <loquacities> ok, i think that's all for that side of things
00:56:59 <loquacities> #topic APAC Meetups
00:57:06 <loquacities> #info Planning for an APAC OpenStack meet up in June, ping asettle & adahms
00:57:22 <loquacities> one thing summit taught me is that the arch guide is definitely recognised as needing work
00:57:26 <adahms> Heya
00:57:44 <adahms> We spoke about this during the last meeting, but there is going to be a lot on during June - July on our side
00:57:45 <loquacities> so the swarm is definitely welcomed by the larger docs community :)
00:57:48 <asettle> loquacities well that's good
00:57:52 <adahms> Yeah, that'll be cool
00:58:07 <loquacities> oops, i've mixed my agenda items
00:58:16 <loquacities> #info Planning for APAC Docs Swarm on 13-14 August, ping Suyog
00:58:20 <asettle> loquacities it's all planned out from my side
00:58:29 <loquacities> asettle: great!
00:58:41 <loquacities> so, do we need to pick a different time for the meetup then?
00:58:58 <JRobinson__> sorry, forgot that the swarm was covered and only reminders are needed closer to the date itself
00:59:01 <loquacities> i think the original plan was to have one soon after summit?
00:59:24 <adahms> Yes, but I just don't think it is going to be feasible at this stage
00:59:26 <loquacities> JRobinson__: i'd like to keep it on the agenda, if that's ok
00:59:31 <asettle> IT was, however, Red hat was unable to come :(
00:59:36 <loquacities> right, ok
00:59:39 <JRobinson__> Wednesday turned out to be a meeting intense day
00:59:50 <JRobinson__> (Wednesday June 3)
01:00:10 <loquacities> ok, maybe we should leave it up to adahms to find a time that works for the RH writers?
01:00:23 <loquacities> i think monday or friday is usually easiest for my team
01:00:28 <asettle> Usually, yep :)
01:00:31 <JRobinson__> loquacities, I can't see any issues with keeping it there as long as meeting managers are okay with the brief ping once in a while
01:00:32 <loquacities> as JRobinson__ said, wednesdays get meeting-heavy
01:00:51 <adahms> Understood
01:00:52 <loquacities> JRobinson__: yeah, i just don't want it dropping off the radar
01:00:59 <JRobinson__> makes sense, yes
01:01:28 <loquacities> ok, adahms can i add an action item for you?
01:01:35 <adahms> Sure
01:01:49 <loquacities> #action adahms to find a suitable openstack meetup time soonish
01:01:52 <loquacities> thanks :)
01:02:11 <loquacities> #topic Meeting time
01:02:19 <loquacities> #info Now on alternating weeks, OpenStack ical is being updated today
01:02:27 <loquacities> #info Shilla is running the US meeting
01:02:35 <loquacities> any questions on the meeting administrivia?
01:03:55 <loquacities> ok, that's it for formal agenda items for today
01:04:00 <loquacities> #topic Open discussion
01:05:07 <loquacities> alright, thanks everyone
01:05:21 <berndbausch> cheers
01:05:26 <loquacities> o/
01:05:27 <darrenc> thanks!
01:05:40 <JRobinson__> thank you o/
01:05:40 <loquacities> #endmeeting