00:32:09 <loquacities> #startmeeting docteam
00:32:10 <openstack> Meeting started Wed Jun 10 00:32:09 2015 UTC and is due to finish in 60 minutes. The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:32:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:32:13 <openstack> The meeting name has been set to 'docteam'
00:32:28 <loquacities> hello documentation lovelies!
00:32:37 <bmoss> hello!
00:32:40 <loquacities> who is here?
00:32:40 <JRobinson__> o/ hello
00:32:44 <darrenc> hello!
00:32:46 <pshige> o/
00:32:56 <adahms> Morning all!
00:33:01 <sunny-dee1> hey
00:33:13 <loquacities> pshige: welcome!
00:33:26 * loquacities quickly adds ironic docs to the agenda, and hopes no one notices
00:33:31 <loquacities> sunny-dee! great to see you!
00:33:45 <pshige> :)
00:33:59 <sunny-dee> loquacities: i'm blushing
00:33:59 <bmoss> what's ironic is that you posted that to the list while expressing the desire that no one notices.
00:34:02 <loquacities> sicarie: hi :)
00:34:06 * sicarie tries to sneak in quietly
00:34:08 <loquacities> bmoss: sssh!
00:34:12 <loquacities> (i think they're on to me!)
00:34:21 <loquacities> sicarie: failed, sorry :P
00:34:27 <loquacities> furface, suyog hello!
00:34:30 <sicarie> that’s about how my day is going
00:34:33 <sicarie> hello!
00:34:33 <bmoss> eh, it's like rain on your wedding day, or free ride when you've already paid.
00:34:34 <furface> hey loquacities :)
00:34:35 <suyog> hi, loquacities!
00:34:59 <loquacities> alrighty, let's get rolling ...
00:35:11 <loquacities> #topic Action items from the last meeting
00:35:31 <loquacities> none from the US meeting
00:35:57 <loquacities> and one for adahms about the APAC openstack meetup
00:36:05 <adahms> Yep
00:36:06 <loquacities> we might hit that one later on in the agenda, so let's move right along
00:36:22 <adahms> Roger that
00:36:30 <loquacities> #topic Install and Config Reference have now been branched for Kilo.
00:36:38 <loquacities> #info To backport, commit to master with Backport: Kilo in your commit message.
00:36:45 <loquacities> that shouldn't be news to anyone at this point
00:36:49 <loquacities> any questions on the kilo branch?
00:37:16 <loquacities> #topic core team changes
00:37:23 <loquacities> #info Please welcome our new core Darren Chan, and bid a fond adieu to Summer Long and Bryan Payne
00:37:57 <loquacities> gee, don't all speak at once :P
00:38:05 <asettle> Woah
00:38:05 <bmoss> Hello Goodbye
00:38:05 <asettle> Sorry
00:38:06 * darrenc takes a bow
00:38:10 <bmoss> quoth the Beatles
00:38:12 <loquacities> lol
00:38:15 <JRobinson__> Darren congratulations :)
00:38:16 <adahms> Welcome darrenc!
00:38:18 <asettle> YAY darrenc
00:38:21 <loquacities> any beatles quote is ok by me :)
00:38:26 <sicarie> congrats darrenc!
00:38:34 <suyog> Congrats, darrenc!
00:38:48 <darrenc> thanks!
00:38:49 <pshige> Congratulations!
00:38:59 <loquacities> #topic Please ensure any bug you work on has been triaged first. This is to prevent unnecessary work.
00:38:59 <JRobinson__> Summer and Bryan - Sad to see you both go :( your patches and expertise and skills were stellar.
00:39:11 <loquacities> so, this one is just a PSA, really
00:39:31 <loquacities> we've noticed a few patches we had to nuke from orbit just before they gated
00:39:49 <loquacities> so making sure someone else has triaged your bug before you work on it is a Really Good Idea (tm)
00:40:03 <loquacities> if you're desperate to get started, feel free to ping someone in the IRC channel or on the list
00:40:13 <loquacities> there should be a core around in most timezones
00:40:21 <loquacities> any questions on that one?
00:40:26 <JRobinson__> Could we flag that as info? re: collaborate to get triage and patches moving
00:40:40 <loquacities> JRobinson__: go right ahead :)
00:40:50 <loquacities> anyone can use the info tag, not just me :P
00:41:14 <JRobinson__> #info Make sure someone else has triaged your bug before work stars. Contact writers in IRC or the list for help
00:41:21 <loquacities> thanks!
00:41:26 <loquacities> ok, that's it for the PSAs
00:41:34 <loquacities> #topic Liberty specs in review
00:41:41 <loquacities> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
00:41:48 <loquacities> #link https://review.openstack.org/183138 (Install Guide RST conversion)
00:41:53 <loquacities> #link https://review.openstack.org/#/c/177934/ (API work)
00:42:05 <loquacities> #info there's also a few training specs, that probably need love
00:42:21 <loquacities> any issues or questions on specs in flight?
00:43:00 <loquacities> ok, let's roll over to speciality team updates ...
00:43:04 <loquacities> #topic Specialty teams
00:43:17 <loquacities> #info HA Guide - RST Underway: https://blueprints.launchpad.net/openstack-manuals/+spec/improve-ha-guide
00:43:30 <loquacities> #info Install Guides - Spec now up for review https://review.openstack.org/183138
00:43:39 <loquacities> #info User Guides - Cloud Admin Guide RST conversion now underway
00:43:45 <bmoss> just a note on this
00:43:50 <loquacities> #link https://wiki.openstack.org/wiki/Documentation/Migrate#Cloud_Admin_Guide_Migration
00:43:53 <loquacities> bmoss: go ahead
00:44:15 <bmoss> Sam-I-Am has audited the networking information in the Cloud Admin Guide, and much of it may be taken out.
00:44:30 <bmoss> So for now please focus RST migration efforts on other sections of the guide
00:44:58 <loquacities> cool, thanks bmoss
00:45:10 <loquacities> you should do that as an info, too, so it goes in the minutes ...
00:45:12 <JRobinson__> #info for the Cloud Admin RST conversion, avoid networking content since the networking content may change soon
00:45:25 <bmoss> JRobinson__ has my back. :)
00:45:26 <loquacities> thanks JRobinson__ :)
00:45:31 <loquacities> he's all over it :P
00:45:35 <JRobinson__> that's right :)
00:45:39 <loquacities> #info Security Guide - No update, but needs love. Lana to touch base with Nathaniel.
00:45:47 <loquacities> i confess, i haven't done this
00:45:47 <asettle> Noted (since I was on the networking stuff)
00:45:47 * sicarie waves hello
00:45:53 <loquacities> hi sicarie :)
00:46:00 <loquacities> i'm sorry i haven't emailed you about this yet
00:46:01 <sicarie> That’s why I’m here - I deliver!
00:46:05 <sicarie> no worries
00:46:07 <loquacities> and i'm excited you came!
00:46:15 <loquacities> (makes me look less slack :P )
00:46:22 <sicarie> hehe
00:46:32 <sicarie> So we have several contributors waiting on the RST migration as well: https://bugs.launchpad.net/openstack-manuals/+bug/1463111
00:46:33 <openstack> Launchpad bug 1463111 in openstack-manuals "OpenStack Security Guide - Convert to RST format" [High,Triaged]
00:46:50 <sicarie> I’d like to outline what work is needed there, put it in that bug, and volun-script helpers in the sec-guide meeting
00:47:07 <loquacities> ohhhh, i didn't realise that was going ahead in this release
00:47:25 <sicarie> I just saw the HAGuide and Cloud Admin Guide, so I’ll go through there, but any outline on how to proceed, what is automated, and what isn’t would be awesome
00:47:46 <sicarie> loquacities: yeah, we were trying to delay it, but there are several significant sections where contributors just don’t want to deal with docbook
00:48:14 <sicarie> I say they deal with python syntax rules, docbook should be fine, but I seem to be in the minority on that
00:48:18 <loquacities> sicarie: #link https://wiki.openstack.org/wiki/Documentation/Migrate
00:48:27 <sicarie> awesome
00:48:33 <loquacities> ok, we can handle that
00:48:56 <loquacities> i also wouldn't mind a blueprint+spec, if that's possible?
00:49:05 <sicarie> Yep, will do that as soon as the work is scoped
00:49:09 <loquacities> excellent
00:49:13 <loquacities> keep me posted :)
00:49:17 <sicarie> will do
00:49:27 <loquacities> thanks sicarie
00:49:34 <sicarie> other than that I’m working on the Networking security section with Edgar, and starting the Compute review
00:49:39 <sicarie> those are in-flight, nothing else major
00:49:44 <loquacities> cool beans
00:50:01 <loquacities> let's move on to the final few speciality teams, then
00:50:04 <loquacities> #info API docs - Please look at the new spec
00:50:16 <loquacities> #info Networking Guide - Test & review.
00:50:26 <loquacities> #info Ops/Arch Guides - New speciality team! Thanks Shilla https://wiki.openstack.org/wiki/Documentation/OpsGuide
00:50:34 <loquacities> #info Config Ref - New speciality team! Thanks Guavain Details TBA
00:51:00 <loquacities> #info also, FYI, we now have a speciality team catch all page to keep track: #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams
00:51:16 <loquacities> any further questions on speciality teams before we move on?
00:51:53 <loquacities> #topic APAC Meetups
00:52:03 <loquacities> #info Planning for an APAC OpenStack meet up in June, ping asettle & adahms
00:52:09 <loquacities> adahms: this is your moment!
00:52:11 <adahms> Heya
00:52:15 <adahms> :)
00:52:30 <adahms> Not much change from the last time we met, I'm afraid
00:52:34 <asettle> adahms, was going to let us know if there was a date in the near to distant future (before swarm) if we can meet
00:52:35 <asettle> Ah
00:52:46 <adahms> Given how much is going on over the next few months, I think the next logical time to meet up will be the swarm
00:52:49 <loquacities> bummer
00:53:01 <loquacities> ok, np
00:53:12 <adahms> It's just going to be a really busy time of year, I'm afraid :(
00:53:17 <loquacities> #info Planning for APAC Docs Swarm on 13-14 August, ping Suyog
00:53:22 <loquacities> adahms: i know them feels
00:53:27 <suyog> hello
00:53:29 <loquacities> hi!
00:53:44 <asettle> The room is all booked and accounted for, suyog ? :)
00:54:03 <suyog> It is. Though any Pizza/food has to be consumed on level 1.
00:54:06 <suyog> :)
00:54:16 <loquacities> man, such draconic measures!
00:54:28 <bmoss> I like how pizza is a separate category from food
00:54:34 <loquacities> asettle: can you please send me an email to remind me to chase rackspace swag?
00:54:38 <adahms> There is pizza, though - this is a good thing
00:54:44 <loquacities> bmoss: it is its own food group
00:54:45 <asettle> loquacities, can do.
00:54:47 <loquacities> ta
00:54:48 <bmoss> indubitably!
00:54:57 <suyog> ha ha.. and i like that category is owned by Rackspace :)
00:55:07 <loquacities> so, i know asettle and sunny-dee have been discussing the architecture of that book
00:55:16 <loquacities> is there anything we need to know about that at this stage?
00:55:44 <asettle> Nothing at the moment. I was talking with bmoss and I haven't heard anything back other than Shilla and her team are happy to help us out
00:55:50 <loquacities> ok, neat
00:55:55 <loquacities> let's move on, then
00:56:02 <loquacities> #topic Ironic Docs
00:56:24 <loquacities> so, devananda and i discussed this at summit
00:56:24 <pshige> I'd like to start discussing on Ironic documentation for Liberty.
00:56:40 <loquacities> (ping mrda you might be interested here)
00:57:08 <pshige> at the cross-project workshops?
00:57:08 <loquacities> so, docs don't currently have capacity to bring ironic docs into our repo
00:57:33 <loquacities> pshige: that's right
00:57:54 <loquacities> however i agreed that what we could do is identify a speciality team to help out with editing/writing support
00:58:26 <loquacities> so the ironic docs get writing help to polish them up, but they'll remain in the ironic repos
00:59:41 <loquacities> i think at this stage we need a good idea of what docs you need help with, so we can best identify a team to help you out
01:00:55 <loquacities> pshige: ??
01:01:07 <pshige> maybe we should start with the install guide
01:01:11 <loquacities> ok
01:01:22 <loquacities> that's often a good place to start :)
01:01:32 <pshige> http://docs.openstack.org/developer/ironic/deploy/install-guide.html
01:02:03 <loquacities> #action: Lana to work with Ironic dev team to identify a docs speciality group to help with updating the Ironic Install Guide http://docs.openstack.org/developer/ironic/deploy/install-guide.html
01:02:07 <pshige> please give us a lot of help to polish it.
01:02:14 <loquacities> we can absolutely do that
01:02:33 <loquacities> it seems instantly logical to me to ask the install guide team, but they're also in the middle of a major RST conversion, so i'll get back to you on that
01:03:06 <loquacities> ok, that wraps up all the formal agenda items i had!
01:03:14 <loquacities> #topic Open discussion.
01:03:14 <pshige> Thank you!
01:03:20 <loquacities> no trouble pshige
01:03:25 <loquacities> thanks for coming along :)
01:03:34 <loquacities> it's great to have representation from the other groups here from time to time
01:04:25 <loquacities> no other points of order?
01:04:41 <suyog> Nothing from me.
01:04:50 <loquacities> easy, ok
01:04:51 <JRobinson__> One email conversation from the openstack-docs list:
01:04:57 <loquacities> JRobinson__: hit me!
01:05:02 <JRobinson__> Common files in RST conversion can turn up build errors
01:05:38 <JRobinson__> #info If a common file is in the toc of one guide, consider moving it into the source file for that guide to prevent build errors
01:05:40 <darrenc> JRobinson__: use the :orphan: directive
01:06:02 <loquacities> oh, is that the repetition issue bmoss was seeing a while back?
01:06:07 <bmoss> yep
01:06:11 <bmoss> it persists
01:06:19 <loquacities> right, we might add that to the PSAs for the next meeting
01:06:20 <bmoss> :orphan: is the easiest workaround
01:06:24 <JRobinson__> #info And the :orphan: directive marking on the file can also prevent sphinx marking the doc as an error
01:06:27 <loquacities> and stick it in the what's up doc for this week, too
01:06:31 <bmoss> but it is a bit of a pain that we need to work around it.
01:06:33 <JRobinson__> thanks darrenc
01:07:18 <loquacities> yep, thanks for letting me know
01:07:29 <JRobinson__> np, loquacities bmoss thanks also
01:07:56 <loquacities> ok, thanks everyone
01:08:16 <loquacities> if there's nothing else ... ?
01:08:16 <bmoss> thanks loquacities
01:08:19 <sicarie> loquacities: thanks!
01:08:25 <suyog> Thanks, loquacities.
01:08:25 <pshige> thanks all!
01:08:29 <loquacities> #endmeeting