00:30:59 <loquacities> #startmeeting docteam
00:31:00 <openstack> Meeting started Wed Jun 24 00:30:59 2015 UTC and is due to finish in 60 minutes.  The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:31:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:31:03 <openstack> The meeting name has been set to 'docteam'
00:31:19 <loquacities> #topic Action items from the last meeting
00:31:40 <loquacities> the only action item i have was on me: Lana to work with Ironic dev team to identify a docs speciality group to help with updating the Ironic Install Guide http://docs.openstack.org/developer/ironic/deploy/install-guide.html
00:31:52 <adahms> Morning!
00:31:58 <loquacities> i'm happy to report that is now underway, it has its own agenda item
00:32:01 <loquacities> morning adahms :)
00:32:04 <bmoss> yay!
00:32:23 <loquacities> ok, let's review specs:
00:32:34 <loquacities> #topic Liberty specs in review
00:32:44 <loquacities> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
00:32:58 <loquacities> nothing too dramatic going on here:
00:33:03 <loquacities> #link https://review.openstack.org/191074 (Debian Install Guide)
00:33:12 <loquacities> #link https://review.openstack.org/#/c/191041/ (Driver docs - requires discussion)
00:33:18 <loquacities> #link https://review.openstack.org/#/c/191077/ (Install Guide Liberty update - WIP)
00:33:23 <loquacities> #link https://review.openstack.org/#/c/177934/ (API work)
00:33:41 <loquacities> so, a couple of install guide pieces (you'll notice the RST conversion one is merged now)
00:33:50 <JRobinson__> the debian install guide rewrite is underway
00:34:01 <loquacities> JRobinson__: they've started?
00:34:17 <JRobinson__> ^the spec for the debian install guide rewrite is underway
00:34:17 <loquacities> the spec isn't approved yet
00:34:24 <JRobinson__> sorry, not clear
00:34:25 <loquacities> oh, right
00:34:33 <loquacities> i got worried for a minute there ;)
00:34:39 <loquacities> hi ShillaSaebi :)
00:34:40 <ShillaSaebi> hello
00:34:42 <ShillaSaebi> :)
00:34:56 <loquacities> yeah, there's still some back-and-forth on the debian install guide
00:35:04 <loquacities> i'm not expecting that work to start for a while yet
00:35:27 <loquacities> ok, let's move on to speciality team reports:
00:35:30 <loquacities> #topic Specialty teams
00:35:38 <loquacities> #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams
00:35:49 <loquacities> #info HA Guide - RST migration underway: #link https://blueprints.launchpad.net/openstack-manuals/+spec/improve-ha-guide
00:35:58 <loquacities> #info Install Guides - RST migration now underway, sign up here: #link https://wiki.openstack.org/wiki/Documentation/Migrate#Installation_Guide_Migration
00:36:05 <loquacities> #info Networking Guide - Test & review for Liberty updates.
00:36:12 <loquacities> #info Security Guide - RST conversion in planning.
00:36:19 <loquacities> #info User Guides - Cloud Admin Guide RST conversion now underway https://wiki.openstack.org/wiki/Documentation/Migrate#Cloud_Admin_Guide_Migration
00:36:27 <loquacities> #info Ops/Arch Guides - New speciality team! Thanks Shilla #link https://wiki.openstack.org/wiki/Documentation/OpsGuide
00:36:34 <loquacities> #info API docs - Please review the spec #link https://review.openstack.org/#/c/177934/
00:36:40 <loquacities> #info Config Ref - New speciality team! Thanks Guavain #link https://wiki.openstack.org/wiki/Documentation/ConfigRef
00:36:48 <loquacities> ok, that's a lot of info
00:37:04 <loquacities> does anyone have any questions or updates on speciality team news?
00:37:26 <Zucan> We want to get started on converting the ops guide to rst.
00:37:32 <loquacities> um
00:37:40 <loquacities> really?
00:37:45 <ShillaSaebi> well we have our first meeting this week
00:37:45 <Zucan> Is that okay? :)
00:37:50 <ShillaSaebi> we haven't decided on anything  yet
00:37:59 <ShillaSaebi> we will be meeting on Thurs
00:38:00 <loquacities> i would hold off on that for the time being
00:38:03 <loquacities> for a couple of reasons
00:38:16 <loquacities> 1. we need to check what o'reilly requirements we have there first
00:38:31 <loquacities> and 2. we have a *lot* of RST conversion going on right now, and i'm worried we're taking on too much
00:38:39 <ShillaSaebi> +1 that makes sense
00:38:41 <loquacities> what time is the meeting?
00:38:48 <ShillaSaebi> let me check my cal
00:38:57 <Zucan> 1. makes sense.  for 2. not all of us are on other doc teams... :)
00:39:09 <ShillaSaebi> 3-4 UTC
00:39:11 <loquacities> i can probably find out the o'reilly requirements pretty easily, so i'll try to get that to you before your meeting
00:39:16 <JRobinson__> arch guide meeting: Thursdays starting June 18 at 1500 UTC in in #openstack-meeting-3
00:39:17 <ShillaSaebi> thanks Lana
00:39:21 <Zucan> Thank you :)
00:39:37 <ShillaSaebi> JRobinson_ is that something worth adding to the wiki page for the specialty teams
00:39:42 <ShillaSaebi> I didn't see it there last time
00:39:43 <loquacities> hold on, 0300 or 150 UTC?
00:39:46 <loquacities> 1500*
00:39:49 <ShillaSaebi> 1500!!
00:40:07 <ShillaSaebi> UTC time conversions - not my strong suit
00:40:11 <ShillaSaebi> I'll get there :)
00:40:14 <loquacities> Zucan: i appreciate that not everyone is working on other teams, but a lot of people are
00:40:22 <Zucan> Agreed
00:40:31 <loquacities> and i'm worried that working on too many conversion projects will take focus away from closing bugs
00:40:38 <JRobinson__> I copied that from the team page at https://wiki.openstack.org/wiki/Documentation/OpsGuide
00:40:45 <loquacities> we're already seeing a drop off in the number of reviews coming through
00:41:17 <ShillaSaebi> yeah we need to first have our meeting, discuss with team and probably start with clean up
00:41:19 <ShillaSaebi> and updating
00:41:25 <loquacities> 25 june?
00:41:31 <ShillaSaebi> yes
00:41:55 <loquacities> ok, that's bad timing for me, but i'll definitely get some info together for you, if i can
00:42:20 <loquacities> #action loquacities to investigate if an ops guide RST conversion is feasible, and report back to the ops guide team
00:42:31 <ShillaSaebi> thank you
00:42:34 <loquacities> np
00:42:50 <loquacities> anything else on speciality teams before we move on?
00:43:32 <loquacities> ok, let's move on then
00:43:40 <loquacities> #topic Doc tools update:
00:43:46 <loquacities> #info openstack-doc-tools 0.29.1 has been released. This fixes a translation bug in 0.29.0
00:44:10 <loquacities> andreas and the i18n team discovered that the 0.29 update broke RST translation
00:44:32 <loquacities> so they've quickly fixed that and released 0.29.1
00:44:39 <katomo> sorry :-(
00:44:51 <loquacities> haha katomo, no sorry needed!
00:44:55 <loquacities> finding bugs is good :)
00:45:11 <loquacities> please do tell us if you discover any more!
00:45:24 <JRobinson__> good news that the translation was repaired
00:46:07 <loquacities> indeed :)
00:46:15 <loquacities> #topic Docs Liaisons
00:46:24 <loquacities> #info Don't forget our lovely liaisons when you're working on a bug, or asking for reviews: #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#Documentation
00:46:37 <loquacities> i've been chatting to our liaisons a bit over the past couple of weeks
00:46:52 <loquacities> and one of hte main requests i'm getting is that you add them to reviews or bugs as you're going
00:47:21 <loquacities> so, if you're working on a nova bug, or have a docs patch in that discusses nova, make sure you cc in the nova liaisons
00:47:25 <loquacities> (for example)
00:47:57 <loquacities> any questions on that?
00:48:04 <ShillaSaebi> nay
00:48:10 <loquacities> great
00:48:12 <katomo> none
00:48:20 <loquacities> #topic i18n Team
00:48:38 <loquacities> #info Remember to keep #link https://wiki.openstack.org/wiki/I18nTeam/docs-translation#Document_categorize updated
00:49:18 <loquacities> if you're working on a doc that is translated, then you need to keep our translators in mind, and helping them to make sure they're not translating and retranslating unecessarily
00:49:34 <loquacities> any questions on translation?
00:49:59 <loquacities> great, let's move on
00:50:11 <loquacities> #topic Ironic Docs
00:50:20 <loquacities> #info Shilla, Gauvain, and Nick are going to be working on reviewing the Ironic Install Guide. If you want to help, please ping Lana.
00:50:40 <loquacities> there's some contention over standards on this at the moment, which we're trying to work out
00:50:53 <loquacities> i'll email the ironic PTL today and try to come to some conclusion on this soon
00:51:06 <ShillaSaebi> yeah i think that would be great
00:51:18 <loquacities> ShillaSaebi: sorry it turned into a bit of a mess :(
00:51:22 <ShillaSaebi> I got a number of my team mates at Comcast to help with them too and it seems like all the doc reviews are -1 and -2 at this moment
00:51:34 <ShillaSaebi> yeah i think once we can agree on the standard, we can move on. no worries!
00:51:45 <loquacities> are you able to send me a list of the current reviews, so that we can get this sorted? (email would be great)
00:51:52 <ShillaSaebi> yes absolutely
00:52:09 <loquacities> yeah, it's frustrating that things are getting marked -1 because of a standards issue
00:52:26 <loquacities> but i'm sure we can come to a agreement here, one way or another
00:52:33 <ShillaSaebi> yup I think so too
00:52:37 <loquacities> :)
00:52:42 <ShillaSaebi> :D
00:52:44 <loquacities> ok, moving on to APAC meetups ...
00:52:50 <loquacities> #topic APAC Meetups
00:52:59 <loquacities> #info Planning for an APAC OpenStack meet up, ping asettle & adahms
00:53:07 <loquacities> obviously this isn't happening in June
00:53:10 <asettle> Nein
00:53:21 <loquacities> adahms: do you have an idea of when the RH people might be able to make this?
00:53:22 <asettle> I think we should revisit this potentially in August
00:53:31 <asettle> Sorry, July
00:53:33 <asettle> I forgot what month It was
00:53:36 <loquacities> it would be nice to meet before the swarm
00:53:43 <loquacities> yep, i agree
00:53:49 <loquacities> adahms: any chance on a july date?
00:54:33 <adahms> Hmm
00:54:47 <adahms> As mentioned during the last meeting, I think the next time we can catch up with be at the swarm, I'm afraid
00:54:53 <loquacities> hrm, ok
00:55:15 <loquacities> asettle: it might be worth going ahead and doing something in july anyway, with the understanding that the RHers might not make it
00:55:30 <asettle> adahms it doesn't have to be any special amount of time. You all eat lunch, right? We can organise a lunch. We are all WFH so it's easy for us to get to you.
00:55:31 <loquacities> i'm nervous about doing a swarm without having some kind of f2f beforehand to work out details
00:55:54 <asettle> loquacities agreed
00:56:05 <loquacities> and let's make sure we advertise it fairly widely, too
00:56:10 <loquacities> see if we can widen the net a little
00:56:29 <asettle> Mailing list ahoy, and I'll try and get a tweet out so we can get everyone to retweet etc.
00:56:34 <loquacities> yep, good plan
00:56:42 <JRobinson__> So a pre-swarm meeting over lunch event in mid July might work
00:56:44 <loquacities> it might be possible to hang off the openstack meetup group, too
00:56:58 <loquacities> asettle: maybe you could ping tim hildred?
00:56:58 <asettle> loquacities sure. I'll work something out.
00:57:02 <asettle> yeah, good idea.
00:57:04 <loquacities> ok, easy, thanks
00:57:12 <loquacities> #info Planning for APAC Docs Swarm on 13-14 August, ping Suyog
00:57:28 <loquacities> in the absence of suyog, are we all good here at the moment?
00:57:39 <asettle> Yep, it has all been confirmed several meetings in a row.
00:57:42 <asettle> This agenda can be removed
00:57:46 <asettle> Other than mentioning that it *is* happening
00:57:51 <loquacities> i don't want it to drop off right now
00:58:05 <asettle> Sure :)
00:58:10 <loquacities> so, be prepared to continue to be bugged about it :P
00:58:16 <loquacities> ok, final agenda item ...
00:58:16 <asettle> I"m so excited :p
00:58:24 <loquacities> i knew you would be :P
00:58:28 <loquacities> #topic Spotlight bugs:
00:58:33 <loquacities> #info Last week's spotlight bugs: two were closed, the third is in progress. Yay!
00:58:50 <loquacities> i was really happy with how this worked last week, so i'm going to keep doing it
00:59:08 <loquacities> here are the new spotlight bugs, from the newsletter i sent out on friday:
00:59:14 <loquacities> #info #link https://bugs.launchpad.net/openstack-manuals/+bug/1330005 Glance image properties and values (low hanging fruit)
00:59:15 <openstack> Launchpad bug 1330005 in openstack-manuals "Glance image properties and values are not documented" [Medium,Fix released] - Assigned to idzzy (idzzy)
00:59:18 <loquacities> #info #link https://bugs.launchpad.net/openstack-manuals/+bug/1394397 Nova notification_driver
00:59:18 <openstack> Launchpad bug 1394397 in openstack-manuals "notification_driver is poorly documented" [Low,Confirmed]
00:59:23 <loquacities> #info #link https://bugs.launchpad.net/openstack-manuals/+bug/1205402 iPXE ISO boot support
00:59:24 <openstack> Launchpad bug 1205402 in openstack-manuals " xenapi: Added iPXE ISO boot support" [Medium,Confirmed]
00:59:43 <loquacities> ohh, it looks like the first one is done already, too :)
01:00:12 <loquacities> one thing i've noticed going through these is that they are often simple fixes, they're just badly written or described bugs, which is why they've been hanging around
01:00:38 <loquacities> so sometimes it's worth spending the time digging into it a little to find out what really needs to be done
01:00:46 <loquacities> any questions on the spotlight bugs?
01:00:51 <ShillaSaebi> nope
01:01:03 <asettle> Nein
01:01:06 <loquacities> great :)
01:01:11 <JRobinson__> calling them out in the newsletter seems to be a good plan :)
01:01:20 <loquacities> JRobinson__: it's working so far :P
01:01:26 <loquacities> #topic Open discussion
01:01:35 <loquacities> anything else anyone wants to talk about?
01:01:39 <JRobinson__> I had one topic for open discussion:
01:01:46 <JRobinson__> patches without bugs -
01:01:57 <loquacities> yep?
01:02:03 <asettle> Mmm good question, was thinking the same thing. People that spot a bug, but don't report it, just fix it
01:02:05 <JRobinson__> in the case of minor patches one digit changed, or one word
01:02:28 <JRobinson__> And if the person is an experienced or core contributor and knows the docs well
01:03:19 <loquacities> i think with a minor patch, that's fine
01:03:39 <loquacities> i'd be cautious with "i noticed the output of this command is wrong", though
01:03:49 <loquacities> i'd like to see that stuff verified before we change it
01:03:59 <Zucan> It definitely is a slipper slope.
01:04:02 <Zucan> slippery even
01:04:09 <loquacities> or "i ran the command [foo] and it didn't work, but [bar] did"
01:04:17 <loquacities> yeah, i agree
01:04:29 <asettle> oh thre are *so* many of those bugs
01:04:30 <loquacities> as a reviewer, we trust you to use your best judgement on these
01:04:45 <loquacities> if you think it needs to be independently verified, then feel free to mark it down
01:04:57 <loquacities> maybe help the submitter out by creating the bug and/or verifying it, too
01:05:13 <loquacities> most things like that are pretty easy to test in devstack
01:06:02 <loquacities> does that answer the question?
01:06:22 <JRobinson__> #info patches without bugs can be addressed with reviewer best judgement - verify if you feel it's needed, or help the submitter by creating the bug and verifying it correctly in triage stages
01:06:29 <JRobinson__> yes it does, thanks loquacities
01:06:31 <asettle> Cheers
01:06:31 <Zucan> It's one of those things where you would like to do the right thing and submit a bug, but likely, somebody will -1/-2 it because there are other things that need to be done.  SO, i have to agree.
01:06:33 <loquacities> nice work, thanks :)
01:07:01 <loquacities> yeah, typos and wording, etc is fine not to have a bug
01:07:17 <loquacities> anything where we're changing commands should really be independently verified
01:07:39 <loquacities> ohai annegentle
01:07:47 <loquacities> we were just wrapping up ;)
01:08:13 <ShillaSaebi> hi Anne!
01:08:52 <loquacities> ok, anything else?
01:08:59 <ShillaSaebi> i don't have anything
01:09:04 <katomo> none
01:09:05 <Zucan> same here
01:09:07 <loquacities> we still have the room for 22 minutes!
01:09:16 <loquacities> ok, i'm calling it then
01:09:21 <loquacities> thanks for your time everyone o/
01:09:21 <Zucan> we can fill it with bug fixing on the spotlights!
01:09:24 <asettle> Thanks Longgeek
01:09:27 <asettle> loquacities
01:09:29 <asettle> God damn tab complete
01:09:29 <loquacities> Zucan: +1!
01:09:35 <loquacities> lol
01:09:36 <ShillaSaebi> thank you and see you all soon :)
01:09:44 <katomo> thanks
01:09:46 <loquacities> #endmeeting