14:00:11 <ShillaSaebi> #startmeeting docteam
14:00:11 <openstack> Meeting started Wed Jul  1 14:00:11 2015 UTC and is due to finish in 60 minutes.  The chair is ShillaSaebi. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'docteam'
14:00:20 <ShillaSaebi> Hi AJaeger
14:00:24 <Sam-I-Am> morning
14:00:25 <berendt> hi
14:00:26 <ShillaSaebi> hello
14:00:33 <katomo> Hi
14:00:43 <ShillaSaebi> hi everyone
14:00:47 <ShillaSaebi> lets go ahead and get started
14:01:15 <ShillaSaebi> #topic Action items from the last meeting
14:01:39 <ShillaSaebi> loquacities was to investigate if an ops guide RST conversion is feasible, and report back to the ops guide team
14:02:03 <ShillaSaebi> She did and we decided that we will wait until the "M" release to discuss it as there is too much RST conversion going on right now
14:02:20 <ShillaSaebi> this was also communicated with the ops guide team and everyones in the loop from that specialty team
14:02:42 <annegentle> hola!
14:02:53 <ShillaSaebi> hi annegentle!
14:03:09 <annegentle> good-o
14:03:13 <ShillaSaebi> anyone have any questions about the action items?
14:03:18 <ShillaSaebi> hi Zucan
14:03:23 <Zucan> Good morning Shilla!
14:03:29 <ShillaSaebi> ok great
14:03:36 <ShillaSaebi> #topic Liberty specs in review
14:03:48 <ShillaSaebi> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
14:03:58 <ShillaSaebi> #link https://review.openstack.org/191074 (Debian Install Guide)
14:04:03 <annegentle> I ran some numbers and in 4.5 months we converted 133 XML files last release.
14:04:05 <ShillaSaebi> #link https://review.openstack.org/#/c/191041/ (Driver docs - requires discussion)
14:04:15 <ShillaSaebi> #link https://review.openstack.org/#/c/191077/ (Install Guide Liberty update - WIP)
14:04:23 <ShillaSaebi> #link https://review.openstack.org/#/c/177934/ (API work)
14:05:21 <ShillaSaebi> so as of last week the spec for the debian install guide rewrite was underway
14:05:56 <ShillaSaebi> not expecting that work to start for a little while
14:06:08 <ShillaSaebi> ok lets go ahead and move on to specialty teams
14:06:09 <annegentle> is Alex here?
14:06:29 <annegentle> He's addressing questions in the review
14:06:50 <ShillaSaebi> paging Alex
14:06:57 <ShillaSaebi> not sure
14:07:16 <ShillaSaebi> it doesn't appear so
14:07:18 <KLevenstein> Debian install guide you say? :)
14:07:23 <Sam-I-Am> there's some notes on the spec
14:07:27 <Sam-I-Am> and also karin
14:07:29 <annegentle> ok, it's fine to move onward if we're just raising awareness of specs and people are talking in the reviews
14:07:42 <KLevenstein> yeah, there is discussion going on in the reviews
14:08:06 <annegentle> Sam-I-Am: I asked in the review itself to be super specific about what arch differences you'd like to be the same
14:08:07 <ShillaSaebi> ok
14:08:47 <Sam-I-Am> annegentle: mmkay, didnt see that comment yet
14:09:14 <KLevenstein> it just posted
14:09:26 <Sam-I-Am> there we go
14:09:36 <ShillaSaebi> cool
14:09:37 <Sam-I-Am> debian has no support for nova-net with debconf
14:09:39 <Sam-I-Am> so thats already out
14:09:47 <Sam-I-Am> i'll comment when i get a chance
14:09:56 <KLevenstein> thanks, Sam-I-Am
14:10:10 <Sam-I-Am> right now finding bugs in linuxbridge agent :/
14:10:23 <annegentle> right, let's be clear
14:10:32 <annegentle> ok
14:10:53 <annegentle> Driver docs, I've commented on, but don't know if we'll be able to remove those.
14:11:00 <annegentle> Sam-I-Am: are you still pursuing that idea?
14:11:15 <annegentle> I also hadn't heard Lana's take on that one
14:11:21 <Sam-I-Am> annegentle: yeah, sort of waiting on lana
14:11:39 <Sam-I-Am> we need to remove crufty stuff, but i really can't take on any more work (such as vendor relations)
14:11:59 <annegentle> Sam-I-Am: sure
14:12:35 <annegentle> Honestly I don't htink vendors have "another place" to put those docs.
14:12:43 <Sam-I-Am> on their own web sites?
14:12:53 <Sam-I-Am> its a product they sell usually
14:12:54 <annegentle> so I still think our best way forward is what we've already done. just my 2 cents
14:12:55 <annegentle> Sam-I-Am: I asked that and was told they don't have a place
14:12:57 <Sam-I-Am> like vmware nsx
14:13:00 <Sam-I-Am> this is Not Free
14:13:04 <Sam-I-Am> in fact, is WAY not free
14:13:07 <ShillaSaebi> +1
14:13:09 <annegentle> Sam-I-Am: I've worked in enterprise doc enviros where I could see that happeneing.
14:13:36 <annegentle> Sam-I-Am: sure, just saying what I discovered from talking to people last release.
14:13:44 <Sam-I-Am> i find it difficult that a company selling a $$$$ product cant find a place to put docs for it
14:13:56 <Sam-I-Am> i'm sure there's nsx docs on the vmware web site somewhere
14:14:04 <Sam-I-Am> (not that its the only offender)
14:14:29 <annegentle> Sam-I-Am: it was more than vmware, oracle, storage drivers, etc.
14:14:37 <annegentle> Sam-I-Am: sure, again, just stating what I found last release.
14:14:51 <AJaeger> I agree with annegentle
14:15:00 <AJaeger> But I feel Sam-I-Am 's load.
14:15:21 <AJaeger> So, what we said is: Add yourself to the wiki, update it yourself, otherwise we remove it eventually.
14:15:36 <AJaeger> Basically saying: WE review but do not write the content
14:15:45 <Sam-I-Am> annegentle: what i have the most problem with is stale content
14:16:02 <Sam-I-Am> and we're not familiar with the third-party stuff enough to clean it up
14:16:10 <annegentle> Sam-I-Am: yep we all do.
14:16:14 <Sam-I-Am> so we get bugs filed, and the third-party people never fix them
14:16:20 <Sam-I-Am> they just dump crap into the repos
14:16:35 <ShillaSaebi> anyone have bandwidth that can reach out to these third-party people?
14:16:39 <AJaeger> For the config-ref guide, I would just say: No contact listed, remove it. Contact listed: Ask for change, wait, remove if nothing happens.
14:16:42 <ShillaSaebi> is that task even worth pursuing?
14:16:52 <Sam-I-Am> AJaeger: that makes sense
14:17:12 <AJaeger> We reached out for config-ref to many people, annegentle added it to her "What's up doc" as well
14:17:43 <AJaeger> Still, now we would need to go through the guide and remove outdated information with no owners...
14:17:49 * AJaeger currently has no time for this
14:18:01 <annegentle> My current take is that I don't htink we'll get different answers than last time, but Lana may want to reach out anyway to see if answers are different. I do think it's worth pursuing
14:18:01 <annegentle> AJaeger: that's a good idea, just need an assignee
14:18:18 <ShillaSaebi> ok any takers?
14:18:52 <AJaeger> So, for e.g. VMware NSX et al: Add a section to "What'S up doc" asking for contacting us - otherwise content gets removed in two weeks...
14:19:20 <Sam-I-Am> do people read that?
14:19:28 <ShillaSaebi> that sounds fine to me but they may miss that email
14:19:31 <ShillaSaebi> maybe a direct email?
14:19:38 <Sam-I-Am> at least our target audience
14:19:52 <ShillaSaebi> yeah it can easily be missed
14:20:12 <annegentle> ShillaSaebi: haven't found one so far, though jaegerandi and I are on the spec Sam-I-Am posted... so blocking the spec until we get assignees
14:20:12 <annegentle> basically that summarizes it
14:20:44 <Sam-I-Am> we need more bodies
14:20:58 <ShillaSaebi> ok we can always send an email to the ML and ask for volunteers
14:21:17 <Sam-I-Am> it would be nice if the devs for the services that have third-party bits could take this on for their project
14:21:34 <Sam-I-Am> they would know the third party bits better than us
14:22:04 <Sam-I-Am> can we ask the liaisons?
14:22:08 <AJaeger> You could ask the neutron doc liason (do we have one) to provide those - or write a specific email to devs with proper subject
14:22:12 <AJaeger> Sam-I-Am: +1 ;)
14:22:12 <annegentle> I also sent email to the third-party ML
14:22:22 <Sam-I-Am> i can probably handle neutron, but... all the other services
14:22:42 <ShillaSaebi> yes we do - Ihar Hrachyshka
14:23:00 <AJaeger> ShillaSaebi: If people don't react, remove it. We can easily readd a change later again...
14:23:06 <Sam-I-Am> AJaeger: +1
14:23:10 <ShillaSaebi> +1
14:23:44 <katomo> +1
14:24:14 <annegentle> sounds good
14:24:17 <ShillaSaebi> ok awesome now the question is, who's going to reach out to the devs
14:24:36 <ShillaSaebi> and we should also run this by Lana
14:25:24 <annegentle> right, set an action for her to circle back on
14:26:18 <ShillaSaebi> ok #action loquacities to circle back on third-party content
14:26:53 <AJaeger> ShillaSaebi: don't put an "ok" before #action
14:26:55 <annegentle> ShillaSaebi: #action has to be at the beginning of the line for note-taking :)
14:27:00 <ShillaSaebi> oh nice thanks
14:27:12 <ShillaSaebi> #action loquacities to circle back on third-party content
14:27:40 <ShillaSaebi> #action Shilla  to e-mail Lana summarizing the solutions for the third-party content
14:28:07 <ShillaSaebi> ok great anything else on this subject?
14:28:22 <Sam-I-Am> nope, just need some movement :/
14:28:33 <ShillaSaebi> yup
14:28:40 <ShillaSaebi> #topic Specialty teams
14:28:56 <ShillaSaebi> #info HA Guide - RST migration underway: #link https://blueprints.launchpad.net/openstack-manuals/+spec/improve-ha-guide
14:29:12 <ShillaSaebi> #info Install Guides - RST migration now underway, sign up here: #link https://wiki.openstack.org/wiki/Documentation/Migrate#Installation_Guide_Migration
14:29:29 <ShillaSaebi> #info Networking Guide - Test & review for Liberty updates.
14:29:39 <ShillaSaebi> #info Security Guide - RST conversion in planning.
14:29:54 <ShillaSaebi> #info User Guides - Cloud Admin Guide RST conversion now underway
14:30:03 <ShillaSaebi> #link https://wiki.openstack.org/wiki/Documentation/Migrate#Cloud_Admin_Guide_Migration
14:30:39 <ShillaSaebi> #info Ops/Arch Guides - New speciality team, had first meeting last week and plan is to work on cleanup and refresh of content as of now
14:30:46 <ShillaSaebi> #link https://wiki.openstack.org/wiki/Documentation/OpsGuide
14:30:55 <ShillaSaebi> #info API docs - Please review the spec #link https://review.openstack.org/#/c/177934/
14:31:17 <ShillaSaebi> #info Config Ref - Another new speciality team! Thanks Guavain #link https://wiki.openstack.org/wiki/Documentation/ConfigRef
14:32:05 <ShillaSaebi> does anyone have any other updates on speciality teams to add?
14:32:08 <Sam-I-Am> i'm working on the network guide scenarios
14:32:24 <Sam-I-Am> also getting some contributions from neutron devs
14:32:33 <ShillaSaebi> thats awesome
14:32:38 <Sam-I-Am> yep
14:32:39 <annegentle> woot
14:32:55 <ShillaSaebi> any other updates on the specialty teams?
14:33:25 <ShillaSaebi> mmmkay moving along
14:33:32 <ShillaSaebi> #topic Doc tools update
14:33:44 <ShillaSaebi> #info openstack-doc-tools 0.29.1 has been released. This fixes a translation bug in 0.29.0
14:34:10 <ShillaSaebi> thank you AJaeger
14:35:13 <annegentle> AJaeger: you want to update? I can.
14:35:13 <annegentle> Basically we have a new openstack-doc-tools release, 0.29, and released version 1.1.0 of openstackdocstheme
14:35:37 <annegentle> oh yes, 0.29.1
14:35:49 <annegentle> thanks for the fixes for translations AJaeger
14:35:59 <ShillaSaebi> yes there was an issue with the 0.29 update that caused problems with RST translation and they've quickly fixed that and released 0.29.1 and thank you!
14:36:56 <ShillaSaebi> ok lets go ahead and move on
14:37:04 <ShillaSaebi> #topic Docs Liaisons
14:37:36 <ShillaSaebi> Don't forget that we have wonderful liaisons when we're working on a bug, or asking for reviews: #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#Documentation
14:37:48 <Sam-I-Am> wish some of them were at these meetings
14:37:55 <ShillaSaebi> yes I agree
14:38:40 <ShillaSaebi> Lana has been communicating with some of these liaisons in the past couple of weeks and one of the requests we are getting is that we add them to reviews or bugs as we're going
14:38:42 <Sam-I-Am> we need to work on this
14:39:15 <Sam-I-Am> most of the docs folks are not involved in any particular non-docs projects
14:39:24 <ShillaSaebi> so as an example, if you're working on a horizon bug, or have a docs patch in that discusses horizon, make sure you cc in the horizon liaisons
14:39:48 <Sam-I-Am> add them to the bug and the patch?
14:39:59 <ShillaSaebi> yes
14:40:36 <ShillaSaebi> any questions on that?
14:40:59 <ShillaSaebi> #topic i18n Team
14:41:08 <ShillaSaebi> #link https://wiki.openstack.org/wiki/I18nTeam/docs-translation#Document_categorize
14:41:56 <ShillaSaebi> if you're working on a doc that is translated, then please keep the translators in mind. We should help them to make sure they're not translating and retranslating unnecessarily
14:42:22 <ShillaSaebi> ok any questions on that
14:42:23 <Sam-I-Am> ShillaSaebi: i'm not really sure how they work
14:42:38 <Sam-I-Am> do they just see changes we make? or go by release
14:43:00 <annegentle> have to drop to get to another meeting in time, will read the notes and log
14:43:01 * annegentle waves
14:43:05 <Sam-I-Am> bye
14:43:07 <ShillaSaebi> bye anngentle
14:43:26 <ShillaSaebi> Sam-I-Am I'm not really sure, AJaeger may have more insight on that
14:43:48 <katomo> Sam-I-Am: translators can see changes at Transifex(translation web service).
14:44:03 <Sam-I-Am> ah
14:44:06 <katomo> Changed strings are pushed automatically.
14:44:30 <katomo> They can find UNtranslated strings.
14:44:37 <Sam-I-Am> ahh
14:44:55 <ShillaSaebi> ok
14:45:21 <janonymous> \o
14:45:55 <ShillaSaebi> ok cool
14:46:04 * AJaeger_ is back, I got disconnected ;(
14:46:08 <ShillaSaebi> welcome back
14:46:45 <ShillaSaebi> ok moving on
14:46:54 <ShillaSaebi> #topic Ironic Docs
14:47:29 <ShillaSaebi> Gauvain, Nick and myself were going to be working on reviewing the ironic install guide
14:47:49 <Sam-I-Am> is there any reason the ironic install guide is in devdocs?
14:47:59 <Sam-I-Am> seems like something that should be in the more official docs
14:48:08 <ShillaSaebi> I think we wanted to move it over but wanted some docs people to review them first
14:48:15 <Sam-I-Am> ok
14:48:26 <ShillaSaebi> so we did that and theres been heavy discussion on conventions
14:48:39 <Sam-I-Am> oh?
14:48:40 <ShillaSaebi> so none of the reviews moved forward
14:48:52 <AJaeger_> Sam-I-Am: spelling of "Bare Metal" vs "Bare metal"
14:49:09 <ShillaSaebi> there's some contention over standards on this at the moment, which we're trying to work out. Lana is suppose to be in touch with the PTL from ironic
14:49:24 <AJaeger_> annegentle is reviewing this with the TC, plan is to create consistency across projects
14:49:49 <ShillaSaebi> #link https://review.openstack.org/#/c/194230/
14:49:52 <Sam-I-Am> AJaeger_: oh, yuck
14:50:02 <ShillaSaebi> #link https://review.openstack.org/#/c/191900/
14:50:14 <ShillaSaebi> yeah feel free to look at those to catch up on what's going on
14:50:29 <ShillaSaebi> it's been a little messy but hopefully will get resolved soon
14:51:04 <ShillaSaebi> any questions on this?
14:51:22 <ShillaSaebi> ok!
14:51:24 <ShillaSaebi> #topic APAC Meetups
14:51:37 <ShillaSaebi> Planning for an APAC OpenStack meet up, ping asettle & adahms
14:51:43 <ShillaSaebi> Planning for APAC Docs Swarm on 13-14 August, ping Suyog
14:51:56 <ShillaSaebi> the APAC OpenStack meetup was originally planned for June but that clearly didn't happen
14:52:32 <ShillaSaebi> any questions/comments?
14:52:44 <ShillaSaebi> #topic Spotlight bugs
14:52:59 <ShillaSaebi> #info Last week's spotlight bugs: two were closed, the third is in progress. Yay!
14:53:08 <ShillaSaebi> #info #link https://bugs.launchpad.net/openstack-manuals/+bug/1330005 Glance image properties and values (low hanging fruit)
14:53:08 <openstack> Launchpad bug 1330005 in openstack-manuals "Glance image properties and values are not documented" [Medium,Fix released] - Assigned to idzzy (idzzy)
14:53:15 <ShillaSaebi> #info #link https://bugs.launchpad.net/openstack-manuals/+bug/1394397 Nova notification_driver
14:53:15 <openstack> Launchpad bug 1394397 in openstack-manuals "notification_driver is poorly documented" [Low,Triaged]
14:53:24 <ShillaSaebi> #info #link https://bugs.launchpad.net/openstack-manuals/+bug/1205402 iPXE ISO boot support
14:53:24 <openstack> Launchpad bug 1205402 in openstack-manuals " xenapi: Added iPXE ISO boot support" [Medium,Won't fix]
14:54:22 <ShillaSaebi> the spotlight bugs seem to be working great, so we will continue bringing these up
14:54:36 <ShillaSaebi> any questions on the spotlight bugs?
14:54:38 <Sam-I-Am> how does one spotlight a bug?
14:55:07 <ShillaSaebi> that's a GREAT question
14:55:13 <ShillaSaebi> they come from the newsletter
14:55:25 <ShillaSaebi> so we should ask Lana who they're chosen
14:55:28 <ShillaSaebi> how*
14:55:59 <ShillaSaebi> #action Shilla to find out how spotlight bugs are chose
14:56:03 <AJaeger_> Sam-I-Am: do you have one you like to spotlight? Consider adding it to loquacities's drafting page for the news letter...
14:56:05 <ShillaSaebi> chosen* aghhh
14:56:19 <ShillaSaebi> yeah thats a good idea
14:56:21 <Sam-I-Am> AJaeger_: oh, i havent seen the drafting page either :/
14:56:36 <AJaeger_> Sam-I-Am: read her news letter completely, it contains a link ;)
14:56:44 <Sam-I-Am> AJaeger_: i figured as much
14:57:10 <AJaeger_> http://lists.openstack.org/pipermail/openstack-docs/2015-June/006865.html - second paragraph
14:57:14 <ShillaSaebi> #link https://wiki.openstack.org/wiki/Documentation/WhatsUpDoc
14:57:31 <ShillaSaebi> ok we've got 3 minutes before we've got to give up the room
14:57:36 <ShillaSaebi> #topic Open discussion
14:57:39 <ShillaSaebi> anything anyone wants to bring up
14:57:56 <Sam-I-Am> this is a serious bug - https://bugs.launchpad.net/keystonemiddleware/+bug/1428317
14:57:56 <openstack> Launchpad bug 1428317 in keystonemiddleware "Turn auth_token plugin config blog post into docs" [High,Triaged] - Assigned to Jamie Lennox (jamielennox)
14:58:08 <Sam-I-Am> although its not in the docs repo
14:58:20 <Sam-I-Am> the primary dev for keystone middleware flat out refuses to write docs
14:58:35 <Sam-I-Am> this will be the second time keystone middleware has undergone significant changes with 0 docs outside of a blog post
14:58:43 <Sam-I-Am> i've had to reverse engineer it both times
14:59:35 <Sam-I-Am> not sure who to contact about that
14:59:42 <Sam-I-Am> maybe the keystone folks
15:00:34 <ShillaSaebi> yeah
15:01:01 <ShillaSaebi> #link https://review.openstack.org/#/q/status:open+project:openstack/keystonemiddleware,n,z
15:01:08 <ShillaSaebi> maybe some of the change owners
15:01:24 <ShillaSaebi> ok looks like we're at time
15:01:27 <Sam-I-Am> yep
15:01:46 <ShillaSaebi> thank you everyone
15:01:50 <ShillaSaebi> i have to jump off for another meeting
15:02:02 <ShillaSaebi> #endmeeting