00:40:24 <loquacities> #startmeeting docteam
00:40:25 <openstack> Meeting started Wed Feb 10 00:40:24 2016 UTC and is due to finish in 60 minutes.  The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:40:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:40:28 <openstack> The meeting name has been set to 'docteam'
00:40:33 <loquacities> sorry for the late start everyone
00:40:42 <elmiko> no worries
00:40:45 <katomo> nop
00:41:12 <Sam-I-Am> hi
00:41:18 <loquacities> heya
00:41:22 <loquacities> thanks for reminding me Sam-I-Am :)
00:41:22 <elmiko> hi
00:41:23 <Sam-I-Am> now i'm here
00:41:26 <katomo> hi
00:41:31 <loquacities> i'd dug down to insane depths on my email ;)
00:41:49 <loquacities> ok, let's go straight to specs
00:41:57 <loquacities> #topic Specs in review
00:42:04 <loquacities> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
00:42:25 <loquacities> #link https://review.openstack.org/#/c/274231/
00:42:36 <loquacities> Installation guide changes for Mitaka
00:42:53 <loquacities> i think i'm a little behind on this one
00:43:06 <Sam-I-Am> yep
00:43:11 <loquacities> i was hoping to chat more about removing the debian guide before we got too far on this
00:43:18 <Sam-I-Am> i'm installing pre-mitaka now :)
00:43:28 <loquacities> for debian?
00:43:43 <Sam-I-Am> no... this is rdo (because i could find packages)
00:43:47 <loquacities> i was thinking it's probably about that time that i should be contacting release-type people for the distros, too
00:43:52 <Sam-I-Am> debian is a lost cause at this point
00:43:56 <loquacities> well, at least we have RDO packages!
00:44:07 <Sam-I-Am> yeah, they built from trunk now which is good and bad
00:44:10 <Sam-I-Am> build
00:44:18 <Sam-I-Am> ubuntu is still milestone 1, so eeoooo
00:44:25 <Sam-I-Am> these are m3
00:44:28 <loquacities> ew
00:44:29 <Sam-I-Am> so.. close.
00:44:36 <Sam-I-Am> enough for me to start figuring out what all changes
00:44:37 <loquacities> also: we have a red hat writer on board, too
00:44:41 <Sam-I-Am> and there's quite a few changes
00:44:49 <loquacities> his name is petr kovar, and he's based in the czech republic
00:44:53 <Sam-I-Am> so far the rdo packages are less broken than usual, so thats a plus
00:45:04 <loquacities> bonus!
00:45:04 <Sam-I-Am> anywho...
00:45:17 <loquacities> ok, that's on my list of things to email people about then
00:45:23 <Sam-I-Am> the changes for rdo will likely impact ubuntu and suse too
00:45:42 <loquacities> yep
00:45:50 <loquacities> when's the next install guide meeting in APAC?
00:45:55 <Sam-I-Am> christian sort of bailed out of heading up the project
00:46:13 <Sam-I-Am> dunno... the US one was today, and i chaired it again
00:46:19 <Sam-I-Am> actually i've always chaired it
00:46:20 <loquacities> ah, next week ok
00:46:26 <loquacities> yeah, i noticed christian hasn't been around much
00:46:34 <Sam-I-Am> he commented on the mitaka spec
00:46:39 <Sam-I-Am> says hes working on some project
00:46:46 <loquacities> we might need to call for volunteers to look after that team again in austin
00:46:54 <Sam-I-Am> the install guide meeting only had 1 other attendee today
00:47:13 <Sam-I-Am> well, regardless of who volunteers, i usually wind up doing it, so i might as well throw my name into that hat
00:47:18 <loquacities> hrm, ok
00:47:32 <Sam-I-Am> should not happen at a summit imo. more e-maily-listy thing.
00:47:37 <loquacities> let's see if we can't rustle up some install guide enthusiasm over the next few weeks, anyway
00:47:41 <loquacities> yeah, we can do that too
00:47:45 <loquacities> anyway, let's move on
00:47:52 <Sam-I-Am> the debian bits :)
00:47:55 <loquacities> #link https://review.openstack.org/#/c/274258/
00:48:06 <loquacities> Convert warnings to errors for local builds
00:48:52 <loquacities> do we need to discuss that at all at this stage?
00:49:18 <Sam-I-Am> its not actually a spec
00:49:22 <Sam-I-Am> its fixing the specs repo
00:49:30 <loquacities> yeah, i was just looking at that
00:49:39 <loquacities> looks like it just needs a workflow
00:49:43 <Sam-I-Am> some bad rst got into our repos
00:49:51 <Sam-I-Am> so i tracked it down
00:50:11 <loquacities> right, got it
00:50:17 <loquacities> #link https://review.openstack.org/#/c/275200/
00:50:24 <loquacities> Manila Installation guide for Mitaka
00:50:52 <loquacities> i thought i told manila ages ago they weren't going in the install guide?
00:51:05 <Sam-I-Am> they seem to have gotten their stuff together
00:51:10 <loquacities> they've been on my case for about six months
00:51:14 <Sam-I-Am> there's a patch waiting that almost meets all of the requirements
00:51:19 <Sam-I-Am> so... if it works... it goes in
00:51:24 <loquacities> is it going to screw things up?
00:51:27 <Sam-I-Am> no
00:51:34 <loquacities> hrm, ok
00:51:38 <Sam-I-Am> so far looks and smells like cinder
00:51:38 <loquacities> i'll trust your judgement on that
00:51:49 <Sam-I-Am> so it can reuse our arch for cinder
00:51:56 <Sam-I-Am> what i didnt want was having to re-arch things
00:51:59 <loquacities> it does kind of undermine the 'defcore only' statement, though
00:52:13 <loquacities> i'm worried it'll open some kind of floodgate
00:52:17 <Sam-I-Am> if all the distros are pushing packages for it, and they work... its good enough.
00:52:24 <loquacities> yeah, that's a fair point
00:52:34 <Sam-I-Am> defcore kind of got murky with the big tent
00:52:35 <JRobinson__> Manila must be closer to reaching maturity levels too.
00:52:47 <loquacities> that's been their main argument all along
00:52:50 <elmiko> yea, pretty sure manila must be close
00:53:01 <loquacities> they wanted to be in the install guide to increase their official maturity
00:53:06 <elmiko> we've integrated it with sahara and i know it's coming in future RDO releases
00:53:06 <Sam-I-Am> so the requirements are a) do packages exist for all distros b) do they work c) can someone else contribute and maintain the content
00:53:33 <Sam-I-Am> its better when services are 'optional'
00:53:39 <loquacities> ok, so here's a q: is a manila person showing up at install guide meetings?
00:53:44 <Sam-I-Am> there was one today
00:53:52 <Sam-I-Am> the ptl, actually
00:53:52 <JRobinson__> ^good question
00:53:58 <loquacities> awesome
00:53:59 <Sam-I-Am> we had a nice long chat
00:54:03 <loquacities> heh
00:54:17 <loquacities> ok, let's move on to speciality teams then
00:54:26 <loquacities> #topic Speciality teams
00:54:40 <loquacities> #link https://etherpad.openstack.org/p/Speciality_Team_Reports
00:54:55 <loquacities> so i've been collected the speciality team reports on this etherpad since the beginning of the year
00:55:04 <loquacities> it's working better than the individual emails i was doing before
00:55:12 <JRobinson__> loquacities, sorry for the delay last week.
00:55:13 <loquacities> and it also gives us a better place to link to for this info
00:55:22 <loquacities> JRobinson__: no trouble, i know you were busy
00:55:31 <JRobinson__> The non email overhead has been greatly appreciated though.
00:55:39 <loquacities> yeah, it seems to be better
00:55:56 <loquacities> so generally i ask for updates on my wednesday, to be completed by around noon on my friday
00:56:05 <elmiko> i think the sec-guide has found someone to work on the neutron chapter
00:56:09 <loquacities> that way, i can get the newsletter out late on a friday afternoon
00:56:16 <loquacities> elmiko: oh, that's good!
00:56:49 <JRobinson__> #info Specialty Team Updates are due Friday. look out for a Wednesday reminder.
00:56:51 <elmiko> but, afaik, we are still working on getting the pdf formatting together
00:56:57 <loquacities> JRobinson__: thanks!
00:57:17 <JRobinson__> np
00:57:17 <loquacities> elmiko: yeah, i was wondering how that was going
00:57:20 <loquacities> is there an update on that?
00:58:59 <elmiko> i know sicarie is investigating it, but he has been pretty loaded up recently
00:59:04 <loquacities> right, ok
00:59:12 <loquacities> i haven't heard anything about it recently
00:59:15 <elmiko> he is getting back to it though
00:59:19 <loquacities> any other comments on speciality teams?
00:59:26 <elmiko> yea, the whole rst->pdf is proving troublesome
00:59:31 <Sam-I-Am> we more or less covered the install guide
00:59:40 <loquacities> elmiko: i'm not terribly surprised, honestly
00:59:40 <Sam-I-Am> networking guide is moving along slowly as usual
00:59:51 <loquacities> Sam-I-Am: yep, install guide is in my sights this week
01:00:00 <loquacities> slowly but surely? ;)
01:00:01 <elmiko> loquacities: par for the course, i suppose ;)
01:00:05 <Sam-I-Am> so much to do, so little time... and people.
01:00:07 <loquacities> elmiko: lol, yep
01:00:12 <Sam-I-Am> plus i've been sucked into networking-ovn
01:00:17 <Sam-I-Am> so thats getting some attention
01:00:25 <JRobinson__> User Guide meeting is still set for tomorrow.
01:00:28 <loquacities> lucky you :P
01:00:30 <loquacities> JRobinson__: thanks
01:00:33 <JRobinson__> No other updates other than that
01:00:44 <Sam-I-Am> also trying to fix neutron's mtu problems
01:00:45 <loquacities> #topic Countdown to release
01:00:48 <Sam-I-Am> thats been a fun one
01:01:11 <loquacities> #info 56 days
01:01:22 <JRobinson__> So about 9 weeks til N release.
01:01:25 <loquacities> #info DocImpact merged; however
01:01:36 <Sam-I-Am> 60 days is usually my trigger for the install guide
01:01:36 <loquacities> heh, bad paste
01:01:49 <loquacities> Sam-I-Am: yeah, i was working on about the same timeframe
01:01:50 <Sam-I-Am> so i was glad a bunch of other stuff broke today and i could spend some time on it
01:02:14 <loquacities> so, docimpact is now merged, and *all* projects are opening docimpact bugs in their own queues
01:02:27 <loquacities> so far, no one has yelled at me over that
01:02:30 <loquacities> which is a nice change
01:02:38 <Sam-I-Am> the neutron folks just find me
01:02:53 <loquacities> they're not stupid ;)
01:03:32 <loquacities> #action loquacities will start contacting release/packaging people for Install Guide
01:03:52 <loquacities> Sam-I-Am: when do you want to start testing, officially?
01:04:15 <Sam-I-Am> right now is the changes/updates period
01:04:20 <Sam-I-Am> like... what breaks in mitaka
01:04:31 <Sam-I-Am> i took a crash course in fernet tokens earlier, for example
01:04:32 <loquacities> yep, so now is the time to work on packages
01:04:44 <Sam-I-Am> #link https://etherpad.openstack.org/p/installguide-mitaka
01:04:48 <Sam-I-Am> thats where the work is going
01:04:49 <loquacities> do you think we can start testing 30 days out?
01:05:01 <Sam-I-Am> more or less 'findings' and changes from them
01:05:05 <loquacities> cool
01:05:07 <loquacities> thanks for that
01:05:29 <Sam-I-Am> yeah in 30 days we should have packages for all distros and be able to test the draft guide, making corrections as necessary
01:05:38 <loquacities> ok, let's roll with that as a plan, then
01:05:59 <loquacities> #info Plan to have testing on Install Guide begin at M-30 days
01:06:14 <loquacities> ok, i think that's all i have on release matters
01:07:01 <loquacities> #Open discussion
01:07:11 <loquacities> #topic Open discussion
01:08:01 <loquacities> anything else to discuss?
01:08:10 <Sam-I-Am> nothing here
01:08:15 <loquacities> cool
01:08:18 <elmiko> nothing from me
01:08:23 <loquacities> ok
01:08:28 <loquacities> thanks everyone :)
01:08:28 <JRobinson__> nothing major to go over.
01:09:01 <loquacities> #endmeeting