19:04:09 <Sam-I-Am> #startmeeting docteam
19:04:10 <openstack> Meeting started Wed Aug  3 19:04:09 2016 UTC and is due to finish in 60 minutes.  The chair is Sam-I-Am. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:04:14 <openstack> The meeting name has been set to 'docteam'
19:04:26 <Sam-I-Am> i'm not really the chair, but no one else is, so here we go
19:04:44 <Sam-I-Am> #topic action items from last meeting
19:05:03 <Sam-I-Am> i dont recall anything in particular
19:05:15 <Sam-I-Am> i was actually at the apac meeting last week
19:05:33 <annegentle_> hey, sorry I'm late
19:05:48 <rcaballeromx> No problem.
19:05:49 <Sam-I-Am> hi anne
19:05:59 <Sam-I-Am> wasnt sure who was chairing this
19:06:06 <annegentle_> I told Shilla I could chair, but looks like you've got it Sam-I-Am -- thanks
19:06:12 <annegentle_> carry on!
19:06:17 <Sam-I-Am> ok
19:06:21 <Sam-I-Am> #topic specs in review
19:06:32 <Sam-I-Am> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
19:07:01 <Sam-I-Am> looks like we only have 3 specs in review, and they've recently received some love
19:07:05 <Sam-I-Am> none of them involve me
19:07:12 <Sam-I-Am> anyone else care to comment on them?
19:07:36 <Sam-I-Am> guess not
19:07:49 <Sam-I-Am> #topic specialty team reports
19:07:59 <Sam-I-Am> anyone from specialty teams here?
19:08:03 <annegentle_> API here
19:08:17 <Sam-I-Am> got anything to tell us?
19:08:46 <annegentle_> sure, the ceilometer/telemetry API reference migration landed today. HURRAH.
19:08:50 <Sam-I-Am> woo
19:08:52 <annegentle_> I think trove is the last one left!
19:09:05 <Sam-I-Am> so all the other services are done?
19:09:08 <annegentle_> We're also getting closer to having the API ref/guides drop-down navigation ready
19:09:36 <annegentle_> Yes. Also check out the new listing of API links generated from projects.yaml the governance repo.
19:09:41 <annegentle_> just a sec hafta find link
19:10:01 <annegentle_> or, well, first things first.
19:10:10 <annegentle_> #info trove API ref migration still in progress
19:10:12 <annegentle_> #link https://review.openstack.org/#/c/316381/
19:10:32 <annegentle_> #info telemetry/ceilometer API ref migration complete, thanks team!
19:10:39 <Sam-I-Am> cool
19:10:46 <Sam-I-Am> looks like the api stuff is catching on
19:10:48 <annegentle_> #info getting closer to having the API ref/guides drop-down navigation ready
19:10:59 <annegentle_> #link https://review.openstack.org/#/c/329508/
19:11:16 <annegentle_> I think we know the order of landing those patches so the web dev stuff holds together.
19:11:28 <annegentle_> Ok, other news on API "completeness"
19:12:19 <annegentle_> #link https://review.openstack.org/#/c/316396/
19:12:25 <annegentle_> that landed yesterday ^^
19:12:33 <annegentle_> So now we can do things like what this patch does
19:12:45 <Sam-I-Am> oh yeah, i remember that one
19:12:46 <annegentle_> #link https://review.openstack.org/#/c/349669/
19:13:28 <annegentle_> So, now we can follow up with the teams who a) don't have API docs or b) have them but won't be in the nav menu
19:13:33 <Sam-I-Am> yay
19:13:37 * Sam-I-Am likes progress
19:13:48 <annegentle_> I think that's the report for this week
19:14:01 <Sam-I-Am> ok, guess we'll hit the networking guide since i'm here
19:14:21 <Sam-I-Am> not a lot going on, but a continuous stream of content patches from networking devs
19:14:30 <Sam-I-Am> i still need to backport the reorg patch
19:14:42 <annegentle_> nice
19:14:49 <Sam-I-Am> then work on updating the scenarios... and of course the endless pile of content that needs love
19:15:13 <Sam-I-Am> any other specialty team reps here?
19:15:36 <Sam-I-Am> #topic liaisons
19:15:45 <Sam-I-Am> anything from doc liaisons here?
19:16:00 <lbragstad> I don't have anything from the keystone side of the house
19:16:26 <annegentle_> oh, I did have an incoming request
19:16:28 <Sam-I-Am> remember that around m3 into rc1, the install guide begins to need updates for the next release
19:16:36 <annegentle_> from rosmaita that's a good idea
19:16:41 <Sam-I-Am> same with the networking guide, or anything else that has config-specific content
19:17:04 <annegentle_> Basically now that we can make nicer status code tables, we should write an example file that contains the status descriptions we'd like to see.
19:17:19 <Sam-I-Am> thats a good idea
19:17:27 <annegentle_> I can take a stab at it, but wanted to ask lbragstad or others, where would you like the example status codes tables to live?
19:17:41 <annegentle_> it's an easy way to do a copy/paste to pre-fill, then add more details per-service later
19:17:50 <lbragstad> annegentle_ hmmm
19:17:53 <annegentle_> lbragstad: do you know about the status table addition? It only went in last week
19:18:01 <lbragstad> annegentle_ not yet
19:18:05 <lbragstad> annegentle_ link?
19:18:15 <annegentle_> lbragstad: yep, getting one
19:18:30 <annegentle_> #link https://review.openstack.org/#/c/349551/
19:18:38 <annegentle_> that's the glance proof-of-concept
19:18:43 <annegentle_> and they look nice
19:19:05 <annegentle_> needs an update in the global requirements
19:19:27 <lbragstad> annegentle_ ah interesting!
19:19:39 <lbragstad> we're encouraging other projects to follow this lead?
19:19:46 <annegentle_> #info now that we can make nicer status code tables, we should write an example file that contains the status descriptions
19:20:29 <annegentle_> lbragstad: yeah I was hoping we'd get all the teams that have their content in rst+yaml to add these status code tables also, but want to find a good way to give them content
19:20:31 <Sam-I-Am> standards are good ideas
19:20:40 <annegentle_> lbragstad: how could we bootstrap it? Ya know?
19:21:05 <annegentle_> lbragstad: and, with the new sidebar nav coming in, teams will need to update the conf.py anyway
19:21:21 <lbragstad> annegentle_ gotcha
19:21:38 <annegentle_> anyway, the point of this meeting is to let people know about it, but also find ways we can give you more stuff to standardize with
19:21:46 <lbragstad> annegentle_ what would the status code description example be like?
19:21:55 <annegentle_> we're at the point where the status codes are consumable but from where
19:22:01 <Sam-I-Am> the release note standardization-ish spec will be nice when its merged/implemented :)
19:22:14 <annegentle_> lbragstad: so it goes into a second yaml file: https://review.openstack.org/#/c/349551/1/api-ref/source/v2/http-codes.yaml
19:22:30 <annegentle_> lbragstad: and what we could do is give the default: text
19:22:39 <annegentle_> and let teams fill in informal: text and also change default:
19:22:52 <annegentle_> but these are standard codes so I'd like to pre-fill somewhat.
19:23:01 <annegentle_> Maybe I just send a note to openstack-dev? with a starter yaml file?
19:23:14 <lbragstad> annegentle_ yeah - that would make sense
19:23:38 <lbragstad> annegentle_ personally - i'd be fine with a super simple template to fill out
19:23:39 <Sam-I-Am> yep
19:23:52 <annegentle_> lbragstad: yeah
19:24:00 <lbragstad> because chances are I'm going to be working through it with various members of my team anyway
19:24:12 <annegentle_> lbragstad: I don't want to sign up for the patching, but can give out a starter file.
19:24:21 <annegentle_> so, ML post ok?
19:24:26 <lbragstad> annegentle_ sure
19:24:33 <rcaballeromx> Yes.
19:24:41 <annegentle_> check.
19:24:47 <annegentle_> Sam-I-Am: feel free to send it as an action
19:25:30 <Sam-I-Am> #action annegentle will post to the dev mailing list regarding status code standardization
19:25:53 <Sam-I-Am> anything else?
19:26:21 <annegentle_> not from here
19:26:24 <Sam-I-Am> #topic newton deliverables
19:26:34 <Sam-I-Am> #link https://wiki.openstack.org/wiki/Documentation/NewtonDeliverables
19:26:44 <Sam-I-Am> tracking what we're trying to complete for newton
19:27:12 <Sam-I-Am> lastly...
19:27:15 <Sam-I-Am> #topic open discussion
19:27:26 <Sam-I-Am> anyone have any other input for the meeting?
19:27:52 <annegentle_> I'll add a line about the file renaming.
19:27:58 <Sam-I-Am> ok
19:28:00 <annegentle_> to the NewtonDeliverables.
19:28:08 <annegentle_> first patch in review for common, woo
19:28:15 <Sam-I-Am> #action annegentle to add file renaming to newton deliverables
19:28:47 <Sam-I-Am> nothing else, we can close it at 30 minutes
19:28:55 <Sam-I-Am> go back and typey typey
19:29:04 <Sam-I-Am> #endmeeting