21:00:07 <loquacities> #startmeeting docteam
21:00:08 <openstack> Meeting started Thu Dec 15 21:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:11 <openstack> The meeting name has been set to 'docteam'
21:01:06 <asettle> Hello
21:01:06 <asettle> o/
21:01:07 <asettle> Sorry
21:01:08 <loquacities> #topic Action items from the last meeting
21:01:10 <asettle> Late to the doccall
21:01:19 <loquacities> doesn't look like we have any actions
21:01:21 <loquacities> asettle: hi!
21:01:25 <asettle> hola!
21:01:28 <loquacities> #topic Specs in review
21:01:30 <asettle> I have stayed awake!
21:01:35 <loquacities> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
21:01:59 <loquacities> #link https://review.openstack.org/408558 	[ha-guide] Proposal to improve the HA guide for Ocata/Pike
21:02:13 <asettle> Hello
21:02:14 <asettle> This is me
21:02:20 <loquacities> indeed :)
21:02:28 <bsilverman_> Hello Alex :slightly_smiling_face:
21:02:31 <asettle> HEYA :D
21:02:50 <asettle> Would love more reviews on this one :) bsilverman_ and the guys from the HA team have had a solid debate, I think we've agreed that it's to stay in the ha-guide
21:03:02 <asettle> So, if the core team is okay with this we should pass it
21:03:08 <asettle> However, we do need a dedicated team
21:03:18 <asettle> 10/10 would recommend that we organise a sprint/swarm of some kind
21:03:27 <bsilverman_> The point about it staying until the arch-guide is in better shape made sense.
21:03:41 <loquacities> agreed
21:03:53 <loquacities> so we just need some core love on that one then
21:03:55 <asettle> bsilverman_: absolutely 10/10 agree
21:03:57 <asettle> I think so, yes
21:04:00 <asettle> And then we can start some planning
21:04:02 <bsilverman_> but at some point I definitely believe it needs to be decentralized again.
21:04:14 <asettle> Planning that should 100% happen in conjunction with the arch guide team. Perhaps we can merge?
21:04:20 <asettle> Merge taems, that is.
21:04:21 <asettle> teams*
21:04:54 <bsilverman_> I think once we get a good handle on what we have, that way Shaun and I can contribute.
21:04:59 <bsilverman_> to HA
21:05:04 <loquacities> cool
21:05:17 <loquacities> ok, the only other one we have is ...
21:05:18 <asettle> Sounds good, perhaps we merge the concentrated efforts. Those who are interested in the HA guide and Arch guide can have a joint specialty team?
21:05:19 <asettle> For now.
21:05:21 <asettle> Sorry.
21:05:30 <loquacities> #link https://review.openstack.org/#/c/391786/  Proposed use case form
21:05:38 <asettle> Sepaking of the arch guide
21:06:05 <bsilverman_> I thought we put this one to bed, but we still haven’t heard from Shaun have we?
21:06:14 <loquacities> it's been banhammered
21:06:19 <asettle> No, I don't believe so. But I think we need to take ownership bsilverman_ he's been very busy with work
21:06:25 <loquacities> i might just abandon it to get it off the radar
21:06:28 <asettle> Shaun's usually okay with that type of ownership
21:06:36 <asettle> Thoughts bsilverman_ ?
21:06:51 <bsilverman_> We’re trying to solve a problem, if we’re going to abandon, we still are left with the problem.
21:07:04 <loquacities> yes, but i'd rather resolve it on the mailing list than in gerrit
21:07:09 <loquacities> same with the HA guide one, tbh
21:07:12 <bsilverman_> So I think we need a new a new proposed solution.
21:07:19 <bsilverman_> yea
21:07:28 <asettle> Okay, perhaps we abandon that particular spec. And then we work on plan B.
21:07:38 <asettle> The HA guide spec should pass. I think that has relevant content that should be worked on.
21:07:39 <loquacities> so, let's leave this out there, and when i get back from leave in jan, i'll follow up both of them on the mailing listy
21:07:41 <loquacities> list*
21:07:41 <bsilverman_> I am guilty of the gerrit abuse on HA :slightly_smiling_face:
21:08:01 <asettle> loquacities: please, that would be good
21:08:02 <loquacities> meh, we all do it, bsilverman_ ;)
21:08:06 <asettle> Add as an action item, loquacities ?
21:08:08 <loquacities> ok, making a note
21:08:10 <loquacities> yep
21:08:14 <asettle> Cool, thanks :)
21:08:20 <bsilverman_> I have no problem with it as written
21:08:20 <loquacities> #action loquacities to follow up on both specs in the new year on the mailing list
21:08:31 <loquacities> ok, let's move on
21:08:39 <loquacities> #topic Speciality teams reports
21:08:48 <loquacities> i suspect we can probably move through this pretty quickly
21:09:00 <loquacities> i only have one speciality team report here, from john
21:09:06 <JRobinson__> Hi all, sorry I was 5 minutes late.
21:09:11 <loquacities> JRobinson__: hi!
21:09:21 <JRobinson__> o/ loquacities
21:09:28 <loquacities> API: Anne Gentle
21:09:31 <loquacities> (not here)
21:09:36 <loquacities> Configuration Reference and CLI Reference: Tomoyuki Kato
21:09:44 <loquacities> (not here)
21:09:49 <loquacities> High Availability Guide: Andrew Beekhof
21:09:56 <loquacities> asettle: did you have anything to report on the HA guide?
21:09:56 <annegentle> loquacities here
21:10:04 <loquacities> oh! hi annegentle!
21:10:09 <annegentle> ohai
21:10:13 <loquacities> sorry, didn't see you sneak in :)
21:10:18 <asettle> loquacities: ping me after API :p
21:10:30 <loquacities> asettle: yep
21:10:43 <annegentle> link: https://review.openstack.org/#/q/status:open+file:api-ref
21:11:36 <annegentle> Only note from API land is that the teams are chugging along -- not many net-new API listings
21:11:44 <annegentle> But plenty of reviews in progress
21:11:48 <loquacities> cool
21:11:53 <loquacities> thanks annegentle
21:11:58 <loquacities> asettle: HA guide?
21:12:02 <asettle> Hey!
21:12:09 <asettle> So, as we saw, the HA guide spec is underway
21:12:20 <asettle> Although regardless of the spec I believe we should be very attentive to the HA guide blueprint at hand
21:12:24 <asettle> https://blueprints.launchpad.net/openstack-manuals/+spec/implement-ha-guide-todos
21:12:28 <asettle> Which is currently underway for anyone interested
21:12:43 <asettle> We are looking to spend some quality time going through the bug list: https://bugs.launchpad.net/openstack-manuals/+bugs?field.tag=ha-guide
21:12:55 <loquacities> don't forget to link your patches to that blueprint, too
21:12:56 <asettle> And figuring out what is still applicable (removing any of those out of date) and moving through the list of updates required
21:13:04 <asettle> Thank you loquacities :) that is important
21:13:20 <asettle> If anyone is interested in helping in the HA guide, hit us up. Last few weeks I have finished all edits I planned to do.
21:13:29 <asettle> But this is now a top priority regardless of spec.
21:13:38 <asettle> BUGS \o/
21:13:39 <loquacities> cool
21:13:42 <loquacities> :P
21:13:48 * asettle takes a breath
21:13:51 <loquacities> ok, next up is
21:13:53 <loquacities> Hypervisor Tuning Guide: Joe Topjian
21:13:56 <loquacities> (not here)
21:14:03 <loquacities> Installation guides: Lana Brindley
21:14:15 <loquacities> So, for install guides, we have a wireframe for you to look at
21:14:24 <loquacities> #link https://openstack.invisionapp.com/share/ZF9OLTYND
21:14:38 <loquacities> if you click on the little grid picture in the bottom right corner, you can see the two versions
21:14:48 <loquacities> and if you click on comments you can read/leave comments
21:15:14 <loquacities> in january, we'll need to make a decision on the final design, and start to create patches for it
21:15:14 <asettle> On that note, I liked the mockups.
21:15:15 <asettle> the first one.
21:15:18 <asettle> With the pictures.
21:15:19 <loquacities> yeah, me too
21:15:36 <loquacities> and i think it could work nicely to bring that design through to the main page eventually too
21:15:43 <loquacities> anyway, that's all from install guides
21:15:46 <asettle> Is this something we are planning to apply to the deployment stuff too?
21:15:51 <loquacities> probably, yes
21:15:57 <asettle> Okay. Using mascots or...?
21:16:10 <loquacities> no, probably by distro still
21:16:17 <annegentle> is it not possible to see your own comments once you post them?
21:16:24 <annegentle> I've posted two comments, does anyone see them?
21:16:28 <loquacities> yep, you need to click on the numbers
21:16:33 <loquacities> it's very unintuitive
21:16:53 <bsilverman_> I left comments too, I liked the pictures.
21:17:02 <loquacities> annegentle: i see your comments
21:17:07 <annegentle> loquacities ok
21:17:35 <loquacities> cool, let's move on
21:17:41 <loquacities> Networking Guide: John Davidge
21:17:51 <loquacities> from John:
21:17:53 <loquacities> Not much from the networking guide this week. A couple more patches in flight to address the OSC transition. This one looks good to me:
21:17:53 <loquacities> https://review.openstack.org/#/c/410550/
21:17:53 <loquacities> Haven�t looked at Ankur�s other patch yet but will get to it soon.
21:18:16 <loquacities> Operations and Architecture Design guides: Shilla Saebi
21:18:20 <loquacities> darrenc: anything to add here?
21:18:31 <darrenc> nothing much to report
21:18:39 <loquacities> ok, np
21:18:39 <darrenc> we've abandoned the specialty team meeting, and referred everyone to this meeting
21:18:51 <ankur-gupta> :)
21:18:52 <loquacities> oh, nice
21:18:55 <asettle> Cool darrenc :)
21:19:28 <loquacities> ok, next up ...
21:19:31 <loquacities> Security Guide: Nathaniel Dillon
21:19:43 <loquacities> I don't think Nathaniel is here?
21:20:03 <loquacities> nope
21:20:06 <loquacities> Training Guides: Matjaz Pancur
21:20:30 <loquacities> (not here)
21:20:35 <loquacities> Training labs: Pranav Salunke, Roger Luethi
21:20:56 <loquacities> those guys don't seem to be here, either
21:21:00 <iphutch> For security guides I was looking to help out on docs but wasn't able to establish a source for up to date content.
21:21:16 <loquacities> iphutch: in what context?
21:21:40 <iphutch> At the moment, the guide is out of date and needs review for nova and neutron
21:21:59 <iphutch> but beyond source code there hasn't been specific bugs filed for out of date content
21:22:02 <loquacities> yeah, most of our aging bugs in the queue are security guide related, too
21:22:20 <loquacities> i think it's starting to date quite badly
21:22:33 <loquacities> perhaps we need to find out if nathaniel is still able to work on it
21:22:50 <iphutch> agreed
21:22:56 <annegentle> iphutch when you say "source" what do you mean?
21:23:12 <loquacities> iphutch: do you mind taking that as an action? (to chase nathaniel)
21:23:16 <annegentle> iphutch the doc source or a person?
21:23:41 <iphutch> I should say, other than taking a deep dive into nova/neutron code to find up to date security info
21:23:56 <loquacities> i'm not sure the source code would even help you much in that case
21:23:58 <asettle> So, that was actually me that recommended iphutch take on the install guide. Similar to how I've attacked the HA guide.
21:24:05 <loquacities> asettle: it's a good plan
21:24:13 <asettle> In all honesty, a lot of the guides that were done in a sprint or otherwise are out of day
21:24:14 <asettle> date*
21:24:19 <asettle> Arch, HA, security
21:24:23 <loquacities> yep
21:24:27 <asettle> We have specialty teams but nobody is keeping it up to date
21:24:34 <asettle> It is good to have a writer AND an SME on board
21:24:37 <asettle> But we don't have that currently
21:24:53 <asettle> I would be good if iphutch could go through the guide, edit it, file bugs, and report back with findings in a week
21:24:56 <loquacities> ok, let's make an action to chase this up
21:24:59 <bsilverman_> The security guide should probably outline best practices and refer any timely security patching to the foundation’s security team pages.
21:25:17 <loquacities> bsilverman_: i believe that's the way it's structured, yes
21:25:19 <asettle> But we do need to address in the new year the fact that a lot of these guides are not being looked after and we do not have the bandwidth to do so
21:25:41 <loquacities> agreed
21:26:02 <loquacities> #action iphutch to chase up the security speciality team to discuss future of guide (with asettle and loquacities)
21:26:08 <iphutch> I am happy to be the writer if I can get a SME on board
21:26:12 <loquacities> ok, last but not least is (drumroll please)
21:26:12 <iphutch> will do
21:26:16 <asettle> iphutch: thank you :)
21:26:18 <loquacities> User guides: Joseph Robinson
21:26:24 <loquacities> JRobinson__: what do you have?
21:26:38 <asettle> \o/
21:26:43 <JRobinson__> The Legacy command changes are continuing at the moment
21:26:54 <JRobinson__> I've updated the task list with more files
21:27:04 <JRobinson__> #link https://wiki.openstack.org/wiki/Documentation/ReorganizeUserGuides#Legacy_to_OpenStack_command_conversion_table
21:27:08 <bsilverman_> I have a whole chapter in an upcoming book on OpenStack security, when it’s published next month, I’ll send you the chapter ophutch.
21:27:27 <JRobinson__> I'm aiming to have all the commands from the End User Guide added.
21:27:28 <bsilverman_> err iphutch
21:27:36 <loquacities> nice work, JRobinson__ :)
21:28:03 <loquacities> ok, any final comments on speciality teams?
21:28:08 <asettle> JRobinson__: do you have any books complete yet?
21:28:11 <JRobinson__> One more bug item -
21:28:17 <asettle> Slash, could you tell us what is left to do etC?
21:28:57 <JRobinson__> asettle, at the moment, I'd say about maybe over half the end user guide has been worked through.
21:29:05 <JRobinson__> As a goal I want to get that one compelted.
21:29:09 <JRobinson__> ^completed
21:29:17 <asettle> Cool :) that's great. Admin guide?
21:29:43 <asettle> I've seen a lot of patches. And ankur-gupta has been helping out a lot too floating between the config guides too I believe.
21:29:46 <JRobinson__> The Administrator guide needs attention, maybe a bit after that, but time constraints means I'll start listing commands from there too within the next week.
21:30:12 <JRobinson__> for sure, and thanks ankur-gupta for your help here :)
21:30:24 <JRobinson__> That bug question:
21:30:27 <JRobinson__> #link https://bugs.launchpad.net/openstack-manuals/+bug/1648101
21:30:28 <openstack> Launchpad bug 1648101 in openstack-manuals "ip netns - needed for cheat sheet in End User Guide?" [Undecided,New]
21:30:33 <ankur-gupta> Yes please let me know if there is anything else i can help out with
21:30:40 <annegentle> JRobinson__ I learned that is a Linux-only command.
21:30:56 <annegentle> JRobinson__ and since our CLI installation instructions also cover Win/Mac I wonder if it's necessary.
21:31:02 <annegentle> Anyone have an opinion?
21:31:47 <JRobinson__> annegentle, yes, it looked like a specific use case. Not sure how often users had encountered or sed the $ ip netns command
21:31:52 <loquacities> it should at least be marked, either way
21:31:56 <JRobinson__> ^used.
21:32:32 <annegentle> loquacities that might be the clearest way to show it
21:32:37 <loquacities> ok
21:32:40 <loquacities> shall we move on then?
21:32:43 <annegentle> JRobinson__ I can take that bug
21:32:44 <bsilverman_> It’s used a lot in troubleshooting linux network issues with instances.
21:32:55 <JRobinson__> ankur-gupta, if anything on the table leaps out, go for it - I can update the table after the patch is up, so don't worry about the admin side of things too much.
21:32:55 <annegentle> bsilverman_ yeah
21:32:58 <annegentle> JRobinson__ can you triage it for me?
21:33:06 <JRobinson__> annegentle, thanks, yes, triage now
21:33:13 <loquacities> #topic Countdown to release:
21:33:16 <bsilverman_> It’s the only way I know to really find out about the namespaces that instances are using.
21:33:23 <loquacities> 68 days to go
21:33:41 <loquacities> #link https://wiki.openstack.org/wiki/Documentation/OcataDeliverables
21:33:54 <annegentle> bsilverman_ yeah, but you do need to be on a Linux machine to use it, so we should indicate that.
21:34:05 <loquacities> #topic PTG Atlanta Feb 20-24 2017
21:34:10 <loquacities> #link http://www.openstack.org/ptg Event info
21:34:17 <loquacities> #link https://pikeptg.eventbrite.com/ Tickets
21:34:22 <loquacities> i believe there are still tickets available
21:34:29 <bsilverman_> annegentle: agreed.
21:34:43 <loquacities> #info Docs is on Monday/Tuesday
21:34:48 <loquacities> #topic Open discussion
21:34:50 <asettle> Anyone going?
21:34:51 <asettle> To the PTG
21:34:52 <asettle> That is
21:34:58 <annegentle> yep, I'll be there asettle
21:35:09 <asettle> Cool! In theory I will be, but *stay tuned*
21:35:14 <annegentle> nice
21:35:15 <bsilverman_> I still need to get approval, need to explain it to company.
21:35:35 <JRobinson__> I'm aiming to go - approval is also under discussion.
21:35:37 <iphutch> Ill be there if we get the final budget thumbs up
21:35:51 <bsilverman_> Have they announced what the “discount” will be off of the Boston summit if we go?
21:36:10 <loquacities> not that i've seen
21:36:10 <annegentle> I had a topic I want to bring up here first --
21:36:14 <JRobinson__> #info the ticket refund date is February 13 - time available for refunds depending on team and organisation budgets.
21:36:24 <annegentle> I noticed a few "cinder" CLI commands in the Horizon UI
21:36:28 <asettle> Ohhhh I see, good info JRobinson__
21:36:32 <annegentle> as explanatory text.
21:36:34 <bsilverman_> true
21:36:37 <asettle> annegentle: oh?
21:36:43 <asettle> Have you an example anywhere?
21:36:56 <annegentle> Do you think it would be ok to propose a blueprint to move those to osc after the docs are updated?
21:37:00 <annegentle> asettle just a sec, yeah
21:37:02 <asettle> Also, I should mention to those that are doing the CLI command conversion, I spoke to Joe too... do not change swift commands.
21:37:12 <asettle> Swift is sticking with 'swift' until further notice.
21:37:17 <asettle> The 'openstack' command is not entirely supported.
21:37:17 <loquacities> annegentle: yes, i think that's a good idea
21:37:45 <annegentle> so, log in as admin, go to Admin > Volumes and then click Create Volume Type.
21:37:57 <annegentle> I don't think there's a huge number of them but it would be nice to update
21:38:08 <annegentle> "This is equivalent to the cinder type-create command."
21:38:18 <annegentle> So it's not even the entire command.
21:38:23 <asettle> Interesting annegentle I hadn't see that. Thank you!
21:38:34 <asettle> Is that a cinder bug or it just incomplete? Or a horizon thing?
21:38:36 <asettle> That's confusing.
21:38:47 <annegentle> asettle I see it as a horizon bug
21:39:00 <loquacities> maybe we should ping horizon
21:39:08 <annegentle> asettle but I may not understand their plugin model
21:39:14 <asettle> Okay, should we file? I mean, I feel bad, it's only Richard and Rob that are basically Horizon now
21:39:14 <annegentle> asettle as to where the strings "live"
21:39:21 <asettle> annegentle: fair enough
21:39:22 <annegentle> asettle  oh we could do these edits ourselves
21:39:24 <asettle> loquacities: could you ping Richard?
21:39:28 <annegentle> that's why I'm bringing it up here
21:39:32 <asettle> annegentle: we could? Okay. We should then.
21:39:37 <loquacities> yeah, sure
21:39:59 <annegentle> but need to understand where those strings are, what translation affect it might have, whether the strings will still fit in boxes, etc.
21:40:09 <david-lyle> what's the ask for horizon?
21:40:10 <annegentle> I bet Richard would know that sort of stuff
21:40:13 <loquacities> #action loquacities to ping Richard Jones about cinder commands in horizon
21:40:15 <annegentle> hey david-lyle
21:40:21 <david-lyle> hi annegentle :)
21:40:43 <annegentle> david-lyle ask could be "hey are these pluggable strings and how do I edit them and would it affect translations and box sizes"
21:40:47 <asettle> david-lyle: it's like you have a radar for the word 'horizon'
21:41:02 <david-lyle> I do watch for it
21:41:03 <annegentle> david-lyle and "hey are the strings stored closer to cinder or horizon?"
21:41:17 <david-lyle> all the strings should be from horizon
21:41:19 <annegentle> david-lyle for reviews and such
21:41:28 <asettle> david-lyle: I do that for 'docs' :P
21:41:39 <david-lyle> we try not to pass on any unlocalized strings to users
21:42:04 <david-lyle> so if there is an issue with some text, filing a bug in horizon is the best place.
21:42:14 <asettle> annegentle: in that case, we can probably do it?
21:42:22 <david-lyle> plugins can provide strings as well, but cinder support is internal to horizon
21:42:31 <annegentle> david-lyle ok
21:42:45 <david-lyle> something like manila or sahara would own their own strings
21:42:46 <annegentle> david-lyle but if the size of the text changes is that a non-issue?
21:42:58 <annegentle> cinder is fewer letters than openstack for example
21:43:04 <annegentle> david-lyle I might be overthinking :)
21:43:11 <david-lyle> generally it is not
21:43:17 <annegentle> great
21:43:29 <annegentle> yeah this seems like a nice next evolution of "OSC everywhere"
21:43:37 <david-lyle> we try to make all text containers vary their size based on content
21:43:52 <annegentle> asettle yeah I really do think so. To me the hard part would be building horizon locally but we have devstack.
21:44:23 <annegentle> asettle heh we have our PTG hack project :)
21:44:34 <annegentle> "Figure out horizon help strings"
21:44:48 <asettle> annegentle: I would really like to go through that with you at the PTG? It's good to learn new things (like last time? Yay deployment guides)
21:44:57 <annegentle> asettle yes!!
21:45:02 <annegentle> me too
21:45:38 <asettle> Let's hack it out :) should be good!
21:45:44 <david-lyle> I'll be at the PTG, please ping me however I can help
21:45:55 <annegentle> david-lyle awesome, consider yourself roped in :)
21:45:59 <asettle> david-lyle: we may seek you out to bash horizon into our submission :P
21:46:11 <asettle> Anne's version seems nicer
21:46:26 <annegentle> asettle hee
21:46:28 <david-lyle> it never worked for me, but with your help we may make more progreess
21:46:35 <annegentle> david-lyle heh
21:46:50 <asettle> \o/ we will do our best
21:46:52 <asettle> She says
21:46:52 <asettle> Now
21:46:56 <asettle> Without much conviction
21:47:20 <loquacities> is that it, guys?
21:47:25 <loquacities> thanks for a good meeting
21:47:28 <asettle> hahahah
21:47:29 <asettle> Yes sorry
21:47:37 <loquacities> and have a great holiday, those who are getting one :)
21:47:41 <loquacities> #endmeeting