21:00:05 <loquacities> #startmeeting docteam
21:00:06 <openstack> Meeting started Thu Jan 12 21:00:05 2017 UTC and is due to finish in 60 minutes.  The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:09 <openstack> The meeting name has been set to 'docteam'
21:00:14 <loquacities> hi everyone!
21:00:20 <AJaeger> o/
21:00:29 <darrenc> hi!
21:01:14 <loquacities> #topic Action items from the last meeting
21:01:19 <jrobinson> Hello o/
21:01:31 <loquacities> so, there's a couple here for me that i haven't done :S
21:01:47 <loquacities> loquacities to follow up on both specs in the new year on the mailing list
21:01:53 <loquacities> ^^ i will do that today
21:01:56 <ianychoi> hi :)
21:02:00 <loquacities> iphutch to chase up the security speciality team to discuss future of guide (with asettle and loquacities)
21:02:07 <loquacities> is iphutch or asettle here?
21:02:11 <iphutch> Hello!
21:02:15 <loquacities> oh hi!
21:02:21 <bmoss> greetings
21:02:27 <skelso> Greetings
21:02:36 <loquacities> wow, full house :)
21:03:03 <iphutch> Followed up with sicarie (are you here?)
21:03:48 <loquacities> i don't think he is
21:03:51 <iphutch> and it looks like the security guide is hitting bumps in the road nested around finding sees for the projects that need most updating: neutron and nova
21:04:02 <iphutch> * SMEs
21:04:09 <loquacities> ah, right
21:04:44 <loquacities> i assume you've started with the cross-project liaisons for those projects?
21:04:45 <annegentle> iphutch that could change as the release dates scurry along
21:04:55 <annegentle> iphutch might be a timing thing as much as a finding thing
21:05:01 <loquacities> that's a good point, too
21:05:06 <iphutch> Best efforts as of right now is looking at code within those projects and trying to figure out what their sec. best practices are but it is a big ask in terms of availability
21:05:12 <annegentle> loquacities it's a hunch anyway
21:05:31 <iphutch> gotcha
21:05:44 <loquacities> and, finally, it's me again:
21:05:46 <loquacities> loquacities to ping Richard Jones about cinder commands in horizon
21:05:50 <loquacities> i will also do that today
21:06:02 <loquacities> #topic Specs in review
21:06:09 <loquacities> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
21:06:24 <loquacities> it's still just that use case form
21:06:35 <loquacities> can we abandon this now?
21:06:45 <loquacities> AJaeger?
21:06:53 <loquacities> https://review.openstack.org/#/c/391786/
21:07:23 * AJaeger checks
21:07:32 <AJaeger> yeah...
21:07:49 <AJaeger> shall I?
21:08:10 <loquacities> done :)
21:08:22 <loquacities> let's move on to speciality teams
21:08:27 <loquacities> #topic Speciality teams reports:
21:08:34 <loquacities> API: Anne Gentle
21:08:50 <loquacities> annegentle: ?
21:09:08 <annegentle> So hopefully you saw on the ML that I'm working on retiring fairy-slipper
21:09:33 <annegentle> It was a good tool, served its purpose, and can now traipse into the sunset.
21:09:39 <loquacities> yay!
21:09:45 <annegentle> #info Retiring fairy-slipper
21:10:00 <annegentle> And thanks to AJaeger and stevemar for the help with the patches
21:10:40 <annegentle> It's not done yet, but patches are in place.
21:11:01 <annegentle> Also in API land, be sure to follow the service catalog naming conventions work going on in the API WG
21:11:07 <AJaeger> annegentle: go ahead and merge ;)
21:11:21 <annegentle> AJaeger heh. don't have +2 everywhere
21:12:01 <annegentle> And there's also a new ec2 api reference: http://developer.openstack.org/api-ref/ec2-api/
21:12:17 <annegentle> Mostly describes the limitations
21:12:49 <annegentle> I think that's it. Any questions for API landia?
21:12:58 <AJaeger> annegentle: you have +2 in fairy-slipper - and a few others as well: https://review.openstack.org/#/admin/groups/1240,members
21:13:24 <loquacities> cool, thanks annegentle
21:13:31 <loquacities> Configuration Reference and CLI Reference: Tomoyuki Kato
21:13:41 <loquacities> i don't think katomo is here, this is what he gave me on email:
21:13:47 <loquacities> Config Reference: Updated a few plug-ins content.
21:13:52 <loquacities> CLI reference: UPdated a few command reference. Unsupport Block Storage API v1 and Image API v1 from the reference.
21:14:12 <loquacities> High Availability Guide: Andrew Beekhof
21:14:28 <loquacities> anyone have updates on the HA Guide?
21:15:05 <loquacities> i'll take that as a no
21:15:06 <annegentle> does Andrew have an IRC nick?
21:15:19 <loquacities> annegentle: i'm not certain i've ever seen him on IRC
21:15:28 <loquacities> Hypervisor Tuning Guide: Joe Topjian
21:15:40 <loquacities> i haven't heard from joe in a while, i should probably ping him
21:15:52 <annegentle> kk
21:15:56 <loquacities> #action loquacities to ping joe topjian re: hypervisor tuning guide
21:16:07 <loquacities> Installation guides: Lana Brindley
21:16:29 <loquacities> obviously, i've been on holiday, so no real update from me. however, we'll need to start testing for ocata RSN
21:16:46 <lbragstad> ++
21:16:47 <loquacities> Networking Guide: John Davidge
21:17:27 <loquacities> anyone with updates from the networking guide?
21:18:04 <loquacities> ok, moving on
21:18:11 <loquacities> Operations and Architecture Design guides: Shilla Saebi
21:18:24 <loquacities> darrenc: can you fill us in?
21:18:30 <darrenc> sure thing
21:18:37 <darrenc> Nothing much to report. Ben Silverman has spent some time refining the Compute content in the Arch Guide draft. Thanks Ben!
21:18:54 <darrenc> We are also looking for more SMEs to help with the Arch Guide. So if you're interested, contact asettle or me :)
21:18:54 <loquacities> cool
21:19:15 <darrenc> I think that's it
21:19:20 <loquacities> thanks :)
21:19:25 <loquacities> Security Guide: Nathaniel Dillon
21:19:26 <darrenc> np
21:19:37 <loquacities> we know sicarie isn't here
21:19:43 <loquacities> anyone else with security guide updates?
21:20:04 <iphutch> Just what I stated earlier
21:20:08 <loquacities> cool
21:20:13 <loquacities> Training Guides: Matjaz Pancur
21:20:48 <loquacities> i haven't heard from matjaz in a little while
21:20:54 <loquacities> any training guides people here?
21:21:26 <loquacities> ok, let's move on
21:21:31 <loquacities> Training labs: Pranav Salunke, Roger Luethi
21:22:00 <loquacities> dguitarbite?
21:22:02 <loquacities> nope
21:22:12 <loquacities> i can say that this patch merged: https://review.openstack.org/#/c/412405/
21:22:24 <loquacities> i'm not sure it's ready to actually use yet, but there it is
21:22:52 <loquacities> and, finally ...
21:22:54 <loquacities> User guides: Joseph Robinson
21:22:55 <AJaeger> they're working now together on the parser and CI
21:23:02 <annegentle> neato
21:23:03 <loquacities> AJaeger: oh good! thanks :)
21:23:13 <loquacities> jrobinson?
21:23:35 <jrobinson> Hi, So the command conversions have happened at a good pace
21:24:08 <annegentle> jrobinson +1 yeah
21:24:14 <loquacities> :)
21:24:17 <jrobinson> The User Guide appear to be mostly complete, with the condition that the trove and manila teams do not have openstack functionality based on the trove and manila commands yet.
21:24:36 <loquacities> great!
21:24:58 <jrobinson> The admin guide I have started checking through the files. I suspect there is more to convert, but I'm feeling confident it will be ready.
21:25:06 <jrobinson> #action jrobinson to follow up manila and trove command status
21:25:12 <loquacities> awesome, thanks jrobinson
21:25:24 <jrobinson> One file has commands that added that were not ready yet however,
21:25:24 <loquacities> is there anything else on speciality teams before we move on?
21:25:37 <jrobinson> #link https://bugs.launchpad.net/openstack-manuals/+bug/1649611
21:25:37 <openstack> Launchpad bug 1649611 in openstack-manuals "Unimpletemed --fixed-ad functionality mentioned in Manage IP addresses in End User Guide" [Medium,Confirmed] - Assigned to Joseph Robinson (joseph-r-email)
21:25:47 <jrobinson> I'm going to patch this today.
21:25:55 <loquacities> ah, ok
21:25:56 <loquacities> np
21:26:10 <jrobinson> thanks again to Alex for the link.
21:26:17 <jrobinson> I think that's all for now :)
21:26:23 <loquacities> cool, thanks jrobinson
21:26:25 <loquacities> is there anything else on speciality teams before we move on?
21:26:26 <jrobinson> Thanks again
21:27:03 <loquacities> #topic Countdown to release:
21:27:15 <loquacities> #info 40 days
21:27:36 <loquacities> i'm at a conference next week, but will begin kicking off all the release tasks
21:27:52 <loquacities> i knew this release would come around fast, but i still wasn't quite ready ;)
21:28:21 <loquacities> so, start thinking about helping out with general updates, install guide testing, etc
21:28:25 <loquacities> #topic PTG Atlanta Feb 20-24 2017
21:28:30 <loquacities> #link http://www.openstack.org/ptg Event info
21:28:34 <loquacities> #link https://pikeptg.eventbrite.com/ Tickets
21:28:38 <loquacities> Docs is on Monday/Tuesday
21:28:51 <loquacities> we'll be rebranding as Docs/i18n
21:29:03 <annegentle> nice
21:29:11 <loquacities> so translators are welcome, as well as docs people
21:29:11 <ianychoi> Yey~ :)
21:29:15 <AJaeger> as long as we don't write docs in German or Japanese ;)
21:29:21 <annegentle> AJaeger hee
21:29:26 <ianychoi> haha
21:29:28 <loquacities> ianychoi: i haven't checked, has that change gone through?
21:29:39 <ianychoi> #link https://wiki.openstack.org/wiki/PTG/Pike/Etherpads
21:29:50 <loquacities> AJaeger: nobody wants to read anything i've written in something other than english, let me tell you ;)
21:30:01 <loquacities> although australian could be considered a language other than english sometimes ;)
21:30:02 <ianychoi> The change was committed here first and I have not checked main page yet (but will be changed within a few days)
21:30:12 <loquacities> awesome! thanks ianychoi :)
21:31:02 <ianychoi> We need to start to gather discussion topics on Etherpad
21:31:07 <loquacities> just a reminder, too, i won't be planning the PTG events, that will up to our new PTL
21:31:17 <loquacities> yes, i'll ping asettle and katomo and get that rolling
21:31:46 <loquacities> #topic Boston Summit
21:31:54 <loquacities> #info CFP is now open #link https://www.openstack.org/summit/boston-2017/call-for-presentations/
21:31:54 <ianychoi> loquacities, +1 :)
21:32:10 <loquacities> #topic Voting
21:32:20 <loquacities> #info PTL nominations open week of 23 Jan.
21:32:26 <loquacities> #info PTL Voting in first week of Feb.
21:32:59 <loquacities> #info Foundation voting is still open.
21:33:24 <loquacities> and katomo is up for foundation board, so make sure you go vote
21:33:36 <loquacities> #topic Open discussion
21:33:39 <loquacities> anything else?
21:34:21 <AJaeger> docs.o.o is served by OpenStack CI and looks fine IMHO
21:34:28 <loquacities> oh! thanks for reminding me :)
21:34:36 <annegentle> nice work AJaeger and infra team!
21:34:37 <loquacities> yes, it looks good to me :D
21:34:37 <AJaeger> OpenStack infra I mean...
21:34:53 <annegentle> AJaeger do you need any more work done on the links?
21:34:54 <loquacities> i was impressed how quickly that all happened
21:34:58 <AJaeger> I have a larger patch up in preparation for Sphinx 1.5 - https://review.openstack.org/#/c/419053/ - reviews are welcome
21:35:06 <annegentle> AJaeger or have you logged bugs against projects?
21:35:22 <AJaeger> annegentle: see my last email to the docs mailing list. Anybody going through that and filing bugs would be cool
21:35:33 <annegentle> AJaeger yeah, saw the note, wasn't sure of next steps
21:35:41 <annegentle> AJaeger to me, seems like bug logging would be a good next step
21:35:42 <AJaeger> annegentle: only filed bugs against ansible to keep asettle busy ;) They were number 1 or 2 with dead links
21:35:47 <annegentle> AJaeger hee
21:35:53 <loquacities> lol
21:35:53 <annegentle> AJaeger she "wins!"
21:36:08 <AJaeger> so, if anybody wants to report bugs: Please do.
21:36:17 <annegentle> AJaeger what was the count on that JSON file?
21:36:24 <AJaeger> 160 lines
21:36:27 <annegentle> I'll take the projects that start with N
21:36:53 <annegentle> #info All: log bugs for the broken links in the JSON file AJaeger sent to the ML
21:37:07 <annegentle> #action annegentle to log broken links bugs for projects that start with n
21:37:16 <annegentle> #info ansible bug links already logged
21:38:24 <ianychoi> For buliding PDFs, I am seeing some latex_elements option in conf.py to apply styles, especially using 'presemble'.
21:38:25 <ianychoi> Using 'presemble' ( http://www.sphinx-doc.org/en/1.5.1/latex.html ) looks nice.
21:38:25 <ianychoi> I will try to speed up to apply a theme within O cycle.
21:38:36 <lbragstad> loquacities do you have a target date when you need feedback from teams on Ocata install process?
21:39:07 <loquacities> we'll probably be freezing the guides in the next couple of weeks
21:39:19 <loquacities> or do you mean for testing?
21:39:33 <loquacities> testing will run right up until we publish
21:39:41 <lbragstad> for testing to make sure project guides accurately reflect changes in Ocata
21:39:46 <lbragstad> ok
21:39:47 <lbragstad> cool
21:39:57 <loquacities> keep an eye on the docs ML for updates
21:40:05 <lbragstad> will do - thanks!
21:40:07 <loquacities> np
21:40:11 <AJaeger> right now we have no links to the pdfs - or have we now?
21:40:32 <annegentle> AJaeger not that I've seen, other than in the www-index, yah?
21:40:49 <AJaeger> exactly - but before we do that, we should review that we like the style.
21:41:05 <AJaeger> style of the PDF I mean
21:41:14 <annegentle> AJaeger yeah, I agree
21:41:25 <annegentle> AJaeger and then a UX review of how users get to the PDFs
21:41:40 <ianychoi> #link http://docs-draft.openstack.org/53/419053/7/check/gate-openstack-manuals-tox-doc-publish-checkbuild/ae3c2d8//publish-docs/
21:41:52 <annegentle> ianychoi though I can't recall if the spec mentions UX review :) only the PDF output review in the spec
21:42:01 <annegentle> ianychoi so I might be jumping further than meant
21:42:17 <AJaeger> you can download pdf like http://docs.openstack.org/ha-guide/HAGuide.pdf
21:42:34 <AJaeger> oh, btw. fungi will soon get us https set up for docs.o.o and developer.o.o
21:42:41 <loquacities> oh, cool
21:42:50 <loquacities> actually, i need a web dev
21:43:00 <loquacities> for the install guide landing page
21:43:03 <loquacities> who should i talk to?
21:43:28 <ianychoi> annegentle, UX review is so important! But.. I need to do more study on applying themes with Sphinx + Latex
21:43:35 <annegentle> fungi yay yay yay omg yay
21:43:43 <loquacities> lol
21:43:52 <annegentle> ianychoi how would you like input on the PDF output? (oh I crack myself up)
21:43:59 <loquacities> annegentle: is my daughter using your keyboard? ;)
21:44:00 <fungi> yep, just need to get around to issuing the cert
21:44:23 <fungi> i have a bunch i need to renew in the coming week and will lump that one in with them
21:44:28 <annegentle> fungi Thanks, sweet.
21:44:37 <AJaeger> fungi, no pressure ;) thanks
21:44:53 <fungi> my pleasure, as always
21:45:14 <ianychoi> annegentle, haha :) Then it might be better for me to open Etherpad for review items
21:45:33 <annegentle> ianychoi these are minor, minor
21:46:07 <ianychoi> annegentle, but sometimes significant with minor :)
21:46:17 <annegentle> ianychoi ha you're preaching to the choir
21:46:53 <ianychoi> annegentle, huk... :)
21:47:06 * AJaeger needs to leave now and waves good-bye
21:47:17 <ianychoi> Good night
21:47:18 <annegentle> AJaeger cya!
21:47:32 <loquacities> cya AJaeger o/
21:47:44 <loquacities> looks like we might be done here?
21:47:55 <AJaeger> just because I sign off? ;)
21:48:05 <annegentle> AJaeger ha ha
21:48:08 <annegentle> AJaeger ye
21:48:12 <annegentle> AJaeger yes
21:48:12 <loquacities> you're the life of the party, AJaeger!
21:48:16 <ianychoi> Haha
21:48:35 <loquacities> ok, thanks everyone
21:48:36 <loquacities> o/
21:48:40 <lbragstad> o/
21:48:41 <loquacities> #endmeeting