21:02:12 <asettle> #startmeeting docteam
21:02:13 <openstack> Meeting started Thu Feb  9 21:02:12 2017 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:17 <openstack> The meeting name has been set to 'docteam'
21:02:19 <asettle> There we go
21:02:31 <iphutch> woohoo
21:02:32 <asettle> #topic Roll call!
21:02:34 <asettle> o/
21:02:40 <skelso> o/
21:02:41 <iphutch> o//
21:02:41 <darrenc> hiya
21:02:45 <jrobinson> Ah it worked. I was about to say, the User Guide tag did that to me once.
21:02:50 <jrobinson> And Hi o/
21:03:06 <asettle> Hahaha jrobinson thanks man. So weird, never happened to me before.
21:03:09 <asettle> Oh well :p
21:03:13 <asettle> Hey everyone :)
21:03:19 <asettle> We'll give it a minute or two more to see what's up
21:03:35 <annegentle> o/
21:03:45 <loquacities> o/
21:03:46 <ankur-gu_> \o/
21:03:56 <asettle> Hey guys!
21:04:03 <loquacities> you had a space before the # ;)
21:04:05 <asettle> Good turn out today :)
21:04:11 <asettle> loquacities: ahhhhhhhh thank you
21:04:20 <asettle> Dat awkward mo when you think you cray
21:04:26 <loquacities> lol
21:04:53 <asettle> Okay, shall we move on? Looks we like got a good team in today :)
21:05:37 <asettle> #topic Action items from the last meeting
21:05:55 <asettle> So far from what I can see, the only action was me: * ACTION: Alex to email specialty team leads about bug triaging
21:06:13 <asettle> So, I messaged all cores, specialty team leads about bug triaging positions. Admittedly to little response.
21:06:18 <asettle> I'd probably like to bring that up again
21:06:46 <asettle> So, for those that weren't here last week - basically we don't have a great way of triaging new bugs in place.
21:06:57 <asettle> My idea? Have a bug triager that rotates on a fortnightly (bi-weekly) basis.
21:07:15 <loquacities> are you just looking for people to start doing that?
21:07:26 <loquacities> or are you going to wait until after ocata goes out?
21:07:37 <asettle> loquacities: mostly was looking for Ocata to go out, and see if there was any major disagreements on the matter first up.
21:07:51 <asettle> Since there was no major disagreements - unless there is now?
21:07:54 <loquacities> ok
21:08:01 <asettle> I'll send out an email asking for volunteers.
21:08:01 <loquacities> i think there's broad approval
21:08:16 <iphutch> yep - it was a good idea
21:08:18 <asettle> Cool. Who would be able (here) to step up in Pike for this?
21:08:24 <loquacities> sign me up
21:08:27 <iphutch> o/
21:08:27 <jrobinson> Yes on the mailing list, there is some more discussion about how this pattern works on the Neutron team before.
21:08:37 <asettle> Swell! Yeha, it's defs worked in the neutron team.
21:08:37 <jrobinson> I'm also ready to triage.
21:08:40 <darrenc> o/
21:08:45 <asettle> Cool guys!
21:08:48 <asettle> Well, let's start.
21:08:49 <asettle> https://wiki.openstack.org/wiki/Documentation/SpecialityTeams
21:08:54 <asettle> If you wanna put your name down in the table
21:08:57 <asettle> I'll organise the dates.
21:09:20 <asettle> The issues column is simply for post-triage concerns.
21:09:30 <asettle> Thanks everyone for volunteering :)
21:10:14 <asettle> Shall we move on to the specialty team reports?
21:10:25 <loquacities> yep
21:10:35 <asettle> #topic Specialty team reports
21:10:40 <asettle> annegentle: you're first up with API :)
21:10:46 <annegentle> hola
21:10:49 <asettle> o/
21:11:13 <annegentle> so, the trove API docs are incomplete after migration, and a user reported the bug to the ML (you all probably saw that)
21:11:23 <asettle> *nods* sure did
21:11:28 <annegentle> I've subscribed laurelm and triaged
21:11:39 <annegentle> I'll also log the missing clustering API info
21:12:01 <asettle> Thanks annegentle :)
21:12:06 <annegentle> And then we're also meeting with flanders, the app dev community manager at the Foundation, to talk about goals for developer.openstack.org
21:12:15 <annegentle> all are welcome, of course
21:12:29 <asettle> We sure are. If anyone's interested in poking their head in, ping me or annegentle :)
21:12:40 <annegentle> #link https://review.openstack.org/#/q/status:open+file:api-ref
21:12:53 <annegentle> and that's the current list of API reference docs reviews
21:13:11 <annegentle> and then also the NFV Orchestration (tacker) team landed their API ref this week.
21:13:26 <bsilverman_7> O/
21:13:36 <asettle> Great :)
21:13:37 <annegentle> and I think that's all there is to report
21:13:39 <asettle> Hey bsilverman_7 :)
21:13:41 <asettle> Thanks annegentle :)
21:13:53 <annegentle> oh, one more thing
21:14:00 <asettle> Hit it!
21:14:18 <annegentle> I want to be sure everyone knows I'd like to coach more people on API docs generally - I don't plan to always be the point person here
21:14:30 <annegentle> so let me know if you're interested
21:14:42 <asettle> Good point, if anyone is interested in putting their hands up or knows someone that loves a good API please let us know :)
21:15:38 <asettle> Okay, so, next up *would* be Kato but he has given us his apologies.
21:15:49 <asettle> But in a small update, noted that:
21:16:18 <asettle> Next up, iphutch with the HA Guide update :)
21:16:30 <iphutch> Sent a message to the ML looking for people interested in helping out on the HA guide for Pike. Planning for the PTG as I can’t attend.
21:16:58 <asettle> Thanks iphutch :)
21:17:24 <asettle> So, next up is the Hypervisor Tuning Guide with Blair. Although I have not been able to get in contact with Blair at all lately. Anyone aware of his presence?
21:17:33 <asettle> loquacities or annegentle ?
21:17:33 <loquacities> haven't heard from him
21:17:42 <asettle> Can't get a peep out of him in emails.
21:17:49 <annegentle> is he real? :)
21:17:50 <annegentle> kidding
21:17:54 <loquacities> i met him once
21:17:56 <asettle> Hahahhaa figment of my imagination
21:17:58 <loquacities> :P
21:17:58 <asettle> loquacities: woah continue
21:18:15 <asettle> Speaking of loquacities - install guide. GO GIRL GO
21:18:16 <loquacities> haven't ever seen him in the same room as batman, though
21:18:20 <loquacities> right, ok
21:18:21 <asettle> *oh*
21:18:41 <loquacities> so we have a landing page review: https://review.openstack.org/#/c/425821/12
21:18:47 <loquacities> #link https://review.openstack.org/#/c/425821/12 landing page review
21:18:50 <asettle> Yesss thank you nishpatwa007
21:18:55 <loquacities> absolutely :)
21:19:05 <loquacities> this is what it looks like so far: http://docs-draft.openstack.org/21/425821/12/check/gate-openstack-manuals-tox-doc-publish-checkbuild/54de4cb//publish-docs/www/project-install-guide/draft/index.html
21:19:23 <loquacities> also: testing is well underway: https://wiki.openstack.org/wiki/Documentation/OcataDocTesting#Installation_Guide
21:19:24 <asettle> Very swish!
21:19:27 <loquacities> #link https://wiki.openstack.org/wiki/Documentation/OcataDocTesting#Installation_Guide
21:19:42 <asettle> Sweet! Great news :)
21:19:48 <loquacities> so, obvs we still have more testing to do, and we need to land that patch, but we're on track :)
21:19:52 <loquacities> that's all from me :)
21:19:55 <asettle> Great :)
21:20:12 <asettle> Next up is John Davidge for the Networking guide but he's off.
21:20:24 <asettle> But on his behalf - I can say that he's been smashing networking guide bugs out of the park
21:20:39 <asettle> And he's working on a Networking Guide working group with the neutron team at the PTG
21:21:05 <asettle> If anyone's interested in getting involved, hit John up! He'll probably run it over the docs and neutron day sessions (all week) to try and get some key deliverables smashed.
21:21:14 <asettle> He is john-davidge on IRC :)
21:21:43 <asettle> Next up, darrenc with Ops and Arch
21:21:58 <darrenc> cool
21:22:05 <darrenc> So there was email discussion last week on what to do with the arch guide
21:22:15 <darrenc> I *think* the general consensus is getting the draft guide published
21:22:31 <darrenc> I'll work with bsilverman_7 to prioritize a list of tasks for Pike, and create bug reports for each task
21:22:34 <asettle> *nods* yep, let's do our best for Pike and push it out
21:22:46 <bsilverman_7> Yes
21:22:58 <asettle> Thanks bsilverman_7 :)
21:23:31 <darrenc> I think there is still one arch guide patch in review
21:23:32 <bsilverman_7> Np. In an uber on way to airport. :-)
21:23:39 <annegentle> darrenc or bsilverman_7 what did you think of the data findings?
21:23:50 <annegentle> or ideas on other homes?
21:24:05 <bsilverman_7> Interesting but inconclusive
21:24:23 <darrenc> I think it showed the arch guide is still needed
21:24:36 <annegentle> darrenc or could be combined with ops guide
21:24:41 <annegentle> darrenc was my other thought
21:24:52 <asettle> Problems is annegentle we just moved the arch stuff out of the ops guide
21:25:16 <annegentle> heh. I'm behind then
21:25:27 <bsilverman_7> Ues, showed that arch is still needed but not buried in ops guide
21:25:44 <bsilverman_7> Ues/yes
21:25:56 <annegentle> yah, ok
21:26:15 <darrenc> so we should remove the arch content in the ops guide. It's been migrated to the arch guide
21:26:27 <asettle> Looking forward to seeing what you guys have got for Pike :)
21:26:31 <annegentle> darrenc ok is it the same in both places?
21:27:45 <bsilverman_7> Improvement s have been made in arch.
21:27:59 <darrenc> Well I movd across the content that was still relevant
21:28:18 <darrenc> and not out of date
21:28:45 <annegentle> cool darrenc I'd like to see the plan on the ML - thanks
21:29:01 <darrenc> but I was relying on bsilverman_7 and shaun's advice :)
21:29:09 <darrenc> will do
21:29:20 <asettle> Okay, cool!
21:29:38 <asettle> #action Darren C to send arch guide action plan to ML
21:29:54 <bsilverman_7> I am full of "advice" see HA debate :-)
21:30:03 <asettle> Apologies everyone - We've got a fair bit to cover just yet :)
21:30:11 <asettle> Next up in Nathaniel with the Security Guide
21:30:22 <asettle> He's not here but I can say that we have successfully moved the sec-guide bugs to the sec team to look after.
21:30:47 <asettle> Sec and doc team to coordinate and come up with action plan for the future of the sec guide at the PTG :)
21:31:03 <loquacities> brilliant idea, that
21:31:03 <asettle> Next up, Training Guides
21:31:09 <asettle> loquacities: I am *soooo* brilliant :P
21:31:13 <loquacities> :)
21:31:24 <asettle> :P
21:31:46 <asettle> Okay, it appears Matjaz is not around for Training Guides
21:31:50 <asettle> I have no update there.
21:31:53 <asettle> Training labs!
21:32:11 <asettle> Roger has left me with a little update note :)
21:32:34 <loquacities> yay!
21:32:36 <asettle> The training-labs team are working on releasing their draft for Ocata to gain some traction (is the TL;DR if that above statement)
21:32:47 <asettle> I've been attending their meetings to try and work with them a bit more :)
21:33:09 <asettle> If anyone has more ideas on how to get support for training-labs - message myself, Pranav, or Roger!
21:33:21 <asettle> And last, but not at all least, jrobinson with the User and Admin guides :)
21:34:09 <jrobinson> Okay, so the legacy command changes have gone through well this release,
21:34:39 <jrobinson> and the next steps is to check with the nova, neutron, cinder, and glance teams on the status of some specific project commands.
21:35:01 <asettle> jrobinson: sounds good! What's left of the command changes?
21:35:03 <jrobinson> At the same time, swift, trove, manila, and ceilometer do not have an OS command set ready yet.
21:36:09 <jrobinson> I don't have an exact list of what's left to change since there is a large number of commands to go through, but I have been through the guides once so far, and a lot of the commands are now OpenStack.
21:36:35 <jrobinson> Last thing is this patch:
21:36:38 <jrobinson> #link https://review.openstack.org/#/c/395729/
21:36:40 <asettle> jrobinson: that's terrific. Would you be able to go through the list perhaps and at the next meeting (which might be after the PTG?) let us know what's left?
21:36:45 <asettle> CooL!
21:36:54 <jrobinson> It's had workflow ticked twice, but not merged yet.
21:37:00 <asettle> jrobinson: the depends-on is not merged.
21:37:14 <asettle> It's got work to do :) so the gate won't pass until the other patch does
21:37:51 <jrobinson> asettle, I'll give it a try, no guarantees I might miss a command in one of the files, however.
21:38:13 <asettle> jrobinson: of course! Of course :) if you want help, please feel free to reach out at any time.
21:38:14 <jrobinson> That's all the User Guide updates for now.
21:38:18 <asettle> Thanks jrobinson :)
21:38:34 <asettle> We have made it to the other side of reports! Hooray!
21:38:37 <asettle> #topic Specs in review
21:38:45 <asettle> #link https://review.openstack.org/#/q/status:open+project:openstack/docs-specs,n,z
21:39:02 <asettle> Which pretty much points to loquacities and archiving
21:39:04 <asettle> #link https://review.openstack.org/#/c/426047/
21:39:08 <asettle> loquacities: any updates for us?
21:39:10 <asettle> Can we help at all?
21:39:16 <loquacities> not really, we can keep iterating
21:39:52 <asettle> What's the odds on it being merged by the PTG? :)
21:40:02 <loquacities> yeah, it'll happen ;)
21:40:33 <asettle> Cool :D
21:40:40 <asettle> Thanks so much for that loquacities
21:40:55 <asettle> Alright guys!
21:40:55 <asettle> #topic Countdown to release:
21:41:06 <asettle> So glad I copied across that colon there
21:41:08 <asettle> #link http://www.timeanddate.com/countdown/launch?iso=20170222T13&p0=1440&msg=OpenStack+Ocata+Release+Day&font=hand
21:41:18 <asettle> 12 days people!
21:41:27 <loquacities> eep!
21:41:37 <asettle> A reminder of our deliverables:
21:41:37 <asettle> #link https://wiki.openstack.org/wiki/Documentation/OcataDeliverables
21:41:52 <asettle> Now, just a quick shout out - does anyone need help with their action items?
21:42:17 <annegentle> I think the new meeting time has been good!
21:42:24 <asettle> annegentle: that's good to hear! :D
21:42:32 <asettle> How is this time suiting everyone? I know it's new. Doesn't suit everyone.
21:42:37 <annegentle> I'm still doing a happy dance every time I see HTTPS
21:42:41 <asettle> But it's been a trial-period this release
21:42:58 <asettle> annegentle: ugh yes! Kato and Andreas did an awesome job of updating that in 10.5 seconds too
21:43:06 <ianychoi> PDF... yep :)
21:43:14 <asettle> ianychoi: well hey night owl!
21:43:18 <annegentle> ianychoi wahoo dee hoo!
21:43:19 <asettle> You have had like what, 5 hours sleep?
21:43:36 <ianychoi> asettle, 5 hour sleeping right haha
21:43:39 <bsilverman_7> I need Gopher and WAIS versions now.
21:43:40 <asettle> :P terrible
21:43:47 <ianychoi> annegentle, hi :)
21:43:52 <asettle> Have you got time to give us a PDF update ianychoi ? :)
21:44:17 <ianychoi> #link http://lists.openstack.org/pipermail/openstack-docs/2017-February/009627.html
21:44:50 <ianychoi> I have summarized there: reviewing and applying to openstackdocstheme would be needed
21:45:05 <annegentle> ianychoi so I looked for reasoning for earlier font choices, and even at that time it took some reviewing to figure out the license. So I think you're better off with the liberation font.
21:45:52 <ianychoi> annegentle, aha then using CartoGothic will have no license conflict?
21:46:03 <annegentle> ianychoi and sorry, I don't have an answer on different variables in conf.py
21:46:16 <annegentle> ianychoi it doesn't, and we checked years ago, but really, go with liberation if the license is ok
21:46:41 <ianychoi> annegentle, aha i see!
21:46:48 <ianychoi> #link http://www.sphinx-doc.org/en/stable/latex.html
21:46:52 <annegentle> ianychoi and I think that we had to ship the ttfs
21:47:05 <annegentle> ianychoi to meet the licensing requirements, and let's not do that :)
21:47:50 <ianychoi> I mainly followed the manual and current conf.py settings would be fine
21:48:20 <ianychoi> #link https://review.openstack.org/#/c/430549/
21:48:30 <ianychoi> The revised patch ships Liberation font!
21:49:07 <loquacities> ooh! cool :)
21:49:22 <asettle> That's great ianychoi :)
21:49:28 <asettle> Is there anything we can help you with?
21:49:38 <annegentle> ianychoi ok, cool, is Liberation both sanserif and serif?
21:50:38 <ianychoi> annegentle, I shipped both of them Sans and Serif
21:50:44 <ianychoi> #link https://review.openstack.org/#/c/430549/6/doc/admin-guide/source/conf.py
21:50:51 <ianychoi> Also mono
21:51:32 <annegentle> ianychoi ok, got it! Nice work.
21:51:52 <asettle> Very cool :)
21:52:02 <ianychoi> Yep.. then would it possible to review https://review.openstack.org/#/c/430263/ and release new openstckdocstheme version?
21:52:33 <asettle> I'm sure once it's merged, bmoss and Maria would be happy to release :) (she says, throwing them under the bus)
21:52:45 <bmoss> +1
21:52:52 <asettle> #action Team to review https://review.openstack.org/#/c/430263/
21:53:10 <asettle> Sorry guys, we gotta get through the rest of the items here :)
21:53:11 <asettle> Won't be too long
21:53:20 <asettle> #topic PTG Atlanta Feb 20-24 2017 - planning underway!
21:53:29 <asettle> Event info:
21:53:29 <asettle> #link http://www.openstack.org/ptg
21:53:38 <asettle> Tickets (in case anyone needs):
21:53:38 <asettle> #link https://pikeptg.eventbrite.com/
21:53:51 <asettle> Planning! Don't forget to put your item up:
21:53:52 <asettle> #link https://etherpad.openstack.org/p/docs-i18n-ptg-pike
21:54:04 <asettle> ianychoi and I will begin our planning for our joint sessions
21:54:11 <asettle> Reminder that docs is on Monday and Tuesday
21:54:14 <ianychoi> Yep :)
21:54:28 <asettle> If you wanna chat, but can't come, we can still represent you, OR have you virtually there :)
21:54:34 <asettle> So don't be afraid to put your name or ideas down
21:54:53 <asettle> #topic Boston Summit
21:55:00 <asettle> CFP is now closed!
21:55:10 <asettle> Looking forward to see who gets their talks in :)
21:55:17 <asettle> For more info:
21:55:19 <asettle> #link https://www.openstack.org/summit/boston-2017/
21:55:28 <asettle> Sorry gotta zip now
21:55:33 <asettle> #topic Bug triaging
21:55:45 <asettle> Reminder to put your name down for bug triaging responsibilities:
21:55:49 <asettle> #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams
21:55:50 <asettle> *phew*
21:55:56 <asettle> #topic Open discussion
21:55:58 <asettle> Everyone as you were
21:56:15 <asettle> 4 minutes left :) any questions, concerns?
21:56:24 <asettle> Reminder that loquacities is technically the PTL sooooo I know nothing
21:56:25 <asettle> :P
21:56:31 <iphutch> please ping me if you you are interested on collaborating for the HA guide in pike :)
21:56:38 <asettle> Thanks iphutch :)
21:56:54 <annegentle> iphutch are you also asking the openstack-operators ML?
21:57:05 <iphutch> sure am
21:57:11 <annegentle> iphutch coo
21:57:14 <annegentle> cool even
21:57:42 <jrobinson> On the ML, there has been a discussion about moving the admin guide to the developer repositories. Just a quick comment to say the Nova team might also be interested in a move.
21:57:50 <ianychoi> And.. it seems that asettle now updates docs crossproject liaison: https://wiki.openstack.org/wiki/CrossProjectLiaisons#Documentation
21:57:58 <asettle> Oh great jrobinson :)
21:58:06 <bsilverman_7> Iphutch, I'll contact you after we clear the arch guide
21:58:06 <asettle> ianychoi: I sure have been!
21:58:14 <ianychoi> I18n-Docs liaison is katomo :)
21:58:22 <asettle> We have a new faces in the Cross Project Doc world - few members are out, few in. We're chasing up a few others.
21:58:29 <asettle> Hooray, thanks ianychoi :)
21:58:36 <iphutch> bsilverman_7: great!
21:58:59 <asettle> jrobinson: we'll probably want to discuss that in depth at the PTG with ildikov
21:59:16 <asettle> But perhaps if you and ildikov could sync up and form an action plan so it's less of a free-for-all - that would be great.
22:00:02 <asettle> Also, if you wanna have a chat about something in these meeting schedules, please update: https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
22:00:04 <asettle> On that note
22:00:06 <asettle> We gotta scoot!
22:00:12 <asettle> That was fast, woah
22:00:19 <asettle> Any questions, concerns, feelings, head over to #openstack-doc
22:00:29 <asettle> Let's start saying hello in our mornings! Make it friendly peeps!
22:00:36 <asettle> Okay, Settle = Out!
22:00:36 <bsilverman_7> C u all at PTG
22:00:36 <ianychoi> Yep iime is going fast. Thanks a lot for today asettle + all docs team members!
22:00:45 <ianychoi> s/iime/time
22:00:55 <iphutch> o/
22:01:01 <ianychoi> o/
22:01:02 <asettle> o/
22:01:05 <asettle> #endmeeting