20:59:56 <asettle> #startmeeting docteam
20:59:57 <openstack> Meeting started Thu Feb 23 20:59:56 2017 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:00 <openstack> The meeting name has been set to 'docteam'
21:00:05 <asettle> Yesssss right on 4pm
21:00:11 <asettle> #action Roll Call
21:00:13 <asettle> o/
21:00:36 <skelso> o/
21:00:39 <iphutch> o//
21:00:55 <asettle> Mornings dudes.
21:01:01 <asettle> Waiting for early morning folks to walk in, let's give it 5
21:01:24 <asettle> I spy a jraim
21:01:26 <asettle> jrobinson:
21:01:30 <asettle> Damnit sorry jraim
21:01:45 <asettle> bmoss: helloooo :)
21:01:49 <bmoss> yo!
21:02:01 <asettle> Welcome!
21:02:08 <asettle> We're giving all the humans until 5 past to make it in
21:02:16 <asettle> Might not make quorum :)
21:02:25 <jrobinson> yes I am here :).
21:02:40 <bmoss> cool
21:02:43 <darrenc> hello o/
21:02:57 <asettle> A wild darrenc appears
21:03:04 <aspiers> o/
21:03:09 <asettle> o/
21:03:10 <darrenc> \o\ /o/
21:03:29 <aspiers> |    |
21:03:40 <aspiers> / \  / \
21:03:43 <asettle> How very meta
21:03:47 <aspiers> damn, I missed
21:03:51 <asettle> hahhahahaha
21:04:00 <asettle> I see, I see
21:04:10 <aspiers> or maybe the one on the right is doing a Usain Bolt impression
21:04:23 <asettle> aspiers: relatively accurate. I'd believe.
21:04:49 <asettle> Alright, let's roll shall we?
21:04:55 <aspiers> aye
21:04:58 * iphutch is ready
21:05:02 <asettle> #topic Action items from the last meeting
21:05:14 <asettle> Number one action! Darren C to send arch guide action plan to ML - Done!
21:05:25 <asettle> Number two action! Team to review https://review.openstack.org/#/c/430263/ - Doing!
21:05:30 <asettle> #link https://review.openstack.org/#/c/430263/
21:05:33 <asettle> Could we get some more eyes on that one please?
21:05:37 <asettle> Specific bmoss and the tools team
21:05:46 <asettle> berendt: if you're floating around, could you take a quick look too?
21:05:47 <darrenc> erm, I don't think I've done that
21:06:18 <darrenc> I was planning to do that post PTG
21:06:20 <asettle> darrenc: pre-PTG planning. Mostly around the steps of 1: look at the analytics, 2: plan at PTG 3: Publish for Ocata
21:06:21 <berendt> yes
21:06:26 <asettle> berendt: gracias
21:06:39 <asettle> But, if you'd like darrenc I can definitely reaction that one :D
21:06:43 <asettle> re-action*
21:06:56 <asettle> Esp cause I know there's more to let everyone know about :)
21:07:07 <darrenc> cool
21:07:38 <asettle> #action Darren C to send out arch-guide action plan to ML! (post-PTG ;))
21:08:07 <asettle> Anyone else got the time to help out with the PDF review? :)
21:08:10 <darrenc> will do :)
21:08:58 <asettle> Okay :)
21:09:00 <asettle> Let's moveeee it onnnn
21:09:02 <asettle> #topic Countdown to release
21:09:06 <asettle> Ocata release is done, YAY!
21:09:18 <iphutch> \o/
21:09:19 <asettle> Big thanks to Maria, and bmoss !
21:09:25 <asettle> As our amazing release managers :)
21:09:44 <asettle> Also, cannot go unsaid, huge thanks to annegentle for stepping in when we released there was some unplanned 404-ing
21:10:26 <asettle> So, thank you all!
21:10:34 <bmoss> on a related note
21:11:02 <bmoss> There is a patch up to update the release tasks in the Contributor Guide: https://review.openstack.org/#/c/437197
21:11:09 <asettle> bmoss: smart :D
21:11:14 <asettle> #link https://review.openstack.org/#/c/437197
21:11:23 <bmoss> so if you're interested, please have a look
21:11:32 <asettle> I will definitely be doing so :) thanks for updating bmoss !
21:11:50 <asettle> On a related note as well, everyone take a look at our swish new landing page!
21:11:52 <asettle> #link https://docs.openstack.org/project-install-guide/ocata/
21:12:04 <asettle> Big thanks to nishpatwa007 who poured his blood, sweat and tears into that bad boy
21:12:20 <asettle> So far it has been well received at the PTG (people like pretty pictures?)
21:12:36 <jrobinson> This looks so good!
21:12:45 <asettle> Yep! Well pleased :D
21:13:13 <darrenc> yes, it looks great!
21:13:28 <jrobinson> Visuals always help to communicate tricky concepts, and we now have a very clear visual explanation of how the install tutorial and guides work.
21:13:54 <jrobinson> Enormous thanks to nishpatwa007
21:13:59 <asettle> And so, without further ado, I announce the pike schedule!
21:14:07 <asettle> #link https://releases.openstack.org/pike/schedule.html
21:14:17 <asettle> Everyone keep that in mind. We'll be releasing last week of Aug/beginning of SEpt
21:14:42 <asettle> I will setup a countdown timer once I'm back in the land of normal
21:15:03 <asettle> Alright! The big cheese!
21:15:04 <asettle> #topic PTG Atlanta Feb 20-24 2017 - What did we achieve?!
21:15:19 <asettle> #link https://etherpad.openstack.org/p/docs-i18n-ptg-pike\
21:15:23 <asettle> Firstly, woah! Look at this etherpad!
21:15:37 <aspiers> hehe
21:15:40 <jrobinson> About seven months in the Pike release, after the short Ocata, it good to have a longer release cycle.
21:15:41 <asettle> I mostly called this meeting to have the opportunity to report back on specific items that were of interest
21:15:48 <asettle> jrobinson: totally dude
21:16:15 <asettle> So, I'm happy to say, we have done an awesome job at the PTG. Cross-project and break out sessions have been great. But we had wonderful support on the Mon - Tues
21:16:37 <asettle> We were a small team, as not many were able to attend, but we welcomed some newcomers - everyone meet skelso
21:16:59 <asettle> Plus, we had lots of drop ins from the Designate, neutron, security, octavia, and ironic teams
21:17:04 <skelso> Hi folks!
21:17:23 <asettle> Some big new changes coming up:
21:17:33 <darrenc> hi skelso o/
21:17:34 <asettle> 1. aspiers has worked hard to introduce reno release notes into docs
21:17:39 <asettle> WoooooO! Thanks aspiers :D
21:17:42 <aspiers> :D
21:17:48 <asettle> aspiers:  if you have your patches you want reviews on, shove them in here now with #link
21:17:52 <aspiers> ok
21:18:05 <aspiers> #link https://review.openstack.org/#/c/437611/
21:18:55 <nishpatwa007> Anytime asettle jrobinson :) I am up for anything
21:19:09 <asettle> nishpatwa007: love your stuff
21:19:10 <asettle> aspiers: thanks!
21:19:19 <asettle> #action Team to review reno patches for docs!
21:19:49 <asettle> 2. Another achievement that is entirely attributed to aspiers and iphutch (and without being said, bsilverman_7 ) - we have crafted a new ToC for the HA Guide
21:19:54 <asettle> If anyone is interested
21:19:56 <asettle> #link https://etherpad.openstack.org/p/HA_Guide
21:20:09 <asettle> skelso was also able to provide some valuable input - great to see new people shaping the future!
21:20:42 <asettle> iphutch: will be working straight up on the structure and from there, actioning in all the ToDos and new content with the OSIC team nad help from aspiers and teh HA team
21:20:43 <skelso> Being nice
21:20:48 <nishpatwa007> kudos
21:20:59 <asettle> If anyone is HA interested, you know where to go ;)
21:21:00 <iphutch> \o\ /o/
21:21:06 <asettle> aspiers and iphutch - do you have anything to add here? :)
21:21:22 <iphutch> thanks to everyone that contributed yesterday! Watch this space as I do some serious re-arranging of current content and we start filing bugs to fill current gaps :)
21:21:31 <aspiers> I guess I have something to add
21:21:44 <aspiers> I've been busy the last few days talking to neutron and cinder folks about HA
21:21:56 <aspiers> and also to the Congress folks at lunch today
21:22:04 <aspiers> so I have some new information to put into the guide
21:22:16 <asettle> aspiers: that's really great!
21:22:27 <asettle> Perhaps you and iphutch can work on org-ing that together?
21:22:28 <aspiers> as the re-arranging starts to happen, obviously we'll encounter some merge conflicts
21:22:31 <aspiers> but that's OK
21:22:37 <aspiers> since fixing the conflicts should be easy
21:22:39 <asettle> Heh, most likely.
21:22:53 <asettle> But! Part of the fun? (she says, unconvincingly)
21:23:53 <aspiers> the biggest outcome from the neutron L3 HA talks (especially this morning) has been https://ethercalc.openstack.org/Pike-Neutron-L3-HA
21:24:05 <aspiers> which is pretty much ready to be converted and imported into official docs
21:24:10 <iphutch> asettle: I'm all for that collab with aspiers
21:24:20 <asettle> #link https://ethercalc.openstack.org/Pike-Neutron-L3-HA
21:24:27 <skelso> That table rocks.
21:24:28 <aspiers> and we have just started to discuss how to do that, with native .rst if possible
21:24:28 <asettle> aspiers: awesome. I am so excited to see that coming in
21:24:33 <asettle> skelso: totally
21:24:37 <aspiers> thanks :)
21:24:45 <asettle> aspiers: bmoss might be able to help you more with that. He's an RST wizard. He bends it to his will.
21:24:47 <asettle> Promise you.
21:24:59 <aspiers> sounds good
21:25:02 <iphutch> aspiers: she's come a long way!
21:25:11 <iphutch> (the doc, that is)
21:25:24 <aspiers> iphutch: yeah, I've been working on that continuously the last 48 hours
21:25:40 <asettle> Man it's impressive.
21:25:47 <asettle> It'll look good in the guide :D
21:25:58 <aspiers> BTW it's possible to export a CSV via https://ethercalc.openstack.org/Pike-Neutron-L3-HA.csv
21:26:11 <aspiers> everyone take a copy now just in case someone accidentally trashes it ;-)
21:26:15 <asettle> Hahhahahaha okay
21:26:19 <asettle> #link https://ethercalc.openstack.org/Pike-Neutron-L3-HA.csv
21:26:55 <aspiers> anyone got a csv to rst table converter handy? :)
21:27:07 <asettle> aspiers: you know, you might be able to use pandoc
21:27:12 <aspiers> yeah maybe
21:27:22 <asettle> Anyway, gotta move on!
21:27:27 <asettle> But if anyone's HA mad, you know where to find them
21:27:45 <asettle> 3. Third big discussion was distributed docs repositories - which more or less lead to the agreement on splitting out the Administrator Guide
21:28:18 <asettle> We had a few projects really interested in this. I have proposed that the docs team work on implementing a best-case specification
21:28:27 <asettle> Pike TODOs:
21:28:28 <asettle> Contact PTLs and project liaisons to inform of new decision
21:28:28 <asettle> Work on specification detailing the 'how' - approve on team
21:28:29 <asettle> Projects + docs to work on appropriate template
21:28:31 <asettle> Queens TODOs:
21:28:33 <asettle> Implementation period
21:28:59 <asettle> Which, jrobinson and Ildiko and myself will be able to implement over the next two release cycles
21:29:11 <asettle> jrobinson: I know you were sick and unable to remotely attend, I can find some time later this week to catch you up on all the crazy
21:29:19 <jrobinson> As I discussed in the last meeting - and after re-reading the etherpad on distributed docs repositories - I am still happy to volunteer to write the spec for the admin guide
21:29:27 <asettle> jrobinson: that's really great! Thank you
21:29:33 <asettle> #action jrobinson to write spec for the admin guide
21:29:42 <asettle> I know that Ildiko is really interested in it, and has promised some help
21:29:50 <asettle> I recommend emailing/messaging her for context :)
21:30:33 <jrobinson> Yes I don't full understand the rationale behind the dev-doc repo linking to an admin guide index.rst file, but I'm sure it will make sense.
21:30:45 <jrobinson> ^symbolic link.
21:31:03 <asettle> Hahhaa yeah, it was pretty fully on. We can definitely sit down and chat about it sometime soon :) it was a big session
21:31:30 <asettle> Okay, moving along (sorry to rush, but we had a lot)
21:31:34 <asettle> 4. Archiving and versioning of documentation
21:31:48 <asettle> We talked a lot about implementation and bmoss was there to help out with some major questions surrounding implementation
21:32:09 <asettle> I dunno if bmoss is at his computer right now to talk more about that, so we might just skip over it :)
21:32:23 <bmoss> I think the notes from the session were pretty good
21:32:27 <asettle> Oh there you are! :)
21:32:40 <bmoss> now it is about getting some patches rolling
21:32:48 <asettle> Sounds good bmoss :) are you in charge of that one with loquacities ?
21:32:59 <bmoss> yep
21:33:05 <asettle> Awesome :) looking forward to seeing it
21:33:20 <bmoss> :)
21:33:50 <asettle> Other big discussions included the security guide
21:33:59 <asettle> We have the sec team on board. We're working on a plan to ensure the guide is maintained.
21:34:12 <asettle> The OSIC team has already hit the ground runinng and taken on board 10 bugs to deliver soon
21:34:36 <iphutch> awesome!
21:34:43 <asettle> Then, we're going to work on scoping an appropriate audience, services, and content. And then start working on a POC and ToC
21:35:05 <asettle> This'll be a slower effort, as we do have less resources. But this is something we are going to ramp over over the coming cycles.
21:35:08 <asettle> Slow burner, if you will.
21:35:30 <asettle> If anyone's interested in security, you know where to head.
21:35:54 <asettle> We also had the neutron team pay a visit to discuss the maintenance of the Networking Guide
21:36:13 <asettle> They're going to be working a bit closer with John Davidge to maintain the guide.
21:36:37 <asettle> He has a list for suggested improvements
21:36:38 <asettle> #link https://etherpad.openstack.org/p/networking-guide-improvements
21:36:51 <asettle> I will ask that he sends out a summary of that too at some point :)
21:37:03 <asettle> And of course, we talked about hte arch guide
21:37:06 <asettle> darrenc - your turn ;)
21:37:44 <darrenc> I think it's covered in the etherpad notes :)
21:38:06 <aspiers> can I add to that etherpad?
21:38:16 <aspiers> one thing discussed today was cross-linking between networking guide and HA guide
21:38:17 <darrenc> but I've drafted a spec for ocata
21:38:20 <aspiers> in both directions
21:38:25 <darrenc> https://review.openstack.org/#/c/436747/
21:38:37 <asettle> aspiers: uhhhhh sure yes
21:38:45 <asettle> #link https://review.openstack.org/#/c/436747/
21:38:48 <asettle> Thank you darrenc !
21:38:55 <darrenc> np :)
21:38:58 <asettle> #action team to review arch guide spec
21:39:08 <asettle> Everyone please take the time to check this out
21:39:16 <asettle> We wanna be dealing pretty heavily with this guide this release
21:39:36 <asettle> Unfortunately it's been long-standing tech debt, and we need to ensure that we are publishing in Ocata and we're moving forward
21:40:24 <asettle> But, in summary
21:40:28 <asettle> We've had a hugely successful PTG
21:40:39 <asettle> Working with ianychoi and the i18n has been really beneficial
21:40:57 <asettle> Here I've just gone through the docs items but we were able to work alongside the i18n for plenty of action items and that was really beneficial cross-project work
21:41:05 <asettle> Would love to see more collaboration
21:41:19 <asettle> If anyone is keen on the notes from those discussions, you can see the full list here:
21:41:20 <asettle> #link https://etherpad.openstack.org/p/docs-i18n-ptg-pike
21:41:49 <asettle> I'll be writing a summary up for super user
21:42:00 <asettle> And will be doing a more indepth summary for the newsletter which I plan to send out tomorrow :)
21:42:01 <aspiers> This was my first real experience with the docs team as a whole, and it was a ton of fun. You guys rock. Thanks a lot everyone! <3 <3
21:42:08 <asettle> Thanks so much for coming aspiers :D
21:42:14 <asettle> IT was really great to have you, honestly.
21:42:23 <asettle> It's really cool to see what good things we can do :)
21:42:41 <asettle> Big thanks also to those who managed to come in remotely!
21:42:45 * aspiers wonders if we can have a PTG every week ...
21:42:46 <asettle> I can't believe that was actually functionaly
21:42:51 <asettle> functional*
21:43:09 <asettle> aspiers: HAHA RIGHT?! I was just talking to Allison about how well this has genuiely gone
21:43:11 <asettle> genuinely*
21:43:18 <asettle> Friggin hell. My typing is just blip today
21:43:38 <asettle> Anywayyyyyyy
21:44:15 <asettle> I'm going to skip the specialty team reports today, a lot of people are all over the place - let's resume normal operation on Thursday, the 9th of March
21:44:23 <asettle> #topic Bug triaging
21:44:30 <asettle> This week's triager is... darrenc !
21:44:38 <asettle> #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams#Bug_Triage_Team
21:44:39 <darrenc> woohoo!
21:44:42 <jrobinson> Sounds like a good plan. There are no new user guide updates.
21:44:47 <asettle> darrenc: unfortunately there is quite a list for you there :P
21:45:16 <darrenc> no problem
21:45:18 <asettle> If anyone is able/interested/has not already signed up to be a bug triager to help out with our team, please sign up on the link above
21:45:35 <asettle> I believe aspiers had some good idea surrouding updating our process and documenting other pieces of assumed knowledge
21:45:39 <asettle> aspiers: do you want to say something a bit more to that?
21:45:49 <aspiers> sure, if I can remember what that was
21:46:01 <aspiers> well, one thing is that I found out how to subscribe to bugs by tag
21:46:07 <aspiers> and I documented it
21:46:22 <asettle> Oh yeah!
21:46:26 <asettle> That was really cool :) thank you
21:46:33 <aspiers> #link https://docs.openstack.org/contributor-guide/doc-bugs.html#tracking-bugs-by-tag
21:46:45 <aspiers> was there something else?
21:46:48 <aspiers> I can't remember
21:47:03 <bmoss> I have a bug-related comment
21:47:54 <bmoss> please file theme, build, and tool bugs in the openstack-doc-tools project on Launchpad
21:48:03 <asettle> Oh!
21:48:05 <asettle> That is an excellent point bmoss
21:48:10 <asettle> We should document that too :p
21:48:13 <asettle> Contrib Guide!
21:48:19 <bmoss> asettle, already done. :)
21:48:29 <asettle> bmoss: have you moved the already existing bugs over?
21:48:32 <bmoss> but I just wanted to mention it since it is a change from that last few releases
21:48:44 <bmoss> not yet, I was waiting until after the release
21:49:08 <bmoss> but also don't worry if you do file a bug in openstack-manuals, if we identify it is as a tools bug we'll just move it over.
21:49:28 <asettle> bmoss: ace :) thank you!
21:49:32 <asettle> berendt: ^^^
21:49:37 <asettle> I just tag Christian when I need him now.
21:49:40 <asettle> It's very efficient
21:49:49 <bmoss> lol
21:49:52 <ianychoi> sorry lol
21:49:58 <ianychoi> docs team meeting time
21:50:10 <asettle> Not at all :)
21:50:11 <ianychoi> I have not recognized it because of another meeting
21:50:11 <asettle> Welcome to the fold
21:50:14 <asettle> That's okay!
21:50:21 <asettle> Did you get the sign?!
21:50:45 <ianychoi> asettle, yep! Thanks a lot! I now have the paper (sign: Docs+I18n)!
21:50:56 <asettle> ianychoi: hooray :D I'm glad to hear it.
21:51:12 <asettle> I picked them up yesterday and was trying to find a good time to give them to you
21:51:14 <asettle> But alas
21:51:21 <asettle> Andy the good deliverer :p
21:51:22 <ianychoi> asettle, and thanks a lot for organizing all especially for with I18n team! Without your help it would be impossible for I18n team to join in PTG
21:51:43 <asettle> Not at all :) am really happy how well it turned out :)
21:51:45 <ianychoi> Haha please delivery my appreciation :)
21:51:50 <asettle> Thank you so much for being an amazing collaborator ianychoi :)
21:51:58 <asettle> Okay, well, we have 8 minutes left
21:52:03 <asettle> #topic Open discussion
21:52:36 <asettle> Anyone? :)
21:52:50 <jrobinson> I don't have anything to add.
21:52:52 <annegentle> heya
21:52:54 <asettle> Sorry for talking your ears off, just wanted to make sure everyone heard the good, the bad, the ugly
21:53:21 <asettle> annegentle: heya!
21:53:29 <asettle> Thanks for being our 404 angel :)
21:53:36 <annegentle> I'd like to have someone write up a good incident report for that pair of 404s
21:53:49 <annegentle> we can get better at that with some better understanding of what happened
21:53:57 <asettle> annegentle: we have updated the contrib guide, but I think that might be best left in the hands of bmoss and Maria
21:54:01 <asettle> and loquacities
21:54:05 <asettle> Would you guys mind?
21:54:40 <ianychoi> And.. sorry for  not following all the things, but I have heard that today morning (here) docs.openstack.org was slow. What was the problem?
21:54:52 <annegentle> asettle yeah, I think Maria was interested in doing that
21:54:58 <asettle> annegentle: that's good :)
21:54:58 <annegentle> ianychoi I hadn't heard that
21:55:02 <asettle> ianychoi: neither ^^
21:55:12 <asettle> I haven't had any issues accessing today
21:55:20 <ianychoi> Oh really
21:55:45 <ianychoi> <gpocentek> docs.openstack.org is terribly slow for me, I am suffering alone or is this a server-side problem?
21:55:56 <ianychoi> reported in #openstack-doc irc channel
21:55:58 <asettle> Hmmm interesting.
21:56:08 <asettle> I'll ping Gauvain again and see what was up
21:56:14 <asettle> I wasn't experiencing any issues
21:56:22 <ianychoi> yep :)
21:56:25 <aspiers> seems fine to me here
21:56:29 <aspiers> ok I'm gonna temporarily sign off here, and head down from my hotel room to the feedback session. great meeting, thanks all and see some of you there!
21:56:38 <asettle> Yeah, will be there!
21:56:42 <asettle> See you shortly :)
21:56:51 <bmoss> o/
21:56:52 <annegentle> ianychoi do you want me to try to do the cross-platform (Mac) scripting work for PDF?
21:56:53 <asettle> Also going to cut this meeting shortly by 4 minutes unless anyone has some major concerns? :)
21:56:58 <skelso> Zips along here.
21:57:00 <jrobinson> o/
21:57:24 <annegentle> ianychoi I can at least start it, wasn't sure if there's a bug already
21:57:36 <asettle> Sweet :)
21:57:47 <asettle> Okay, I'm going to close this one out annegentle - if you and ianychoi wouldn't mind moving over to doc?
21:58:05 <iphutch> Thaanks everyone!
21:58:12 <asettle> o/ thanks dudes!
21:58:19 <asettle> #endmeeting