16:00:40 <asettle> #startmeeting docteam
16:00:41 <openstack> Meeting started Thu Jun  1 16:00:40 2017 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:45 <openstack> The meeting name has been set to 'docteam'
16:00:52 <mlavalle> o/
16:00:54 <asettle> #topic Roll call
16:01:00 <asettle> hi!
16:01:03 <mlavalle> o/
16:01:04 <rluethi> sup
16:01:20 <AJaeger> o/
16:01:25 <jungleboyj> o/  Coming to represent the Cinder peeps.  :-)
16:01:33 <asettle> And here I was, worried we wouldn't have quorum
16:01:39 <asettle> Looking at chicken pie recipes instead
16:01:40 <asettle> :p
16:02:20 <jungleboyj> Mmmm, Chicken Pie sounds good.  Guess I need to start thinking about lunch.
16:02:23 <asettle> I'll wait until 5 past before I get going.
16:02:28 <asettle> Yeah that was my thoughts today
16:03:14 <dhellmann> o/
16:03:19 <asettle> Ahoihoi
16:04:09 <asettle> Okay, let's start :)
16:04:09 <asettle> #topic Action items from the last meeting
16:04:18 * asettle asettle to chat to rluethi about training-labs and guides future
16:04:24 <asettle> rluethi: we didn't quite manage that, did we? :p
16:04:31 <rluethi> not that I know of.
16:04:47 <rluethi> well, there is always another chance.
16:05:00 <asettle> Let's book in some time next week to chat? Just an IRC convo, but I can send you a cal invite so at least we both know :)
16:05:06 <asettle> That sound alright?
16:05:11 <rluethi> deal.
16:05:17 <asettle> Done!
16:05:20 <ianychoi> o/
16:05:21 <asettle> I'll keep that action item though
16:05:29 <asettle> #action asettle to chat to rluethi about training-labs and guides future
16:05:36 * asettle asettle and ianychoi to discuss planning changes with translation activities
16:05:42 <asettle> This, we also did not do, did we ianychoi ? :p
16:05:55 <ianychoi> asettle, we have the same memory :)
16:06:05 <amotoki> o/
16:06:09 <asettle> Hahaha good good. Okay. Well. Let's also book in some time to talk this week :) how does that sound?
16:06:11 <asettle> amotoki: welcome :)
16:06:22 <ianychoi> Pretty cool!
16:06:33 <asettle> Excellent, excellent
16:06:37 <asettle> Will keep that action item up then
16:06:42 <asettle> #action asettle and ianychoi to discuss planning changes with translation activities
16:06:48 <asettle> #topic Count down to release
16:06:54 <asettle> #link https://www.timeanddate.com/countdown/newyear?p0=24&msg=Pike+release&ud=1&font=slab
16:07:01 <asettle> 30 weeks LOL
16:07:06 <asettle> But, that's coming up pretty damn fast
16:07:09 <ianychoi> LoL (2)
16:07:15 <asettle> I sent out a call for release managers today
16:07:22 <asettle> If anyone is interested and can help out, I would really appreciate it
16:07:40 <asettle> We need release help more than ever now. Esp considering our cores are continuing to dwindle
16:07:53 <asettle> Anyone interested?
16:07:56 <jungleboyj> The releases always do seem to come out of nowhere .
16:08:17 <asettle> We like to surprise you all with documentation
16:08:21 <asettle> It's an incredibly boring surprise
16:08:21 <dhellmann> asettle : what's involved in that?
16:08:26 <jungleboyj> :-)
16:08:31 <jungleboyj> dhellmann:  +1
16:08:42 <asettle> Without going into specifics too deeply
16:08:44 <asettle> #link https://docs.openstack.org/contributor-guide/release.html
16:08:52 <asettle> HEre's our overview
16:08:53 <asettle> #link https://docs.openstack.org/contributor-guide/release/taskoverview.html
16:09:14 <dhellmann> ok, I'll review those
16:09:18 <asettle> It's mostly regarding the install guide testing, packages, CPL checks (we should add the doc-tag to that list)
16:09:36 <asettle> Publishing branches, making sure the www stuff is up-to-date
16:10:08 <jungleboyj> I am planning/hoping before the end of Pike to get the docs bug mess in Cinder cleaned up a bit.
16:10:13 <asettle> Previously, two people volunteer to help out. The PTL and the managers will meet, sync up, and make sure that all release items are all done :)
16:10:18 <asettle> jungleboyj: woooo! :D
16:10:20 <asettle> Love the sound of that
16:10:26 <asettle> Do you need anything from us?
16:10:32 <jungleboyj> asettle:  Thought you would.
16:10:46 <asettle> I'm easily pleased.
16:11:08 <jungleboyj> asettle:  No, going to come join your meetings here.  Go through the bugs out there and do some cleanup / triage .  I will bring you all questions as they arise.  :-)
16:11:20 <asettle> Wonderful :) well, welcome. Thanks for coming :)
16:11:27 <asettle> Let us know what we can do to help you along the way :)
16:11:30 <asettle> Happy to answer any questions
16:11:34 <jungleboyj> Discovered I like documentation while working on upstream-institute
16:11:36 <asettle> I'm in the UK
16:11:47 <jungleboyj> Will do.
16:11:47 <asettle> Well, I'm glad to hear that!
16:12:13 <jungleboyj> So, I will help those release items from that aspect.
16:12:21 <asettle> That sounds great :) thanks. We appreciate that.
16:12:29 <jungleboyj> My pleasure.
16:12:31 <asettle> Okay, well if nobody is going to jump at the opportunity to be release managers right this second, i'll move on :p
16:12:32 <ianychoi> jungleboyj, wow more Docs-philic people :)
16:12:53 <jungleboyj> ianychoi:  :-)  Yep.  You helped inspire me.  ;-)
16:13:00 <asettle> I have never heard of it being referred to as 'docs-philic' but I think that's hilariously great.
16:13:14 <jungleboyj> asettle: +2
16:13:26 <ianychoi> jungleboyj, haha it's great pleasure. I also learned a lot from you during latest upstream institute!
16:13:38 <amotoki> :)
16:13:39 <asettle> Aw :)
16:13:45 <asettle> Okay team, let's keepa rolling
16:13:49 <asettle> #topic Operations Guide
16:13:58 <asettle> Some of you may have seen my emails that contained info about this
16:14:05 <asettle> Here's my most recent email to the ops list
16:14:05 <asettle> #link #topic Operations guide
16:14:07 <asettle> Oh ffs
16:14:11 <asettle> Copy pasta is hard
16:14:13 <asettle> #link http://lists.openstack.org/pipermail/openstack-operators/2017-June/013633.html
16:14:30 <asettle> TL;DR - we have three options for the future of hte ops guide, and I'm voting for option 3
16:14:32 <asettle> I wanna hear what you all think
16:15:28 <amotoki> honestly this topic raises me a question what is a difference between admin guide and ops guide
16:15:30 <AJaeger> asettle: option 3 means somebody needs to move it somehow in the wiki - so needs a volunteer and ownership
16:15:45 <rluethi> amotoki: +1
16:16:11 <asettle> amotoki: well, that's what the session was about. We all very much came to the conclusion that the two guides, although one was technically more theoretical, and one more practical, they were both for hte same audience
16:16:24 <asettle> Therefore, we decided that we had to go one of three ways with the guide's future
16:16:39 <asettle> In the session, the operators agreed that we should do option 3
16:16:44 <asettle> But I want to make sure the community agrees
16:16:49 <asettle> And as AJaeger says - we get some volunteers to help this move
16:16:50 <amotoki> i see. that makes sense.
16:17:26 <rluethi> asettle: If it's pretty much the same subject, how will they differ going forward?
16:17:32 <jungleboyj> That seems sensible.  An understandable division of the documentation.
16:17:47 <asettle> rluethi: in content, or maintainability?
16:18:07 <amotoki> regardless of wiki or git repo, who takes ownership? ops team from UC?
16:18:10 <rluethi> Well, the email talks about where each guide lives, but how is the content different?
16:19:19 <asettle> Ah, so, as I mentioned above - the main difference is mostly that one guide (ops) is more theoretical and concerns desiging, creating, and administratoring a production cloud
16:19:28 <asettle> Whereas admin is more about managing and troubleshooting
16:19:46 <asettle> Does that make sense?
16:20:02 <rluethi> I hope it does for the target audiences :).
16:20:06 <jungleboyj> asettle:  The admin guide is more driven by development while the ops guide is driven by developers.  RIght?
16:20:18 <rluethi> To me, it sounds like a difficult line to draw.
16:20:19 <jungleboyj> sorry
16:20:29 <jungleboyj> ops driven by operators
16:20:38 <asettle> Haha yep, with that correction, yep
16:20:54 <asettle> We still have the intention to move the Administration Guide out to the project repos for that reason
16:20:54 <ianychoi> But.. such all migration from current ops-guide to Wiki would require huge effort - maybe creating a basic wiki for ops-guide (same table of contents, migrating just key content, and referring to current ops-guide in docs.o.o would be a first step?
16:21:12 <jungleboyj> :-)  Yeah, minor detail.  So, having the ops guide easily accessible to operators on the wiki and making admin guide closer to what developers are used to makes sense.
16:21:21 <asettle> ianychoi: that's not a bad idea - we could then call for help?
16:21:30 <asettle> jungleboyj: yep, that's pretty much my thinking
16:21:37 <asettle> I probably haven't been clear enough in my email :/
16:21:54 <amotoki> another option on ops-guide is to delegate core team.
16:22:03 <asettle> What do you mean by that, amotoki ?
16:22:25 <jungleboyj> The challenge is going to be making the developers do it.  :-)
16:22:35 <asettle> jungleboyj: yo literally the story of my life
16:22:37 <amotoki> asettle: the wiki is not so easy to maintain. I believe gerrit review is really useful even for operators
16:22:40 <asettle> My autobiography will be titled that.
16:22:57 <asettle> amotoki: I completely agree with you. But we've struggled *so* much to get contributions from operators
16:22:59 <asettle> THey dont' want to use gerrit
16:23:04 <jungleboyj> :-)
16:23:06 <ianychoi> asettle, +1, because the most huge effort I think is that .rst syntax and MediaWiki syntax are not compatible. Migrating all the content may require long period..
16:23:18 <amotoki> hehe, difficult choice :p
16:23:29 <jungleboyj> ianychoi: :-(
16:23:35 <asettle> Hahhaha oh dear.
16:23:37 <asettle> You're all very correct.
16:23:58 <asettle> Hmm, anyway, let's see if I get any response from the ML - if not, I think we should make an executive decision. dhellmann - what would be TC appropriate protocol there?
16:24:31 <AJaeger> asettle: I think we're in charge here, no need for TC IMHO
16:24:32 <dhellmann> if you don't get a response, or if you don't have volunteers to do the work?
16:24:59 <asettle> AJaeger: mostly just wondering if TC would have an issue with me going "okay, no responses, nobody cares, bye bye guide"
16:25:02 <jungleboyj> Can the work of moving to the wiki be split among the team here.  Everyone take a section, reformat and move?
16:25:16 <asettle> jungleboyj: we normally would do that, but we barely have a team as is :(
16:25:18 <dhellmann> yeah, you don't need the tc to weigh in unless the decision is to mothball the guide
16:25:19 <dhellmann> and then it's just a matter of going through the process
16:25:26 <asettle> Coolio hoolio
16:25:30 <asettle> What is "the process"?
16:25:50 <dhellmann> jungleboyj : the whole point of this transition period is that there is not really a pool of people to do work like that
16:25:58 <asettle> ^ what he said
16:25:58 <dhellmann> asettle : let me find the doc, stand by
16:26:03 <asettle> Swell, swell
16:26:38 <dhellmann> asettle : https://docs.openstack.org/infra/manual/drivers.html#retiring-a-project
16:26:38 <jungleboyj> Ok.
16:27:00 <asettle> #link https://docs.openstack.org/infra/manual/drivers.html#retiring-a-project
16:27:01 <asettle> Just for later
16:27:04 <asettle> Thanks
16:27:05 <asettle> Okay
16:27:09 <asettle> This is good info :) AJaeger ^
16:27:29 <asettle> On that note, I'll move to the next topic because it's related
16:27:33 <asettle> #topic Docs team going forward
16:27:49 <asettle> So, we're looking to gather as many volunteers to help us do a lot of heavy lifting in the coming months
16:27:57 <asettle> So, I'm hoping we can all pool in and do some recruiting
16:29:25 <asettle> It appears that from our ML discussion
16:29:26 <asettle> #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/117162.html
16:29:33 <asettle> That we have chosen to go with option 1
16:29:40 <asettle> "We could combine all of the documentation builds, so that each project has a single doc/source directory that includes developer, contributor, and user documentation."
16:30:02 <asettle> We're going to need a really nice, special, helpful, person in infra to help us out :)
16:30:04 * asettle looks at AJaeger
16:30:30 * AJaeger is happy to review and advise - but cannot be in the driver seat
16:30:56 <asettle> Sounds good - AJaeger could you help us recruit someone (or recommend?) we could talk to about driving this with us
16:31:03 <dhellmann> I'll help with the build stuff, if AJaeger will help with reviews
16:31:19 <ianychoi> AJaeger, regarding this, maybe translation build jobs also need to be unified for Documentation builds?
16:31:34 <dhellmann> it should just be a matter of a new job that looks very much like the existing one, with a different publisher step, right AJaeger?
16:31:36 <asettle> Hmm, would it affect translation?
16:31:47 <dhellmann> good point
16:32:25 <asettle> How integrated are the builds currently?
16:32:32 <dhellmann> we already have translation jobs for the release notes. we can use those as the basis for new jobs.
16:32:35 <AJaeger> dhellmann: yes. You need to figure out whether we still to "tox -e venv python setup.py build_sphinx" or run "tox -e docs" instead - and then how to publish
16:33:20 <ianychoi> dhellmann, good point - yes all releasenote build jobs and AFAIK you, AJaeger, amotoki helped a lot
16:33:24 <AJaeger> translations will be affected
16:33:26 <amotoki> but the translation script does a lot, so we might need to update it. I believe AJaeger and i can help it
16:33:54 <dhellmann> ok. let's get the regular build stuff going and then add translations to it.
16:33:55 <AJaeger> dhellmann: I'm happy to review
16:33:58 * dhellmann likes to work in phases
16:34:06 <asettle> So, for the build changes - should we be looking at writing a spec, and then getting the plans nutted out a bit further?
16:34:16 <ianychoi> dhellmann, amotoki. AJaeger: Thanks a lot all!
16:34:38 <ianychoi> (I will follow such activities)
16:34:39 <amotoki> asettle: +1  it clarifies what's happening
16:34:47 <asettle> Okay
16:34:54 <asettle> #action asettle to write spec for build changes
16:35:22 <dhellmann> I can help with that, too
16:35:31 <asettle> Sweet, thanks dhellmann :)
16:35:37 <asettle> #topic Speciality teams reports
16:35:42 <asettle> annegentle: you around for the API report? :)
16:36:43 <asettle> Guessing not at the moment :) we can come back
16:36:49 <asettle> I can't see Matjaz either
16:36:55 <asettle> rluethi: it's all you and the Training Labs :)
16:37:24 <rluethi> We merged a few patches for Windows hosts, and there are a few more under review or otherwise pending.
16:37:24 <amotoki> regarding the API ref,  https://review.openstack.org/#/c/464255/ is proposing the addition of a new format. feedback would be appreciated.
16:37:25 <patchbot> patch 464255 - os-api-ref - WIP Add support for making sub-elements clearer
16:37:34 <asettle> #link #topic Speciality teams reports
16:37:36 <asettle> Thanks amotoki :)
16:37:41 <asettle> rluethi: that's cool :)
16:37:44 <rluethi> New features will have to wait until that's done.
16:38:28 <ianychoi> rluethi, cool for training-labs :)
16:38:45 <rluethi> I hope so :).
16:38:49 <asettle> Wonderful :) thanks for the update rluethi
16:39:34 <asettle> #topic Bug triaging
16:39:39 <asettle> #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams#Bug_Triage_Team
16:39:46 <asettle> Ben is our current bug triage liaison. Problems?
16:39:50 <asettle> (not that I heard of)
16:39:55 <asettle> I just pinged him, but he might not be around
16:40:00 <asettle> Next up is Olga (ogusarenko) for the 5 Jun - 19 Jun
16:40:19 <asettle> #topic Open discussion
16:40:26 <asettle> Okay, we're at the end folks. I don't think I have much else.
16:40:40 <asettle> I'm going to jump into the security team's meeting after this to talk about the Security Guide if anyone is interested
16:41:15 <mlavalle> asettle: I just want to let the team know that I have volunteered to be the Neutron liaison here
16:41:23 <asettle> mlavalle: wonderful :D thanks for coming along mlavalle
16:41:33 <asettle> mlavalle: have you had a peak at the Networking Guide by any chance?
16:41:53 <asettle> amotoki has been helping us out with a bunch of stuff, which has been awesome
16:41:54 <dhellmann> asettle : which channel?
16:41:56 <mlavalle> asettle: well, I look at different chapters every now and then
16:42:05 <asettle> dhellmann: #openstack-meeting-alt
16:42:16 <asettle> mlavalle: Okay cool :) well, john-davidge was pretty hands on! Which was great
16:42:20 <asettle> I don't know if you have the time for htat?
16:42:34 <amotoki> mlavalle: this is useful for me https://review.openstack.org/#/q/status:open+project:openstack/openstack-manuals+path:%255Edoc/networking-guide/.*
16:42:35 <jungleboyj> :-)  So we have an official Cinder and Neutron Liaison now.
16:42:47 <jungleboyj> Is there some place I should indicate that in the wiki?
16:42:51 <asettle> Yessss
16:42:54 <asettle> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#Documentation
16:42:56 <asettle> I was just about to shoot htat ot you
16:42:58 <asettle> that to you*
16:43:03 <asettle> If you could both update, that'd be great
16:43:05 <jungleboyj> asettle:  Thank you.
16:43:24 <mlavalle> amotoki: am I stepping on your tows? Should you be the Neutron liaison?
16:43:24 <asettle> Wellycomb
16:43:31 <mlavalle> ^^^toes
16:43:59 <amotoki> mlavalle: np. it is yours. i have too many hats...
16:44:23 <jungleboyj> Done.
16:44:31 <mlavalle> asettle: I have also too many hats. But this role was deemed important in a recent Neutron team meeting
16:44:57 <amotoki> mlavalle: asettle: we can share the loads. no worries
16:45:02 <asettle> Thanks for helping, it is important :) the Networking Guide is a highly valued doc and we really appreciate all updates and maintenance the neutron team can offer
16:45:11 <asettle> THank you both :) I really appreciate that
16:45:29 <mlavalle> asettle: so I would like to get guidance from you and amotoki as to where help is critical
16:45:54 <ianychoi> #link http://eavesdrop.openstack.org/meetings/openstack_i18n_meeting/2017/openstack_i18n_meeting.2017-06-01-07.18.html
16:46:00 <asettle> So, amotoki was picking up where John left off on this bug: https://bugs.launchpad.net/openstack-manuals/+bug/1656378
16:46:02 <openstack> Launchpad bug 1656378 in openstack-manuals "Networking Guide uses RFC1918 IPv4 ranges instead of RFC5737" [High,In progress] - Assigned to Chason (chen-xing)
16:46:04 <asettle> #link https://bugs.launchpad.net/openstack-manuals/+bug/1656378
16:46:08 <asettle> This is a high priority for us
16:46:19 <ianychoi> asettle, I think PDF support for translated documents would be possible. :)
16:46:32 <amotoki> ah... the remaining part is to change IP address/cidr in figures
16:46:42 <asettle> amotoki: ah wonderful! That's it?!
16:46:58 <asettle> ianychoi: wonderful :D
16:47:11 <amotoki> I believe all stuffs in the rst contents have been clean up
16:47:22 <asettle> Oh that's such good news!
16:47:23 <asettle> Thank you amotoki :)
16:47:32 <asettle> Okay, well, mlavalle that was a number one prio
16:47:37 <amotoki> I will post changes in figures in this month
16:47:39 <asettle> But I would appreciate bug tackling: https://bugs.launchpad.net/openstack-manuals/+bugs?field.tag=networking-guide
16:48:06 <mlavalle> asettle: ok, I'll keep an eye on that and will coordinate with amotoki
16:48:14 <asettle> Also, I know John had some plans for improvements here
16:48:15 <asettle> #link https://etherpad.openstack.org/p/networking-guide-improvements
16:48:17 <amotoki> one difficult thing is the netwokring guide sometimes use too many networks :(
16:48:24 <asettle> True that
16:48:32 <amotoki> we sometimes use four networks...
16:48:37 <asettle> Jeez :P
16:49:20 <amotoki> moving on ?
16:49:30 <asettle> Hahha oh yes! Sorry, we're in open discussion
16:49:33 <asettle> Anything from anyone else? :)
16:50:25 <asettle> Okay! Let's close it out :)
16:50:28 <asettle> Thanks for coming guys :)
16:50:45 <jungleboyj> Thanks!  Enjoyed joining you all today.
16:50:46 <rluethi> See you
16:50:53 <asettle> Thanks for coming jungleboyj :)
16:50:55 <asettle> o/
16:51:00 <asettle> #endmeeting