16:00:32 <asettle> #startmeeting docteam
16:00:33 <openstack> Meeting started Thu Jun 29 16:00:32 2017 UTC and is due to finish in 60 minutes.  The chair is asettle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:37 <openstack> The meeting name has been set to 'docteam'
16:00:55 <asettle> Anyone around? :)
16:01:05 <ianychoi> asettle, hi!
16:01:15 <AJaeger> \o/
16:01:20 <asettle> ianychoi: you woke up ridiculously early again :P
16:01:33 <rluethi> hey
16:01:40 <amotoki> o/
16:01:56 <ianychoi> asettle, haha it's 1am here - I am awake late now :)
16:02:15 <asettle> ianychoi: ah! that's not tooooo bad
16:02:20 <atheneum> exit
16:02:45 <ianychoi> asettle, :) Actually amotoki is the same :)
16:02:51 <asettle> I know, amotoki is alos crazy
16:02:57 <amotoki> it is a bit easier to join early morning meetings :)
16:03:00 <rluethi> our japanese friends are true heroes.
16:03:05 <AJaeger> asettle: lovely kind of crazy ;)
16:03:05 <asettle> rluethi: true that
16:03:11 <ianychoi> Haha..... :)
16:03:16 <amotoki> * easier than ....
16:03:30 <asettle> Okay, I'll give till 5 past the hour, as always
16:03:34 <asettle> For those that would like to take a look
16:03:36 <asettle> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Documentation_team_meeting
16:03:38 <asettle> The meeting agenda
16:04:03 <asettle> Very short. I'll be focusing on previous action items, coming release, and then if anyone wants to talk about the migration, I'll leave this meeting chan open for the full hour
16:05:37 <asettle> Okay, let's start
16:05:43 <asettle> #topic Action items from the last meeting
16:05:51 <asettle> Which, was like, meeting AGES ago!
16:05:55 * asettle asettle to chat to rluethi about training-labs and guides future
16:05:58 <asettle> Done! Tick that box
16:06:09 <asettle> I don't know if we *really* came to a conclusion, I think we'll have to chat some more about what the labs are doing
16:06:12 * rluethi nods
16:06:19 <asettle> dhellmann had some ideas regarding collaboration with the deployment teams
16:06:27 <asettle> This is something we should probably discuss further
16:06:40 <rluethi> I have not heard anything regarding this.
16:06:45 <asettle> I know dhellmann is in another meeting right now, so, when he's back rluethi we should find some time to chat
16:06:45 <rluethi> Haven't I?
16:07:00 <rluethi> k
16:07:05 <asettle> rluethi: no, I haven't brought it to you just yet :) was a passing conversation I had with Doug. But we would like to discuss the team's future with you :)
16:07:08 <asettle> It was a passing though
16:07:33 <rluethi> Also, I have not heard back from marketing(?) re: web access stats.
16:07:53 <asettle> rluethi: to be honest, neither. I'll chase them up for it :) thanks for reminding me
16:08:03 <asettle> #action asettle to chase up foundation for web access stats
16:08:11 <asettle> Okay, next action
16:08:12 * asettle asettle and ianychoi to discuss planning changes with translation activities
16:08:34 <asettle> ianychoi: we briefly spoke, and translation is greatly affected by the docs stuff. We're keeping tabs of impacts here:
16:08:36 <asettle> #link https://etherpad.openstack.org/p/doc-future-problems
16:09:05 <ianychoi> asettle, yep :)
16:09:25 * asettle asettle to write spec for build changes
16:09:33 <asettle> Which, I hope you have ALL seen by now
16:09:35 <asettle> #link http://specs.openstack.org/openstack/docs-specs/specs/pike/os-manuals-migration.html
16:10:06 <asettle> Okay, continuing on swiftly
16:10:25 <asettle> The big topic of the day is...
16:10:28 <asettle> #topic Doc migration
16:10:42 <asettle> So, for all doc-ers here that are helping out, save this in your tabs!
16:10:43 <asettle> #link https://review.openstack.org/#/q/status:open+topic:doc-migration
16:10:57 <asettle> The spec was passed last week thanks to dhellmann
16:11:05 <asettle> For those that haven't read the spec (uh, please do)
16:11:28 <asettle> THe project teams are currently in the process of moving out their project-relevant documentation into their specific repo
16:11:30 <asettle> With guidance from out team
16:11:31 <asettle> our*(
16:11:49 <asettle> So, anyway - I'm opening up this floor for people to come in with questions, concerns, etc
16:12:38 <asettle> We've had a lot of people coming to us over the last few weeks
16:13:42 <asettle> dhellmann: is keeping track of the migration here
16:13:43 <asettle> #link https://doughellmann.com/doc-migration/
16:14:48 * AJaeger thanks dhellmann for tremendous work on this!
16:15:09 <asettle> Absolutely!
16:15:15 <asettle> Thank you AJaeger :)
16:15:19 <annegentle> hear, hear! dhellmann for president!
16:15:26 <annegentle> wait. :)
16:15:26 <asettle> dhellmann: has done an amazing job of getting us all started when half of us simply just don't have the time
16:15:32 <asettle> annegentle: nah man I'm all for it continue :p
16:15:43 <annegentle> for sure
16:16:03 <ianychoi> +1 So great work, dhellmann !
16:16:33 * atheneum cheers for dhellmann
16:18:40 * setuid +1's dhellmann
16:21:44 <annegentle> so do we prioritize the sitemap.xml work higher than other work based on trying to get our search hits improved?
16:21:52 <annegentle> or is it all high priority already?
16:22:13 <asettle> annegentle: I admittedly thought it was all high priority already, but I could be wrong.
16:22:47 <annegentle> asettle it is... haven't heard a need to strictly prioritize other than the sitemap.xml coming up on the mailing list today
16:23:09 * annegentle admires the burndown chart. That is a thing of beauty
16:23:18 <asettle> Yeah, the burndown chart is hella impressive
16:23:40 <asettle> annegentle: the way I understand it, prio 1 is sitemap, then it'll be a domino effect of falling cards once we merge that first patch from dhellmann
16:26:42 <AJaeger> what exactly do you want to do with the sitemap?
16:27:47 <annegentle> AJaeger apparently it'll help with our problem of search hits bringing up old release content first
16:27:59 <annegentle> AJaeger rather than updated docs
16:28:22 <asettle> Which - I agree, is a priority. We've been having this issue for ages, and if we can help solve it sooner rather than later, I'm all for it.
16:28:31 <annegentle> AJaeger I think the current sitemap planning looks like an improvement
16:31:22 <AJaeger> annegentle: I still don't know what actually to do.
16:31:52 <AJaeger> We need to regenerate the sitemap *after* dhellmann's reorg changes land. Since the complete docs.o.o page will look totally different.
16:32:03 <AJaeger> If we need to change logic, we can do that anytime.
16:32:47 <asettle> That's true too
16:33:48 <annegentle> AJaeger does the generation automation take into account active/inactive projects?
16:33:49 <AJaeger> IMHO we need to help getting the site ready, regenerate sitemap.xml so that it points to all the new and changed content - and then work on improving it. Besides regenerating it, I have not seen anything actionable yet.
16:33:54 <annegentle> AJaeger that's all I was thinking could be additional
16:34:25 <AJaeger> annegentle: it takes into accounts 404s. So, if we add those 404s as redirects to .htaccess, the sitemap will not find the pages.
16:34:49 <AJaeger> We already remove retired projects from all our index pages, so nothing should point to them.
16:34:52 <annegentle> AJaeger ok
16:35:11 <AJaeger> But somebody needs to double check. retirement is not happening often - but we have no scripts to check.
16:35:23 <annegentle> AJaeger yeah it was the scripting I was curious about
16:35:31 <AJaeger> With dhellmann's changes to put all projects into yaml files, we can easily script and check that it does not contain retired projects
16:35:54 <annegentle> AJaeger that's great and what I was hoping!
16:36:04 <AJaeger> (dhellmann's yaml files are used to generate the index pages we have)
16:36:31 <annegentle> AJaeger should i capture that thought anywhere?
16:36:54 <AJaeger> So, IMHO: Merge dhellmann's changes, write a script on top of his stack to cross check that we only list official products listed in governance - and that way we do not need to check for retirement since retirement means removal from governance docu
16:37:15 <AJaeger> annegentle: yes, on the future problems etherpad
16:37:20 <annegentle> AJaeger will do
16:37:35 <AJaeger> thanks, annegentle !
16:41:10 * AJaeger needs to leave now and waves good bye
16:41:17 <asettle> Adios AJaeger o/\
16:41:42 <rluethi> bye, AJaeger !
16:44:02 <annegentle> oh goodie, I have the cSS fix that should fix the dropdown list for releases! Yippee
16:44:43 <asettle> annegentle: \o/
16:44:46 <ianychoi> (I also need to leave now - see u all!)
16:44:50 <asettle> I'll keep my eyes open!
16:44:52 <asettle> Cya ianychoi :)
16:49:28 <annegentle> asettle one thing to think about is writing a policy for when to set up your conf.py to have releases... I can take that on
16:49:52 <asettle> That'd be really helpful! Thank you annegentle :)
16:51:17 <asettle> I assume based on crickets everyone understands the migration perfectly ;)
16:51:21 <asettle> Terrific :D
16:51:35 <asettle> Any objections to shutting down a few minutes early? I gotta catch a train if possible :)
16:52:48 <rluethi> silence is compliance?
16:52:58 <asettle> rluethi: you got it pal ;)
16:53:09 <rluethi> :)
16:53:13 <asettle> If anyone gets stuck or does have more concerns, you know where to find me or dhellmann
16:53:23 <asettle> rluethi: let's chat some more in the future about things :) i'll shoot an email your way this week!
16:53:33 <rluethi> k
16:53:33 <asettle> Thanks to annegentle for being bug triage liaison for this fortnight
16:53:42 <asettle> I'll send a reminder email to Maria to keep up the duty!
16:53:42 <annegentle> it wasn't bad at all!
16:53:50 <asettle> annegentle: anything to report? :)
16:53:58 <annegentle> not really!
16:54:03 <asettle> Neat, that's what I like to hear :)
16:54:05 <annegentle> Basically asking for more info on a few
16:54:08 <annegentle> that's about it
16:54:18 <asettle> Sweet. Well, I think the bug triage liaison role is working for us
16:54:58 <annegentle> oh yeah
16:55:35 <asettle> Sweet, well, on that note :)
16:55:41 <asettle> Adios homies! Thanks all for stopping by :)
16:55:47 <annegentle> byeee!
16:55:50 <asettle> Hopefully we'll continue to be succcessful!
16:55:51 <asettle> o/
16:55:55 <asettle> #endmeeting