16:00:16 <pkovar> #startmeeting docteam
16:00:16 <openstack> Meeting started Wed Nov 29 16:00:16 2017 UTC and is due to finish in 60 minutes.  The chair is pkovar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:20 <openstack> The meeting name has been set to 'docteam'
16:00:42 <pkovar> #topic roll call
16:00:50 <pkovar> o/
16:00:53 <pkovar> \o
16:01:03 <pkovar> \o/
16:01:04 <jamesmcarthur> \o
16:01:17 <eumel8> \o/
16:01:26 <jungleboyj> o/
16:01:56 <pkovar> meeting agenda available at the usual location at https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting
16:03:10 <pkovar> let's wait for a few more mins
16:03:21 <chason> o/
16:05:12 <pkovar> okay, first item
16:05:20 <pkovar> #topic Docs team vision document
16:05:28 <pkovar> #info Merged
16:05:33 <pkovar> #link https://docs.openstack.org/doc-contrib-guide/team-vision.html
16:05:51 <pkovar> i think we haven't had a mtg for a while, so just fyi
16:06:12 <pkovar> thanks again to everybody who helped with contributing to the vision doc!
16:06:29 <jungleboyj> That is good news.  :-)
16:06:51 <pkovar> we merged this right before the summit, actually
16:07:32 <pkovar> #topic Docs retention policy changes
16:07:40 <pkovar> #info WIP
16:07:47 <pkovar> #link https://review.openstack.org/#/c/521961/
16:07:52 <pkovar> mitaka content is back
16:08:05 <pkovar> as you can see: https://docs.openstack.org/mitaka/
16:08:47 <pkovar> also, links to mitaka guides got fixed yesterday
16:08:53 <pkovar> thanks again, team
16:09:04 <jamesmcarthur> hooray!
16:09:12 <pkovar> now, we need to work on the ocata part
16:09:21 <pkovar> stable/ocata branch, that is
16:09:45 <pkovar> as per http://specs.openstack.org/openstack/docs-specs/specs/queens/retention-policy.html#work-items
16:09:53 <pkovar> "Update the stable/ocata branch of openstack/openstack-manuals to build the admin, CLI, and user guides using series-specific URLs. (owner needed)"
16:10:21 <pkovar> someone eager enough to give it a try (ie. own it)?
16:11:14 <pkovar> please let me know or just go ahead and submit a patch, otherwise i will take it :)
16:11:24 <eumel8> btw: we restore also language specific landing pages? like https://docs.openstack.org/mitaka/de/
16:11:30 <pkovar> (later this week)
16:12:03 <pkovar> eumel8: looks like we don't mention it in the spec
16:12:37 <pkovar> eumel8: is that something the i18n team wants to restore?
16:12:46 <eumel8> mhm, I will check this later and ask the language teams about the opinions
16:12:56 <pkovar> ok, thanks eumel8
16:13:17 <jamesmcarthur> It seems like it would be good to have the language versions restored as well.
16:13:26 <pkovar> #action eumel8 to ask the language teams about restoring language landing pages
16:13:50 <pkovar> yes, though i  think we would need a new owner for those patches
16:14:03 <pkovar> ie. a volunteer :)
16:15:21 <pkovar> #info Flagging deprecated releases
16:15:22 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123381.html
16:15:38 <pkovar> jamesmcarthur: do you know if there is an update?
16:15:53 <jamesmcarthur> Yes, that's me. I'm sorry to say I haven't made any progress. It is high on my list, but I have been buried with other Foundation work.
16:16:20 <jamesmcarthur> I'd like to have a patch ready for review within the next few weeks.
16:16:33 <pkovar> help needed? or are we clear on what is the next step/deliverable? (hate that word)
16:16:43 <pkovar> jamesmcarthur: sounds good thanks!
16:17:09 <jamesmcarthur> Doug has already volunteered to answer any questions for me when the time comes.
16:17:24 <pkovar> jamesmcarthur: do we plan to flag all content, not just deprecated releases?
16:17:32 <jamesmcarthur> I have the HTML and CSS ready, just need to get the patch in.
16:17:56 <eumel8> we don't use watermarks?
16:17:58 <pkovar> #info jamesmcarthur to work on patch, dhellmann to help with Q's.
16:18:01 <jamesmcarthur> pkovar: i thought the request was just for all docs pertaining to a depreacted release
16:18:13 <pkovar> jamesmcarthur: correct
16:18:27 <jamesmcarthur> deprecated, sorry
16:18:33 <pkovar> flagging all releases was just an idea in the thread i think
16:18:42 <jamesmcarthur> eumel8: that's another option
16:19:05 <jamesmcarthur> the idea was to do something a bit more "in your face" so people could tell from the get go that the contnet was bad
16:19:08 <pkovar> we can iterate i think :)
16:19:13 <eumel8> saw this in project doc like https://docs.openstack.org/openstack-ansible/latest/
16:19:29 <eumel8> yeah, a red banner is more visible
16:19:34 <pkovar> yeah, like a flow banner
16:19:41 <eumel8> k
16:20:04 <jamesmcarthur> eumel8: probably wouldn't hurt to do both, in the event someone prints it out
16:20:08 <pkovar> so that ppl see it even when following deep links
16:20:20 <jamesmcarthur> though... do people really print things out anymore?
16:20:39 <pkovar> hard to say but we do provide pdfs
16:20:46 <pkovar> for core suite, that is
16:21:23 <jamesmcarthur> pkovar: ok, good to know
16:21:59 <pkovar> ianychoi worked on spec to provide pdfs build for more content, btw
16:22:04 <jamesmcarthur> pkovar: perhaps a subtle watermark is a good idea as well (possibly a separate patch)
16:22:25 <pkovar> jamesmcarthur: yeah, would do it as a separate patch
16:24:03 <eumel8> pdf spec: #link https://review.openstack.org/#/c/509297/
16:24:12 <pkovar> #chair eumel8
16:24:13 <openstack> Current chairs: eumel8 pkovar
16:24:17 <pkovar> #link https://review.openstack.org/#/c/509297/
16:24:32 <pkovar> #info pdf spec ^
16:25:07 <pkovar> #info think about providing a watermark too, possibly as a separate patch. good for pdfs
16:25:58 <pkovar> next topic?
16:26:07 <eumel8> yes, pls
16:26:12 <pkovar> mostly as a retrospective
16:26:13 <pkovar> #topic OpenStack Summit Sydney
16:26:18 <pkovar> #info Summary of docs sessions posted
16:26:23 <pkovar> #link https://www.rdoproject.org/blog/2017/11/summary-openstack-summit-docs-sessions/
16:26:50 <pkovar> for those who attended the summit, let me know if i missed anything
16:27:40 <pkovar> #topic Rocky PTG
16:27:47 * dhellmann arrives late
16:27:48 <pkovar> #info Planning etherpad for docs+i18n created
16:27:54 <pkovar> #link https://etherpad.openstack.org/p/docs-i18n-ptg-rocky
16:28:03 <pkovar> thanks goes to eumel8
16:28:04 <eumel8> great stuff from Sydney, thx for sharing
16:28:41 <pkovar> a Q for all of you
16:28:43 <pkovar> #info Parcel time into small chunks or have full-day focus on one team agenda?
16:28:52 <pkovar> this is from the recent -dev ML thread
16:28:59 <pkovar> what do  people prefer?
16:29:59 <pkovar> or let me rephrase the Q, did the denver schedule work for us?
16:30:12 <eumel8> depends on the topics
16:30:13 <dhellmann> when is the docs team being given time to meet? on the theme days or the team days?
16:30:46 <pkovar> dhellmann: i asked for two days, but didn't specify it yet
16:30:48 <dhellmann> ok
16:31:00 <pkovar> hoping it works for i18n, eumel8?
16:31:04 <pkovar> or do we need more?
16:31:05 <dhellmann> I'd personally prefer those be on the team days
16:31:23 <dhellmann> we may need a list of topics before we know how long we'll need :-)
16:31:37 <eumel8> pkovar: you already answered the survey from Kendall?
16:31:51 <pkovar> good point, let's start gathering feedback
16:32:20 <pkovar> eumel8: yes, then realized you might as well :)
16:32:42 <eumel8> the first question was, how many people will be there and I think docs team and I18n are together as usualy
16:33:04 <pkovar> eumel8: yes, so i just recycled numbers from denver
16:33:23 <pkovar> i think it's really hard to estimate at this point
16:33:24 <eumel8> pkovar: I would mention that fact ;) read the email just now and will fill out the form later
16:33:38 <pkovar> eumel8: cool
16:34:14 <eumel8> pkovar: I would say first of all: we're there! with 8-12 people
16:34:35 <pkovar> eumel8: let's agree to start soliciting feedback on agenda now :)
16:34:42 <pkovar> eumel8: 8-12 people sounds good
16:35:19 <pkovar> #info for PTG, two days planned, ca.  8-12 people
16:35:45 <pkovar> eumel8: what's the preference wrt team days?
16:36:00 <pkovar> i am fine with what dhellmann suggests
16:36:06 <pkovar> that is, team days
16:36:13 <eumel8> sure
16:36:20 <pkovar> any objections?
16:36:59 <pkovar> #action send an email to start gathering input wrt ptg agenda
16:37:11 <pkovar> eumel8: do you want to send a separate email for i18n?
16:37:34 <pkovar> and keep agenda separate? (in the same etherpad)
16:38:03 <pkovar> we will need to work on the schedule later anyway
16:38:13 <pkovar> so this would be for the initial phase
16:38:14 <pkovar> only
16:38:17 <jungleboyj> I am planning to be at the PTG.
16:38:35 <eumel8> pkovar: you can send an email for both teams to openstack-dev, I will separate send a message to openstack-i18n
16:38:44 <eumel8> with a reference
16:38:44 <pkovar> jungleboyj: any preferences wrt meeting during team days (or not)?
16:38:57 <pkovar> eumel8: cool
16:39:10 <jungleboyj> Well, I will be busy in the Cinder meetings on Wednesday - Friday.  :-)
16:39:14 <pkovar> #action pkovar to send an email for both teams to openstack-dev
16:39:25 <pkovar> right
16:39:33 <eumel8> thx
16:39:45 <pkovar> same might apply for other people
16:40:29 <jungleboyj> pkovar:  ++
16:40:45 <dhellmann> don't let my preference count as more than one; if lots more people are available on the theme days then we should meet then
16:41:21 <eumel8> ++
16:41:40 <chason> ++
16:41:41 <pkovar> so when getting input, let's also ask people to sign up and share their day and time preferences
16:41:53 <pkovar> then we can decide on the team's preference
16:42:00 <pkovar> sounds good?
16:42:14 <eumel8> yeah
16:42:38 <pkovar> any nay's ? :)
16:42:44 <dhellmann> sounds good
16:42:54 <pkovar> #action when getting input, let's also ask people to sign up and share their day and time preferences
16:42:54 <jungleboyj> Yay!
16:43:20 <pkovar> good good
16:43:38 <pkovar> anything else for ptg?
16:43:49 <eumel8> not yet :)
16:44:00 <pkovar> hehe, right! lost of planning ahead
16:44:06 <pkovar> lots, rather!
16:44:21 <eumel8> but time flies..
16:44:54 <pkovar> i know, vacation, company shutdowns. we need to start now
16:45:22 <pkovar> next topic...
16:45:55 <pkovar> #topic closing openstack-docs mailing list
16:46:20 <pkovar> i plan to close the list for new mail and subscribers tomorrow
16:46:23 <pkovar> any objections?
16:46:41 <pkovar> the plan to close soon was announced
16:46:50 <pkovar> so i think we are good to go
16:46:56 <eumel8> ok
16:47:06 <pkovar> the reason is we want to have a single place to discuss [docs] topics
16:47:22 <pkovar> though we should all agree to use the same tag for docs conversatiosn
16:47:33 <pkovar> conversations, even
16:47:53 <pkovar> i sometimes forget and use [doc]
16:48:22 <pkovar> hope it doesn't break too many filters
16:48:25 <eumel8> auto-correct ;)
16:48:39 <pkovar> too fancy for my ancient mail client!
16:49:11 <eumel8> welcome to the 90ies  ;)
16:49:29 <pkovar> #action close the list for new mail and subscribers tomorrow
16:50:18 <pkovar> there has been almost no traffic recently so hopefully not many people will complain
16:51:11 <pkovar> #topic Branches vs everything in master
16:51:32 <pkovar> this is mostly about installation guide common content restructure
16:51:35 <pkovar> Common Install Guide content should be branched/split up per-release?
16:51:49 <pkovar> any preferences?
16:52:20 <pkovar> we can discuss later, not a prio for this week i think
16:52:49 <pkovar> #topic sitemap automation suggestions
16:52:56 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123228.html
16:53:17 <pkovar> jamesmcarthur: not sure if you know about any updates there?
16:53:28 <pkovar> feedback was requested a while ago
16:53:43 <pkovar> also about the scope of content
16:53:52 <pkovar> any new input on this?
16:54:43 <dhellmann> we had a discussion about that last week
16:54:54 * dhellmann hunts for the irc nic
16:55:11 <jamesmcarthur> pkovar: yes, mguiney is working on this
16:55:16 <dhellmann> there we go
16:55:17 <dhellmann> sorry, mguiney
16:55:21 <jamesmcarthur> :)
16:55:37 <pkovar> #action mguiney working on this
16:55:58 <pkovar> heh
16:57:12 <pkovar> okay, thanks
16:57:18 <pkovar> 3 mins
16:57:25 <pkovar> so just for fyi items
16:57:40 <pkovar> s/so just for fyi items/so just fyi items/
16:57:48 <pkovar> #topic Bug Triage Team
16:57:52 <pkovar> #link https://wiki.openstack.org/wiki/Documentation/SpecialityTeams
16:58:18 <pkovar> thanks, chason and eumel8 for your help with bug triage!
16:58:32 <chason> np :D
16:58:36 <eumel8> yeah, at your service :)
16:58:51 <pkovar> others, please consider joining the fun
16:59:09 <pkovar> is ianychoi around?
16:59:25 <pkovar> we can discuss topic PDF builds later
16:59:33 <pkovar> one min!
16:59:39 <mguiney> o/
16:59:44 <pkovar> #topic Open discussion
16:59:49 <eumel8> maybe too late for him
17:00:20 <pkovar> eumel8: yeah :(
17:00:33 <eumel8> I think the proposal needs more review from other people: #link https://review.openstack.org/#/c/509297/
17:00:56 <pkovar> #topic PDF builds
17:01:02 <pkovar> #link https://review.openstack.org/#/c/509297/
17:01:03 <eumel8> also what AJaeger wrote
17:01:11 <pkovar> #info the proposal needs more review from other people
17:01:41 <pkovar> good, let's close the mtg now and then we can continue in the channel
17:01:44 <pkovar> thanks everybody
17:01:50 <jungleboyj> Thanks!
17:01:53 <eumel8> thx pkovar
17:01:57 <pkovar> #endmeeting