16:02:31 <pkovar> #startmeeting docteam
16:02:32 <openstack> Meeting started Wed Apr  4 16:02:31 2018 UTC and is due to finish in 60 minutes.  The chair is pkovar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:35 <openstack> The meeting name has been set to 'docteam'
16:03:04 <ianychoi> :)
16:03:22 <pkovar> ianychoi: anything you want to discuss in particular today?
16:04:44 <ianychoi> pkovar, Would u review https://review.openstack.org/#/c/557848/ ? I did not change language landing pages on https://review.openstack.org/#/c/556969/ so need to fix it.
16:05:57 <pkovar> ianychoi: will have a look, thanks
16:06:13 <pkovar> that one somehow slipped through the cracks for me, not sure why
16:06:17 <ianychoi> Thanks a lot!
16:06:45 <pkovar> ianychoi: thank you for working on this and https://review.openstack.org/#/c/556969/
16:07:06 <pkovar> i think that change definitely made the landing pages more usable
16:07:52 <pkovar> long dropdown lists are evil :)
16:08:43 <ianychoi> pkovar, it's my pleasure - when I accidently saw the source of dropitems on index pages, I found that changing sizes would be relatively simple :)
16:09:23 <pkovar> ianychoi: what are your thoughts on re-implementing the dropdowns as simple lists, as pointed out by frank in https://review.openstack.org/#/c/556969/ ?
16:09:39 <pkovar> the reason being that dropdown lists are not very user friendly
16:10:24 <pkovar> though if we did, that would probably require a major redesign of the site
16:10:46 <pkovar> (just thinking aloud here)
16:12:13 <ianychoi> I think so. It would be nice if simple additional design is applied on the location of current dropitem positions or between "Documentation for.. & description" and "Release Notes / Installation Guides.."
16:12:59 <pkovar> yeah, something like that
16:13:17 <pkovar> #topic dropdown menus on docs.o.o
16:13:47 <pkovar> #info design idea: re-implement dropdown menus as simple lists, as pointed out by frank in https://review.openstack.org/#/c/556969/
16:14:00 <pkovar> #info to make the site more mobile friendly
16:15:10 <pkovar> maybe with a bit of scripting, clicking the buttons more releases or Languages could show a list
16:15:26 <pkovar> that way we would save some space on the page
16:15:40 <pkovar> and only show the lists when the user wishes so
16:16:02 <pkovar> /brainstorming :)
16:17:20 <ianychoi> Simple idea might be like: https://ibb.co/coCMjx
16:18:16 <pkovar> ianychoi: that's good
16:18:25 <pkovar> #link https://ibb.co/coCMjx
16:19:07 <pkovar> doesnt take much space, yet its simple
16:21:11 <ianychoi> I am not so good at designing web pages but just know some knowledge on editing HTMLs.
16:22:34 <ianychoi> For releases, it would look nice I think. I am not sure how it would look after languages are enumerated but the style like https://docs.openstack.org/i18n/latest/ would be nice I think.
16:23:49 <pkovar> yeah, this may require larger discussion with more people
16:24:05 <pkovar> then we might find a design volunteer too :))
16:24:14 <ianychoi> agreed :)
16:25:09 <pkovar> will probably be best to start a thread in -dev or even create a blueprint to catch more attention
16:25:55 <pkovar> #action consider starting a thread / blueprint to discuss design changes
16:26:11 <ianychoi> +1 :)
16:26:31 <pkovar> i remember that one of the design feedback item we got back during the pike cycle was on lists in general
16:26:46 <pkovar> such as the list of proejcts in https://docs.openstack.org/queens/user/
16:27:37 <pkovar> the feedback being that it would be good to make the page better than just a list of links
16:28:49 <ianychoi> Aha.. I just think that making bold for project names would be nice.
16:28:53 <pkovar> maybe turning the lists into something like https://www.openstack.org/software/project-navigator/ would be god
16:28:56 <pkovar> good, rather
16:29:35 <pkovar> yeah, or tweaking the font slightly
16:29:50 <pkovar> like in https://www.openstack.org/software/project-navigator/ they use all caps and bold
16:30:22 <pkovar> #topic design ideas for docs.o.o
16:30:59 <pkovar> #info idea: make the landing pages with project lists more beautiful
16:31:17 <pkovar> #info  like in https://www.openstack.org/software/project-navigator/ they use all caps and bold for project names
16:32:17 <ianychoi> I am not sure but maybe project mascot logos would be stored in openstack-manuals repository?
16:32:26 <ianychoi> Then we can make use of mascot logos
16:33:25 <pkovar> another idea, yes
16:34:10 <pkovar> #info idea: re-use mascot logos that would be stored in openstack-manuals
16:37:39 <ianychoi> Let's think about it more :)
16:37:48 <ianychoi> Maybe moving to next would be fine?
16:37:57 <pkovar> yep :)
16:38:23 <pkovar> so let's do announcements & kudos :)
16:38:31 <ianychoi> +1 :)
16:38:37 <pkovar> #topic
16:38:40 <pkovar> oh
16:38:46 <pkovar> #topic vancouver summit
16:38:48 <ianychoi> Next, I would like to ask some opinions on documentation builds and PTI: https://review.openstack.org/#/c/545377/ and https://review.openstack.org/#/c/509297/
16:38:56 <ianychoi> Maybe next and next :)
16:39:34 <pkovar> sure thing, let me just post a link real quick
16:39:38 <pkovar> #link https://www.openstack.org/summit/vancouver-2018/summit-schedule/global-search?t=docs
16:39:58 <pkovar> #info summit schedule is up with two  docs talks / sessions planned
16:40:11 <pkovar> #info co-located with i18n
16:40:29 <pkovar> #info thanks to our presenters
16:40:45 <pkovar> if anybody is interested in joining, let us know
16:40:58 <pkovar> okay, that would be it
16:41:12 <pkovar> #topic documentation builds and PTI
16:41:26 <ianychoi> Thanks :)
16:41:44 <pkovar> ianychoi: shoot your question :)
16:41:58 <pkovar> or comments, even
16:42:09 <ianychoi> From the comments on two links, I think changing something on PTI ( https://governance.openstack.org/tc/reference/pti/python.html ) is needed I think.
16:43:05 <pkovar> stephenfin: are you around by any chance?
16:43:24 <ianychoi> Then, where can I propose my idea on changes to support PDF or translated documentation builds? Some comments imply that I need to propose in infra specs: http://specs.openstack.org/openstack-infra/infra-specs/ or submitting to governance repo like https://review.openstack.org/#/c/508694/ would be nice?
16:44:07 <ianychoi> I tried to reach mordred but failed for weeks because of time difference - hope that I can discuss soon or meet during Vancouver Summit
16:44:39 <ianychoi> Comments indicate that such changes are not the target of docs-specs
16:44:50 <pkovar> ianychoi: i can help with writing the spec for infra if needed, but would you consider asking the infra team directly?
16:44:52 <openstackgerrit> Merged openstack/api-site master: Imported Translations from Zanata  https://review.openstack.org/558034
16:44:55 <pkovar> on irc first
16:45:37 <pkovar> yeah, i was under impression docs-specs would be the best place, but this is really an infra thing
16:45:38 <ianychoi> pkovar, nice suggestion :)
16:45:47 <pkovar> so we need help from them anyway
16:46:12 <pkovar> as for us, docs + i18n we already agreed we want to move forward with this :)
16:46:49 <pkovar> also, i think frank would be also able to help
16:47:33 <pkovar> #info updating PTI wrt  https://review.openstack.org/#/c/545377/ and https://review.openstack.org/#/c/509297/ might be needed
16:47:56 <pkovar> #info seeking help from infra team, will probably need to create a spec
16:48:58 <pkovar> ianychoi: or would you prefer to just go ahead and submit a wip patch to trigger the discussion with infra?
16:49:01 <openstackgerrit> Frank Kloeker proposed openstack/api-site master: Build and publish eo api-quick-start  https://review.openstack.org/558877
16:49:28 <ianychoi> pkovar, thanks - I will do it soon and share here and infra channel
16:49:57 <pkovar> ianychoi: great, then we can easily iterate when we have something to start with :)
16:50:30 <ianychoi> :) thanks a lot, pkovar for kind comments!
16:51:09 <pkovar> ianychoi: thanks for volunteering, that's the most important thing always ! :)
16:51:27 <mordred> ianychoi: oh. wow, I'm terrible
16:51:45 <ianychoi> pkovar, you're welcome :) mordred, hello!
16:52:25 <pkovar> #info thanks ianychoi for driving project docs translations and pdf builds
16:52:44 * mordred waves
16:52:56 <pkovar> /me waves back at mordred
16:53:14 * ianychoi thanks a lot all :)
16:54:30 <pkovar> anything else to discuss today?
16:54:44 <pkovar> maybe more kudos? :)
16:55:11 <ianychoi> Nope from me :)
16:55:19 <pkovar> #info thanks stephenfin for keeping projects updated wrt sphinxcontrib-apidoc
16:55:27 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128817.html
16:55:34 <pkovar> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128594.html
16:56:30 <ianychoi> Looks so nice :)
16:56:40 <pkovar> okay, i think we can wrap this up
16:56:55 <pkovar> thank you again :)
16:56:58 <pkovar> #endmeeting