13:01:21 <annegentle> #startmeeting DocTeamMeeting
13:01:22 <openstack> Meeting started Wed Aug 28 13:01:21 2013 UTC and is due to finish in 60 minutes.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:25 <openstack> The meeting name has been set to 'docteammeeting'
13:01:32 <annegentle> #topic Action items from last week
13:02:15 <annegentle> roadnick to meet with Kersten to help through the WADL journey
13:02:26 <annegentle> Nick emailed his regrets that he couldn't attend so I don't know the status.
13:02:33 <annegentle> annegentle codify our reviewing policies - done
13:02:44 <annegentle> I do need to add that we don't require a bug for each patch submitted
13:03:10 <annegentle> #action annegentle to clarify for reviewing policy whether we require a bug per patch
13:03:17 <annegentle> Next action, sgordon propose more often meetings on -docs Mailing List - done.
13:03:25 <annegentle> Though sgordon is still out this week
13:03:47 <annegentle> But, the ical feed is updated to every other Tuesday, we're just here this morning because a few of us missed it yesterday so I rescheduled.
13:03:58 <annegentle> #topic Docs Boot Camp Sept 9-10
13:04:01 <EmilienM> annegentle: the meeting time stays wed 1pm UTC ?
13:04:09 <annegentle> EmilienM: nope goes back to Tues
13:04:17 <annegentle> EmilienM: this is a one-time move
13:04:19 <annegentle> for this week
13:04:47 <annegentle> #link https://wiki.openstack.org/wiki/Docs_Bootcamp_2013
13:04:58 <annegentle> We have nearly 25 people signed up. Great turnout.
13:05:06 <annegentle> The wiki page has instructions for what you should have set up on your laptop.
13:05:18 <annegentle> The schedule is shaping up to be half learn/labs, half unconference where we put up a board for future discussions.
13:05:26 <annegentle> Mirantis is taping the sessions and we'll post after camp.
13:06:01 <annegentle> Any questions on Docs Boot Camp?
13:06:33 <nerminamiller> annegentle: are all listed installs applicable to all attendees?
13:06:35 <annegentle> welcome nerminamiller and summerLong!
13:06:41 <summerLong> hi!
13:06:48 <nerminamiller> hi!
13:06:53 <annegentle> nerminamiller: good question. I would consider the autodoc and publican to be optional
13:07:00 <annegentle> off the top of my head
13:07:21 <nerminamiller> thanks
13:07:39 <annegentle> I'm getting excited to come to California
13:08:02 <annegentle> figuring out lunch, dinner, entertainment.
13:08:12 <annegentle> Ok on to
13:08:15 <annegentle> #topic Admin guides
13:08:45 <annegentle> I put this on there just to let people know the latest for the four we're parting out, and to see how a larger one looks.
13:09:07 <annegentle> Block Storage is already done, config moved to config, install to install.
13:09:13 <annegentle> Object Storage is in progress.
13:09:47 <annegentle> Compute Admin is pretty well parted out to user guide and config guide but more work needs to be done to delete outdated content.
13:10:20 <annegentle> Network Admin Guide hasn't been pieced out but I did talk to emagana about what goes where.
13:10:29 <annegentle> nerminamiller: how's the larger guide looking?
13:10:52 <annegentle> nerminamiller: I haven't looked at the outline again since last week
13:11:03 <nerminamiller> annegentle: the matchup with the blueprint is almost done.
13:11:11 <nerminamiller> i took it offline to work on it.
13:11:23 <nerminamiller> hope to replace it by cob today.
13:11:25 <annegentle> nerminamiller: okie
13:11:47 <annegentle> nerminamiller: are you thinking the Compute Admin guide "becomes" the OpenStack Admin guide?
13:11:52 <nerminamiller> also considering merge with ops guide. will propose in more detail in the blueprint.
13:12:01 <annegentle> nerminamiller: or should I just wait for the blueprint :)
13:12:13 <nerminamiller> re: compute = yes
13:12:27 <annegentle> nerminamiller: ok good-o
13:12:32 <summerLong> And don't touch compute until you're done...
13:12:40 <summerLong> Just hit something with quotas...
13:12:53 <annegentle> summerLong: oh it'll merge! :)
13:12:56 <annegentle> summerLong: I think
13:13:08 <annegentle> summerLong: so who shouldn't touch compute
13:13:21 <nerminamiller> not touching a thing :)
13:13:25 <summerLong> But the question is whether quota info will remain?
13:13:32 <annegentle> summerLong: oh yes it needs a home
13:13:52 <summerLong> Is in admin user guide already.
13:13:57 <annegentle> summerLong: quotas and rate limiting I've seen in config ref too though, it's configuration.
13:14:37 <summerLong> Am doing xi includes from admin gd into project admin guides?
13:15:05 <annegentle> summerLong: the idea is to make the project admin guides super small so that they could be xi:included into a larger admin guide (I think, correct me if that's wrong)
13:15:30 <annegentle> summerLong: quota configuration is already out of the compute admin guide on the master branch
13:15:42 <annegentle> summerLong: and into the config ref
13:16:57 <annegentle> summerLong: is that crazy making?
13:17:06 <summerLong> Hmm, definitely
13:17:11 <annegentle> summerLong: oh dear
13:17:41 <summerLong> Is now everywhere. It's in the admin user guide already. Had finished chapters on those (updated)
13:18:06 <summerLong> No problem with it not being in the project guides of course.
13:18:06 <annegentle> summerLong: if it's modular it's easy to move right
13:18:13 <summerLong> Yes.
13:18:20 <annegentle> summerLong: ohhhh right the admin user guide
13:18:28 <annegentle> summerLong: yes it makes sense for quota setting to be in there
13:18:40 <annegentle> summerLong: nerminamiller is outlining yet another admin guide
13:18:50 <annegentle> summerLong: so what you've done should stay, yes.
13:18:58 <annegentle> this kind of confusion is what I'm afraid of
13:19:01 <summerLong> yes, the 'system' admin guide.
13:19:12 <annegentle> but -- I think there's good reason for an admin user guide
13:19:13 <summerLong> But would be good to have consistent info across guides.
13:19:18 <annegentle> nerminamiller: be sure to read what is in the admin user guide
13:19:22 <annegentle> summerLong: yes
13:19:25 <nerminamiller> will do
13:19:50 <summerLong> And I'll take a look at the config ref?
13:19:53 <annegentle> so. Admin User Guide = Covers user tasks performed through the dashboard and CLIs for admin users.
13:19:54 <nerminamiller> i'm looking at the ops as well
13:20:08 <annegentle> Administration Guide = Covers system administration tasks like maintaining, monitoring, and customizing an initially installed system. Could also be called "Cloud Administration Guide."
13:20:18 <annegentle> I'm using shortened titles which is bad.
13:20:21 <annegentle> Sorry y'all.
13:20:43 <annegentle> summerLong: the config ref has quota info in it now, about how to configure, so do try to consolidate as needed.
13:20:50 <annegentle> summerLong: good catch
13:20:57 <summerLong> Ok, will do.
13:21:04 <annegentle> We could also call the Admin User Guide the User Guide for Administrators.
13:21:16 <annegentle> Ok any more questions
13:21:32 <annegentle> on Admin Guides in all their glory?
13:21:44 <dianefleming> yes, i had a question about name for user guide for admins - the title
13:21:58 <annegentle> dianefleming: sure
13:22:01 <dianefleming> what do people prefer 1) Admin User Guide 2) User Guide for Administrators
13:22:23 <dianefleming> I'm currently calling the regular User Guide -> End User Guide, but I could shorten to "User Guide"
13:22:41 <dianefleming> so we would have User Guide and User Guide for Administrators
13:22:54 <annegentle> Hm... thinking
13:23:06 <dianefleming> we can discuss on docs list later - just throwing it out there
13:23:17 <summerLong> Sort of liked the earlier pairing of End User and Admin User guides.
13:23:38 <annegentle> dianefleming: yeah it's a good question - I like Admin User Guide but I like shorter titles.
13:23:58 <brucer> Hm, I thnk having a guide name that is a subset of another guide name not such a good idea.
13:24:02 <dianefleming> I'm fine with End User Guide and Admin User Guide
13:24:13 <nerminamiller> poll users?
13:24:21 <annegentle> brucer: so no "User Guide for Administrators"
13:24:29 <dianefleming> @brucer don't know what you mean
13:24:44 <brucer> yeh, rather Admin UG and End UG
13:25:02 <nerminamiller> agree with brucer
13:25:04 <dianefleming> that's fine - I'll do that
13:25:37 <annegentle> dianefleming: ok good, you can definitely tell the ML and then if anyone hollers we'd reconsider but I think Admin UG and End UG
13:25:48 <annegentle> #agreed Admin User Guide and End User Guide titles
13:25:54 <annegentle> ok, moving along
13:25:57 <annegentle> #topic Install guides
13:26:18 <annegentle> shaunm: I won't put you on the spot but I'll report what I know and you can chime in
13:26:39 <shaunm> ok
13:26:49 <annegentle> After several weeks trying to get some hardware from Cisco only to find out it is VMS they give out in their lab, shaunm is going to rig laptops for testing install instructions
13:27:11 <annegentle> basically, a laptop with a USB > Ethernet NIC added on works well for a 2 NIC "server"
13:27:23 <annegentle> it's what the Rackspace training group uses for portability
13:27:37 <annegentle> shaunm: you can add any other updates you have
13:29:13 <annegentle> There have been continual patches to the install guides
13:29:17 <shaunm> that's about it
13:29:24 <annegentle> even one came in yesterday that I'll backport to grizzly
13:29:31 <annegentle> shaunm: are you going to submit a patch this week?
13:29:51 <annegentle> shaunm: with a consolidated install guide?
13:30:50 <shaunm> yes, though probably not complete
13:31:10 <annegentle> shaunm: sure.
13:31:30 <annegentle> The install architectures are at https://etherpad.openstack.org/havanainstall
13:31:32 <annegentle> #link https://etherpad.openstack.org/havanainstall
13:31:37 <annegentle> any questions on install?
13:32:19 <annegentle> Ok, going to translation
13:32:30 <annegentle> #topic Translation builds
13:32:51 <annegentle> we do have a reply from daisy on the mailing list
13:33:12 <annegentle> sounds like they'd need a tools directory for each repository so that translated files can be sliced and built
13:33:30 <annegentle> Sounds like we still have work to do.
13:33:53 <annegentle> I'm also working with Todd Morey, a designer at the Foundation, to ensure we do a good job with other-language landing pages for docs.
13:34:10 <annegentle> Any questions on translation builds?
13:34:20 <summerLong> How many languages will be supported?
13:34:46 <summerLong> Ok, silly question.
13:34:51 <summerLong> How long is a piece of string.
13:35:04 <annegentle> summerLong: Long story, but basically we have the Ops Guide in Chinese and Japanese now
13:35:08 <annegentle> summerLong: heh
13:35:22 <annegentle> summerLong: well, yes, and also, the po files are available on Transifex for many many languages
13:35:37 <annegentle> summerLong: but we have 2 now
13:35:40 <nerminamiller> plans for any other languages?
13:36:21 <annegentle> nerminamiller: you say "plans" :)
13:36:38 <nerminamiller> :)
13:36:41 <annegentle> nerminamiller: if you look at https://www.transifex.com/projects/p/openstack-manuals-i18n/resources/
13:36:59 <annegentle> nerminamiller: you can see that there are five full translations of the API Quick Start
13:37:13 <annegentle> Chinese, Russian, Korean, Portuguese, Vietnamese
13:37:20 <annegentle> Those are some of the most active language communities
13:37:26 <annegentle> But, that's also a very small guide.
13:37:50 <annegentle> Every Summit, we talk about their plans, I'm not saying it's not planned, just saying it's a huge coordination effort
13:37:55 <annegentle> and we try to enable as much as we can
13:38:05 <annegentle> while not slowing down English content dev.
13:38:07 <annegentle> Does that help?
13:38:20 <nerminamiller> thanks
13:38:31 <annegentle> Any more questions on Translation? It's good for us all to know about the moving pieces and parts.
13:39:21 <annegentle> Ok, onward
13:39:26 <annegentle> #topic Bugs and DocImpact
13:39:33 <annegentle> #link https://launchpad.net/openstack-api-site/+milestone/havana
13:39:52 <annegentle> #link https://launchpad.net/openstack-manuals/+milestone/havana
13:40:09 <annegentle> I don't put this topic at the bottom of the agenda to de-emphasize its importance :)
13:40:33 <annegentle> There are 217 bugs targeted for admin/config/end users, and 72 targeted for API docs.
13:40:38 <annegentle> These are serious numbers.
13:40:57 <annegentle> We've done a great job getting the info and making it into data with DocImpact.
13:41:09 <annegentle> So keep looking at what you can do for doc bug fixes.
13:41:29 <annegentle> And, recruit the dev who put DocImpact in the commit message to write docs.
13:41:41 <EmilienM> +1
13:41:52 <EmilienM> it's a matter of education :)
13:42:12 <annegentle> EmilienM: yep, and coaching to help them find the right place to put it now that we've done a lot of moving around.
13:42:24 <EmilienM> sure
13:42:25 <annegentle> There are a lot of Fix Released on that list too
13:42:34 <dianefleming> I'll try to knock out some of the api-site ones
13:42:41 <annegentle> dianefleming: ok thanks
13:42:57 <nerminamiller> i'll commit to some this week as well
13:43:06 <annegentle> There are only 5 or 6 Triaged so even if all you can do is put a comment saying what to do to fix the bug, that's a help
13:43:12 <dianefleming> sure
13:43:16 <dianefleming> will do
13:43:18 <annegentle> Triaged means someone else can fix the bug with the info in the comments.
13:43:32 <annegentle> Ok! Shall we go to Open Discussion?
13:43:38 <annegentle> #topic Open discussion
13:43:39 <EmilienM> I would like to talk about openstack-ha guide
13:43:39 <EmilienM> #link https://blueprints.launchpad.net/openstack-manuals/+spec/improve-high-availability-support
13:43:39 <EmilienM> #link http://docs.openstack.org/trunk/openstack-ha/
13:43:39 <EmilienM> I did not make a good progress this summer, but I'm on it right now.
13:43:39 <EmilienM> I'm currently working on https://bugs.launchpad.net/openstack-manuals/+bug/1196099
13:43:40 <EmilienM> to bring neutron dhcp agent in HA, the doc is already here :
13:43:40 <annegentle> EmilienM: go ahead
13:43:41 <uvirtbot> Launchpad bug 1196099 in openstack-manuals "openstack-ha guide / Active-Active section: Miss Network section " [Wishlist,Confirmed]
13:43:44 <EmilienM> #link http://docs.openstack.org/trunk/openstack-network/admin/content/demo_multiple_operation.html
13:43:47 <EmilienM> my question is: can I give basic explaining and redirect to the neutron doc ?
13:43:49 <EmilienM> :)
13:44:13 <annegentle> EmilienM: have you asked emagana if he's good with that? He's our doc liaison for Neutron
13:44:22 <annegentle> EmilienM: does the Neutron doc have HA info?
13:44:38 <EmilienM> annegentle: I know him, I'm going to ping him
13:44:44 <annegentle> EmilienM: ok, good.
13:44:48 <EmilienM> annegentle: as I say, yes; for DHCP only.
13:44:52 <annegentle> EmilienM: also is it known how to make neutron HA?
13:44:56 <annegentle> EmilienM: oh ok.
13:45:02 <EmilienM> my second thing where I need help is that neutron does not provide yet active / active HA for some agents. You can run them by active / passive using Pacemaker / Corosync. So what I plan to do, is to write it in the active / passive sections, and document active / active in explaining that it's not supported yet, but they can have HA with active / passive (and refer to the AP section).
13:45:02 <EmilienM> Make sense ?
13:45:17 <annegentle> EmilienM: what is your sense of whether multi-host will make it into havana for neutron?
13:45:36 <EmilienM> annegentle: multihost is only for DHCP afik
13:45:42 <annegentle> EmilienM: Yes, I think it's best to indicate where active/active is NOT available
13:45:51 <annegentle> EmilienM: ok
13:45:55 <EmilienM> annegentle: L3, metadata, lbaas aren't scalable yet
13:46:02 <EmilienM> ok.
13:46:09 <annegentle> EmilienM: ok, and L3 is nearly always what users are after it would seem
13:46:13 <EmilienM> everything is fine for me, let's go to work now :)
13:46:18 <annegentle> EmilienM: sweet
13:46:26 <EmilienM> thx annegentle
13:46:37 <annegentle> I wanted to point out a Marketing portal is available
13:46:39 <annegentle> #link http://www.openstack.org/marketing
13:46:55 <annegentle> Also I'm attending once-monthly content meetings with Foundation staff, went to the first one last week.
13:47:22 <annegentle> Discussing what content needs created, prioritizing it and finding resources.
13:47:38 <annegentle> Last week was a chance to get to know each other, there were mostly company reps.
13:48:19 <annegentle> We should be getting first-run tshirts at docs boot camp, woo
13:48:41 <annegentle> I think that's it! Anyone else?
13:48:49 <sarob> Nope
13:48:56 <annegentle> sarob: lurk!
13:48:58 <annegentle> :)
13:49:04 <sarob> ;)
13:49:07 <annegentle> Ok take back 11 minutes of your day!
13:49:10 <annegentle> #endmeeting