03:00:58 <Loquacities> #startmeeting DocTeamMeeting
03:00:58 <openstack> Meeting started Tue Dec 17 03:00:58 2013 UTC and is due to finish in 60 minutes.  The chair is Loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:01:02 <openstack> The meeting name has been set to 'docteammeeting'
03:01:22 <Loquacities> agenda is here:
03:01:26 <Loquacities> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
03:01:51 <Loquacities> #topic Action items from the last meeting
03:02:12 <Loquacities> chandankumar to update https://wiki.openstack.org/wiki/Documentation/HowTo#Reviewing_Documentation with note about WIP
03:02:31 <Loquacities> chandankumar isn't up yet, by the looks, so we can probably move right on
03:02:59 <fifieldt> welcome NickChase
03:02:59 <Loquacities> #topic Monthly Google Hangout starting Jan 2014
03:03:31 <Loquacities> anne has agreed to start running these monthly, now
03:03:34 <Loquacities> starting in jan
03:03:37 <Loquacities> any comments on that?
03:03:48 <Sam-I-Am> sounds like a great idea
03:04:10 <Loquacities> yeah, everyone seems very positive about it :)
03:04:17 <fifieldt> it's continuing in line with our previous one, pretty much, isn;t it?
03:04:25 <fifieldt> which was pretty cool
03:04:34 <Loquacities> yep, pretty much
03:04:39 <fifieldt> cool, it's a good idea :)
03:04:41 <Loquacities> also, the office hours are officially dead now
03:04:44 <slong> sorry, forgot to switch
03:04:56 <Loquacities> #topic Operations Guide developmental edit
03:05:08 <Loquacities> i'm going to c&p some stuff from anne from the last meeting on this topic ...
03:05:15 <fifieldt> ta
03:05:27 <Loquacities> 14:06:07 <annegentle> As most of you probably know, the Ops Guide is being edited by O'Reilly
03:05:28 <Loquacities> 14:06:34 <annegentle> We have our first set of comments, mostly high level, and next week we'll have annotaed PDFs of the first couple of chapters
03:05:28 <Loquacities> 14:06:43 <annegentle> I can't spell annotated apparently
03:05:28 <Loquacities> 14:07:14 <annegentle> then, by mid-January, we'll have edits of the entire book, and at the end of January we're doing a mini sprint in Boston with the original authors
03:05:28 <Loquacities> 14:07:46 <nermina> nice
03:05:30 <Loquacities> 14:07:49 <annegentle> I think Brian, the O'Reilly editor, can meet us those days since they're nearby
03:05:50 <Loquacities> 14:08:48 <annegentle> Some of the tasks: expand the preface to situate the Ops Guide in relation to the other guides, an intro chapter about OpenStack showing a high-level overview and emphasizing how components work together
03:06:06 <Loquacities> 14:10:43 <annegentle> Another interesting comment we're working through is that the book contains tactics but not a lot of strategy
03:06:06 <Loquacities> 14:10:53 <annegentle> My favorite is that it is quite "clean" heh
03:06:06 <Loquacities> 14:11:12 <annegentle> So we'll answer questions like, how does the cloud controller make your job easier? what do you need to be concerned about?
03:06:10 <Loquacities> i think that covers the highlights
03:06:14 <nermina> hi all
03:06:17 <Loquacities> any comments on that?
03:06:19 <Loquacities> hey nermina
03:06:30 <slong> hi nermina
03:06:49 <slong> Loquacities,
03:07:03 <slong> just a question about timing for new info going in. Have a contributor.
03:07:03 <sgordon> Loquacities, insert misgivings about annotated PDFs here
03:07:09 <sgordon> ;)
03:07:33 <Loquacities> sgordon: they're just for the review AIUI, what's the concern?
03:07:51 <Loquacities> slong: i'm fairly certain we can't get any real new content into it at this stage
03:07:57 <Loquacities> but i'm happy to chase that up with anne
03:08:06 <Loquacities> can you drop me an email?
03:08:06 <slong> Ok, will wait until after the January sprint perhaps.
03:08:09 <fifieldt> do we know what kind of content?
03:08:10 <sgordon> Loquacities, having already been through the process of actioning such a review of one of the guides in the past i feel for whoever ends up doing the work
03:08:24 <Loquacities> slong: i think that would be wise
03:08:32 <Loquacities> sgordon: ah, fair enough
03:08:36 <Loquacities> concern noted, in that case ;)
03:08:41 <slong> fifieldt, rhel architecture, since it's pretty ubuntu-centric.
03:08:56 <fifieldt> oh
03:08:59 <fifieldt> right
03:09:37 <slong> Just would like to get it in before the next release.
03:09:43 <Loquacities> slong: it's needed, for sure
03:09:47 <fifieldt> do we know operators who have many months of experience running a production openstack cloud on rhel?
03:09:54 <sgordon> fifieldt, is that a joke?
03:09:55 <sgordon> yes
03:09:58 <Loquacities> lol
03:10:10 <sgordon> that was what the mailing list thread was about, we were asked to identify someone
03:10:16 <slong> The contributor is one such, Graeme Gillies (if I spelled it right).
03:10:36 <slong> He's volunteered to take a look.
03:10:39 <Loquacities> nice
03:10:42 <fifieldt> doesn't look like a cloud operator to me ... ?
03:10:53 <sgordon> fifieldt, how do you figure
03:11:04 <fifieldt> linkedin ?
03:11:12 <sgordon> he operates our internal openstack cloud
03:11:25 <fifieldt> a lab cloud, then
03:11:39 <sgordon> fifieldt, it's not a lab cloud
03:11:43 <Loquacities> it's production
03:12:06 <fifieldt> cool, well maybe writing up a description of that for the examples in the tail end of the book would be a good start
03:12:11 <Loquacities> but it's not like he's the only one, either
03:12:23 <slong> Just have to start somewhere.
03:12:33 <fifieldt> of course
03:12:40 <fifieldt> just want to avoid "vendor" labels
03:12:40 <Loquacities> let's chat to anne about late additions
03:12:49 <slong> Definitely.
03:12:55 <Loquacities> ok, moving on
03:12:56 <sgordon> fifieldt, given the way the book was set up that is a tad rich ;)
03:13:12 <Loquacities> #topic Doc core can now set a patch to WIP
03:13:24 <fifieldt> I'd be interested in knowing more sgordon, but let's do that in pm channel :)
03:13:34 <Loquacities> 14:13:03 <annegentle> This is just a public service reminder as a new part of our review process
03:13:34 <Loquacities> 14:14:03 <annegentle> Anyone up for updating the wiki with the new ability to set a patch as WIP?
03:13:35 <Loquacities> 14:14:19 <annegentle> I think it goes in https://wiki.openstack.org/wiki/Documentation/HowTo#Reviewing_Documentation
03:13:49 <sgordon> i think the open question here is, when do we want to use this facility
03:14:04 <Loquacities> so it doesn't look as though that's been updated yet
03:14:14 <Loquacities> sgordon: i confess, i'm not across this issue
03:14:18 <sgordon> gerrit will automatically abandon a patch that has been minused and not touched for two weeks
03:14:28 <sgordon> but we need to determine what makes a patch something we want to push to WIP
03:14:37 <fifieldt> I have an example of a -core using WIP:
03:14:39 <fifieldt> https://review.openstack.org/#/c/61898/
03:14:48 <fifieldt> see this terrible patch and the change to WIP not done by mde
03:14:49 <fifieldt> me*
03:15:14 <Loquacities> hrm, ok
03:15:16 <Loquacities> seems sane
03:16:32 <Loquacities> no other comments on that?
03:16:43 <Sam-I-Am> well, sort of...
03:16:47 <Loquacities> go ahead
03:17:29 <slong> There's nothing at all about WIP in the HowTo. Should be added for the normal user as well,or?
03:17:40 <Sam-I-Am> i noticed that the associated launchpad bug will change to 'in progress' but only after i submit something for review.  would this set some sort of similar flag there?
03:17:43 <Loquacities> yeah, good point slong
03:18:07 <Loquacities> the bug changes in response to the Partial-Bug flag in the commit message
03:18:26 <Loquacities> slong: it's probably worth mentioning that core is able to do this
03:18:46 <slong> Yes, both,would say.
03:18:53 <Loquacities> yep
03:18:59 <slong> Didn't know to use WIP until fifieldt clued me in.
03:19:08 <Loquacities> are you volunteering to update that, slong? ;)
03:19:09 <fifieldt> yeah, would be good to put something in
03:19:10 <slong> On largish commits...
03:19:17 <fifieldt> encouraging people to put stuff "up early"
03:20:24 <slong> Sure, but might have to wait a bit.
03:20:27 <sgordon> you can submit your own changes as WIP
03:20:40 <Loquacities> slong: thanks
03:20:59 <Loquacities> #action slong to update the HowTo to include WIP info
03:21:42 <Loquacities> #topic Doc tools update - openstack-doc-tools repository
03:21:45 * slong can never tell when sgordon is pulling a funny
03:22:00 <Loquacities> 14:15:54 <annegentle> Andreas has been working steadily at the new repo setup
03:22:00 <Loquacities> 14:16:10 <annegentle> Here's a link to the review queue
03:22:00 <Loquacities> 14:16:12 <annegentle> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-doc-tools,n,z
03:22:00 <Loquacities> 14:17:11 <annegentle> He's also working through the right way to get consistent gate checks on all the docs repos
03:22:01 <Loquacities> 14:17:43 <annegentle> This move also helps with building translated documents
03:22:08 <Loquacities> there was no further comment in last week's meeting
03:22:13 <Loquacities> any comment from this side of the globe?
03:22:54 <Loquacities> i'll take that as a no
03:22:58 <Loquacities> #topic Doc Bug Day Dec 20
03:23:07 <Loquacities> that's this friday, folks
03:23:11 <fifieldt> yay :)
03:23:22 <fifieldt> can I ask someone in .au to send a reminder when they wake up
03:23:26 <fifieldt> to start the day
03:23:40 <slong> 4am work for you?
03:23:47 <Sam-I-Am> 00 utc to 00 utc?
03:23:58 <Sam-I-Am> i should plan to be up 24 hours...
03:24:17 <fifieldt> lol, nice early start there slong :D
03:24:17 <Loquacities> fifieldt: i can try and make sure i put something in the irc chan in our tz, if you like
03:24:28 <fifieldt> I'm thinking also the mailing list
03:24:33 <fifieldt> just replying to the post I have there
03:24:35 <Loquacities> oh, that's a good idea too
03:24:53 <Loquacities> it might also be a good idea to make some noise the day before, as well
03:24:57 <Loquacities> just so people don't forget
03:25:16 <Loquacities> ok, that's all i have on the agenda
03:25:21 <Loquacities> #topic Open discussion
03:25:32 <Sam-I-Am> so whats the game plan for these sprints?
03:25:47 <Loquacities> for the doc bug day?
03:25:49 <Sam-I-Am> yeah
03:25:53 <Loquacities> just do as many bugs as you can :)
03:26:07 <Sam-I-Am> any priorities? heat? age?
03:26:12 <Loquacities> docs!
03:26:21 <Loquacities> ;)
03:26:39 <fifieldt> :D
03:26:51 <Sam-I-Am> what about reviewing?  leave that until later?
03:26:55 <Loquacities> just get in an do what you can
03:27:00 <Loquacities> and*
03:27:17 <Loquacities> good question
03:27:21 <Loquacities> what do you think fifieldt?
03:27:48 <Sam-I-Am> also wondering about working on the same thing someone else is working on
03:27:57 <fifieldt> I think I'll switch between both reviewing and writing
03:28:05 <fifieldt> make sure you assign yourself straight away
03:28:09 <fifieldt> don't start writing until you do
03:28:10 <Loquacities> fifieldt: yeah, i had vague plans of the same thing
03:28:23 <Loquacities> and yes, change the bug owner to yourself before you start
03:28:39 <Sam-I-Am> sure.  i've had them stolen before...
03:28:44 <fifieldt> and triage before the day if you get  a chance
03:28:45 <Loquacities> and make sure you hit refresh on the bug before you take it, too
03:29:11 <Sam-I-Am> also found cases of similar bugs being worked on by multiple people at the same time
03:29:26 <Loquacities> yep, it happens
03:29:44 <Sam-I-Am> Loquacities: is there any way to set 'in progress' in launchpad before the first submission for review?
03:29:58 <Loquacities> yes, you can just change the status of the bug
03:30:03 <Sam-I-Am> i dont think i can triage anything in lp
03:30:06 <fifieldt> yes, all users have this feature
03:30:12 <Loquacities> but assigning it to yourself is the best way to indicate that you're working on it
03:30:47 <Sam-I-Am> ok, i see now :)
03:30:52 <Loquacities> awesome
03:30:55 <Loquacities> any other business?
03:31:54 <Loquacities> oh, before i close the meeting, i wanted to reiterate anne's comment about the docs meeting ...
03:32:12 <Loquacities> no one is expected to attend a docs meeting that is outside of their timezone
03:32:35 <Loquacities> two a month is plenty, so hopefully this mechanism of alternating each week will work for that
03:33:00 <nermina> i'm just online all the time
03:33:06 <Sam-I-Am> this is way outside of my time zone, but more convenient
03:33:11 <Loquacities> nermina: sleep is for the weak ;)
03:33:14 <slong> :D nermina, you work slug
03:33:21 <Loquacities> Sam-I-Am: whatever tz works for you is fine :)
03:33:27 <nermina> it's overrated
03:33:42 <Loquacities> ok, that's it folks ...
03:33:47 <Loquacities> #endmeeting