13:02:19 <annegentle_> #startmeeting DocWebTeam
13:02:20 <openstack> Meeting started Tue Dec 11 13:02:19 2012 UTC.  The chair is annegentle_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:23 <openstack> The meeting name has been set to 'docwebteam'
13:02:35 <annegentle_> #link http://wiki.openstack.org/Meetings/DocTeamMeeting
13:03:24 <annegentle_> I probably should have looked up the last name for this meeting but oh well
13:03:26 <annegentle_> welcome koolhead17
13:03:41 <annegentle_> Ok, first item, actions from last meeting
13:03:42 <koolhead17> hi annegentle_ fifieldt
13:03:56 <fifieldt> argh!
13:04:02 <annegentle_> #link http://eavesdrop.openstack.org/meetings/doc_web/2012/doc_web.2012-11-13-13.06.html
13:04:08 * annegentle_ looks
13:04:18 * annegentle_ Anne to ask CI team if there's notification capability with a patch with DocImpact actually merges
13:04:24 <annegentle_> Done, basically no. :)
13:04:47 <annegentle_> I have been very specific on notifications on review.openstack.org Settings page and that helps me track API changes. But not code changes.
13:05:06 <annegentle_> fifieldt: oh now I see why "argh!" :)
13:05:09 * annegentle_ fifieldt to send an followup email to the dev list thanking them for their response to the ":use docimpact" email
13:05:18 <fifieldt> yes, unfortunately I didn't do this
13:05:27 <annegentle_> fifieldt: you can do it this week, we're still seeing good response
13:05:28 <fifieldt> the good news is, it's still able to be done
13:05:32 <fifieldt> yes miss
13:05:35 * annegentle_ Anne to send summary report of Google Analytics info to openstack-doc mailing list
13:06:20 <annegentle_> Done. #link http://lists.openstack.org/pipermail/openstack-docs/2012-November/000304.html
13:06:34 <annegentle_> http://lists.openstack.org/pipermail/openstack-docs/2012-November/000304.html
13:06:43 <annegentle_> Der!
13:06:50 <annegentle_> old paste :)
13:06:52 * annegentle_ Anne to investigate PDF file naming
13:06:59 <annegentle_> Done. I'll report more on that during the Doc Tools portion.
13:07:04 <fifieldt> cool
13:07:07 * annegentle_ Anne to send Dan Wendlandt a list of highest priority Quantum doc bugs
13:07:14 <annegentle_> Done, Dan and team have been very responsive
13:07:25 * annegentle_ Anne to link to EmilienM's getting started doc from http://www.openstack.org/software/start/
13:07:33 <annegentle_> Done, right EmilienM --
13:07:49 <annegentle_> and last but not least.
13:07:50 * annegentle_ Anne to send email to Christian Berendt with proposal for moving forward with SLES OpenSuse install info
13:08:45 <annegentle_> Done. This request was well-received, though I should follow up again.
13:08:53 <fifieldt> ooh, cool
13:08:54 <annegentle_> They have an entire guide in German.
13:08:58 <fifieldt> :O
13:09:01 <annegentle_> yeah!
13:09:03 <fifieldt> awesome
13:09:18 <annegentle_> But I've asked them to integrate into the Adv. guide (The Install and Deploy one).
13:09:34 <fifieldt> sounds good
13:09:49 <annegentle_> so that there can be a separate SLES guide (like Ubuntu and RHEL/Centos/Fedora have)
13:10:03 <annegentle_> Whew! That's all the Actions. Any questions?
13:10:32 <annegentle_> I need to use my IRC nick for Action assignment, I had just used "Anne."
13:10:57 <annegentle_> So! Let's switch topics to Doc Bug Squash Day
13:11:10 <fifieldt> #link http://webnumbr.com/untouched-bugs-in-openstack-manuals-
13:11:38 <annegentle_> thanks I was just looking for that fifieldt
13:11:48 <annegentle_> I thought I went GREAT, thanks fifieldt for all your hard work
13:12:02 <annegentle_> Only bit of follow up is to do a few more back ports I believe to stable/folsom.
13:12:15 <fifieldt> indeed, I've not been doing well in that department
13:12:18 <annegentle_> I'm in training all week this week (annegentle_ learns Python the Hard Way)
13:12:28 <fifieldt> do we need to go through say, the last month of commits, to check for backportability?
13:12:29 <annegentle_> so realistically I won't get to it this week
13:12:43 <annegentle_> fifieldt: yes we're nearly caught up but I keep having nagging feelings that it's not all there
13:12:52 <koolhead17> annegentle_: fifieldt we need some cleanup as well :P
13:13:13 <annegentle_> did anyone else sense that git's automatic merges were adding in spurious end tags?
13:13:16 <koolhead17> from the docs and re drawing some of the diagrams/archs
13:13:17 <annegentle_> or was that just me?
13:13:32 <fifieldt> I only noticed that on that commit I commented on
13:13:34 <fifieldt> it was strange
13:13:42 * koolhead17 has not made commit for sometime
13:14:41 <fifieldt> I guess that's an action for all - to check out for end tag weirdness ?
13:14:41 <annegentle_> fifieldt: we merged in 15+ patches
13:15:12 <annegentle_> fifieldt: yeah. I also was trying to ensure any given patch wasn't affecting the same file
13:15:30 <annegentle_> koolhead17: get on it man! :) Just kidding.
13:15:46 <koolhead17> annegentle_: :D
13:15:51 <annegentle_> What should our plans be for Thursday's code bug squash?
13:15:56 <koolhead17> was sick for few days. feeling great today
13:15:58 <annegentle_> Ideas: Keep an eye out for DocImpact.
13:16:00 <koolhead17> will do some bug fix
13:16:29 <annegentle_> koolhead17: awesome. I had the worst upper respiratory infection last week but it's clearing now…
13:16:48 <koolhead17> nice
13:16:56 <fifieldt> ouch
13:17:21 <fifieldt> Well, we could also trawl the dev project's bugs looking for things which can be assisted by docs
13:17:25 <fifieldt> but that's a lot of work
13:17:34 <annegentle_> fifieldt: wow yeah. But a good task for a bug day
13:17:35 <fifieldt> and there might be more to gain by just fixing our existing bugs
13:17:46 <annegentle_> fifieldt: yes absolutely
13:17:49 <koolhead17> annegentle_: and api realted changes
13:17:53 <koolhead17> and wiki page changes
13:17:56 <koolhead17> achges
13:18:01 <koolhead17> *changes
13:18:07 <annegentle_> koolhead17: that's a good clean up -- wiki. Esp. before the migration
13:18:10 <annegentle_> which is the next topic.
13:18:18 <annegentle_> and I keep doing /topic but it's not changing the topic? Anyway.
13:18:29 <koolhead17> annegentle_: did you like my idea of adding bold "only for A/B/C" release"
13:18:34 <fifieldt> try #topic
13:18:37 <fifieldt> rather than /topic
13:18:43 <koolhead17> so people using that don`t get confused
13:18:50 <annegentle_> #topic wiki migration
13:19:01 <annegentle_> thanks! fifieldt
13:19:07 * fifieldt hat tip
13:19:12 <annegentle_> Just wanted to put it on our agenda in case there are any questions
13:19:21 <annegentle_> I still need to respond to the question about the new contributor page
13:19:50 <annegentle_> basically from talking to the CI team, waiting for the DNS switchover is the only likely "wait" period or delay for new contributors
13:19:57 <koolhead17> annegentle_: i can work on the wiki page later tonight and add that extra line after going through all the pages about which version of OS it is supported
13:20:06 <annegentle_> koolhead17: that would be great.
13:20:15 <annegentle_> koolhead17 found that the "Flags" wiki page is for Essex
13:20:30 <annegentle_> koolhead17: honestly you could just point it to the Folsom link
13:20:56 <annegentle_> Add this code to wiki pages to indicate the page is outdated: <<Include(DeprecatedPage)>>
13:21:18 <annegentle_> Since we don't really keep docs on the wiki, I'd prefer to prune more than keep.
13:21:41 <annegentle_> I haven't done a wiki clean out for a while, so koolhead17 if you're up for it that would be great
13:21:45 <koolhead17> annegentle_: yes i will do that as you suggested in your mail. and do you want me to add extra bold folt with one sence as well
13:21:47 <fifieldt> awesome
13:22:05 <koolhead17> saying limited to a/b/c release
13:22:14 <koolhead17> i see some content for bexer release there
13:22:19 <koolhead17> :)
13:22:25 <annegentle_> koolhead17: see how http://wiki.openstack.org/Documentation just points to other places? That's the ideal to me.
13:22:26 <fifieldt> eek
13:22:47 <annegentle_> koolhead17: yeah :) I found notes from an install fest from 2 years back
13:22:54 <koolhead17> annegentle_: :D
13:23:20 <koolhead17> so either clean up or add tag along with a warning saying its restricted to pervious version support
13:23:24 <annegentle_> Ok, moving along if there's no questions?
13:23:34 <annegentle_> koolhead17: yeah with a preference to just CLEAN :)
13:23:38 <fifieldt> all good
13:23:41 <annegentle_> cool
13:23:46 <annegentle_> #topic Doc Tools Update
13:24:02 <annegentle_> David Cramer had to get kids to school this morning so I got his report yesterday
13:24:09 <koolhead17> annegentle_: cool. let me ping you later tonight with pages which i feel totally outdated
13:24:15 <koolhead17> and we can take call on the same then
13:24:19 <annegentle_> They work in 3 week sprints, and in this next sprint they are working on automatically generating site map.xml
13:24:45 <annegentle_> #info Maven Plugin working on auto-generating sitemap.xml at build time
13:24:56 <annegentle_> They're also moving into the OpenStack CI infrastructure
13:25:12 <annegentle_> The other area of interest to us is the PDF output file naming.
13:25:43 <annegentle_> They're fixing the "bug" that is in 1.6.0 that means we can't use it -- PDF files are named based on date metadata and we don't name our PDF files that way.
13:25:57 <annegentle_> we name PDF files using the "release name" variable in the pom.xml.
13:26:08 <annegentle_> So we should be good to go
13:27:04 <annegentle_> but not until the release at the end of their 3 week sprint
13:27:08 <fifieldt> ok
13:27:16 <annegentle_> when 1.6.1 comes out, we'll need to do a bunch of pom.xml work
13:27:23 <annegentle_> to pull out the "postProcess" parts
13:27:29 <annegentle_> since all that'll be automated
13:27:37 <annegentle_> I hope to never open a bug again about the PDF link breaking!
13:28:05 <annegentle_> and the site map.xml will help a bunch at release time, plus just make our google strength better
13:28:06 <koolhead17> annegentle_: yeah :P
13:28:11 <annegentle_> better/more accurate
13:28:21 <annegentle_> ok snuck in one more agenda item before open discussion
13:28:25 <fifieldt> brilliant
13:28:28 <annegentle_> #topic Outreach Program for Women
13:28:45 <annegentle_> Ok, we've been interviewing candidates and helping them with first patches.
13:28:55 <fifieldt> oh cool!
13:28:56 <annegentle_> Many are interested in coding, but I had a handful of doc candidates and I hope to get one!
13:29:09 <annegentle_> I'll let you know if we get one! The selection process ends Dec 11
13:29:13 <annegentle_> er. Today!
13:29:14 <annegentle_> :
13:29:16 <annegentle_> :)
13:29:28 <fifieldt> yesterday ! :P
13:29:44 <koolhead17> annegentle_: cool
13:29:48 <annegentle_> I want to direct her mostly to API doc bugs, but that can change over the course of the internship.
13:29:51 <koolhead17> so we will ahve some helping hand
13:29:56 <annegentle_> The start period isn't until January.
13:30:03 <koolhead17> grr
13:30:21 <annegentle_> koolhead17: yep! And we'll need to help her too - she's starting from zero OpenStack knowledge but already has a patch, it's a requirement of the program.
13:30:23 <koolhead17> but if someone is really interested in contributing wont mind starting right away
13:30:24 <koolhead17> IMHO
13:30:41 <annegentle_> yeah I bet she will actually unless she has school obligations
13:30:52 <koolhead17> annegentle_: cool.
13:30:52 <annegentle_> The program is intended for students in the southern hemisphere at this time of year.
13:31:01 <annegentle_> so she will be 40 hours a week on OpenStack docs.
13:31:05 <fifieldt> I am on leave from work from ~today to January 14th ... I might have time to help
13:31:06 * annegentle_ does a happy dance
13:31:16 <annegentle_> fifieldt: fabulous!! I'll intro her when I can announce
13:31:33 <annegentle_> Ok, good timing, at a half hour! Nice.
13:31:40 <annegentle_> #topic Open discussion
13:31:57 <fifieldt> ok
13:32:03 <koolhead17> fifieldt: awesome :D
13:32:14 <fifieldt> got more for us Anne? or shall the rabble start pitching in now? :)
13:32:24 <koolhead17> :D
13:32:25 <annegentle_> sure!
13:32:30 <annegentle_> :) That's all I got.
13:32:42 <fifieldt> so, just throwing out one of the things from the ML
13:32:49 <fifieldt> Do we want to try and set a Grizzly bug day
13:32:51 <fifieldt> well in advance
13:32:54 <fifieldt> so we can all be free-ish
13:33:03 <koolhead17> fifieldt: +1
13:33:04 <koolhead17> :D
13:33:05 <fifieldt> to ensure that when grizzly goes live
13:33:13 <fifieldt> those listed against it's milestone are in
13:33:19 <fifieldt> s/those/those bugs
13:33:34 <koolhead17> fifieldt: annegentle_  lets find someone who can help us with cleaning the arch diagram and some other stuff
13:33:36 <annegentle_> fifieldt: great idea
13:33:51 <koolhead17> am not sure in nova-network and nova-volume will b there in grizzly
13:34:05 <annegentle_> fifieldt: do you have an idea of how much G1 is undocumented? I haven't really analyzed.
13:34:22 <fifieldt> well
13:34:39 <fifieldt> #link https://launchpad.net/openstack-manuals/+milestone/grizzly
13:34:44 <fifieldt> I've been not working on grizzly bugs
13:34:45 <koolhead17> some features like nova-cells and also if vendors want we can add there drivers in cinder doc
13:34:51 <fifieldt> in preference for ones that affect folsom
13:34:57 <annegentle_> fifieldt: wow, 32 g1 doc tasks
13:35:15 <annegentle_> koolhead17: did nova cells make it in finally? It didn't make G1
13:35:33 <koolhead17> annegentle_: it will to G hopefuuly :P
13:35:35 <annegentle_> #info 32 G1 doc tasks recorded, ready for someone to work on
13:35:39 * fifieldt is using cells in production :P
13:35:45 <annegentle_> fifieldt: nice :)
13:35:57 <koolhead17> fifieldt: :D
13:36:13 <koolhead17> fifieldt: so can we add that somewhere to be added in the doc
13:36:18 <annegentle_> I did want to mention that we'll try for an Operators Doc Sprint in Februrary 2014.
13:36:22 <koolhead17> and removing many other stuff
13:36:23 <annegentle_> eek! 2013!
13:36:24 <fifieldt> already got a bug lodged koolhead17
13:36:34 <fifieldt> tehehe
13:36:37 <koolhead17> annegentle_: lets do that.
13:36:40 <koolhead17> fifieldt: waoo cool
13:36:58 <fifieldt> koolhead17, https://bugs.launchpad.net/bugs/1075669
13:36:59 <uvirtbot> Launchpad bug 1075669 in openstack-manuals "grizzly: Support for cells in Compute (nova)" [Undecided,New]
13:37:15 <annegentle_> #action annegentle_ to write a proposal to Foundation requesting funding of Doc Sprint in Feb 2013 including Adam Hyde as facilitator
13:37:59 <annegentle_> So how can we time a date in advance? Is it right around G2 that we'll want another doc bug sprint?
13:38:19 <fifieldt> #link http://wiki.openstack.org/GrizzlyReleaseSchedule
13:38:33 <fifieldt> I think after G3
13:38:43 <annegentle_> Was a Tuesday a good day of the week? I liked it.
13:38:44 <fifieldt> because there's a chance things change
13:38:52 <fifieldt> I've already seen some options that changed names
13:38:59 <fifieldt> in processing DocIMpacts
13:39:06 <koolhead17> fifieldt: yeah correct
13:39:09 <fifieldt> so we don't want to do it too early, imo
13:39:16 <annegentle_> fifieldt: ok, that makes sense then.
13:39:27 <annegentle_> fifieldt: it'll run up into that Doc Sprint proposed though, but maybe that's ok
13:39:33 <annegentle_> and good timing even
13:39:57 <koolhead17> annegentle_: so when are you thinking to have it after G3
13:40:16 <annegentle_> or what about Tues Feb 19, right before G3?
13:40:32 <annegentle_> the proposal for the Doc sprint is Feb 25-29
13:40:53 <fifieldt> that could work -
13:40:53 <annegentle_> G3 is Feb 28
13:40:58 <fifieldt> get a head start on doc bugs
13:41:00 <koolhead17> yes works for me
13:41:04 <fifieldt> then do the doc sprint
13:41:10 <annegentle_> it's tight but gives us good data
13:41:15 <annegentle_> cool
13:41:21 * annegentle_ needs to get that proposal done!
13:41:41 <annegentle_> Okay, what else is going on?
13:41:43 * annegentle_ thinks
13:42:08 <annegentle_> I'll try to do a doc status report tomorrow for the week
13:42:23 <annegentle_> Seriously, great work on the doc bug day. That was fantastic.
13:42:30 <fifieldt> bugs <100 before end of year?
13:42:37 <annegentle_> fifieldt: YES.
13:42:45 <fifieldt> how ? :D
13:43:17 <annegentle_> fifieldt: let's see if the Intern can help in Dec… and I'll rally some groups at the Rack.
13:43:24 <fifieldt> :)
13:43:28 <koolhead17> annegentle_: cool
13:43:31 <annegentle_> and? Maybe your mailing list post will inspire?
13:43:48 <fifieldt> hmm, maybe we need another mailing list post for inspiration
13:43:51 <koolhead17> annegentle_: which mail?
13:43:53 <koolhead17> :P
13:43:55 <annegentle_> AT&T wants to contribute more, how can I match doc bugs with a person there?
13:43:55 <fifieldt> asking for help from those devs in the know
13:44:03 <fifieldt> what are they interested in?
13:44:09 <annegentle_> fifieldt: your note of gratitude for using DocImpact
13:44:14 <fifieldt> yup
13:44:17 <annegentle_> fifieldt: not sure, that's a good starting question.
13:44:26 <koolhead17> also here in meetup am expecting some contribution starting to happen soon
13:44:27 <koolhead17> :)
13:44:34 <koolhead17> met som eenthu folks/kids
13:44:40 <koolhead17> *enthu
13:44:51 <annegentle_> koolhead17: oh yeah?
13:44:58 <fifieldt> AT&T:  "a developer-centric cloud." The service will be focused on providing developers of cloud apps low-cost entry into AT&T's hosting services, and a choice of public or private access, as well as an option for "bare-metal" provisioning of hardware for developers requiring specific server configurations, and options for cloud storage, network configuration and monitoring.
13:45:06 <annegentle_> koolhead17: do we need a better "here's how you get started with docs?"
13:45:22 <koolhead17> annegentle_: i will blog one tonight :P
13:45:24 <annegentle_> fifieldt: yep, they're operating plenty… Essex I believe.
13:45:28 <annegentle_> koolhead17: oh good idea
13:45:34 <fifieldt> they're involved in the bare metal stuff in grizzly?
13:45:51 <koolhead17> and also planning to get the same published in some other blog pages too
13:46:17 <koolhead17> fifieldt: it be great if they can help us including that part in our doc
13:46:24 <fifieldt> aye
13:46:32 <fifieldt> anyway, we have a wall of work
13:46:37 <fifieldt> so they can work on their interest :)
13:46:45 <fifieldt> That's all from me
13:46:58 <koolhead17> :P
13:47:00 <annegentle_> okay, cool.
13:47:10 <annegentle_> I'm good to go -- call it a wrap!
13:47:24 <annegentle_> #endmeeting