13:42:09 <annegentle-web> #startmeeting docwebteam
13:42:11 <openstack> Meeting started Tue Jan 8 13:42:09 2013 UTC. The chair is annegentle-web. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:42:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:42:14 <openstack> The meeting name has been set to 'docwebteam'
13:42:26 <annegentle-web> woo! I need to remember to be consistent so the eavesdrop directories line up
13:42:30 <annegentle-web> Let's review action items
13:42:36 <fifieldt> #info http://wiki.openstack.org/Meetings/DocTeamMeeting
13:42:46 <EmilienM__> hello :)
13:42:51 <fifieldt> (nb - we forgot to use #action for action items last time)
13:43:00 <annegentle-web> EmilienM__: hello!
13:43:12 <fifieldt>
13:04:18 * annegentle_ Anne to ask CI team if there's notification capability with a patch with DocImpact actually merges
13:43:14 <annegentle-web> Looks like the one with #action was for me to write a proposal to Foundation requesting funding of Doc Sprint in Feb 2013 including Adam Hyde as facilitator
13:43:32 <fifieldt> sorry
13:43:40 <fifieldt> I am reading the previous previous meeting's action items
13:43:43 <fifieldt> please ignore me
13:43:43 <annegentle-web> fifieldt: hee
13:43:46 <annegentle-web> no worries
13:43:54 <annegentle-web> so the proposal was written and funded, woo!
13:43:59 <fifieldt> congratulatons
13:44:17 <Daisy_> great ! Do you have a link for that proposal?
13:44:18 <fifieldt> for my part I also sent the thank-you email re: docimpact
13:44:20 <annegentle-web> I've been following up with the group and will keep working on travel and lodging arrangements
13:44:34 <fifieldt> looking forward to that
13:44:38 <annegentle-web> Daisy_: it was in email but I could certainly put it into a etherpad
13:44:56 <annegentle-web> #action annegentle-web to share the proposal for the book sprint
13:45:06 <annegentle-web> maybe even blog about it? Not sure.
13:45:42 <annegentle-web> Oh yeah usually I point to the agenda
13:45:44 <annegentle-web> #link http://wiki.openstack.org/Meetings/DocTeamMeeting
13:45:47 <fifieldt> might raise expectations too much :)
13:45:56 <annegentle-web> #topic Action items
13:46:08 <fifieldt> hi lorin1!
13:46:10 <annegentle-web> I think that's it for action items, I did send out a status report last week
13:46:22 <fifieldt> got it, yup
13:46:39 <annegentle-web> #link https://lists.launchpad.net/openstack/msg19757.html
13:46:40 <lorin1> hi fifieldt
13:47:04 <annegentle-web> Let's talk about the wiki migration briefly.
13:47:08 <annegentle-web> #topic wiki migration
13:47:16 <fifieldt> so, what's going on?>
13:47:17 <annegentle-web> I say briefly because I know little about the latest :)
13:47:23 <fifieldt> ah :)
13:47:43 <annegentle-web> I understand that Stefano (reed) is going to work with a team going forward
13:48:03 <reed> ?
13:48:16 <annegentle-web> reed: did I hear that right on IRC yesterday?
13:48:21 <annegentle-web> heh, hear. :)
13:48:25 <reed> wiki migration?
13:48:31 <annegentle-web> reed: moving to mediawiki
13:48:40 <reed> I know nothing about that, sorry
13:49:00 <annegentle-web> reed: wow, sorry, don't want to invent responsibilities :)
13:49:20 <annegentle-web> so all I know is I have an email in to Ryan Lane to see if he found someone to work on the styling
13:49:21 <reed> I've mentioned working on wikiPedia page about openstack
13:49:30 <annegentle-web> reed: oh that was it!! Sorry.
13:49:34 <reed> :)
13:50:11 <annegentle-web> my current sense of the mailing list posts is that people wanted it cleaner in the beginning
13:50:18 <annegentle-web> and we need a plan to get it clean
13:50:26 <annegentle-web> styling, content, macros, etc.
13:50:32 <annegentle-web> any other comments on the wiki migration?
13:50:35 <Daisy_> who will do the wiki migration? doc team?
13:50:54 <annegentle-web> Daisy_: Ryan Lane at Mediawiki already did it and has the scripts, and the CI team has puppet-ized the install
13:51:04 <fifieldt> umm, content
13:51:04 <reed> the technical part of the migration will be done by ryan and the infra team
13:51:05 <annegentle-web> Daisy_: so really it's more about CI than docs since we don't use the wiki for docs really
13:51:18 <reed> the content will have to be reviewed/fixed by all of us
13:51:23 <annegentle-web> to me, the wiki is for project management
13:51:24 <fifieldt> I've been wandering through http://wiki.openstack.org/TitleIndex
13:51:29 <annegentle-web> reed: yep, exactly
13:51:29 <fifieldt> and removing crap
13:51:33 <fifieldt> is this a good time to do that?
13:51:35 <annegentle-web> fifieldt: GOOD
13:51:35 <Daisy_> so if migrating the existing content, why need a plan to get it clean?
13:51:59 <annegentle-web> Daisy_: because https://wiki-staging.openstack.org/wiki/Main_Page is not very pretty
13:52:04 <annegentle-web> #link https://wiki-staging.openstack.org/wiki/Main_Page
13:52:26 <annegentle-web> fifieldt: well, the content migration happend the 3rd week of Dec, so deleting pages on the wiki now would have to be redone if I understand it
13:52:43 <fifieldt> ah
13:52:46 <fifieldt> that's not good
13:52:49 <fifieldt> I just did A through C
13:52:57 <annegentle-web> fifieldt: wah.
13:53:03 <annegentle-web> fifieldt: but needed.
13:53:04 <Daisy_> oh. the main page looks ugly.
13:53:11 <fifieldt> I didn't think there was consensus yet on the content migration
13:53:18 <annegentle-web> Daisy_: yeah and migrated content esp. tables and graphics need cleanup
13:53:21 <annegentle-web> fifieldt: ah okay
13:53:31 <fifieldt> there was still some debate about the interim period of nonediting
13:53:55 <fifieldt> certainly I'm not the only one editing the wiki
13:53:57 <Daisy_> does Doc team own the clean job?
13:54:01 <fifieldt> #link http://wiki.openstack.org/RecentChanges
13:54:12 <annegentle-web> Daisy_: I don't think so, and I'm not raising my hand :)
13:54:13 <fifieldt> so I would say content migration needs to be redone
13:54:21 <annegentle-web> but, perhaps we could organize the day of cleanup
13:54:31 <annegentle-web> I say "we" meaning "me" most likely
13:54:39 <annegentle-web> gah the nickname crazies!
13:54:58 <annegentle-web> #action annegentle-web to investigate wiki migration status
13:55:14 <annegentle-web> okay, good on wiki?
13:55:20 <Daisy_> at least, we need to make sure the content about documentations are correct and right there.
13:55:33 <fifieldt> clarity is good
13:55:35 <annegentle-web> Daisy_: yep, I did ensure that was okay, but more eyes the better always
13:55:43 <Daisy_> ok
13:56:00 <fifieldt> anne - when you get the info, perhaps email it out
13:56:00 <annegentle-web> For example, this page is correct: http://wiki.openstack.org/Documentation/
13:56:04 <fifieldt> it seems there is confusion
13:56:13 <annegentle-web> fifieldt: yeah I need to circle back to the mailing list for certain
13:56:22 <annegentle-web> #topic doc tools update
13:56:23 <fifieldt> ta
13:56:37 <annegentle-web> So I have a giant email ready to send to openstack-docs about what it takes to get to 1.6.2 of the Maven plugin
13:56:48 <annegentle-web> Basically I've been investigating and testing
13:57:09 <annegentle-web> the difficulty is that we need to change doc jobs in the CI project at the same time we merge these pom.xml changes
13:57:18 <annegentle-web> it's not impossible, just need to be careful and plan
13:57:20 <fifieldt> yay, coordination
13:57:25 <annegentle-web> hee
13:57:51 <annegentle-web> I'll send that this morning so you all can review and ask questions
13:58:00 <Daisy_> ok.
13:58:06 <annegentle-web> #topic open discussion
13:58:12 <annegentle-web> Daisy_: do you want to talk about translation?
13:58:16 <fifieldt> want to make an action item for the last point, anne?
13:58:24 <fifieldt> i.e. send the email for all to review
13:58:30 <fifieldt> just for completeness
13:58:31 <fifieldt> :)
13:58:35 <Daisy_> yeah.
13:59:12 <Daisy_> Firstly, I'd like to talk about the review in Transifex.
13:59:52 <Daisy_> The review check box doesn't appear to common translators.
14:00:20 <Daisy_> so translators cannot do the review. The only review can be done when it is merged into the main repository, which is not good.
14:00:51 <annegentle-web> Daisy_: yep been seeing that on the mail thread
14:01:19 <annegentle-web> Daisy_: So the centralized translation coordinator isn't quite right?
14:01:31 <Daisy_> so the problem is if we want to use Transfifex to do the review, we need to manage the long list of coordinators.
14:01:32 <Daisy_> Right.
14:02:04 <fifieldt> is it possible to nominate a 'leader' per language, and that 'leader' can manage the list of people for that language?
14:02:16 <annegentle-web> fifieldt: I think that is one idea floating around
14:02:32 <fifieldt> coolo
14:02:43 <fifieldt> I'm just not sure what kind of role management is possible within transifex
14:02:50 <annegentle-web> Daisy_: so you sense the translators feel more "loyalty" and get more "points" in the transifex system than in review.openstack.org (Gerrit) (That's my sense of it.)
14:03:01 <Daisy_> I only see project maintainer and coordinators.
14:03:20 <Daisy_> project maintainer, coordinators, and translators.,
14:04:04 <Daisy_> I just feel review in Transifex is more easy than in Gerrit for a reviewer.
14:04:09 <annegentle-web> Daisy_: so I like the proposed idea that translators could act as "project technical leads" do
14:04:25 <annegentle-web> Daisy_: yeah I think that's right also, that Transifex is their preferred review mechanism
14:05:08 <Daisy_> Yes, if we regard translators as "project technical lead", they can review by Gerrit then.
14:05:25 <annegentle-web> Daisy_: what about this: could you write up what the role of a lead translator would be? And what permissions they'd need where?
14:05:47 <annegentle-web> Daisy_: perhaps then we can "recruit" for that role? For example, from the User Groups
14:05:47 <Daisy_> ok, sure.
14:05:59 <Daisy_> great idea !
14:06:08 <annegentle-web> reed: any thoughts on translation coordination?
14:06:12 <Daisy_> Let's recruit.. after the infrastucture is ready.
14:06:24 <annegentle-web> Daisy_: yeah I think that's right also... timing matters.
14:06:52 <annegentle-web> Daisy_: ok, thanks! Also do you need more CI help?
14:07:01 <Daisy_> not now, I think.
14:07:06 <annegentle-web> Daisy_: ok
14:07:10 <Daisy_> I need to do ...
14:07:28 <Daisy_> #action Daisy write up what the role of a lead translator would be? And what permissions they'd need where?
14:07:30 <Daisy_> firstly.
14:07:40 <annegentle-web> Daisy_: yep, sounds right
14:07:40 <Daisy_> then let's see what help we need from CI team.
14:07:48 <annegentle-web> EmilienM__: what are your thoughts on the barrage of comments on the basic install?
14:07:51 <reed> annegentle-web, I'd love to but it's not clear to me what the problem is
14:08:10 <annegentle-web> reed: okay, I'll send you a LONG email thread :)
14:08:15 * EmilienM__ reading comments
14:09:19 <reed> annegentle-web, private or on the list?
14:09:21 <annegentle-web> EmilienM__: basically "Thiago" never did get it set up? I guess?
14:09:30 <annegentle-web> reed: to your stefano@openstack email
14:10:24 <EmilienM__> annegentle-web: indeed
14:10:31 <annegentle-web> EmilienM__: I tried to respond to Thiago as much as I could but he didn't really explain his setup
14:10:32 <EmilienM__> annegentle-web: I'll work on that later toay.
14:10:37 <annegentle-web> EmilienM__: that would be great, thanks
14:11:01 <EmilienM__> annegentle-web: we definitly need more review on this work, and I'll do my best to improve it, with the help of other guys
14:11:03 <annegentle-web> EmilienM__: I never figured out whether there are ubuntu bugs that prevent him
14:11:23 <annegentle-web> EmilienM__: my concern was that this "blew up" right after you added Quantum -- maybe Quantum isn't basic :)
14:11:31 <EmilienM__> ahah
14:11:41 <EmilienM__> nothing is basic, actually
14:11:45 <koolhead17> EmilienM__: 3 node setup cannot be basic :)
14:11:50 <annegentle-web> EmilienM__: Heh
14:11:59 <annegentle-web> Well, maybe we need to revisit "Basic"
14:12:13 <annegentle-web> Such as -- if there is no such thing as Basic, do we even claim there to be
14:12:14 <koolhead17> its called multinode :D
14:12:16 <EmilienM__> believe me, it's nothing comparing to production ;)
14:12:42 <annegentle-web> fifieldt: I'm not sure if you're moderator on the basic install comments, can I add you?
14:13:05 <fifieldt> sure
14:13:08 <EmilienM__> #action EmilienM to reply to comments & fix bugs if they exist.
14:13:14 <EmilienM__> annegentle-web: ok for you ?
14:13:24 <fifieldt> I haven't been online much these few weeks - internet at folks place is iffy - apologies
14:13:46 <annegentle-web> #info Our new intern starts this week, Laura Alves da Quinta (ladquin on IRC) from Buenos Aires, Argentina
14:13:47 <fifieldt> [plus, there's a beach here :)]
14:13:52 <fifieldt> wow, cool!
14:13:52 <annegentle-web> fifieldt: hee
14:14:13 <annegentle-web> Wish she was here this morning! I didn't tell her about it, shoot.
14:14:31 <annegentle-web> So welcome her if you see her online.
14:14:44 <annegentle-web> And if it's okay with you all, I'll have her ask you questions if she gets stuck.
14:14:52 <annegentle-web> Her focus will be API docs and she's already patching.
14:15:11 <fifieldt> great :)
14:15:46 <annegentle-web> Okay, w'ere over time due to the late start, my apologies.
14:15:49 <annegentle-web> Anything else?
14:16:18 <fifieldt> oh
14:16:20 <fifieldt> one more
14:16:33 <fifieldt> I think I'm going to start fixing grizzly bugs now
14:16:46 <fifieldt> the ones which are confirmed on launchpad seem stable enough
14:16:49 <fifieldt> to write them in
14:16:50 <annegentle-web> fifieldt: ok, feeling like the code is going in?
14:16:53 <annegentle-web> fifieldt: GREAT
14:16:56 <fifieldt> yup
14:16:57 <annegentle-web> fifieldt: go for it
14:17:26 <lorin1> I've been adding the person who submitted the commit to the reviewers in the DocImpact-related doc stuff.
14:17:35 <lorin1> They are usually pretty good about giving feedback.
14:17:48 <annegentle-web> lorin1: good thinking
14:18:07 <annegentle-web> lorin1: yeah approve that one for config drive
14:18:08 <fifieldt> nice one
14:18:26 <annegentle-web> Okay, see you all around on IRC I sure hope. :)
14:18:32 <annegentle-web> #endmeeting