08:59:12 <gsagie> #startmeeting Dragonflow
08:59:12 <openstack> Meeting started Mon Dec 7 08:59:12 2015 UTC and is due to finish in 60 minutes. The chair is gsagie. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:59:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:59:15 <openstack> The meeting name has been set to 'dragonflow'
08:59:34 <gsagie> ok, welcome everyone to our first IRC meeting
09:00:13 <gsagie> We are going to talk about areas we are working for the next version and hopefully more people will join in later meetings
09:00:27 <gsagie> #topic testing
09:00:45 <gsagie> Yuli, Shlomo you are starting to look at functional testing right?
09:00:59 <Shlomo_N> Yep
09:01:44 <gsagie> ok, there is one bug that Shlomo is looking at and got a bit complicated, i will look at it to see whats going on
09:02:21 <gsagie> As we discussed for the first stage we are going to work on writing tests that add logical elements to Neutron and verify that they are configured correctly in the DB
09:02:45 <gsagie> #action Yuli_s to start creating functional testing of Neutron plugin and DB client
09:03:34 <gsagie> #action Shlomo_N implement functional tests leveraging the work Yuli done
09:03:55 <gsagie> I am currently looking at how to run these tests in the gate with a working devstack
09:04:02 <gsagie> and Rally, which is our next step
09:04:15 <gsagie> #action gsagie look at Rally and how to run tests on the gate with devstack
09:04:25 <gampel> we need to fix the gate errors first
09:04:28 <gsagie> #action gsagie Make tempest testing work
09:04:47 <gsagie> gampel: yes, but this is currently non voting and i will work on it but it may take some time
09:05:21 <gampel> can we run the test on top of it even if it failed
09:05:21 <gsagie> Billy: Can you please share what are you working on?
09:05:45 <gsagie> gampel: the plan is to create a different job for that, and when its stable we can make it voting
09:06:32 <gampel> Ok got it
09:06:37 <gsagie> BillyXu
09:06:59 <BillyXu> we will start security group function this week.
09:07:47 <gsagie> BillyXu: ok, did you manage to setup a working Dragonflow do you need any help?
09:08:15 <BillyXu> no problem for dragonflow setup
09:08:20 <gampel> BillyXu: did you see the spec folder with the DNAT spce example, you would have to follow the same with SG
09:08:34 <BillyXu> an problems, I'll contact with you.
09:09:06 <BillyXu> if any problems, I'll contact with you.
09:09:06 <gsagie> Billy: ok that is great, its an important task for us
09:09:35 <gsagie> #action BillyXu create SG spec/design and get familiar with what is needed in the code
09:09:47 <gsagie> BillyXu: you can join #openstack-dragonflow if you need any help
09:10:18 <BillyXu> ok, no problem.
09:10:19 <gsagie> We have also updated alot of documentation to the repository, you can read and understand the project more
09:10:31 <BillyXu> sure
09:10:38 <gsagie> #link http://docs.openstack.org/developer/dragonflow/distributed_dragonflow.html
09:10:47 <gsagie> #link Dragonflow docs http://docs.openstack.org/developer/dragonflow/distributed_dragonflow.html
09:11:15 <gsagie> Billy: The time for this IRC meeting is ok for you two?
09:11:49 <BillyXu> this time is ok for raofei and me.
09:12:17 <gsagie> ok great, let him know he can also come online and feel free to ask
09:13:04 <gsagie> #topic DB integration
09:13:12 <gampel> we are going to land two new DB I hope this week dima is working on RethinkDB and Ahron the RamCloud
09:13:14 <BillyXu> he failed to login irc meeting. he is trying now.
09:13:39 <gsagie> #info RAMCloud integration to merge this week
09:13:48 <gsagie> i saw the patch is ready
09:14:12 <gsagie> gampel: We might want to also look at packaging in conjunction to stabilize things
09:14:30 <gampel> I think it is , i will ask dima and ahron to join the IRC meeting next week
09:14:55 <gsagie> #action gampel talk with Aharon and Dima to join the IRC Meeting
09:15:05 <gampel> gsagie: i agree Shlomo all ready opened a bug for the Ramcloud missing packages
09:15:33 <gsagie> gampel: yeah, thats missing requierments, i was talking about a Dragonflow package
09:15:55 <gsagie> Shlomo_N: what packages are missing for RAMCloud?
09:16:40 <Shlomo_N> gsagie: I found only two packages, but I want to install it again on clean env. and make sure there are no other packages.
09:17:40 <gampel> gsagie: do you mean pip packaging for Dragonflow or devstack
09:17:50 <gsagie> gampel: maybe also RDO
09:18:16 <gampel> gsagie: i see i will look into this and report for next meeting
09:18:35 <gsagie> #action gampel to look at RDO packaging
09:19:10 <gsagie> Shlomo_N: okie, we might need to install these packages in RAMCloud script
09:19:16 <gsagie> #topic open discussion
09:19:27 <gsagie> Anyone has any other topic to add or want to raise something?
09:19:35 <gampel> Yoli, Shlomo: can you give a brief of the new bugs found
09:20:12 <Yuli_s> I found strange bug with traceroute
09:20:37 <gampel> Yuli_s: can you share the link number
09:20:49 <Yuli_s> sec.
09:20:58 <gsagie> Welcome Raofei
09:21:10 <milo_raofei_> Hi Gsagie
09:21:13 <Yuli_s> https://bugs.launchpad.net/dragonflow/+bug/1521629
09:21:13 <openstack> Launchpad bug 1521629 in DragonFlow "traceroute packet delay" [Undecided,New]
09:24:20 <gsagie> ok, i will take a look at this bug and report to next meeting
09:24:33 <gsagie> #action gsagie to look at https://bugs.launchpad.net/dragonflow/+bug/1521629 for next meeting
09:24:34 <openstack> Launchpad bug 1521629 in DragonFlow "traceroute packet delay" [Undecided,New]
09:24:52 <gampel> Yuli_s: any other Major bugs found this week ?
09:25:17 <Shlomo_N> I think we should improve the rejoin for supporting RAMCloud, look @ this bug: https://bugs.launchpad.net/dragonflow/+bug/1522029
09:25:17 <openstack> Launchpad bug 1522029 in DragonFlow "rejoin-stack isn't supports RAMCloud" [Undecided,New] - Assigned to Li Ma (nick-ma-z)
09:25:46 <Yuli_s> gampel: nop
09:26:25 <gampel> #topic no-dhcp-agent
09:26:36 <gsagie> #topic DHCP agent
09:27:04 <gampel> This week we landed the patch that allow us to run without the q-dhcp agent
09:27:43 <gsagie> #info Dragonflow running without q-dhcop agent
09:27:47 <gampel> currently it support only ipv4 ditst dhcp
09:28:25 <gampel> If you need IPV6 dhcp the dhcp agent must be installed
09:28:45 <gampel> i will add a new BP to support SDN based IPV6 application
09:29:11 <gampel> ipv6-sdn-dhcp-app
09:29:28 <gsagie> #action gampel register bp to support IPV6 DHCP (ipv6-sdn-dhcp-app)
09:29:49 <gsagie> gampel: i think we also need to move most of the tasks from Trello to blue prints, i will do it
09:30:02 <gsagie> #action gsagie convert Dragonflow Trello to launchpad bps/bugs
09:30:11 <gampel> we need to make sure to test in the next weeks both deployments with q-dhcp and without
09:30:46 <gampel> I will register a spec for dhcp ipv6 app as well
09:30:59 <gampel> #action gampel register a spec for dhcp ipv6 app
09:31:28 <gsagie> gampel: added that action :)
09:31:37 <gsagie> only the person that started the meeting can use the commands i believe
09:31:50 <gampel> ops sorry
09:32:47 <gsagie> #topic Questions?
09:32:54 <milo_raofei_> I think dhcp maybe need to enhance also. current dhcp app support DHCP_DISCOVER/DHCP_OFFER/DHCP_REQUEST/DHCP_ACK, maybe also need to support release/decline msg etc
09:32:54 <gsagie> so anything else? :)
09:33:35 <gsagie> milo_raofei_: good point, we should document this. You are working with Billy on the security groups for first stage?
09:33:58 <gampel> milo_raofei_: this is a good idea can you please submit a bug
09:34:20 <milo_raofei_> sure. I will raise a bug.
09:34:31 <gsagie> #action milo_raofei_ add a bug about missing functionality and suggestions for current DHCP (release/decline msgs)
09:34:56 <milo_raofei_> yes, i work with billy
09:35:22 <gsagie> okie, we are at #openstack-dragonflow or in email if you need any help
09:36:07 <gsagie> I think that all the missing parts for the security groups design are there (in Ryu and OVS) and its an interesting task :)
09:36:24 <gsagie> ok, anything else from anyone?
09:36:52 <milo_raofei_> thank you. I will join
09:37:36 <milo_raofei_> yes. we are interested in security group and NAT based on latest ovs.
09:37:57 <gampel> I think that NAT support is not there yet
09:38:00 <gsagie> okie, i think there is another person that also want to work on Kuryr?
09:38:45 <gampel> I think he did not join i will talk with him to join next week
09:38:58 <gsagie> okie
09:39:31 <gampel> maybe he is here kexiaodong
09:39:38 <kexiaodong> I want to join kuryr.
09:39:54 <gampel> kexiaodong: hi
09:40:12 <kexiaodong> hi gampel
09:40:39 <gampel> kexiaodong: a very good first task will be to integrate dragonflow with kuryr
09:41:14 <gsagie> kexiaodong: we can talk about Kuryr more offline, are you available to start working on it?
09:41:20 <BillyXu> kexiaodong will working on kuryr.
09:41:20 <BillyXu> he will consider dragonflow intergated with kuryr
09:41:35 <gsagie> okie
09:41:49 <gsagie> #action kexiaodong to look at integrating Dragonflow with Kuryr
09:42:07 <BillyXu> kexiaodong also work together with me.
09:43:07 <gsagie> ok, welcome BillyXu, Raofei and Kexiaodong
09:43:18 <gsagie> to the Dragonflow/Kuryr team :)
09:43:25 <BillyXu> thanks.
09:43:37 <gsagie> gampel: anything else?
09:43:47 <gampel> nop thank you very much
09:43:55 <BillyXu> no, thanks.
09:44:04 <gsagie> ok thanks everyone for joining!
09:44:08 <gsagie> #endmeeting