09:00:14 <gsagie> #startmeeting dragonflow
09:00:14 <openstack> Meeting started Mon Dec 14 09:00:14 2015 UTC and is due to finish in 60 minutes.  The chair is gsagie. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:17 <openstack> The meeting name has been set to 'dragonflow'
09:00:33 <gsagie> ok i have a feeling this is going to be a short meeting
09:00:40 <Shlomo_N> :)
09:00:58 <gsagie> #info gsagie Yuli_s , Shlomo_N in the meeting
09:01:06 <gsagie> #topic security groups
09:01:13 <yuli_s> 大家好
09:01:33 <gsagie> any chance rafoei, BillyXu are here?
09:01:46 <gsagie> raofei
09:02:13 <gsagie> kexiaodong?
09:02:24 <gsagie> ok
09:02:37 <gsagie> #action BillyXu, raofei to update on security groups design
09:02:47 <gsagie> i havent seen any progress in the repository yet
09:03:19 <gsagie> #action BillyXu, raofei upload any progress for review, and please review other patches in repository
09:03:44 <gsagie> #topic testing
09:04:26 <gsagie> ok, i have started adding rally and tempest infrastructure to Dragonflow
09:04:41 <gsagie> Yuli any update on the fullstack tests?
09:04:47 <gsagie> yuli_s
09:05:10 <gsagie> #link https://review.openstack.org/#/c/255279/
09:05:17 <yuli_s> Yes, I have fixed all open issues
09:05:40 <gsagie> okie good, we need to start creating similar tests to other areas in the plugin
09:06:10 <yuli_s> Yes
09:06:11 <gsagie> Shlomo_N: is working on rethinkDB didnt get to unit tests yet
09:06:28 <Shlomo_N> u r r8
09:06:43 <gsagie> #action yuli_s create more fullstack tests to other elements in the DB
09:06:59 <gsagie> #action gsagie add fullstack tempest job to openstack infra
09:07:24 <gsagie> we might also want to start adding test code for rally to benchmark DB operations
09:07:33 <gsagie> Aharon, dima you here by any chance?
09:08:04 <gsagie> #action gsagie design scale testing infrastructure to the DB
09:08:40 <gsagie> We are going to create a test suit for testing the various DB options, basically introduce many writing/reading controllers and be able to benchmark the backend DB for Dragonflow
09:09:04 <gsagie> i guess after we have something initial that works , we can use Rally for it but not sure resource wise how applicable it will be
09:09:30 <gsagie> #topic DB
09:09:43 <gsagie> #info RAMCloud is merged
09:09:52 <Shlomo_N> I have finished with the RAMCloud patch. Also done few functional tests on multinode env.
09:10:12 <gsagie> #info RAMcloud verified by Shlomo_N to work, including on multinode env
09:10:18 <gsagie> ok, good job Shlomo
09:10:42 <gsagie> still need to finish rethink db integration
09:10:55 <Shlomo_N> it was minimal tests, it must be deeply tested
09:10:59 <gsagie> #action dima, Shlomo_N finish RethinkDB integration https://review.openstack.org/#/c/225642/
09:11:28 <gsagie> Shlomo_N: yes, thats why i think its better we concentrate on writing unit/functional tests and then we can automatically run it for all DB backends faster
09:11:36 <gsagie> rather then re-test it for every change
09:11:53 <gsagie> and fullstack tests of course
09:12:24 <gsagie> we do want Aharon and Dima here in the meeting, gampel is not here but will forward action for him
09:12:38 <gsagie> #action gampel talk with Aharon and Dima to join the IRC Meeting
09:13:02 <gsagie> anything else on the DB Yuli/Shlomo?
09:13:15 <Shlomo_N> nop
09:13:35 <yuli_s> Nop
09:13:38 <gsagie> #topic DHCP
09:13:53 <gsagie> noticed Rafoei added bug for missing DHCP messages
09:15:04 <gsagie> #link raofei  add eda bug about missing functionality and suggestions for current DHCP -  https://bugs.launchpad.net/dragonflow/+bug/1524348
09:15:04 <openstack> Launchpad bug 1524348 in DragonFlow "dhcp app is missing some functionality which are defined by protocol" [Undecided,New]
09:15:29 <gsagie> some actions from last meeting still needs to be addressed:
09:15:32 <gsagie> #action gampel register a spec for dhcp ipv6 app
09:15:52 <gsagie> #action gampel register bp to support IPV6 DHCP (ipv6-sdn-dhcp-app
09:16:20 <gsagie> I have updated the rally job to work without q-dhcp, need to update tempest job to also work with out it
09:16:32 <gsagie> #action gsagie update tempest job to work without q-dhcp
09:17:08 <gsagie> Btw, we have tempest job now running without failures, we have masked some tests in order to make it work and its currently not voting so we will need to start fixing the tests
09:17:27 <gsagie> #info pay attention to the tempest job test failures when proposing patches
09:17:45 <gsagie> #topic Kuryr and Dragonflow
09:17:56 <gsagie> kexiaodong: ping
09:18:18 <gsagie> #action  kexiaodong to look at integrating Dragonflow with Kuryr
09:18:19 <kexiaodong> I see you comment, will review now
09:18:31 <gsagie> kexiaodong: which comment?
09:19:27 <gsagie> kexiaodong: would you please like to share any progress or what you are doing?
09:19:28 <kexiaodong> e, that was comment from vikas choudhary.
09:19:41 <gsagie> i saw you started doing some work on Kuryr
09:20:53 <gsagie> There is some work in Kuryr that we need for Dragonflow which is the OVS un-binding script
09:21:15 <gsagie> would you like to work on that for the first part? and then look at full integration of Kuryr and Dragonflow (shouldnt be hard)
09:21:46 <kexiaodong> Last week I got a environment with kuryr, and bind with ovs.
09:21:54 <gsagie> ok cool
09:22:08 <gsagie> if you noticed, the unbind part is currently not implemented yet
09:22:22 <gsagie> will be appreciated if you can work on that if you have time
09:23:04 <kexiaodong> Unbind has only comment,not code
09:23:30 <gsagie> yes, thats why i offer you to work on it
09:23:46 <kexiaodong> I will try to
09:23:48 <gsagie> will be good starting task
09:23:54 <gsagie> ok, let me know if you need any help
09:24:10 <gsagie> #action kexiaodong work on Kuryr OVS unbind script
09:24:15 <kexiaodong> I think it will be like ovs-docker?
09:24:18 <gsagie> we will need this part for Dragonflow as well
09:24:46 <gsagie> kexiaodong: i assume so, basically you will need to delete the port added by the script, shouldnt be a long patch
09:25:12 <gsagie> #link https://review.openstack.org/#/c/254417/
09:25:16 <gsagie> check this patch ^^
09:25:29 <gsagie> and talk with me if you need any help
09:25:38 <kexiaodong> ok, I will prepare to do it
09:26:03 <gsagie> thanks, sounds good
09:26:09 <gsagie> #topic bugs
09:26:33 <gsagie> ok, so we changed the devstack plugin a bit and i think re need to re-work on the rejoin_stack.sh
09:26:40 <gsagie> i will do it
09:26:57 <gsagie> #action gsagie re-work on rejoin stack for default devstack etcd
09:27:11 <gsagie> Li Ma is here by any chance? because i saw he added some bugs
09:27:32 <Shlomo_N> Maybe you can also fix the RAMcloud rejoin bug
09:27:59 <gsagie> Shlomo_N: i will assign this to you :) please talk with Li Ma and tell him he can join to this meeting and also our channel
09:29:09 <gsagie> and please try to understand from him the other bugs and problems, we need some clarifications on the bugs
09:29:14 <gsagie> so we can address them faster :)
09:29:26 <gsagie> #action Shlomo_N check RAMCloud rejoin_stack bug
09:29:51 <gsagie> i had an action to look at the traceroute bug, but didnt get to it, so moving to next meeting
09:29:56 <gsagie> #action  gsagie to look at https://bugs.launchpad.net/dragonflow/+bug/1521629 for next meeting
09:29:56 <openstack> Launchpad bug 1521629 in DragonFlow "traceroute packet delay" [Undecided,New]
09:30:42 <gsagie> Shlomo_N/yuli_s/kexiaodong: anything else on the bugs?
09:31:03 <Shlomo_N> I have open bug for RAMCloud missing packages
09:31:25 <gsagie> Shlomo_N: ok so you going to work on that after rethinkdb right?
09:31:37 <gsagie> #action Shlomo_N work on missing RAMCloud packages
09:32:30 <Shlomo_N> ok
09:32:47 <gsagie> Yuli anything for you?
09:33:13 <yuli_s> I will continue adding new tests
09:33:27 <gsagie> okie
09:33:56 <gsagie> #action gsagie convert Dragonflow trello to bugs and blueprints
09:34:14 <gsagie> #topic open discussion
09:34:42 <gsagie> Just as a note, i have added a wiki page for Dragonflow, if anyone wants to add/edit something feel free to do so
09:37:59 <gsagie> ok, thanks everyone that attend
09:38:04 <gsagie> and see you next week :)
09:38:07 <gsagie> #endmeeting