#openstack-meeting-4: dragonflow

Meeting started by gsagie at 08:58:08 UTC (full logs).

Meeting summary

    1. gampel, kun_huang, diga, yuli_s, gsagie in meeting (gsagie, 08:58:28)
    2. Shlomo will not attend this meeting (gsagie, 08:58:41)

  1. security groups (gsagie, 08:59:20)
    1. abaron and yuli_s in meeting :) (gsagie, 08:59:44)
    2. security groups design https://review.openstack.org/#/c/261903/ (gsagie, 09:00:03)
    3. https://review.openstack.org/#/c/262634/ (gsagie, 09:01:32)
    4. ACTION: dingboopt finish and merge security groups configuration from plugin (gsagie, 09:04:24)
    5. ACTION: dingboopt start reading sg configuration from the controller and sending to sg application (gsagie, 09:04:50)

  2. blueprints (gsagie, 09:07:48)
    1. http://docs.openstack.org/developer/dragonflow/specs/distributed_dnat.html (gsagie, 09:08:32)
    2. ACTION: raofei optionally start looking at distributed dnat task (gsagie, 09:10:49)
    3. https://review.openstack.org/#/c/263019/ (gsagie, 09:11:43)
    4. ACTION: gsagie write publish-subscriber abstraction spec (gsagie, 09:14:18)
    5. https://review.openstack.org/#/c/263035/ (gsagie, 09:21:17)
    6. https://review.openstack.org/#/c/262423/ (gsagie, 09:23:49)
    7. ACTION: gsagie start writing a plan for selective proactive integration (gsagie, 09:25:39)
    8. ACTION: gampel have a plan for DB inconsistent problems between DF and Neutron (gsagie, 09:26:28)

  3. testing (gsagie, 09:27:25)
    1. https://review.openstack.org/#/c/263042/ yuli_s fullstack patch (gsagie, 09:30:54)
    2. ACTION: yuli_s work on update fullstack tests (gsagie, 09:31:27)
    3. ACTION: yuli_s work on OVS flows related tests (gsagie, 09:31:40)
    4. ACTION: gsagie refactor fullstack test class (gsagie, 09:33:21)
    5. https://review.openstack.org/#/c/262981/ remove python3 gate tests (gsagie, 09:34:13)
    6. ACTION: gsagie add unit tests examples once python3 job is fixed (gsagie, 09:36:15)
    7. warm regards to nick-ma and hope he feels better soon :) (gsagie, 09:37:55)
    8. https://review.openstack.org/#/q/status:open+project:openstack/rally+branch:master+topic:bp/vm-workloads-framework (gsagie, 09:39:03)
    9. https://review.openstack.org/#/c/254851/6 (gsagie, 09:39:13)
    10. kun_huang waiting for HW for scale testing (gsagie, 09:40:05)
    11. ACTION: gsagie, Shlomo sync with kun_huang regarding daily VMTP CI tests for Dragonflow (gsagie, 09:42:40)

  4. DB (gsagie, 09:43:47)
    1. ACTION: move all DBs installtions into services similar to what we did with etcd (gsagie, 09:45:42)
    2. ACTION: gampel merge and fix final things with RethinkDB (gsagie, 09:45:56)
    3. nick-ma update next meeting regarding zookeeper integration (gsagie, 09:46:24)
    4. https://review.openstack.org/#/c/261731/ (gsagie, 09:46:52)
    5. ACTION: diga start working on unit tests for the controller (gsagie, 09:47:49)
    6. https://review.openstack.org/#/c/262796/ (gsagie, 09:48:24)

  5. bugs (gsagie, 09:48:48)
    1. ACTION: gsagie look at failing tempest tests and convert them to bugs (gsagie, 09:49:21)

  6. open discussion (gsagie, 09:51:16)
    1. next week meeting is canceled, we will continue week after (gsagie, 09:53:39)


Meeting ended at 09:54:43 UTC (full logs).

Action items

  1. dingboopt finish and merge security groups configuration from plugin
  2. dingboopt start reading sg configuration from the controller and sending to sg application
  3. raofei optionally start looking at distributed dnat task
  4. gsagie write publish-subscriber abstraction spec
  5. gsagie start writing a plan for selective proactive integration
  6. gampel have a plan for DB inconsistent problems between DF and Neutron
  7. yuli_s work on update fullstack tests
  8. yuli_s work on OVS flows related tests
  9. gsagie refactor fullstack test class
  10. gsagie add unit tests examples once python3 job is fixed
  11. gsagie, Shlomo sync with kun_huang regarding daily VMTP CI tests for Dragonflow
  12. move all DBs installtions into services similar to what we did with etcd
  13. gampel merge and fix final things with RethinkDB
  14. diga start working on unit tests for the controller
  15. gsagie look at failing tempest tests and convert them to bugs


Action items, by person

  1. diga
    1. diga start working on unit tests for the controller
  2. dingboopt
    1. dingboopt finish and merge security groups configuration from plugin
    2. dingboopt start reading sg configuration from the controller and sending to sg application
  3. gampel
    1. gampel have a plan for DB inconsistent problems between DF and Neutron
    2. gampel merge and fix final things with RethinkDB
  4. gsagie
    1. gsagie write publish-subscriber abstraction spec
    2. gsagie start writing a plan for selective proactive integration
    3. gsagie refactor fullstack test class
    4. gsagie add unit tests examples once python3 job is fixed
    5. gsagie, Shlomo sync with kun_huang regarding daily VMTP CI tests for Dragonflow
    6. gsagie look at failing tempest tests and convert them to bugs
  5. kun_huang
    1. gsagie, Shlomo sync with kun_huang regarding daily VMTP CI tests for Dragonflow
  6. raofei
    1. raofei optionally start looking at distributed dnat task
  7. yuli_s
    1. yuli_s work on update fullstack tests
    2. yuli_s work on OVS flows related tests


People present (lines said)

  1. gsagie (144)
  2. gampel (29)
  3. kun_huang (13)
  4. yuli_s (12)
  5. raofei (10)
  6. dingboopt (6)
  7. diga_ (3)
  8. openstack (3)
  9. diga (2)


Generated by MeetBot 0.1.4.