09:00:19 <gsagie> #startmeeting dragonflow
09:00:20 <openstack> Meeting started Mon Feb 15 09:00:19 2016 UTC and is due to finish in 60 minutes. The chair is gsagie. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:23 <openstack> The meeting name has been set to 'dragonflow'
09:00:29 <gsagie> Hello everyone, who is here for the meeting?
09:00:55 <dingboopt> o/
09:00:55 <gampel> Hi gsagie
09:01:13 <Shlomo_N> hi, I am here
09:01:31 <oanson> Hi
09:01:43 <gsagie> #info gampel, dingboopt, Shlomo_n, raofei, oanson, gsagie in meeting
09:01:52 <Shlomo_N> Yuli will absent 2day
09:02:05 <gsagie> okie
09:02:16 <gsagie> gampel: Any chance to remind to DuanKebo? ;)
09:02:21 <gampel> OK
09:02:49 <raofei> Duankebo is offline
09:02:56 <gsagie> #topic big-tent
09:03:19 <gsagie> Just to update everyone, we have applied to become a formal project
09:03:43 <Shlomo_N> congrats
09:03:43 <gsagie> as part of the big-tent and not as part of the Neutron stadium, the patch can be reviewed here: https://review.openstack.org/#/c/277153/
09:03:55 <gsagie> Shlomo_N: its just a request, not an approval yet
09:03:57 <raofei> good!
09:04:23 <gsagie> #topic security groups and port security
09:04:29 <DuanKebo> Congradulations!
09:04:48 <gsagie> dingboopt: you have been working on that up until the security groups application, would you mind to update?
09:04:54 <dingboopt> I have install flow related to sg using ryu lib
09:05:03 <dingboopt> and everythin is ok
09:05:08 <dingboopt> util now
09:05:22 <gsagie> ok good, so we are missing only the application right now, right?
09:05:23 <dingboopt> and I have already write some code
09:05:28 <dingboopt> yes
09:05:44 <dingboopt> I have already write some app code
09:05:46 <gsagie> ok good, when you can please upload it to the repository, its important we do all testing with it
09:05:48 <dingboopt> and some test
09:05:55 <gsagie> good job!
09:05:57 <dingboopt> this week
09:06:10 <dingboopt> I will upload some code
09:06:12 <gsagie> regarding port security, we need allowed address pairs right?
09:06:19 <dingboopt> yes
09:06:30 <gsagie> ok, and you also working on that application right?
09:06:36 <gsagie> we have anything open there?
09:06:54 <dingboopt> currently I focus on security group
09:06:57 <gsagie> gampel: we need to merge this spec : https://review.openstack.org/#/c/263019/
09:06:57 <dingboopt> app
09:07:14 <gsagie> for port security , i think we have an agreement there, but please review
09:07:18 <gampel> Ok i will review it
09:07:18 <gsagie> dingboopt: ok cool
09:07:30 <gsagie> #action dingboopt upload security groups patch for review
09:07:30 <dingboopt> ok, I will review this bp
09:07:36 <dingboopt> ok
09:07:41 <gsagie> #action gampel, dingboopt review port security patch
09:08:01 <gsagie> anything else on this subject?
09:08:10 <dingboopt> no
09:08:18 <gsagie> Shlomo_N will need to start adding some specific scenarios to the scale testing
09:08:25 <gsagie> so we can test security groups performance
09:08:47 <gsagie> talked with him about some scenarios, we should add them to the specs as well and also add to openstack-performance
09:09:02 <gsagie> #topic DB consistency
09:09:13 <gsagie> nick-ma is not here, he is back tommorow
09:09:36 <gampel> I suggest we talk about this in our channel with him
09:09:42 <gsagie> we have some solution based on nick-ma ideas that we would like to go with
09:09:56 <gsagie> and we will talk with him after the meeting and update the spec accordingly so everyone can review
09:09:58 <gsagie> and comment
09:10:12 <gsagie> #action gampel,gsagie,nick-ma update DB consistency spec
09:10:53 <gsagie> DuanKebo: we want you to also be part of this conversation obviously
09:11:03 <gsagie> DuanKebo: tommorow will be ok with you?
09:11:04 <DuanKebo> OK no
09:11:08 <DuanKebo> no problem
09:11:21 <gampel> the idea is to have two phase commit and relay on df db swap and replace atomic operation
09:11:56 <gsagie> ok great, we also need you guys feedback of course as some ideas/comments are also based on hujie spec as well
09:12:07 <gsagie> #topic publish-subscribe
09:12:08 <dingboopt> all key-value db support swap and replace atomic operation?
09:12:24 <gsagie> dingboopt: we are going to have this as a requierment, but yes
09:12:34 <dingboopt> got it
09:12:46 <gsagie> gampel: would like to update regarding the publish subscribe?
09:13:01 <gampel> yes the first patch should merge today please review
09:13:21 <gampel> link: https://review.openstack.org/#/c/263322/
09:13:47 <gampel> this will take care the neutron server api publishers
09:13:52 <gsagie> #link https://review.openstack.org/#/c/263322/ publish subscribe spec
09:14:22 <gampel> the chassis's will be in this phase sent via the same publishers in the flowing patch
09:14:37 <gampel> #link: https://review.openstack.org/#/c/280079/
09:14:49 <gsagie> ok, thanks for taking care of that long patch gampel, certainly a hard part of our solution
09:15:00 <gampel> we will add this week a patch for the publisher discovery
09:15:26 <gampel> currently it is configuration on the DF controller side (list of publishers)
09:16:10 <gsagie> DuanKebo: important you guys review and understand it, because i think you will need to do something very similar in Redis
09:16:12 <gampel> reliability will come next , and it will relay on the DB consistency adding version per object
09:16:53 <gampel> Please all try to reveiw today so we could move it into control scale testing
09:17:00 <gsagie> okie, anyone has any questions or issues to raise regarding this?
09:17:40 <gsagie> #topic ovsdb monitor
09:17:52 <gsagie> #link https://review.openstack.org/#/c/274332/
09:17:52 <raofei> ok, we ill review them.
09:18:03 <gsagie> wb DuanKebo
09:18:19 <gsagie> regarding ovsdb monitor, i reviewed it, https://review.openstack.org/#/c/274332/
09:18:25 <DuanKebo_> Yes, just offlined.
09:18:30 <gsagie> has few comments, but i think after the fix we can merge it
09:18:37 <gsagie> and start sending code
09:18:45 <gsagie> hujie here?
09:18:51 <gsagie> #link ovsdb monitor https://review.openstack.org/#/c/274332/
09:19:46 <gsagie> DuanKebo: just needs to make sure hujie fix the small comments on the patch and start sending code for this, i think we all agree what needs to be done there
09:20:00 <DuanKebo_> Yes
09:20:07 <DuanKebo_> He is coding now
09:20:18 <gsagie> okie, thanks
09:20:29 <DuanKebo_> he also will update the spec
09:20:44 <gsagie> #action hujie fix ovsdb monitor spec and upload code to repository
09:20:50 <gsagie> #topic controller reliability
09:21:09 <gsagie> #link https://review.openstack.org/#/c/274334/ controller reliability
09:21:14 <gsagie> heshan : would like to update?
09:21:22 <gsagie> hshan
09:21:42 <DuanKebo_> one second
09:21:57 <gsagie> hi hshan :)
09:22:04 <gsagie> we are talking about your controller reliability spec
09:22:13 <hshan> hi gsagie:)
09:22:22 <hshan> okay
09:22:27 <gsagie> i like your idea to change the cookie field and use this, added some comments on the review for you to consider
09:22:54 <gsagie> but i think that everything is solved right? as you will have a "sync finish" notification sent
09:22:57 <gsagie> on all cases
09:23:12 <gsagie> is there anything open you would like to discuss about?
09:24:17 <DuanKebo_> he is typing
09:24:26 <hshan> sync process should delete flows, so the sync process need to be a dragonflow app
09:25:33 <gsagie> hshan: okie, so we need to define an "API" for this application that recieve a sync finished call
09:25:43 <gsagie> and also adds to all applications something that tells them the cookie ide
09:25:46 <gsagie> right?
09:25:46 <hshan> yes
09:26:12 <gsagie> okie, you will also need to change some code for existing applications that use the cookie id already
09:26:17 <gsagie> do you need any help ?
09:26:36 <gampel> we can add it to the DF Ryu base class
09:26:58 <hshan> agree with you
09:27:10 <gsagie> gampel: good idea, but he will still need to change some applications that already use the cookie id for something else
09:27:16 <hshan> I've make some modification locally
09:27:17 <gsagie> (i think DHCP uses it as well)
09:27:25 <gampel> no it does not
09:27:42 <gsagie> gampel: you dont use it for packet ins to controller?
09:28:04 <gampel> I use the metadata but i will look into it and and comment in the spec
09:28:14 <gsagie> okie
09:28:35 <gsagie> hshan: please let us know if you need any help as your patch might get complicated, maybe not
09:28:47 <gsagie> but please update us if you see any problem as we need to fix it fast :)
09:28:52 <gsagie> #topic selective proactive
09:28:58 <hshan> okay
09:29:01 <gampel> hshan: try to spit it into smaller patches
09:29:08 <gsagie> #link selective proactive https://review.openstack.org/#/c/275199/
09:29:22 <hshan> okay, i will
09:29:26 <gsagie> DuanKebo: welcome back :) how is selective proactive going on?
09:29:45 <DuanKebo> I start writing code now.
09:30:14 <DuanKebo> I need to add a topology module.
09:30:18 <gsagie> ok great, please fix few small comments on spec so we can merge it, but i think its in good shape
09:30:34 <gsagie> DuanKebo: maybe we should talk about this, why do you need another module?
09:30:44 <DuanKebo> Yes, I have saught your comments
09:30:50 <DuanKebo> fix them today.
09:30:55 <gsagie> ok, thanks
09:31:24 <gsagie> i think we need to see if we really need another module or we can manage it simpler in the controller (with the ovsdb monitor part)
09:32:04 <DuanKebo> If we put this function in controller
09:32:25 <DuanKebo> I worry about that the controller become too big
09:32:30 <DuanKebo> and complex.
09:33:04 <gsagie> DuanKebo: ok agree, when you have just the structure maybe it will be good to upload patch for review
09:33:09 <gsagie> so we can understand your plans
09:33:28 <DuanKebo> OK
09:33:36 <DuanKebo> another problem
09:33:53 <gsagie> ?
09:33:56 <DuanKebo> I need to receive sorthbound message
09:34:04 <DuanKebo> such as port online event.
09:34:22 <DuanKebo> Currently, controller can't receive them.
09:34:34 <gsagie> yes, we need to add this
09:34:36 <DuanKebo> Only app can
09:34:54 <gsagie> so the controller can recieve port notifications from the ovsdb monitor
09:34:57 <gampel> this again can be added to the base df Ryu class
09:35:02 <gsagie> i can add this connection
09:35:11 <gsagie> gampel: its not something we want in the application
09:35:17 <gsagie> i think
09:35:43 <DuanKebo> Yes, another way is we register the module to dispacher
09:35:47 <gsagie> DuanKebo: i think this should be send to the same queue the controller is listening for DB updates and sent to your module
09:36:17 <gsagie> since this is a DB update from the switch..
09:36:26 <gsagie> DuanKebo: yeah, good idea we can use the dispatcher
09:36:27 <gsagie> for this
09:36:59 <gampel> I am not sure, you do not think the application should be notified ?
09:37:26 <DuanKebo> Your idea also can achieve the target.
09:37:50 <gsagie> gampel: we are talking about the part that recognize a port, fetch all tenant information (register notification) and then call the apps
09:37:50 <DuanKebo> Hi gampel, could you give more details?
09:38:07 <gsagie> in the end, the apps will be notified
09:38:26 <gsagie> and of course they will still need to get the port up/ down, which we now bring from OpenFlow
09:38:48 <gsagie> what i talked with DuanKebo and the team is that we dont really need the openflow part when we have OVSDB monitor
09:38:51 <gampel> I see so i agree that the best way will be via the queue and add a action
09:38:53 <gsagie> its little more efficient
09:39:35 <gsagie> DuanKebo: once you upload the code and the OVSDB monitor we can see whats the best way to connect them, i will work on this with you
09:39:45 <gsagie> its a problem i am sure we can solve :)
09:40:02 <DuanKebo> Yes.
09:40:29 <gsagie> #action DuanKebo,gsagie work on how the ovsdb monitor communicate with topology module and send events
09:40:35 <gsagie> #topic distributed DNAT
09:40:43 <gsagie> raofei: saw your patch good work!
09:40:56 <gsagie> #link distributed dnat https://review.openstack.org/#/c/279434/
09:41:15 <gsagie> gampel left some comments, please see if you can address them and we can merge this
09:41:17 <gsagie> anything open?
09:41:18 <gampel> raofei: you have to merge your testing with the new destructor patch
09:41:19 <raofei> due to the merge conflict, it will be done today
09:41:39 <raofei> yes, I have merge the latest code from master
09:42:03 <gsagie> #action raofei address comments on patch and continue for dnat application
09:42:10 <gsagie> ok thanks raofei, good work
09:42:12 <raofei> the changed code will be committed today.
09:42:30 <gsagie> #topic redis db
09:42:39 <gsagie> DuanKebo: anything needed on this topic?
09:43:09 <DuanKebo> It is ok
09:43:20 <DuanKebo> or sorry
09:43:23 <DuanKebo> one second
09:43:39 <gampel> DuanKebo: are you planning to add a new redis pubsub driver or just use the internal redis DB notification
09:43:46 <DuanKebo> on open issues to discuss.
09:44:10 <DuanKebo> We will use the sub/pub arch
09:44:29 <DuanKebo> and add a redis sub/pub driver for it
09:44:36 <gampel> DuanKebo: let me know if you need my help
09:44:41 <gsagie> okie great
09:44:57 <gsagie> #topic testing
09:45:32 <gsagie> Shlomo_N is working on scale testing here, we will publish results as soon as we have something for current code, but of course we want all the features in before we do the serious testing
09:45:48 <gsagie> Yuli is working on the API/DB control plane performance part
09:45:54 <gsagie> Shlomo_N: anything to add?
09:46:03 <Shlomo_N> I have done the performance testing for L3-centralized agent.
09:46:14 <Shlomo_N> Now I am working on data plane performance testing of DVR.
09:46:30 <Shlomo_N> I am doing these tests for reference to DragonFlow performance
09:46:45 <gsagie> oanson has added an infrastructure so we can simulate and perform pipeline testing using tap devices that simulate neutron ports and define policies on the expected behaivour
09:47:00 <gsagie> #link https://review.openstack.org/#/c/275714/ testing infrastructure
09:47:13 <gsagie> oanson is here if you have any question how to use it, he is adding documentation
09:47:19 <gsagie> oanson: right?
09:47:28 <oanson> Documentation has already been added
09:47:37 <oanson> Now waiting for additional comments and review
09:47:55 <gampel> is there any one else working on scale testing control/data ?
09:47:58 <gsagie> ok cool, so please everyone working on new patches/features, see how you can build tests with this
09:48:52 <gsagie> DuanKebo: also wanted to mention thank you for the good work you guys are doing, i think we have agreement on most specs and we can continue with uploading code to all the features
09:48:58 <gsagie> so thanks!
09:49:24 <gsagie> DuanKebo, dingboopt, raofei: anyone doing scale testing?
09:49:29 <DuanKebo> Thank you for your help!
09:49:49 <gsagie> I think Kun mentioned we suppose to get the hardware in hangzhou after the holiday
09:50:24 <gsagie> #topic open discussion
09:50:32 <gsagie> Anything else by anyone?
09:50:42 <gsagie> :(
09:51:02 <gampel> omer: do you want to present your mcast spec
09:51:26 <gsagie> dingboopt, raofei: good work you two :) i think we have good progress on your work
09:51:34 <oanson> ok
09:51:47 <oanson> I have uploaded a spec to add and IGMP and multicast application.
09:52:03 <oanson> The spec is available for review here: https://review.openstack.org/#/c/278400/
09:52:14 <gsagie> #link IGMP support in Dragonflow spec https://review.openstack.org/#/c/278400/
09:52:30 <oanson> It is planned to make the virtual routers multicast-enabled routers, and support *smart* multicast routing
09:52:42 <dingboopt> the servers have not arrived
09:52:51 <oanson> This means that multicast packets will be sent only to group members, and only to compute nodes containing group members.
09:53:14 <oanson> I am adding now a few finishing touches gsagie asked, hopefully to be finished today.
09:53:26 <gsagie> ok, good work oanson
09:53:36 <gsagie> certainly an interesting feature for Dragonflow
09:53:48 <gsagie> more interesting if we can combine it with the physical infrastructure
09:54:02 <gampel> dingboopt: :'( we relay need to start scale testing on large infrastructure as soon as possible
09:54:04 <gsagie> okie thanks everyone
09:54:33 <gsagie> and please stop by in #openstack-dragonflow if anything is needed
09:54:42 <gsagie> anything else gampel?
09:55:46 <gampel> nop thank you every one
09:55:56 <gsagie> thanks and see you all next week!
09:55:58 <gsagie> #endmeeting