09:00:31 <gsagie> #startmeeting dragonflow
09:00:32 <openstack> Meeting started Mon Mar  7 09:00:31 2016 UTC and is due to finish in 60 minutes.  The chair is gsagie. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:36 <openstack> The meeting name has been set to 'dragonflow'
09:00:42 <gsagie> Hello everyone, who is here for dragonflow meeting
09:00:52 <dingboopt> o/
09:00:52 <oanson> Hi
09:01:11 <gsagie> o/
09:01:22 <gampel> hi
09:01:26 <gsagie> okie intimate meeting today..
09:01:47 <gsagie> #info gampel, dingboopt, oanson, gsagie in meeting
09:02:13 <gsagie> #info DuanKebo is in meeting soon (hopefully)
09:02:45 <gsagie> yuli_s ?
09:03:40 <gampel> DuanKebo will join in one min
09:03:47 <gsagie> okie lets wait few seconds then
09:04:02 <gsagie> yuli_s !!!:)
09:04:09 <yuli_s> Hello !
09:04:17 <gsagie> Duankebo, welcome and thanks for joining
09:04:21 <DuanKebo> Hello!
09:04:33 <gsagie> #info yuli_s and DuanKebo the two last dragons have arrived in the meeting!
09:04:36 <gsagie> #topic bugs
09:04:52 <gsagie> ok, i want to start with bugs, anyone has any idea of any notable bug?
09:05:15 <gampel> we need to deal with the MTU bug  i can take it
09:05:23 <gsagie> gampel: link?
09:05:27 <gampel> one sec
09:05:32 <gsagie> Hello feipeng
09:05:35 <gsagie> welcome
09:05:38 <feipeng> hi
09:05:50 <feipeng> gsagie
09:05:57 <gampel> link: https://bugs.launchpad.net/dragonflow/+bug/1549170
09:05:57 <openstack> Launchpad bug 1549170 in DragonFlow "mtu 1460 works bad with VxLan" [Medium,New]
09:06:02 <gsagie> we really need to start testing things because the code changes frequently and we havent tracked bugs
09:06:04 <gsagie> too much
09:06:20 <gampel> link: https://bugs.launchpad.net/dragonflow/+bug/1496699
09:06:20 <openstack> Launchpad bug 1496699 in DragonFlow "MTU configuration in dragonflow" [Medium,New] - Assigned to Gal Sagie (gal-sagie)
09:06:21 <gsagie> anyone would like to be in charge of bugs and let us know at every meeting the notable bugs? and also help triage them
09:06:45 <oanson> I can take it.
09:06:47 <gampel> yuli_s: will you take this ?
09:06:59 <yuli_s> sure
09:07:06 <gsagie> okie great, lets switch every week
09:07:10 <oanson> Does this include setting up a testing site? Or just watching launchpad?
09:07:27 <gsagie> oanson: just launchpad and triaging bugs
09:07:33 <gsagie> and setting priorities
09:07:37 <gsagie> you can of course consult with us all
09:07:48 <gsagie> #action oanson to be in charge of bugs this week
09:07:56 <gsagie> #action yuli_s in charge of bugs next week
09:08:01 <gsagie> okie
09:08:06 <gsagie> #topic DB consistency
09:08:25 <gsagie> gampel: for the MTU its assigned to me, would you like me to do it?
09:08:44 <gampel> i can do it assign it to me
09:08:47 <gsagie> okie
09:09:09 <gsagie> #action gampel to take over bugs 1496699 and 1549170
09:09:09 <openstack> bug 1549170 in DragonFlow "mtu 1460 works bad with VxLan" [Medium,New] https://launchpad.net/bugs/1549170
09:09:09 <gsagie> thanks
09:09:10 <openstack> bug 1496699 in DragonFlow "MTU configuration in dragonflow" [Medium,New] https://launchpad.net/bugs/1496699 - Assigned to Gal Sagie (gal-sagie)
09:09:20 <gampel> i just need testing input about what is the MTU for VxLan ... GRE
09:09:25 <gsagie> ok for DB consistency, nick-ma is not here but anyone has any comment on code?
09:09:40 <gsagie> gampel: np, you can take from the VXLAN/GRE mech drivers in Neutron
09:09:47 <gsagie> they have constants for the overhead
09:09:50 <gampel> I will
09:10:31 <gsagie> okie, so lets skip DB consistency, i think the code is pretty much done but still need to
09:10:34 <gsagie> create a full sync process
09:11:01 <gampel> whats the status of the full sync patch
09:11:05 <gsagie> #action nick-ma identify all the missing parts for DB consistency (full sync, sync from controllers and so on..)
09:11:30 <gsagie> gampel: its transfered to oanson, however its on hold until the DB consistency is merged and then we can do this by versions
09:11:41 <gampel> got it
09:12:08 <gsagie> #topic pub-sub
09:12:14 <gsagie> gampel / oanson: care to update?
09:12:44 <gampel> omer: can you share the status
09:12:57 <oanson> The new pub sub API was merged
09:13:09 <DuanKebo> we have verified the foundamental founction of sub/pub based on redis
09:13:15 <oanson> We're adding a few finishing touches, but the ZMQ passes the tests
09:13:33 <DuanKebo> it works fine currently.
09:13:41 <gsagie> DuanKebo: last meeting we talked about doing some benchmarking compared to ZeroMQ , any results?
09:13:45 <yuli_s> the zmq tests work in my dev box
09:14:20 <gampel> Not yet we will ad it to the control path testing yuli is doing
09:14:25 <DuanKebo> Gal, this can be done after the basic function test of it1
09:14:43 <DuanKebo> we are not working on it yet.
09:15:04 <gsagie> DuanKebo: okie, that sounds reasonable to me, i prefer we test after we verify functionality
09:15:07 <gsagie> or basic functionality
09:15:09 <gampel> I think that we need to make sure first we integrate and test every thing together and then benchmark
09:15:24 <gsagie> okie good
09:15:26 <gampel> gsagie:  i saw you question about the compute node config
09:15:26 <DuanKebo> We are building the perf test enviroment.
09:15:41 <gsagie> yes gampel, i talked with oanson about that and we spotted the error
09:15:47 <gampel> DuanKebo:  you should work with shlomo
09:15:47 <gsagie> the problem, he is going to fix it
09:15:48 <nick-ma> sorry, I am in the Intel site joining bug smash activity and promoting dragonfIow projects. I didn't notice the meeting time.
09:16:04 <gsagie> Hi nick-ma! no problem :)
09:16:07 <DuanKebo> Yes Eran.
09:16:09 <gampel> hi nick-ma
09:16:33 <gsagie> oanson: right? we have this covered?
09:16:43 <oanson> I uploaded one fix about it. It's still not trivial to select a subscriber in a compute node.
09:16:54 <gampel> we should all review this week redis path and try to merge it
09:16:56 <oanson> I'll update the example .conf files.
09:17:12 <gsagie> nick-ma: we talked about DB-consistency, i assigned a task to you to list all the missing parts (like the full sync and so on..) anything you would like to add?
09:17:45 <gsagie> i think the first part is completed
09:17:47 <nick-ma> Got it.
09:18:00 <gsagie> and just waiting for more review power
09:18:17 <nick-ma> I will fix all the reviews in that patch. Last week it has passed ci already.
09:18:27 <gsagie> #action oanson clarify configuration of subscriber vs publisher in dragonflow and update documentation
09:18:42 <nick-ma> And I will update the spec and provide the missing part.
09:18:48 <gsagie> nick-ma: okie great, thanks!
09:19:20 <gsagie> #action all review redis patch
09:19:22 <gampel> please review pub sub spec so we could merge
09:19:29 <gampel> link: https://review.openstack.org/#/c/263733/
09:19:32 <nick-ma> Okie.
09:19:37 <gsagie> #action all review pub-sub spec https://review.openstack.org/#/c/263733/
09:19:43 <gsagie> #topic redis driver
09:19:59 <gsagie> DuanKebo: anything to update/open on this? or from your side everything is implemented and working
09:20:21 <DuanKebo> basic function of redis for db and pub/sub works fine
09:20:38 <DuanKebo> we need more review for the code
09:20:50 <DuanKebo> and merge it asap
09:21:06 <gsagie> okie great, good job
09:21:22 <gsagie> #topic security group and port security
09:21:32 <gsagie> dingboopt: please update :)
09:21:40 <dingboopt> I fix some bugs and test it mannually, it works fine
09:21:42 <DuanKebo> we have tested sg also
09:22:01 <gsagie> dingboopt: everything is uploaded for review ?
09:22:04 <DuanKebo> basic use cases all passed
09:22:04 <gsagie> in gerrit
09:22:24 <gsagie> cool, we will conduct L3 performance test on it once merged
09:22:35 <dingboopt> I should write test code and then it will be ready for review
09:22:49 <gsagie> dingboopt: okie great, so we should expect it this week right?
09:22:55 <dingboopt> ok
09:23:04 <gsagie> #action dingboopt write test code for sg and send for review
09:23:10 <gsagie> ok good job dingboopt !
09:23:17 <DuanKebo> dingboopt, you have done a great job!
09:23:24 <dingboopt> thanks
09:23:43 <gsagie> yep indeed! very good job and we would like your feedback and reviews on other patches as you raise good points
09:24:08 <gsagie> #topic distributed dnat
09:24:12 <gsagie> Raofei is here?
09:24:15 <dingboopt> ok,
09:24:41 <gampel> dingboopt: you could use omer framework for app testing for the SG
09:24:54 <dingboopt> ok
09:25:08 <gsagie> i have seen he posted the DNAT app code, but he is going to have some comments on the review
09:25:09 <DuanKebo> We wil test dnat this week
09:25:21 <gsagie> so lets see if we can answer the review comments fast
09:25:32 <gsagie> because i want us to merge everything together as soon as possible
09:25:36 <gampel> ok
09:25:49 <gsagie> we are in a kind of senestive time right now where we merge many new features
09:26:00 <gsagie> so important to keep testing everything
09:26:07 <dingboopt> raofei will join us in one minute
09:26:12 <dingboopt> I just notified him
09:26:14 <gsagie> dingboopt: okie great
09:26:32 <gsagie> lets move to selective proactive until he comes
09:26:38 <gsagie> #topic selective proactive and ovsdb monitor
09:27:49 <DuanKebo> we tested selective proactive last week.
09:27:50 <gsagie> so i have my patch => https://review.openstack.org/#/c/284178/
09:28:09 <DuanKebo> basic function is fine.
09:28:20 <gsagie> DuanKebo: how are you doing testing ?
09:28:26 <gsagie> you dont have all the missing parts yet
09:28:34 <gsagie> or you mean unit tests?
09:28:38 <DuanKebo> we use devstack
09:28:51 <DuanKebo> create vm/network/subnet and sg
09:29:18 <gsagie> but for selective proactive to work you need all the parts (including my patch) merged
09:29:22 <DuanKebo> We use a real multi-node devstack enviroment.
09:29:29 <gsagie> so not sure how you test it all
09:29:38 <DuanKebo> Yes, we merged you patch
09:29:42 <gsagie> okie
09:29:53 <gsagie> nice then, so we only have to do review at this point?
09:30:01 <gsagie> and start testing everything once all is merged to master?
09:30:19 <gampel> gsagie: i will add a patch on to of yours to not break pubsub until we have it all merge
09:30:32 <gsagie> gampel: i added this code
09:30:38 <DuanKebo> yes, we need to speed up the review and merge actiion
09:30:39 <gsagie> to my patch as it was failing the tests
09:30:40 <gampel> ok i will take a look
09:30:53 <gampel> :)
09:30:58 <gsagie> okie DuanKebo: me and gampel will take a look
09:31:10 <gsagie> and nick-ma :)
09:31:23 <DuanKebo> It's really not convinient because we have to merge one patch atfer one patch
09:31:24 <nick-ma> hello
09:32:00 <gsagie> DuanKebo: yes, but i think that on most patches there are review comments
09:32:10 <gsagie> so we need to see how we can also address them before we merge
09:32:21 <gsagie> raofei: any update on the dnat code?
09:32:22 <nick-ma> we need to provide dependency on the related patches, or it is hard for me to review one by one.
09:32:54 <raofei> yes. there are too match patchs are implemented and not merged, there are many conflict need to rebase and rebase again.
09:33:03 <raofei> yes. I have commit the code
09:33:22 <raofei> and did the integrated test.
09:34:04 <gsagie> raofei: yes, we need to send as small patch as possible so we can review faster and avoid merging, but good work on your part, i do know oanson already have some comments on your patch so please review
09:34:12 <gsagie> we will take a look this week
09:34:14 <gampel> raofei:  lets all try to reveiw all the patches
09:34:34 <raofei> but it seems impact the UT, I will resolve it ASAP.
09:34:38 <gampel> i think that we can create priority  on which we should merge first
09:34:48 <raofei> OK, please review it.
09:34:52 <DuanKebo> Can we focus on review patch one by one?
09:34:56 <raofei> all of you.
09:34:57 <gsagie> yes, good idea gampel
09:35:02 <gampel> so we all focused on reviewing them before the others
09:35:21 <gampel> i think we should start Redis , SG , DNAT what do you think ?
09:35:33 <gsagie> gampel: i think selective proactive is also important
09:35:47 <gsagie> but yes thats the first priority now
09:35:53 <gsagie> and DB consistency
09:36:15 <nick-ma> Yes :-)
09:36:36 <gsagie> :)
09:36:50 <gampel> ok lets all try to review those during the next two days
09:36:57 <gsagie> okie, so i dont think we really have any open known issue right now, just need to review faster :)
09:37:04 <gsagie> so good times!
09:37:06 <DuanKebo> patch about the nb_api(add topic)
09:37:06 <gsagie> good job everyone
09:37:19 <gampel> yes very good job :)
09:37:27 <gsagie> DuanKebo: will make sure to merge it today
09:38:01 <DuanKebo> gsagie, great
09:38:11 <gsagie> #topic open discussion
09:38:22 <gsagie> nick-ma: care to share what you guys doing at Intel?
09:38:28 <gsagie> and what people are saying about Dragonflow?
09:38:52 <nick-ma> all the community developers from China get together
09:39:08 <nick-ma> Discuss and fix bugs
09:39:10 <gsagie> funny thing is i saw in the OVN mailing list they are now talking about the DB problems and how much it would be good to have a pluggable DB layer ;)
09:39:21 <gampel> I think it is  important   to move the OVS daemons to service
09:39:41 <gsagie> nick-ma: sounds nice
09:39:42 <gampel> and mandate new DB to run as a service
09:39:47 <oanson> That's my next item
09:39:50 <gsagie> gampel: agreed
09:39:52 <gampel> cool
09:40:15 <gsagie> #action oanson convert OVS to services
09:40:19 <nick-ma> Great job on dog. They are all asking roadmap and make it in production.
09:40:26 <nick-ma> On df
09:40:47 <gsagie> #action gsagie Document addition of new DB process
09:41:02 <gsagie> nick-ma: cool, we would love to arrange remote meetings with anyone that is interested
09:42:13 <gsagie> DuanKebo, dingboopt, raofei, feipeng, yuli_s: anything else you would like to discuss about?
09:42:32 <gampel> yuli_s do you want to share the control testing progress
09:42:41 <yuli_s> sure
09:42:51 <yuli_s> i am hacking rally tests now
09:43:03 <gsagie> cool
09:43:09 <DuanKebo> No. We are focusing on the integration test.
09:43:13 <nick-ma> Huang_kun may be helpful
09:43:18 <gsagie> good job yuli_s
09:43:33 <gsagie> we do want to get some control plane/API numbers soon
09:43:34 <raofei> I hope I can do more things later on this interest project.
09:43:36 <yuli_s> rally is increadible peace of code
09:44:02 <gsagie> raofei: sure, we have a many items in the roadmap :) we would love your help
09:44:10 <raofei> :)
09:44:17 <gampel> what about the servers ? did Huang_kun  got them
09:44:20 <yuli_s> :)
09:44:34 <nick-ma> He is with me.
09:44:49 <nick-ma> I will find and ask him.
09:45:09 <gampel> thanks and let him know we need his help with rally
09:45:21 <nick-ma> Yes, of course.
09:45:50 <gsagie> okie everyone, thanks for attending and lets hope most/all of the features are going to be merged by next meeting!
09:46:05 <nick-ma> Thanks
09:46:06 <gampel> thanks
09:46:12 <gsagie> btw, anyone is coming to the summit and already know it?
09:46:21 <gsagie> DuanKebo: anyone from your team by any chance?
09:46:33 <gsagie> raofei, dingboopt: ?
09:46:40 <DuanKebo> Maybe next time;-_
09:46:46 <nick-ma> I'm going.
09:47:04 <raofei> no, maybe next time:)
09:47:04 <gsagie> okie
09:47:16 <gsagie> :(
09:47:35 <gsagie> next time is in Barcelona, so going to be more interesting :)
09:47:45 <gsagie> anyway thanks for the time and meeting and talk with you later!
09:47:56 <gsagie> #endmeeting