09:00:23 <oanson> #startmeeting dragonflow
09:00:24 <openstack> Meeting started Mon Jun 27 09:00:23 2016 UTC and is due to finish in 60 minutes.  The chair is oanson. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:25 <oshidoshi> let's go
09:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:28 <openstack> The meeting name has been set to 'dragonflow'
09:00:34 <gampel> Hi
09:00:37 <oanson> Who's here for the meeting?
09:00:40 <yuval> o/
09:00:43 <oshidoshi> oanson: you're 25 seconds late, your british citizenship has been cancelled
09:01:05 <oanson> #info oshidoshi, yuval , gampel are in the meeting.
09:01:15 <yuli_s> hello
09:01:22 <oanson> #info yuli_s is also in the meeting
09:01:28 <Shlomo_> hi
09:01:36 <oanson> #info Shlomo_ is also in the meeting
09:01:53 <shachar> I am not
09:02:00 <oanson> Let's wait another minute to see if anyone else joins, and then we can begin
09:02:19 <oshidoshi> I think we can start with the agenda, people can always read the log afterwards
09:02:28 <oanson> All right.
09:02:41 <oanson> Since there was no agenda published, these are the topics I plan to cover:
09:02:44 <oanson> Road Map
09:02:51 <oanson> Openstack Barcelona Summit
09:02:57 <oanson> Performance Testing
09:02:59 <oanson> Bugs
09:03:02 <oanson> Open Reviews
09:03:05 <oanson> Open Discussion
09:03:17 <oanson> #topic Road Map
09:03:24 <oshidoshi> hey hujie
09:03:33 <hujie> Hi :)
09:03:48 <oanson> #info hujie is in the meeting
09:03:54 <oanson> Hi, hujie
09:04:05 <hujie> Hi Omer :)
09:04:12 <oanson> #link https://etherpad.openstack.org/p/dragonflow-newton
09:04:30 <oanson> This is the ether pad containing our thoughts for the N cycle road map
09:04:54 <oanson> I think we should have a general idea what we plan to do.
09:05:19 <oanson> Or at least prioritize the items
09:05:47 <oanson> Anyone has any thoughts? Any requirements?
09:05:55 <gampel> DB synchonization    ML2/L3 Service Plugin    Packaging and Distribution are TOP priority  in my mind
09:06:19 <oanson> These are indeed the top listed items.
09:06:33 <oanson> I am working on Packaging at the moment - testing openstack-ansible.
09:07:00 <gampel> We can start marking them with priority in this page
09:07:10 <oanson> There was some ML2 code that was merged. It should be tested.
09:07:26 <oanson> Maybe even add a gate test for it.
09:07:44 <gampel> We could mark  with MUST have Nice to have  ....
09:08:11 <gampel> I agree that we need another gate job for ML2 at least for the period we support both
09:08:56 <oanson> I've added MUST and NICE TO HAVE headers to the etherpad. Please feel free to move things about.
09:09:45 <oanson> In any case, the order of the file should be treated as priority. If you think something is more important than another, make sure they are ordered correctly.
09:09:47 <hujie> I'm working on DB synchonization, in Neutron side, I have implement the db comparison logic but lack the separate process and db comparison trigger mechanism, and in local controller side, I started coding yesterday:)
09:10:14 <oanson> hujie, that's great! Thanks!
09:12:03 <oanson> Is wangyongben here?
09:12:23 <hujie> l3 plugin patch  and qos patch have been committed
09:12:52 <hujie> I try to find he, wait a min
09:12:56 <oanson> For QoS I see both spec and implementation still under review.
09:13:17 <oanson> Same for L3.
09:13:49 <oanson> I think that once we agree on the priorities, the etherpad should be made into a roadmap spec.
09:14:07 <oanson> This way our plans are available to other contributors.
09:14:40 <gampel> I think that Networking-SFC feature could bring new members to the DF community, it some think we got allot of request for in Austin
09:14:47 <hujie> he is not in company now, and his espace is leave status
09:15:10 <hujie> service chaining?
09:15:23 <oanson> gampel, yes, but we need to decide what we do, before doing it.
09:15:31 <oanson> I understand the API is still under development.
09:16:10 <hujie> we use SCH or other protocol to contain service chain metadata?
09:16:58 <oanson> hujie, I'm not familiar with SCH. Could you please provide a link?
09:18:16 <oanson> In any case, I think the SFC first needs a spec.
09:18:39 <oanson> Any volunteers? :)
09:18:57 <hujie> https://datatracker.ietf.org/wg/sfc/documents/
09:19:02 <gampel> The API is define, the interaction between the Neutron overylay and the SFC is not defined clearly
09:19:38 <oanson> Then this has to be cleared up - or to decide how to do it flexibly.
09:19:47 <gampel> DO you apply SG or not , is it for ports on the same L2 etc
09:20:02 <oanson> #link https://datatracker.ietf.org/wg/sfc/documents/
09:20:49 <gampel> any way i thing that we should start a  group for SFC   brain storm
09:21:03 <oanson> gampel, sounds like a good idea
09:21:50 <gampel> I mean for the DF integration
09:22:15 <oanson> Yes
09:22:52 <oanson> Say the #openstack-dragonflow channel, tomorrow morning? at 7am UTC? Is that good for everyone?
09:23:14 <hujie> I have take part in a service chain project in 2014, but the metadata is contained in source Mac not SCH
09:23:55 <oshidoshi> maybe we're getting into too many details right now about SFC
09:23:59 <oanson> Yes
09:24:21 <hujie> ok, other topic :)
09:24:23 <oanson> #info SFC brain storming, #openstack-dragonflow at 7AM UTC 28/06/2016,
09:24:28 <oanson> Let's move on to the next topic
09:24:33 <oshidoshi> oanson: maybe capture action item to start the SFC brainstorm
09:25:04 <oanson> #action oanson, gampel, hujie, oshidoshi SFC brain storming, #openstack-dragonflow at 7AM UTC 28/06/2016,
09:25:05 <oshidoshi> okay, that 'info' works as well :)
09:25:09 <oanson> oshidoshi, better?
09:25:18 <oanson> #topic Openstack Barcelona Summit
09:25:34 * oshidoshi feeling oh so much better
09:25:42 <oanson> Glad to hear it.
09:26:09 <oshidoshi> okay, so we have quite a few items brewing about in our topic list
09:26:24 <oanson> oshidoshi: The stage is yours, then :)
09:26:32 <oshidoshi> hujie: you guys have compiled some initial list of your own?
09:27:58 <oshidoshi> okay, seems we're alone
09:28:05 <hujie> pardon?
09:28:05 <oanson> All right.
09:28:20 <hujie> what's initial list?
09:28:26 <oanson> hujie, do you have some talks or topics you want to submit?
09:28:27 <oshidoshi> hujie: oh, here you are... did you guys started a list of talks for Barcelona?
09:28:58 <hujie> I have a patch
09:29:01 <hujie> sec
09:29:23 <hujie> https://review.openstack.org/#/c/329806/
09:29:28 <feipeng1> omer, about dnat support multi-ext-gw, I heard from yuli that you will discuss it with us when you come to China next week ?
09:29:55 <oanson> feipeng1, we can also discuss it here if we'll have time, but sure.
09:30:08 <oshidoshi> guys, hold on.  we're currently discussing the Barcelona OpenStack summit topics
09:30:15 <hujie> oshidoshi
09:30:15 <hujie> oshidoshi
09:30:15 <hujie> oshidoshi: not yet, we are busy in HWS production development :)
09:30:31 <oanson> hujie, the deadline is very close.
09:30:48 <oanson> hujie, the deadline is very close.
09:31:05 <oshidoshi> hujie: you don't need to prepare the presentations - just a topic with a short abstract, otherwise you will not have stage time in Barcelona
09:31:20 <oshidoshi> sure, I suggest we put the proposals with abstracts in etherpad, and people can review there
09:31:51 <oshidoshi> oanson: grab an action item for that?
09:31:56 <feipeng1> omer, seem that yuli's method need linux script, add now lack of design for multi-ex-gw, how about use old way of mac learning
09:32:02 <oanson> #link https://etherpad.openstack.org/p/dragonflow_barcelona_summit_talks
09:32:20 <oshidoshi> oanson: \okay, we're done with this topic for today, you can move on
09:32:25 <oanson> #action everyone Put titles and abstracts in etherpad, and review others'
09:32:42 <oanson> #topic Performance Testing
09:32:50 <oanson> Shlomo_, anything to report?
09:33:30 <Shlomo_> I am about to finish the dev of the data-plane performance framework
09:33:44 <Shlomo_> The reporting is already working nicely
09:34:00 <Shlomo_> Need to cover few bugs and add a readme file
09:34:18 <Shlomo_> Hope to setup this week a meeting and present you my work
09:34:31 <feipeng1> oanson: when will you come to China ??
09:34:34 <oanson> That's great!
09:34:44 <Shlomo_> 10x
09:35:31 <oshidoshi> okay, next topic?
09:35:34 <oanson> feipeng1, let's take this offline.
09:35:41 <oanson> #topic Bugs
09:35:47 <oanson> yuli_s, Anything to report?
09:36:05 <yuli_s> we have owners for all high severity bugs
09:36:17 <yuli_s> hm,
09:36:29 <yuli_s> i want to discus one issue / problem
09:36:40 <oanson> Sure, go ahead
09:36:50 <yuli_s> when creating vm we can assign ip to it from public network
09:37:01 <yuli_s> do we want to support this
09:37:02 <yuli_s> ?
09:37:22 <oanson> When creating a VM, it should get an IP according to the subnet to which it is connected.
09:37:36 <oanson> So I don't understand the question...
09:37:45 <yuli_s> yes, you are right
09:37:52 <yuli_s> but admin has more permissions
09:38:08 <yuli_s> he can create VM already with FIP
09:38:18 <yuli_s> without private network
09:38:24 <oanson> You mean FIP only, with no overlay network IP?
09:38:30 <oanson> Is there a use-case for this?
09:38:31 <yuli_s> yes
09:38:48 <yuli_s> '
09:38:59 <oanson> yuli_s, what's the use-case?
09:39:12 <yuli_s> it is just possible to do it,
09:39:37 <oshidoshi> I think what yuli_s is asking, is if we want to support placing a VM directly on the ex-router
09:39:46 <oanson> I understand that.
09:40:12 <oanson> If there is a use-case, it would weigh heavily.
09:40:18 <gampel> Only admin can create a VM on public network
09:41:30 <oshidoshi> okay, anything else?
09:41:36 <yuli_s> I suppose, we need to allow or to block this behaviour
09:41:54 <oanson> yuli_s, What's the current behavior?
09:42:06 <yuli_s> it works from gui,
09:42:17 <gampel> for admin right ?
09:42:29 <yuli_s> but I have not tested the rules
09:42:38 <yuli_s> @gampel right
09:43:44 <gampel> Ok so the admin should provide IPAM for the public net
09:43:51 <hujie> if we want to deploy virtual router, maybe we need admin to create router uplink port from external network
09:43:56 <oanson> yuli_s, let's take this offline. I would like to move forwards.
09:44:04 <yuli_s> ok
09:44:23 <oanson> #topic Open Reviews
09:45:11 <oanson> If anyone has any reviews that they feel have been forgotten?
09:45:19 <hujie> HI would you please review this patch: https://review.openstack.org/#/c/329806/
09:45:27 <oanson> #link https://review.openstack.org/#/c/329806/
09:45:42 <oanson> hujie, I will look at it today.
09:45:48 <oanson> #action oanson review https://review.openstack.org/#/c/329806/.
09:45:51 <hujie> ok, thx
09:46:00 <oanson> Any others?
09:46:10 <hujie> what about vlan patch?
09:47:09 <oshidoshi> hujie: re 329806 - did you discuss with Gal?
09:47:17 <hujie> yes
09:47:24 <hujie> he know what I mean :)
09:47:44 <oshidoshi> okay, he didn't review it since patchset 6
09:47:50 <hujie> @@
09:48:09 <hujie> I'll try to find he
09:48:23 <oshidoshi> he's on sick leave, but will be back soon
09:48:53 <oanson> In general, we should all continue to review patches when possible. There is a lot of new content
09:49:00 <hujie> ok
09:49:05 <oanson> Anything in particular that needs to be looked at?
09:49:25 <hujie> what about vlan patch?
09:49:32 <hujie> committed by Liuhaixia
09:49:47 <oanson> hujie, you mean the spec?
09:49:54 <oanson> I will look at it today as well.
09:50:11 <oanson> All right, then let's move forwards.
09:50:18 <oanson> #topic Open Discussion
09:50:19 <hujie> ok thx
09:50:44 <oanson> There floor is for anyone who would have it
09:50:48 <oanson> The*
09:51:37 <oanson> Guess we're done then.
09:51:44 <oanson> Thanks, everyone!
09:51:47 <hujie> :)
09:51:52 <oanson> #endmeeting