09:00:49 <oanson> #startmeeting Dragonflow
09:00:50 <openstack> Meeting started Mon Jan  2 09:00:49 2017 UTC and is due to finish in 60 minutes.  The chair is oanson. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:53 <openstack> The meeting name has been set to 'dragonflow'
09:01:00 <dimak> Hello
09:01:08 <oanson> Hi, there!
09:01:15 <hshan> hi~
09:01:33 <oanson> xiaohhui, nick-ma_ lihi, yuli_s, you guys here?
09:01:44 <yuli_s> yes
09:01:47 <irenab> hi
09:02:00 <lihi> Hi
09:02:12 <oanson> #info dimak hshan yuli_s irenab in meeting
09:02:23 <lihi> :(
09:02:24 <oanson> Let us begin
09:02:33 <oanson> #info lihi is in meeting too
09:02:42 <oanson> #topic Roadmap
09:02:57 <oanson> lihi, since you *are* in the meeting, why don't you update us about IPv6 support? :)
09:04:19 <lihi> No update yet
09:04:26 <lihi> Hopfully by tomorrow I'll have another patch ready (router discovery), or I'll let you know that that part is not possible yet
09:04:47 <oanson> All right
09:05:01 <lihi> I'm still not sure about the ovs support in this configuration
09:05:02 <oanson> Note everyone that neighbor advertiser is available here: https://review.openstack.org/412208
09:05:35 <oanson> All right. If needed, we'll review the errors offline
09:05:57 <oanson> dimak, what do you want to discuss, NB refactor or SFC?
09:06:07 <dimak> Both
09:06:19 <oanson> Fire away
09:06:33 <dimak> About NB refactor I started writing some code and tests for the new model construction code
09:06:51 <dimak> And send a patch to add jsonmodels to openstack requirements
09:07:22 <dimak> The infra guys pointed out some issues there and I send a pull request last week to address them
09:07:43 <dimak> Szczepan (jsonmodels' author) replied to my email today, said he'll take a look
09:07:50 <oanson> That's great!
09:07:52 <dimak> Hopefully we can get this requirement added
09:08:27 <dimak> Then I had some other issues with the package that need fixing, if we'll get Szczepan's cooperation I'll send few more patches
09:08:54 <dimak> Thats on the jsonmodels front
09:09:09 <dimak> Do we have other open issues in the refactor?
09:09:40 <oanson> There is the locking issue I mentioned in the channel. You want to bring this up now?
09:09:57 <dimak> We can bring this up although I'm not 100% familiar
09:10:19 <oanson> Additionally, I will update the spec, hopefully it can be pushed in soon, though it seems to have stabilised.
09:10:49 <dimak> Lets take locking issue to DF channel, I prefer to take a look at the code first
09:10:55 <oanson> The question is this: In the mechanism driver, we have a locking mechanism so that objects won't be updated in parallel and information won't be lost
09:11:15 <oanson> Do we want to keep this mechanism in the mech driver, or move it into the model code?
09:11:37 <irenab> agree with dimak, let discuss it later once we get enough knowledge on the locking
09:11:45 <dimak> What means of synchronization we have in models code?
09:11:45 <oanson> But we can continue discussion in the DF channel. Everyone is also (more than) welcomed to comment on the spec. Or we can handle this later
09:12:03 <oanson> dimak, none so far, that I know
09:12:28 <irenab> dimak,  what do you mean by synchronization?
09:12:28 <dimak> Its problematic then, lets postpone this discussion for now
09:12:50 <oanson> All right. What about SFC?
09:13:33 <oanson> dimak, ?
09:13:42 <dimak> Of, I didn't make enough progress for SFC unfortunately
09:13:59 <dimak> But I have most of the separation coded
09:14:10 <dimak> Into SFC app, that relies on a driver
09:14:10 <oanson> No worries. I think the NB refactor is more important. SFC will go much easier once that is done.
09:14:35 <oanson> Not sure I understand. Could you please elaborate?
09:14:41 <dimak> {MPLS, NSH} driver code will be simple enough, just installing specific flows
09:15:21 <oanson> I see.
09:15:23 <dimak> and SFC app itself driving them based on NB model events
09:15:30 <oanson> All right. Then let's move on.
09:15:40 <oanson> Chassis health and service health
09:15:48 <dimak> I hope to get a simple single machine working code today :)
09:15:59 <oanson> dimak, great. Thanks!
09:16:01 <oanson> I want to stress a point that came up in the reviews.
09:16:12 <oanson> The two items are related, but not one instead of the other
09:16:22 <nick-ma_> Hi all
09:16:32 <oanson> My understanding was that one relies on the other (rajivk's work relies on xiaohhui)
09:16:40 <oanson> nick-ma_, hi.
09:17:14 <oanson> It would be great if rajivk and xiaohhui work together on this, so that code will be reused and not repeated.
09:17:14 <nick-ma_> Yes,  I think so
09:17:59 <oanson> Since they aren't here, I'll put this as an action so they'll see it
09:18:23 <oanson> #action xiaohhui rajivk collaborate on chassis and service health, since one feature relies on the other
09:18:36 <oanson> TAPaaS
09:18:42 <oanson> The spec was approved.
09:18:58 <oanson> yuli_s, how soon can we expect a PoC?
09:19:27 <yuli_s> i hope to release it next week
09:19:39 <oanson> Great. Thanks!
09:20:17 <oanson> yuli_s, on a different item, are the rally tests stable now?
09:20:36 <oanson> I'll take this opportunity to also thank hujie for the great work on the locking in the mech_driver which has greatly improved the rally tests.
09:20:40 <yuli_s> yes, it is going ok,
09:20:48 <oanson> Great!
09:21:00 <yuli_s> I am just curious about the locks you talked about
09:21:08 <oanson> Yes?
09:21:26 <yuli_s> if that can be a result of the changes in the database locking mechanism
09:21:51 <oanson> Not sure I understand you question?
09:22:15 <yuli_s> i will talk with Dima about this problem
09:22:19 <yuli_s> to see if it is related
09:22:39 <oanson> yuli_s, I'm completely lost. Could you please explain?
09:22:54 <irenab> yuli_s, what problem did you see?
09:22:55 <yuli_s> sec.
09:23:26 <yuli_s> "<oanson> There is the locking issue I mentioned in the channel. You want to bring this up now?
09:23:26 <yuli_s> "
09:23:55 <oanson> yuli_s, this is related to the northbound api refactor. I thought you were there during the discussion.
09:24:22 <yuli_s> ok
09:24:31 <oanson> Anyway, we agreed to get back to that later (after irenab and dimak had a chance to go through the code)
09:24:58 <oanson> Anything else for roadmap?
09:25:38 <oanson> All right
09:25:43 <oanson> #topic Open Discussion
09:26:00 <oanson> Next week I'll start looking at bugs. So prepare your hazard suits
09:26:35 <oanson> That's all I have really. The floor is for the taking
09:26:36 <nick-ma_> :-)
09:26:38 <dimak> What about making fullstack voting?
09:26:47 <yuli_s> i am working on adding rally to compare results with older versions
09:26:48 <oanson> dimak, it's on my todo list :)
09:26:56 <irenab> oanson, I want to look at the DF API we talked previously, will try to draft spec by the end of the week
09:27:22 <oanson> irenab, that's great! Do you want to elaborate, or keep us in suspense until the spec is up?
09:27:29 <dimak> irenab, did you have a chance to look at openapi?
09:27:38 <oanson> yuli_s, that's great! Do you have anything to report on it?
09:27:56 <irenab> nothing to update yet, starting from https://etherpad.openstack.org/p/dragonflow_api
09:28:17 <yuli_s> i am struggling with the servers
09:28:29 <irenab> dimak, I want to start from the requirements (spec)
09:28:34 <oanson> #link API etherpad https://etherpad.openstack.org/p/dragonflow_api
09:28:40 <yuli_s> this time networking issues
09:28:56 <oanson> yuli_s, you mean the Openstack CI servers?
09:29:05 <irenab> dimak, OpenAPI looks like a good way to follow
09:29:07 <yuli_s> nop
09:29:24 <oanson> irenab, all right. apart from AAA, is there anything that's not simple?
09:29:36 <yuli_s> just technical issues
09:30:27 <oanson> yuli_s, I am not sure I understand. Could you please elaborate?
09:30:30 <irenab> oanson, do not think so. We need proper scope definition
09:30:59 <oanson> irenab, yes. That would help :)
09:31:12 <oanson> Although I think we have most of it covered in the etherpad
09:31:44 <irenab> oanson, correct. But from list of bullets it should evlove into spec
09:31:53 <irenab> evolve
09:32:03 <yuli_s> the servers I am working with are in different network,
09:32:08 <yuli_s> their router is not working
09:32:40 <oanson> yuli_s, irenab, let's serialise the conversations :) irenab, you go first (since I think we're reaching the conclusion here)
09:33:00 <oanson> irenab, great. Then I'm looking forwards to it :)
09:33:14 <irenab> oanson, nothing to add yet, just wanted to mentuion I will be looking into DF API
09:33:34 <oanson> irenab, All right. Thanks!
09:33:43 <oanson> As I said, looking forwards to it :)
09:33:45 <oanson> yuli_s, go!
09:34:13 <yuli_s> i am trying to resolve networking issues on the servers,
09:34:17 <yuli_s> the servers I am working with are in different network,
09:34:19 <oanson> yuli_s, I don't understand what servers are you talking about. What networks? What routers?
09:34:20 <yuli_s> their router is not working
09:34:33 <yuli_s> i need to install latest devstack
09:34:42 <yuli_s> so, I need to find a solution for that
09:34:50 <oanson> yuli_s, are these technical issues? Or design issues?
09:35:18 <yuli_s> technical issues
09:35:25 <oanson> yuli_s, then let's take it offline.
09:35:29 <yuli_s> ok
09:35:42 <oanson> Any other open issues?
09:36:33 <oanson> Any other issues in general? Flying cows, alien abductions, etc.?
09:36:40 <yuli_s> nop
09:37:11 <oanson> Well, thanks everyone for the hard work. Join us next time!
09:37:19 <oanson> #endmeeting