19:00:35 <oanson> #startmeeting Dragonflow
19:00:36 <openstack> Meeting started Mon Dec 18 19:00:35 2017 UTC and is due to finish in 60 minutes.  The chair is oanson. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:39 <openstack> The meeting name has been set to 'dragonflow'
19:00:43 <dimak> o/
19:00:50 <leyal> o/
19:01:12 <oanson> CrayZee, you with us too?
19:01:15 <CrayZee> yup
19:01:23 <oanson> #info dimak leyal CrayZee are in meeting
19:01:40 <oanson> All right. I think that's the best we're gonna get, and better than usual for this time :)
19:01:45 <oanson> #topic Roadmap
19:01:57 <oanson> No updates on LBaaS (As far as I know)
19:02:13 <CrayZee> None from my side at least
19:02:13 <oanson> lihi started looking at DNS integration with Dragonflow. I think there's also a spec.
19:02:45 <CrayZee> https://review.openstack.org/527956
19:02:55 <oanson> CrayZee, beat me to it :)
19:03:03 <oanson> #link DNS as a service spec https://review.openstack.org/#/c/527956/
19:03:05 <CrayZee> She offered two options and asked to vote
19:03:21 <leyal> also bit me :)
19:03:43 <oanson> leyal, please tell me you meant beat and not bit :)
19:03:48 <CrayZee> :D
19:04:03 <oanson> All right. So dimak and I will have to review it and vote.
19:04:11 <dimak> Adding myself
19:04:12 <leyal> :D
19:04:27 <oanson> Upgrades
19:04:36 <dimak> We discussed it earlier
19:04:52 <dimak> to support migration code first
19:05:03 <dimak> or independently, if not first
19:05:04 <oanson> We had a discussion offline this morning - if I recall, we agreed that we have a migration script for Dragonflow, an Alembic Migration for Neutron DB,?
19:05:25 <oanson> dimak, not sure I understand what you meant?
19:05:29 <dimak> I think we just need DF upgrages
19:05:34 <dimak> and DF migration
19:05:40 <dimak> that will also reconcile existing data
19:05:55 <oanson> But some changes need to be done in Neutron DB too
19:06:09 <oanson> The DHCP ports is an excellent example
19:06:20 <dimak> Can we make those online?
19:06:47 <dimak> I think we kind of can
19:07:04 <oanson> I'd prefer not, for two reasons: 1. We'll be dependent on Neutron code for upgrade. 2. We might end up needing both versions of the model
19:08:21 <dimak> Umm
19:08:22 <leyal> dimak , i think that will cause to events on objects that already exsist in DF db
19:08:30 <dimak> Why?
19:08:52 <oanson> Let's go about this differently - let's outline the 2-3 options we have in the spec, and take the discussion there. I don't want to eat up too much meeting time for this.
19:08:53 <leyal> we add those object during the DF-DB upgrade , and then create them in neutron ..
19:09:02 <oanson> dimak, if you could add your suggestion? And I will add mine?
19:09:08 <dimak> Sure
19:09:14 <oanson> Great. Thanks!
19:09:33 <oanson> #action oanson dimak update upgrade spec
19:09:44 <oanson> Deployment
19:10:08 <oanson> I understand lihi is making some progress with OSA, but it's slow-going.
19:10:22 <oanson> There are some OSA-side gate issues she's getting
19:11:02 <oanson> RPM packaging - I've added a request to add jsonutils to RDO. Apparently EPEL isn't enough :(. I'll bump some of my contacts tomorrow if it doesn't get any attention soon.
19:11:20 <oanson> Migration into DF - CrayZee if I recall this is on you, right?
19:11:21 <dimak> Something we can help with?
19:11:32 <dimak> (+1s and stuff)
19:11:43 <oanson> dimak, let me see if the contacts I have come through. If not, I'll ask.
19:11:50 <dimak> Cool
19:11:50 <CrayZee> oanson: no progress with this one yet
19:11:52 <oanson> I think it's mainly to approve the RDO package request
19:12:00 <oanson> CrayZee, no worries.
19:12:16 <oanson> I assume you'll start with a spec?
19:12:40 <CrayZee> first thing when I get to this task :)
19:12:52 <oanson> Sure. :) No rush.
19:12:55 <CrayZee> was busy with gates fixing this week
19:13:04 <oanson> Yes. Let's get to that
19:13:05 <oanson> Gates -
19:13:13 <oanson> CrayZee, how's our tempest?
19:13:17 <CrayZee> Rally is working as expected
19:13:31 <CrayZee> tempest issues - mostly fixed
19:13:40 <CrayZee> two types of issues remain:
19:14:03 <CrayZee> 1. BGP issues - command line and containers.
19:14:23 <CrayZee> 2. One problem in the cross tenant traffic - dimak is helping me on this one
19:14:56 <dimak> Yeah ,the devstack I spun up for this crashed, will respin tomorrow :(
19:14:58 <oanson> All right. Let's wait with the BGP issues - we will need help from the neutron-dynamic-routing guys.
19:14:59 <CrayZee> I am puzzled with the first and not sure we have anything to do about it
19:15:26 <CrayZee> oanson: agree
19:15:53 <oanson> It looks like it's Neutron guys. We can find out who's active and ping them.
19:16:16 <oanson> I don't think there was any progress on the other gates
19:16:25 <CrayZee> speaking of active
19:16:44 <CrayZee> tried to get help on the opensack-oslo channel about the OSProfiler - no one answers
19:16:57 <CrayZee> will see when their weekly is and bug them
19:17:07 <oanson> That's probably a good idea
19:17:08 <CrayZee> :P
19:17:26 <oanson> I don't remember their timezone. I was sure they were mostly European...
19:17:57 <oanson> Back to gates - I can probably set up a grenade job in a patch, now that I don't need project-config for that
19:18:28 <oanson> s/I/we/. dimak, I don't remember how we split this one up between us?
19:18:51 <oanson> Or do you want to wait for the spec to be merged, first?
19:19:05 <dimak> oanson, we decided to get at it once we're happy with upgrades
19:19:18 <oanson> So I'll leave it be for now
19:19:25 <oanson> Let's concentrate on the spec
19:19:42 <oanson> Troubleshooting -
19:20:01 <CrayZee> skydive - no progress yet.
19:20:07 <oanson> I don't have anything to update here.
19:20:23 <oanson> Documentation -
19:20:39 <oanson> No updates from me. But I should upload an introductory blog post to the blog.
19:21:00 <oanson> Anyone wants to say something about the roadmap?
19:21:08 <CrayZee> oanson: would you like me to write that blogpost we talked about?
19:21:14 <oanson> Yes
19:21:22 <CrayZee> k
19:21:56 <oanson> #topic Bugs
19:22:06 <leyal> CrayZee , secrets in compeny :)
19:22:29 <CrayZee> :P it is a surprise
19:22:41 <oanson> I've fleshed out the patches for bug 1720734
19:22:41 <openstack> bug 1720734 in DragonFlow "Floating IP association to LBaaS VIP supported by Octavia does not work" [Critical,In progress] https://launchpad.net/bugs/1720734 - Assigned to Omer Anson (omer-anson)
19:23:13 <oanson> The first patch in the chain: https://review.openstack.org/#/c/516101
19:23:44 <oanson> It fails on the OVSDB reconnect test, even though I'm rebased above CrayZee's fix
19:24:05 <CrayZee> please rebase it over https://review.openstack.org/527625
19:24:24 <dimak> oanson, I raised a concern there about port status updates
19:24:31 <CrayZee> you rebased it  over the first patch in the patchset, use the laters
19:24:35 <CrayZee> latest
19:24:55 <oanson> dimak, I solved that today
19:25:06 <oanson> CrayZee, it's rebased over master latest
19:25:09 <dimak> don't see it in code :(
19:25:31 <CrayZee> sec
19:26:10 <dimak> oanson, Ok nevermind
19:26:13 <oanson> dimak, line 98 and onwards in port_behind_port.py
19:26:26 <dimak> :)
19:27:44 <oanson> And dimak I moved the tests out of test_apps in a new patch. Since the test file should also include the regular trunk app tests
19:27:54 <oanson> Since from Dragonflow point of view, it's the same application
19:28:03 <dimak> oanson, Cool, will take a look
19:28:17 <oanson> Cheers. Will fix the pep8 errors tomorrow
19:28:29 <oanson> Hopefully I'll also find out why the fullstack tests fail :)
19:28:38 <dimak> Looks good all in all, though I'll re-review in the morning. Its too late for +2's :P
19:28:47 <oanson> No worries.
19:29:00 <oanson> By then zuul should approve it too
19:29:10 <oanson> That's all I have for bugs. Anyone else?
19:29:34 <oanson> #topic Open Discussion
19:29:39 <oanson> The floor is free
19:30:30 <oanson> All right then. Thanks everyone for coming!
19:30:38 <CrayZee> Cheers
19:30:42 <oanson> #endmeeting