16:01:15 <csatari> #startmeeting edge-computing-group
16:01:16 <openstack> Meeting started Wed Aug  1 16:01:15 2018 UTC and is due to finish in 60 minutes.  The chair is csatari. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:19 <openstack> The meeting name has been set to 'edge_computing_group'
16:01:39 <csatari> #topic Roll Call
16:02:04 <mbeierl> #info Mark Beierl (Dell EMC)
16:02:23 <csatari> #info Gergely Csatari (Nokia)
16:02:52 <csatari> #info This is a discussion of https://wiki.openstack.org/wiki/Image_handling_in_edge_environment
16:10:42 <csatari> #topic One Glance with multiple backends
16:11:36 <csatari> #info Multiple backend support was added during Rocky as an FFE. It is an experimental API. We should go and play with it.
16:12:58 <csatari> #info Support for multiple active backends is ongoing. Allowing multple backends of the same type is also ongoing.
16:14:21 <csatari> #info Used backend is defined by the user. Glance have a default backend configured, this will be used when the user does not define a backend.
16:16:21 <csatari> #info It will be possible to run a Glance API server in every edge cloud instance. Each Glance would be able to access each others images, but could be configured to use their own backends as default.
16:17:18 <csatari> #info When acessing each others images the Glance API would stream the image from the remote backend and chache it.
16:18:04 <csatari> #info For this we need a datapath between the backends.
16:19:51 <csatari> #info Optionally it is possible to set up CEPH synchronisation, but for this some hooks are needed to write to the Glance databese when an image synchronisaiton were finished.
16:21:53 <csatari> #info Q: How about invalidation of an image in the local cache. A: As the cache is really cache there is no invalidation served.
16:27:56 <csatari> #action Add API servers to the figure, add a database replica to the figure.
16:31:05 <csatari> #info Glance supports multiple backends with all Glance backups except http
16:34:58 <csatari> #info Image properties are synchronised via the Glance database.
16:36:56 <csatari> #info Glance does not care about the details of synchronisation. As long as all the Glance API services access the same database the metadata synchronisation will work.
16:40:50 <csatari> #info Flavor synchronisation should be discussed with Nova.
16:41:38 <csatari> #info Question: Does Nova checks if the image fits info the flavor?
16:50:40 <csatari> #info If there is a Glance API runnig in a site we need to have the database credentials there.
16:53:38 <csatari> #info Q: Can the OpenStack services running in the edge cloud instances use the images from the local Glance? There is a worry that OpenStack services (e.g. nova) still need to get the direct URL via the Glance API which is ONLY available at the central site. A: It is a special case when CEPH is used by both Glance and Nove. This can be avoided by allowing Glance to access all the CEPH instances as backends but
16:53:38 <csatari> restrict Nova from access the remote CEPH backends. (Or let CEPH to do the synchronisation)
16:55:04 <csatari> #info Q: Is CEPH backend CEPH block of CEPH RGW in the figure? A: Glance talks directly to the CEPH block. It is possible to configure CEPH RGW via Swift.
16:56:15 <csatari> #info In case the Swift + CEPH RGW in a cluster mode the image replicaiton is automatic. In this case the Nova direct access to CEPH should be disabled and everything should be via Glance API.
16:57:57 <csatari> #info Glance metadata is always in Glance. Even if Swift is used as a backend.
16:59:50 <csatari> #info 70% of Glance users are using CEPH as a backend.
17:00:11 <csatari> #topic Finishing notes
17:01:08 <csatari> #info We should have some more discussions like this.
17:01:55 <csatari> #info csatari will update the wiki and send the result around.
17:06:28 <csatari> #endmeeting