13:03:38 <gongysh> #startmeeting evoque
13:03:39 <openstack> Meeting started Wed Oct 14 13:03:38 2015 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:42 <openstack> The meeting name has been set to 'evoque'
13:04:06 <gongysh> hello
13:04:09 <lawrancejing> 、0
13:04:12 <lawrancejing> \o
13:04:13 <lawrancejing> hello
13:04:37 <lawrancejing> https://github.com/openstack/evoque
13:04:45 <gongysh> thank you to register this project
13:04:55 <lawrancejing> lol
13:05:03 <gongysh> #info project repo is https://github.com/openstack/evoque
13:05:16 <gongysh> #link https://github.com/openstack/evoque
13:05:44 <lawrancejing> where is liangbo..
13:06:00 <gongysh> it seems you have set the repo up.
13:06:42 <lawrancejing> yep
13:06:52 <gongysh> have you register this project with governance site?
13:07:05 <lawrancejing> i thought that we could start with simple ticket for evoque
13:07:18 * gongysh is looking up the project creator task site
13:09:03 <gongysh> #link http://docs.openstack.org/infra/manual/creators.html#adding-the-project-to-the-ci-system
13:09:20 <gongysh> find the Add New Repository to the Governance Repository section
13:10:00 <gongysh> lawrancejing: have you done it?
13:10:17 <lawrancejing> i haven't add that
13:10:30 <gongysh> so will you add it?
13:10:51 <lawrancejing> of course
13:11:20 <gongysh> #action lawrancejing will add project into governance repo
13:11:30 <lawrancejing> have someone tried the service : http://freshservice.com/
13:12:05 <gongysh> no for me
13:12:38 <gongysh> did any one?
13:13:14 <gongysh> shake also recommended this one https://www.otrs.com/solutions/?lang=zh-hans
13:13:22 <EinstCrazy> not either
13:13:46 <zhangjn> may referance itil
13:13:57 <lawrancejing> i'm not very clear about adding project into governance repo:   Temporary proposal for big tent adoption of senlin-->  https://review.openstack.org/#/c/234162/
13:14:20 <lawrancejing> ITIL  and ITSM
13:14:44 <lawrancejing> freshservice   just like ITSM
13:15:04 <gongysh> ok, a good reference from senlin
13:15:38 <zhangjn> https://www.axelos.com/best-practice-solutions/itil.aspx?utm_source=itil-officialsite&utm_medium=redirect&utm_campaign=redirects
13:15:44 <gongysh> #info reference senlin about join big tent  at https://review.openstack.org/#/c/234162/
13:16:53 <gongysh> so we have so many reference sample, it is a good start
13:16:55 <lawrancejing> Next meeting we should add some agenda..:)
13:17:26 <zhangjn> :)
13:17:34 <gongysh> so let's discuss who will cover what reference system.
13:17:52 <gongysh> zhangjn cover itil?
13:18:35 <lawrancejing> i will cover the freshservice
13:18:51 <gongysh> lawrancejing: great
13:19:10 <gongysh> zhangjn, what about your itil?
13:19:19 <nick-ma> so, it is not just a ticket mgmt system?
13:19:20 <EinstCrazy> Good
13:19:38 <yangyapeng> Good
13:19:43 <lawrancejing> nick-ma from awcloud, welcome:)
13:20:01 <gongysh> nick-ma: it depends how to define the 'ticket'?
13:20:30 <nick-ma> yes, so i just wonder what the project scope is.
13:20:31 <gongysh> nick-ma: when I first see the evoque, a ticket system, I thought about 12306.
13:20:41 <lawrancejing> it depens, but the evoque is for operations, anyway
13:21:17 <lawrancejing> gongysh: lol
13:21:40 <zhangjn> I will cover ITIL which part of ticket.
13:22:09 <lawrancejing> agree with nick-ma, we should clearify the project scope
13:22:10 <zhangjn> ITIL is so big that I can't cover it.
13:22:13 <gongysh> let us review some famous system, such as itil, freshservice first
13:22:35 <gongysh> zhangjn, we just need ticket part.
13:22:39 <lawrancejing> or we'll lose ourself。
13:22:47 <zhangjn> I can give you more info about ITIL.
13:23:02 <lawrancejing> cool, thanks zhangjn
13:23:08 <gongysh> after we have some knowledge, we can start define our model.
13:23:46 <gongysh> do we use pecan?
13:23:49 <EinstCrazy> He has studied ITIL for some time
13:24:04 <lawrancejing> pecan pecan pecan
13:24:23 <gongysh> zhangjn: for fudang university program?
13:24:37 <yangyapeng> fudan?
13:24:37 <gongysh> #startvote pecan, pecan, pecan
13:24:38 <openstack> Unable to parse vote topic and options.
13:24:49 <gongysh> #startvote pecan pecan pecan
13:24:51 <openstack> Unable to parse vote topic and options.
13:24:53 <EinstCrazy> For Tianjin
13:25:16 <gongysh> #startvote pecan paste
13:25:17 <openstack> Unable to parse vote topic and options.
13:25:42 * gongysh is searching how to start a vote
13:27:05 <zhangjn> http://pan.baidu.com/s/1jGHAMZ8
13:27:10 <gongysh> #startvote what teck to form our API? pecan, paste
13:27:11 <openstack> Begin voting on: what teck to form our API? Valid vote options are pecan, paste.
13:27:12 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
13:27:48 <gongysh> #vote pecan
13:27:51 <zhangjn> this is book for ITIL in my share link.
13:27:53 <nick-ma> vote pecan
13:27:58 <nick-ma> #vote pecan
13:27:59 <lawrancejing> vote pecan
13:28:07 <nick-ma> #
13:28:11 <zhangjn> vote pecan
13:28:18 <lawrancejing> #vote pecan
13:28:20 <gongysh> start with #
13:28:33 <zhangjn> #vote pecan
13:28:34 <EinstCrazy> #vote pecan
13:29:20 <gongysh> liangbo:  what teck to form our API? pecan, paste
13:29:34 <gongysh> #showvote
13:29:35 <openstack> pecan (5): lawrancejing, gongysh, zhangjn, EinstCrazy, nick-ma
13:30:00 <liangbo> #vote pecan
13:30:28 <gongysh> it seems unanimous vote.
13:30:32 <gongysh> #endvote
13:30:32 <openstack> Voted on "what teck to form our API?" Results are
13:30:33 <openstack> pecan (6): gongysh, nick-ma, zhangjn, EinstCrazy, liangbo, lawrancejing
13:31:01 <zhangjn> ZZzz
13:31:05 <gongysh> so what other stuff to discuss?
13:31:54 <gongysh> #topic open discuss
13:31:57 <lawrancejing> what' the work of next week?
13:32:17 <gongysh> learn some advanced ticket system
13:32:28 <gongysh> I thought you know what to do.
13:33:02 <lawrancejing> yep
13:33:38 <nick-ma> i suggest to use etherpad for collaboration. any ideas related with project scope need to be recorded and shared with others.
13:33:39 <gongysh> next week, we will have zhangjn, lawrancejing to report new discovery about ticket system.
13:34:23 <EinstCrazy> Well, what should be produced after learning? architecture?
13:34:36 <lawrancejing> should use etherpad
13:34:46 <lawrancejing> nice for collaboration
13:34:46 <gongysh> nick-ma, I think we will have it in our project's doc.
13:35:45 <gongysh> etherpad is also good for discuss, after that we will make it into project's doc.
13:36:06 <lawrancejing> doc is fine, but i prefer etherpad: https://etherpad.openstack.org/p/evoque
13:36:32 <lawrancejing> make some conclusion into docs.
13:37:10 <gongysh> fine
13:37:31 <nick-ma> you decide.
13:37:44 <gongysh> we will use etherpad for daily work tool
13:38:09 <gongysh> #info use etherpad for daily work tool https://etherpad.openstack.org/p/evoque
13:38:25 <gongysh> anything else?
13:38:48 <lawrancejing> not for me
13:39:29 <gongysh> one more thing, how to promote this project to attract more guys in
13:40:07 <gongysh> any idea?
13:40:10 <lawrancejing> nick-ma
13:40:54 <gongysh> nick-ma: how does your system resolve the ticket part?
13:41:11 <nick-ma> i think we need to make version 0.1 first, define project scope, use cases, functionality/test framework.
13:41:38 <nick-ma> we use otrs, an open source ticket mgmt system. :-) so i know about it.
13:42:01 <nick-ma> but i have no idea about ITIL/ITSM systems. they are too huge to use for SMB.
13:42:01 <gongysh> nick-ma: project scope is to form a ticket system
13:43:06 <zhangjn> redmine is a good ticket mgmt system :)
13:43:23 <gongysh> nick-ma: can you begin to write some use cases?
13:44:38 <gongysh> nick-ma: today I also got some knowledge from OTRS
13:45:04 <nick-ma> of course i can.
13:45:16 <gongysh> nick-ma: thanks
13:45:37 <gongysh> #action nick-ma will help to create first use cases.
13:46:03 <gongysh> liangbo, do u have any idea?
13:46:44 <nick-ma> btw, redmine doesn't support delegation, afaik.
13:47:20 <gongysh> queue is alos cool from OTRS
13:48:18 <liangbo> I think we should implement the first 0.1, curd just fine. then we talk about BPM part.
13:49:20 <gongysh> liangbo: curd what, don't we need some base models first?
13:49:49 <lawrancejing> maybe some sample crud
13:50:29 <nick-ma> first define the base model of objects and interaction among them.
13:50:35 <lawrancejing> so the research and crud at the same time
13:51:47 <gongysh> we can set up the pecan framework, and client project
13:52:10 <lawrancejing> and i could lead the dashboard:)
13:52:38 <gongysh> lawrancejing: sure, that is your dish.
13:53:11 <gongysh> who can set pecan framework?
13:53:44 <gongysh> liangbo?
13:53:47 <lawrancejing> EinstCrazy?
13:54:24 <gongysh> EinstCrazy,  the ATOM guy?
13:54:38 <liangbo> gongysh, don't you think that's an architect work?
13:54:45 <EinstCrazy> I'm YuChangcai
13:54:52 <yangyapeng> ?
13:55:10 <gongysh> EinstCrazy, got it, Einstain.
13:55:33 <EinstCrazy> ...
13:55:42 <gongysh> liangbo, could you help?
13:55:49 <gongysh> 5 more mins ...
13:55:56 <yangyapeng> diaozhatian
13:55:57 <lawrancejing> hmm, we'll help you with the work
13:56:06 <lawrancejing> liangbo's busy with angularjs
13:56:47 <gongysh> ok,  let's do it after meeting.
13:56:57 <lawrancejing> liangbo lead me  to the angular way, thanks liangbo
13:57:07 <gongysh> #endmeeting