08:00:14 <diablo_rojo> #startmeeting fc_sig
08:00:15 <openstack> Meeting started Wed Mar 14 08:00:14 2018 UTC and is due to finish in 60 minutes.  The chair is diablo_rojo. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:18 <openstack> The meeting name has been set to 'fc_sig'
08:00:24 <cmurphy> hello
08:00:24 <thingee> o/
08:00:27 <diablo_rojo> Hello :)
08:00:36 <gmann_> hi
08:00:48 <diablo_rojo> Already two more people than I had even hoped for :)
08:01:22 <diablo_rojo> I guess I don't need to ask if people are around we can just hop to it!
08:01:32 <diablo_rojo> #link https://wiki.openstack.org/wiki/First_Contact_SIG#Meeting_Agenda Meeting Agenda
08:01:39 <masayukig[m]> \o
08:02:00 <diablo_rojo> I also created a ping list spot in the agenda if you all want to get pinged when I start things next time.
08:02:56 <diablo_rojo> Little bit of an intro, at the PTG we discussed doing a weekly meeting to kind of just go through some standing weekly items and then go through anything new (if there are things).
08:03:32 <diablo_rojo> The two standing items being going through unmerged patches from new contributors and going through ask.openstack.org questions tag as contributor or contribution.
08:03:40 <diablo_rojo> So!
08:03:47 <diablo_rojo> #topic New Contributor Patches
08:04:14 <diablo_rojo> #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open New Contributor and Unmerged Patches
08:04:54 <diablo_rojo> The idea is to go through this list and wherever our areas of expertise overlap, try to go and assign people to review them.
08:04:59 <diablo_rojo> Or something like that.
08:05:54 <gmann_> i can see 2 tempest patch which i can do quickly. seems pep8 error in one of them. i will help them
08:05:55 <diablo_rojo> I figure for the first few weeks we can just take a chunk of the list at a time and then as the weeks progress we will be more up to date and there will be less to go through.
08:06:05 <diablo_rojo> gmann_, awesome :)
08:06:06 <gmann_> +1
08:06:12 <diablo_rojo> That would be super helpful!
08:06:35 <thingee> interesting we got patches going back to 2014. I see one that has never gotten an answer back then.
08:06:51 <thingee> patches going back to 2014 with that filter*
08:06:52 <gmann_> for other projects patches, should we add core team of PTL to respond if they are stuck without review ?
08:07:04 <diablo_rojo> If there are ones we can't cover, hopefully we have a project liaison that we can poke to look at/foster the newbie if they aren't already
08:07:22 <gmann_> ah yea project liaison
08:07:26 <diablo_rojo> thingee, that's super sad :( Hopefully routinely going through them will make that not a problem anymore.
08:08:18 * diablo_rojo looks through list
08:08:53 <thingee> maybe as a data point we can try to shrink this list, or the ones that have never gotten an answer.
08:09:03 <cmurphy> a lot of these are for the sandbox repository, we probably don't really need reach out on those?
08:09:05 <thingee> probably some of these can be abandoned by now
08:09:14 <masayukig[m]> It looks many of them are in the sandbox project
08:09:15 <diablo_rojo> cmurphy, yeah I would think not.
08:09:22 <diablo_rojo> Seeing a lot of DNMs too.
08:09:26 <thingee> oh heh I'm not even look at projects :)
08:09:28 <gmann_> yea we can clean those
08:09:29 <thingee> sleepy mike
08:09:34 <diablo_rojo> Maybe we can reach out to them about abandoning them?
08:09:46 <diablo_rojo> thingee, you and me both :)
08:10:25 <gmann_> #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+project:+openstack-dev/sandbox
08:10:52 <diablo_rojo> Okay so maybe not getting around to assigning anything this round, but wherever we have spare time in the next week, to spend a few minutes reviewing what we can and then reaching out to those that should be abandoned.
08:10:59 <diablo_rojo> Theres a lot of cleanup to do.
08:11:15 <thingee> sansandbox is open, so maybe we need some periodic cleaner thing
08:11:45 <diablo_rojo> thingee, yeah that would be helpful
08:11:54 <diablo_rojo> Easier to focus on what needs to be focused on.
08:12:10 <thingee> or our filter can ignore sandbox :)
08:12:21 <diablo_rojo> Yeah that totally works too
08:13:00 <diablo_rojo> How do you even filter out a certain project?
08:13:25 <cmurphy> add NOT project:openstack-dev/sandbox
08:13:37 <masayukig[m]> #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+-project:+openstack-dev/sandbox
08:13:37 <cmurphy> https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+NOT+project:openstack-dev/sandbox
08:13:39 <diablo_rojo> Ah, all caps.
08:13:40 <masayukig[m]> ?
08:13:46 <diablo_rojo> lowercase wasn't cutting it
08:13:48 <masayukig[m]> ah, NOT
08:14:08 <cmurphy> the - works too
08:14:21 <diablo_rojo> Way more manageable length of list when you take those out
08:14:28 <thingee> oh you can also do -project:openstack/sandbox
08:14:43 <diablo_rojo> cmurphy, you so smart :)
08:14:43 <masayukig[m]> yeah, https://review.openstack.org/Documentation/user-search.html#_negation
08:14:45 <thingee> oh nvm cmurphy already mentioned that
08:14:58 <diablo_rojo> So many things I didn't know how to do.
08:15:01 <thingee> today I learned :)
08:15:13 <diablo_rojo> Me too!
08:15:44 <masayukig[m]> same here!
08:15:44 <gmann_> #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+-project:+openstack-dev/sandbox
08:15:51 <gmann_> - is easy one :)
08:16:11 <diablo_rojo> Okay so I propose we all take an action item to like.. go respond to 3? 5? or if you can't respond, find a project liaison to cover it?
08:16:14 <thingee> good collaboration folks
08:16:15 <diablo_rojo> Does that seem reasonable?
08:16:21 <diablo_rojo> +1
08:17:06 <gmann_> +1
08:17:15 <diablo_rojo> I see some swiftclient ones maybe we can get mattoliverau on
08:18:02 <thingee> also -openstack-dev/ci-sandbox
08:18:53 <masayukig[m]> +1
08:19:29 <diablo_rojo> #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+-project:+openstack-dev/sandbox+OR+-project:openstack-dev/ci-sandbox
08:19:31 <diablo_rojo> ?
08:19:50 <diablo_rojo> Even shorter list now.
08:21:40 <diablo_rojo> Okay so I can update that link on the agenda
08:21:47 <diablo_rojo> for next time
08:22:11 <masayukig[m]> I think it should be AND? #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+-project:+openstack-dev/sandbox+AND+-project:openstack-dev/ci-sandbox
08:22:52 <diablo_rojo> #Action Everyone try to review to or get a project liaison to review a min of three patches from this list for next week
08:23:26 <diablo_rojo> Onto the next standing item
08:23:48 <diablo_rojo> #topic ask.openstack.org questions
08:24:16 <diablo_rojo> So, I imagine this will be similar where we have a sizable list in the beginning and will have to slowly whittle it down.
08:24:26 <gmann_> yea
08:24:43 <gmann_> just replied on one post though that was little old - https://ask.openstack.org/en/question/93608/how-can-i-contribute-if-im-junior-level-developer/
08:24:54 <gmann_> but seems need moderator approval before answer gets posted.
08:24:59 <diablo_rojo> #link https://ask.openstack.org/en/questions/scope:all/sort:activity-desc/tags:contribution/page:1/ Contribution
08:25:44 <diablo_rojo> Do they always need moderator approval?
08:26:02 <diablo_rojo> #link https://ask.openstack.org/en/questions/scope:all/sort:activity-desc/tags:contributor/page:1/ Contributor tag
08:26:11 <diablo_rojo> That one is a bit shorter
08:26:39 <diablo_rojo> Neither is that bad
08:27:22 <diablo_rojo> So maybe the action item for this one is just respond to 2?
08:27:25 <gmann_> this msg  - "Your post was placed on the moderation queue and will be published after the moderator approval. At least 10 karma points is required to post links"
08:27:26 <diablo_rojo> Does that work for people?
08:27:43 <diablo_rojo> gmann_, oh interesting
08:28:07 <gmann_> after 10 karma it might work wihtout approval
08:28:13 <diablo_rojo> Helps with avoiding spam and bots I would think.
08:28:17 <diablo_rojo> gmann_, yeah
08:29:05 <gmann_> RE: respond to 2 post works fine for me.
08:29:17 <diablo_rojo> Since I didn't hear objections to the proposal I will make that another action item :)
08:29:25 <gmann_> :)+1
08:29:36 <diablo_rojo> #action Respond to at least 2 questions on ask.openstack.org
08:30:03 <diablo_rojo> #topic New Contributor of the Week
08:31:04 <diablo_rojo> So this idea was brought up a while ago- I think by ttx originally. I thought since we would be sifting through code reviews and focusing on new contributors any way it would be easy enough for us to come up with a name each week and like two sentence to maybe include in the developer digest?
08:31:11 <diablo_rojo> thingee, thoughts on that?
08:32:01 <gmann_> idea is nice.
08:32:23 <diablo_rojo> gmann_, I can't take credit for it, but I definitely agree.
08:32:26 <gmann_> but what will be the criteria to choose? quality of code, complexity of patch, project etc?
08:32:47 <diablo_rojo> gmann_, I think it can vary week to week.
08:33:06 <diablo_rojo> Those would be things to keep in mind for sure.
08:34:27 <diablo_rojo> #action If one of the reviews you do is of particular note, try to remember to bring the person up during this part of the meeting next week
08:35:01 <diablo_rojo> Okay, last planned agenda item!
08:35:15 <diablo_rojo> #topic Rollover of #openstack-101 to #openstack-dev
08:35:17 <thingee> sounds fine to me, anyone can contribute to the dev digest here: https://etherpad.openstack.org/p/devdigest
08:35:45 <diablo_rojo> thingee, oh yes! Thanks for the link, I had it on the agenda and forgot to actually use it lol.
08:35:46 <thingee> can make a section to mention new contributors. ok yes new topic ;)
08:35:56 <diablo_rojo> thingee, falling asleep? :)
08:36:10 <thingee> eh yea :D
08:36:30 <gmann_> what time there for you guys? mid night?
08:36:40 <diablo_rojo> So, basically we want to roll this channel over and if I recall, we got the directions on how to do it from fungi at the PTG and its in our FC SIG etherpad.
08:36:46 <thingee> 1:36, but DST with a 1 year old
08:36:48 <diablo_rojo> gmann_, closing in on 2 AM
08:37:00 <gmann_> omg
08:37:15 <diablo_rojo> Basically my reason for bringing this up is that it doesn't have an owner :)
08:37:35 <diablo_rojo> If anyone wants to start moving this forward it would be vastly appreciated :)
08:37:51 <thingee> diablo_rojo: i can figure it out
08:38:06 <diablo_rojo> thingee, oh cool that would be awesome.
08:38:23 * diablo_rojo goes to get link fungi provided
08:38:52 <diablo_rojo> #link https://docs.openstack.org/infra/system-config/irc.html#renaming-an-irc-channel
08:38:57 <diablo_rojo> thingee, ^^
08:39:03 <thingee> ack
08:39:24 <gmann_> thingee: thanks
08:39:32 <thingee> omg irc commands
08:39:59 <thingee> the worse kind too of having to talk to chanserv.
08:40:00 <diablo_rojo> ha ha ha yeah a lot of them
08:40:07 <diablo_rojo> yeah..
08:40:30 <thingee> always feel weird telling that person my password.
08:40:40 <diablo_rojo> I guess I will owe you a woodford reserve for handling all that :)
08:41:21 <diablo_rojo> The tips on that section are also very interesting
08:41:30 <cmurphy> spotz had a suggestion on the ml to direct to #openstack instead of #openstack-dev, thoughts on that?
08:41:42 <thingee> oh haha this will be interesting fun?
08:42:50 <diablo_rojo> cmurphy, yeah I had seen that but didn't get time to respond. I feel like in general we want to direct to #openstack-dev since the fc sig was originally formed in response to people that needed help with the contribution process?
08:43:29 <diablo_rojo> Other people have thoughts?
08:43:44 <thingee> contribution can be more than dev, so #openstack can be fine.
08:43:56 <diablo_rojo> At this point the contributor guide points #openstack-dev but that can be changed
08:44:05 <thingee> I think i just want people somewhere active that they can feel like they want to listen in and maybe contribute in discussion
08:44:41 * diablo_rojo doesn't currently sit in the #openstack channel
08:44:52 <diablo_rojo> is it pretty active?
08:44:56 <cmurphy> both channels are more active than -101 so i don't have strong feelings either way
08:45:03 <diablo_rojo> All the usual suspects?
08:45:12 <diablo_rojo> Fair :)
08:45:19 <thingee> I sit in there, and very seldomly answer questions. I don't always feel like I have the right answer, though maybe that would trigger someone smarter to answer.
08:45:22 <diablo_rojo> I agree #openstack-101 needs to go away
08:45:23 <cmurphy> slightly different group of active people than in -dev
08:46:23 <diablo_rojo> Maybe we can direct to both? Depending on the interest? I would hate for people to be shuffled to one and then get shuffled to the other.
08:46:38 <diablo_rojo> Especially before they are used to IRC and watching 10 channels at once.
08:48:20 <gmann_> #openstack channel says "Openstack Support Channel, Development in #openstack-dev | Wiki: http://wiki.openstack.org/ | Docs: http://docs.openstack.org/ | Answers: https://ask.o..."
08:48:37 <gmann_> which looks more generic one to redirect people to right things
08:49:17 <diablo_rojo> gmann_, yeah I am seeing in the irc list that it says: 'general discussion, support '
08:50:34 <diablo_rojo> I guess I still lean towards pointing people to #openstack-dev..
08:51:04 <diablo_rojo> I can respond on the ML tomorrow morning with my thoughts.
08:51:24 <diablo_rojo> #topic General Discussion
08:53:07 <diablo_rojo> Only other thing I have to mention is if we see someone pushing the same sort of patch in a bunch of different projects (i.e. spelling change or link updates) we should probably reach out to them? I know this was kind of why the SIG was created in the first place.
08:53:57 <diablo_rojo> Just something to be mindful of I guess.
08:54:14 * diablo_rojo is getting too tired to string words together into an actual sentence
08:54:43 <diablo_rojo> So thats all I had!
08:54:49 <diablo_rojo> 6 min to spare.
08:54:56 <diablo_rojo> Anyone have anything else to mention?
08:55:08 <gmann_> nothing from my side.
08:55:34 <diablo_rojo> Coolio.
08:55:35 <thingee> nothing here, thanks for leading diablo_rojo
08:55:44 <diablo_rojo> Thanks for staying up thingee :)
08:55:59 <diablo_rojo> And thank you everyone else for coming to our first meeting!
08:56:11 <gmann_> thanks diablo_rojo for chairing.
08:56:19 <thingee> we'll have shirts printed
08:56:26 <diablo_rojo> Don't forget to add yourselves to the ping list.
08:56:37 <diablo_rojo> thingee, I do love OpenStack T-Shirts
08:56:55 <diablo_rojo> Without further ado...
08:56:58 <diablo_rojo> #endmeeting