08:00:15 <diablo_rojo> #startmeeting fc_sig
08:00:16 <openstack> Meeting started Wed Mar 28 08:00:15 2018 UTC and is due to finish in 60 minutes.  The chair is diablo_rojo. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:19 <openstack> The meeting name has been set to 'fc_sig'
08:00:21 <cmurphy> hello
08:00:29 <diablo_rojo> Hello cmurphy :)
08:00:46 <diablo_rojo> I 100% forgot to email a reminder about the meeting today so we will see who else shows up.
08:01:07 <mattoliverau> o/
08:01:07 <diablo_rojo> gmann, mattoliverau around?
08:01:15 <mattoliverau> haha beat you
08:01:34 <diablo_rojo> I also only remembered I had to run this 20 min ago when I was headed to bed lol
08:01:39 <diablo_rojo> But I remembered!
08:01:48 <mattoliverau> that's the important thing!
08:01:54 <diablo_rojo> True :)
08:01:56 <cmurphy> I managed to look at my calendar this morning, for which I'm very impressed with myself
08:02:11 <mattoliverau> cmurphy: wow, nice work ;)
08:02:17 <cmurphy> ikr
08:02:21 <diablo_rojo> cmurphy, you and I are just killing it at the clutch play
08:02:30 <cmurphy> hi5
08:02:33 * mattoliverau notes that actually is a feat knowing the suse canendaring system :P
08:02:56 <cmurphy> mattoliverau: i actually figured out how to export my groupwise calendar to my gmail calendar
08:03:15 <cmurphy> (i've since forgotten how i did that so don't ask)
08:03:19 <mattoliverau> ahh, smart.. I just use gmail for everything upstream
08:03:25 <diablo_rojo> We'll give gmann_ another few minutes to show up and see if any newcomers want to join the party before getting started.
08:03:46 <gmann_> diablo_rojo: hi
08:03:51 <diablo_rojo> mattoliverau, same and I set all my meetings for the Iceland Timezone so they match UTC
08:03:52 <gmann_> sorry i was in internal meeting
08:03:58 <diablo_rojo> Oh hello gmann_ :)
08:04:01 <diablo_rojo> No worries
08:04:06 <diablo_rojo> Still just chatting.
08:04:07 <cmurphy> gmail actually has a UTC option now
08:04:13 <mattoliverau> oh you don't need that anymore.. google calendar finally has a UTC option!
08:04:15 <diablo_rojo> cmurphy, WUT
08:04:23 <diablo_rojo> Since when?
08:04:24 <cmurphy> it is very exciting
08:04:26 <mattoliverau> I figured it out when adding the FC SIG meeting
08:04:28 <cmurphy> since pretty recently i think
08:04:48 <diablo_rojo> Oh man. Sounds like I get to play calendar cleanup tomorrow.
08:05:03 <mattoliverau> well not really, because Iceland is still always UTC
08:05:49 <diablo_rojo> I suppose.
08:06:10 <diablo_rojo> Well, since the usual suspects are here- should we get started?
08:06:14 <mattoliverau> yup
08:06:29 <diablo_rojo> #link https://wiki.openstack.org/wiki/First_Contact_SIG#Meeting_Agenda Agenda!
08:06:45 <diablo_rojo> #topic New Contributor Patches
08:06:54 <diablo_rojo> Did everyone do their homework?
08:07:09 <mattoliverau> I did... even if it was today :P
08:07:25 <diablo_rojo> mattoliverau, still counts if it was done before I asked if it was done.
08:07:31 <mattoliverau> \o/
08:07:45 <gmann_> I think I did not but donot remember if I reviewed few during weekend
08:08:15 <diablo_rojo> I don't think I reviewed them, but I was working on some other things instead (one of them being a later topic) so hopefully you all will accept that.
08:08:33 <mattoliverau> There wasn't any Swift ones, so I grabbed the stackalytics ones, reviewed. and mentioned this group if they wanted help/connected as they get started.
08:08:56 <cmurphy> that's a good idea
08:08:58 <diablo_rojo> I for sure did one- we have a potential storyboard intern who just pushed her first patch :)
08:09:06 * gmann_ mobile irc client does not get scroll down on new msg.
08:09:13 <diablo_rojo> mattoliverau, that is a good idea
08:09:35 <diablo_rojo> gmann_, oof thats obnoxious- I would guess thats a setting somewhere.
08:09:47 <mattoliverau> yeah, and I learnt many people make mistakes when adding themselves to stackylitics.. I thought it was just me :P
08:10:07 <diablo_rojo> mattoliverau, I don't think so- its super non intuitive
08:10:13 <gmann_> diablo_rojo: checking in setting ..
08:10:37 <diablo_rojo> Last I recall I still work for IBM in stackalytics. Can't remember if I ever updated it.
08:10:47 <mattoliverau> lol, opps
08:10:59 <mattoliverau> there getting all your credit
08:11:12 <mattoliverau> *they're
08:12:00 <diablo_rojo> mattoliverau, if I looked at stackalytics  I might care, but I don't really anymore
08:12:22 <diablo_rojo> Anywho, in reviews did anyone find a new contributor they want to bring to the 'New Contributor of the Month' table?
08:12:46 <mattoliverau> Though based on the current reviews noone to really add to the contributer of the week/month. One got it right and the other 2 didn't.. on of the 2 literally copied over the first entry in the list... rendering the first person in stackylitics gone.
08:13:00 <mattoliverau> *one of the 2
08:13:35 <diablo_rojo> I might actually say the potential outreachy storyboard intern- She has come into the project and pushed a patch in ~a week. She already pushed a new patchset today too.
08:13:39 <diablo_rojo> mattoliverau, lol
08:13:52 <diablo_rojo> cmurphy, or gmann_ got anyone?
08:13:53 <gmann_> Same from me, No one as of now. The one I thought not yet replied on review comments.
08:14:06 <mattoliverau> diablo_rojo: nice
08:14:21 <cmurphy> no one stands out in keystone at the moment :/
08:15:09 <mattoliverau> seems getting new contribs to push a follow up patchset is the hard part.
08:15:15 <diablo_rojo> Oh well. I'll give it till the end of the week and then I will move ahead with our potential intern- not sure if I want to do an OpenStack Blog post, or just throw something in the dev digest or do a super user or just make a wiki page..
08:15:30 <mattoliverau> maybe it's the first big barrier. that and time to review usually
08:15:44 <diablo_rojo> mattoliverau, agreed- the first patchset is easier than the follow ups more often than not.
08:15:46 <diablo_rojo> Yeah
08:15:57 <gmann_> Yea
08:16:40 <mattoliverau> Yeah, so something to make sure we've focused on here and in OUI I  guess
08:16:43 <diablo_rojo> If any of you come up with a different new contrib of the week, ping be by Fridayish and we can make a decision.
08:16:49 <gmann_> If we can find them in irc it is easy to help them but hats not case always
08:16:51 <mattoliverau> kk
08:16:52 <diablo_rojo> mattoliverau, indeed.
08:17:04 <gmann_> Sure.
08:17:38 <diablo_rojo> gmann_, yeah. And the people that show up in irc, ask a question, don't get an answer right away and dissappear without leaving contact info.. Hard to circle back to them.
08:18:03 <gmann_> True
08:18:18 <mattoliverau> yeah, but from their point of view, how long is waiting long enough.
08:18:48 <mattoliverau> I see that all the time and am like, damn missed them.. but they do tend to stay for 5 - 10 minutes.
08:18:55 <diablo_rojo> For them I'm sure they think 20 min or less, in reality I would say give it 12 hours before trying something different.
08:19:16 <diablo_rojo> mattoliverau, more things to stress in OUI
08:19:21 <mattoliverau> yeah, exactly
08:19:28 <gmann_> Yea bcz, they might use irc on browser and close if no reply at same time
08:19:36 <mattoliverau> but for some people permanent connection to IRC is hard
08:19:47 <gmann_> Exactly
08:19:48 <mattoliverau> ^ and that
08:20:11 <diablo_rojo> Which is why emails to the ml's are good  if you can't stick around on IRC
08:20:23 <mattoliverau> I guess that's why ask openstack is actually a pretty good option.. except I don't think it's really as well monitored
08:20:37 <diablo_rojo> Not as well as it used to.
08:20:40 <diablo_rojo> Thats for sure
08:21:36 <diablo_rojo> #action Everyone- same homework for next week  3+ reviews (or delegation of reviews) of new contributor patches
08:21:54 <diablo_rojo> Onto the next topic! Unless someone else has more to say on this one.
08:22:45 <diablo_rojo> I'll take the silence as a no.
08:22:48 <diablo_rojo> #topic ask.openstack.org monitoring
08:22:59 * diablo_rojo opens tabs to look for new questions
08:23:15 <mattoliverau> I didn't see any
08:23:37 <diablo_rojo> Me neither.
08:23:48 <mattoliverau> well that was an easy topic then :)
08:23:58 <diablo_rojo> Boom. Cruising through this agenda.
08:24:18 <diablo_rojo> #topic Rollover of #openstack-101
08:24:44 <mattoliverau> Any update on this?
08:25:02 <diablo_rojo> This is not done yet. Haven't talked to thingee in a while, but haven't seen movement.
08:25:28 <diablo_rojo> I don't think he would be offended if someone wanted to take this off his plate?
08:25:41 <diablo_rojo> I think he was just being awesome and stepping up cause no one else volunteered.
08:26:17 <mattoliverau> kk, well it's the easter long weekend so I don't plan on doing much this coming week. (between these meetings)
08:27:00 <mattoliverau> let's see what happens by next meeting and then if no one steps up I'll figure out how to do a thing.
08:27:01 <diablo_rojo> mattoliverau, was that a 'I volunteer as tribute since its a long weekend' or a 'not it, its a long weekend' ?
08:27:11 <diablo_rojo> Got it
08:27:16 <mattoliverau> not it, it's a long weekend
08:27:20 <diablo_rojo> Noted.
08:27:25 <diablo_rojo> I think it can wait another week.
08:27:35 <mattoliverau> but also a I volunteer.. so really it was both
08:27:48 <diablo_rojo> Ha ha works for me.
08:27:54 <gmann_> :-)
08:28:01 <diablo_rojo> if you need the directions I can find them again for you mattoliverau
08:28:16 <mattoliverau> cool, I'm sure I'll ask after next meeting :P
08:28:34 <diablo_rojo> Ha alright :)
08:28:38 <diablo_rojo> #topic Forum Discussion Planning
08:28:58 <diablo_rojo> #link https://etherpad.openstack.org/p/FC_SIG_Rocky_Forum Planning Etherpad
08:29:33 <diablo_rojo> Looks like fungi added a second idea to the etherpad
08:29:42 <mattoliverau> I think it would be cool to have some time to all meet up face to face.. and potentually trick more people into helping
08:29:50 <diablo_rojo> mattoliverau, +1
08:30:01 <diablo_rojo> I think that is part of the goal behind idea #1
08:30:33 <diablo_rojo> idea #2 is more pratical- a draft planning session of what contributors need allowed from their companies to actually contribute back to the community
08:30:35 <gmann_> And open time for all new people or company representative if they have any query etc
08:30:53 <diablo_rojo> gmann_, yeah they could fit in both discussions
08:30:56 <diablo_rojo> I think
08:31:30 <diablo_rojo> The second idea is an expansion on a discussion that started with the tc
08:31:38 <diablo_rojo> #link https://etherpad.openstack.org/p/Contributing_Organization_Guide
08:31:45 <mattoliverau> oh #2 is interesting. if that is happening getting an idea of all the problems so we can try and solve some would be good
08:32:03 <persia> One of the issues we've had with the #2 discussion in the past is that we often don't have representatives from companies that don't have lots of contributors, which makes the discussion theoretical.  Would the audience from FC_SIG likely include such representatives?
08:32:26 <mattoliverau> ^ that
08:32:35 <mattoliverau> I was just going to say something similar
08:32:53 <mattoliverau> I've love for us to talk about it, but without someone who has the issues present it's hard
08:33:10 <cmurphy> I won't put him on the spot but I'll ask one of our keystone contributors to be present, he was useful about shedding some light on these things at the TPG
08:33:17 <cmurphy> PTG*
08:33:32 <persia> I've anecdotal reports from a few companies (including some in China), but if there is a good way to get folk to explain what might be hard, that would be hugely helpful in terms of documenting it.
08:33:34 <diablo_rojo> If we propose that topic (probably jointly with the tc) I would like to broadcast its happening as widely as possible to get some of those representatives
08:33:36 <gmann_> Ok, bcz it is hard to find new developers in summit due to budget
08:33:37 <mattoliverau> cmurphy: cool, if you could, that'll be awesome.. no pressure tho, on him
08:34:05 <diablo_rojo> If we know what companies struggle with it- we can definitely do more targeted outreach too
08:34:45 <mattoliverau> persia: anecdotal is better then nothing.. so could be a start.
08:35:10 <diablo_rojo> We can have the discussion with as many people as we can get there.
08:35:43 <diablo_rojo> It could be a living document too- updating as we go.
08:35:45 <mattoliverau> I've noticed Swift reviews from China but they never show up in channel.. I wonder if they've got the same problem. Maybe I'll try and reach out.
08:36:00 <mattoliverau> diablo_rojo: +1
08:36:06 <diablo_rojo> Just having something more formalized would be good to be able to point organizations at
08:36:33 <gmann_> +1
08:36:58 <diablo_rojo> I can try to remember to bring this up in the TC meeting tomorrow.
08:37:16 <cmurphy> anecdotally, it's sometimes technical and part social - hard to participate in a synchronous conversation if you're not confident in your english skills
08:37:24 <mattoliverau> diablo_rojo: good idea.. if you remember :) (I know it's late there)
08:37:31 <diablo_rojo> cmurphy, true
08:37:51 <mattoliverau> cmurphy: +1
08:38:09 <persia> Or find counterparties before 8 or 9 UTC :)
08:38:12 <diablo_rojo> I would like if it was only social barriers and not technical ones- if we could get all the companies in OpenStack to be on the same page with letting their contributors participate...
08:38:15 <cmurphy> persia: that too
08:38:19 <diablo_rojo> think of how much more action we would see :)
08:39:37 <diablo_rojo> So I guess thats two forum discussions we can propose. I can start drafting abstracts this week/weekend for review next week. Forum submissions close the 15th I think?
08:40:07 <diablo_rojo> Anyone ever proposed one before?
08:41:02 <mattoliverau> yeah, but it want only a few lines and aimed at operators
08:41:13 <mattoliverau> seemed to work at least for atlanta
08:41:16 <mattoliverau> PTG
08:41:34 <gmann_> For usual operator feedback it works well :-)
08:41:35 <mattoliverau> if you write something up I'm happy to review it
08:41:59 <mattoliverau> not that I'm a wordsmith or anything.. I'm Australian.. I only know bad english
08:42:08 * diablo_rojo can look at the application to see if there are other questions, just being lazy currently
08:42:45 <diablo_rojo> And last topic!
08:43:04 <diablo_rojo> #topic Cleaning up sanbox and & sandbox-ci patches
08:43:23 <diablo_rojo> I wrote a thing to post on old patches.
08:43:26 <diablo_rojo> Hello! Thank you for your first patch :) I see that it has gone untouched for quite a while so in an effort   to clean up this repository, I will abandon it. If you would like it to be restored or have any other questions about how to contribute upstream, please reach out to myself ($IRCNICK) or any of the other First Contact SIG members[1] on IRC in the #openstack-dev channel. [1] https://wiki.openstack.org/wiki/First_Contact_SIG
08:43:39 <mattoliverau> nice words
08:44:09 <cmurphy> Maybe add a link to the new contributor guide?
08:44:20 <gmann_> Looks good. +1
08:44:21 <diablo_rojo> Thank you. I wrote them when I hadn't been up for 18 hours and only slept for 6 the night before :)
08:44:22 * cmurphy also not bothered by just leaving those patches open
08:44:23 <persia> Just to confirm: that's only for changes that are single changes by unique submitters where no patch to any other repo predates that change?
08:44:30 <diablo_rojo> cmurphy, yeah that would be a good addition.
08:44:41 <persia> If not, maybe replace "first" with "experimental" or "sandbox".
08:45:14 <diablo_rojo> persia, talking about the literal sandbox repo and for new contributors and for patches that are circa 2+ years ago
08:45:27 <cmurphy> persia: they are patches that get reviewed by the "welcome new contributor" bot which only reviews people's first submission
08:45:46 <persia> diablo_rojo: Just wanted to confirm it was really "new contributors", as I know my first change to the sandbox project wasn't my first change submitted to gerrit :)
08:45:56 <mattoliverau> the search though is looking for the new contributor message, so I guess they could have pushed a patch elsewere though right?
08:46:12 <diablo_rojo> persia, good clarification
08:46:21 <persia> mattoliverau: I think the new contributor bot looks gerrit-wide, so it really is just first changes submitted.
08:46:22 <diablo_rojo> mattoliverau, yeah since that one they could have pushed another
08:46:44 <diablo_rojo> I suppose I didnt look at the few I wrote that on and abandoned to see if they had other open patches
08:47:03 <mattoliverau> we could write a tool to look for that though.
08:47:43 <diablo_rojo> mattoliverau, at this point I just use the gerrit query, but yeah could do that
08:47:54 <gmann_> Both cases we need to abandon and I think same msg works ok
08:48:26 <mattoliverau> I have some old code we used to use for looking for possibly abandoned swift patches. Maybe I'll see if it still works (api the same), and then do a new contrib + sandbox then a follow up search on the results to get a list of 1 time contribs and only in sandbox.
08:48:29 <mattoliverau> gmann_: true
08:48:48 <diablo_rojo> mattoliverau, that would be cool.
08:49:03 <diablo_rojo> Either way, not that pressing.
08:49:18 <diablo_rojo> And thats the last planned topic I had :)
08:49:22 <diablo_rojo> #topic AOB?
08:49:46 <diablo_rojo> cmurphy, any interest in coming to help us run Upstream Institute? :)
08:49:57 <diablo_rojo> mattoliverau, can attest to how fun it is :)
08:50:04 <cmurphy> sure
08:50:12 <mattoliverau> oh yeah it's great.. especially the people!
08:50:19 <mattoliverau> about that on my end..
08:50:35 <diablo_rojo> mattoliverau, we need you!
08:50:36 <cmurphy> I've never looked into it, I suppose it involves making it to the summit a couple of days early?
08:50:51 <diablo_rojo> cmurphy, correct- its saturday and sunday before the summit starts
08:51:05 <cmurphy> so would need buy-in from my employer
08:51:25 <cmurphy> also not sure yet what the board meeting schedule is
08:51:37 <diablo_rojo> We do genuinely need a keystone rep.
08:51:55 <gmann_> Usually it is same day on Sunday. Last time it was at least
08:52:05 <mattoliverau> diablo_rojo: I hate to be the bearer of bad news, but I can't make OUI this summit (though I really wanted to be there).. turns out months ago we got our babymoon dates wrong by only a few days, so will kinda be on a beach in Fiji until the Sunday of Vancouver. I thought it was planned ending the weekend before.. seriously it wasn't planned to conflict because I'd planned to be at OUI.
08:52:10 <diablo_rojo> cmurphy, yeah that does get in the way. smcginnis usually comes for part of the time and then ducks out to the board meeting when he needs to
08:52:46 <cmurphy> mattoliverau: i'm so sorry for you
08:52:47 <mattoliverau> cmurphy: if it helps my employer was happy with me doing it last time :)
08:52:56 <cmurphy> mattoliverau: that does help ;)
08:53:11 <mattoliverau> cmurphy: I know.. it's going to be hard.
08:53:12 <cmurphy> diablo_rojo: i can probably follow smcginnis's lead there
08:53:16 <diablo_rojo> I love the scathing sarcasm there
08:53:25 <gmann_> mattoliverau: v ll miss u there
08:53:30 <mattoliverau> cmurphy: but it was serously a mistake that we tried to change
08:53:37 <diablo_rojo> cmurphy, cool :) We would love to have you.
08:54:05 <cmurphy> awesome
08:54:27 <diablo_rojo> mattoliverau, we will need to find a different Australian to stand in for you this round.
08:54:45 <gmann_> :-)
08:54:45 <mattoliverau> diablo_rojo: I promise to do extra work during the forum
08:55:02 <diablo_rojo> mattoliverau, I'm holding you to that :P
08:56:22 <mattoliverau> if you want I'll send photos from the fiji resort :P
08:56:29 <diablo_rojo> cmurphy, as we get closer I can pull you into the planning stuff. For now theres not much to do besides work on adding to the contributor guide and rip out content from the old slides. Maybe update some exercises.
08:57:09 <cmurphy> diablo_rojo: cool, i'm also adding the meetings to my calendar
08:57:16 <diablo_rojo> cmurphy, awesome :)
08:57:21 <diablo_rojo> mattoliverau, :P
08:57:37 <diablo_rojo> Anyone got anything else in our last three minutes?
08:58:17 <diablo_rojo> two...
08:58:46 <mattoliverau> I think you can go to bed a little early diablo_rojo
08:58:50 <mattoliverau> :P
08:59:06 <diablo_rojo> one..
08:59:29 <diablo_rojo> Okay I'm going!
08:59:33 <diablo_rojo> #endmeeting