08:00:19 <diablo_rojo> #startmeeting fc_sig
08:00:20 <openstack> Meeting started Wed Apr 18 08:00:19 2018 UTC and is due to finish in 60 minutes.  The chair is diablo_rojo. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:23 <openstack> The meeting name has been set to 'fc_sig'
08:00:29 <diablo_rojo> gmann, mattoliverau, cmurphy
08:00:29 <cmurphy> o/
08:00:34 <diablo_rojo> cmurphy, hello :)
08:00:41 <cmurphy> sorry i missed last week, was on vacation
08:00:46 <gmann> o/
08:00:57 <diablo_rojo> cmurphy, no problem :) Go somewhere fun?
08:01:11 <cmurphy> diablo_rojo: yes! I went to Iceland
08:01:28 <diablo_rojo> cmurphy, OH MAN thats awesome!
08:01:41 <diablo_rojo> Favorite part?
08:02:05 <gmann> great
08:02:07 <cmurphy> the auroras and the giant glacier
08:02:26 <diablo_rojo> Oh yeah I bet the auroras are pretty easy to see there
08:04:11 <diablo_rojo> mattoliverau, said he might be a little late so we can give him a few minutes to show up before we get started
08:04:23 <gmann> yea
08:04:47 <diablo_rojo> #link https://wiki.openstack.org/wiki/First_Contact_SIG#Meeting_Agenda Today's Agenda
08:04:54 <diablo_rojo> in case anyone wants to add anything last minute
08:05:05 <mattoliverau> make it
08:05:10 <mattoliverau> made it
08:05:24 <mattoliverau> tho apparently I can't type
08:06:14 <mattoliverau> diablo_rojo: you can stop watching youtube now :P
08:06:32 <diablo_rojo> mattoliverau, wasn't watching this time :P
08:06:45 <diablo_rojo> So without further ado, lets get this party started!
08:06:58 <diablo_rojo> #topic New contributor patches!
08:08:08 <diablo_rojo> Have we noticed any areas that we are struggling to get a liaison to help with? I can work on filling out the list again.
08:08:33 <mattoliverau> I looked.. there wasn't much in the last 7 days at least.
08:08:38 <diablo_rojo> Tempted to send something to the ML and be like I'm signing up PTL's. If you don't want on my list, find another person to delegate.
08:08:48 <mattoliverau> oh, there are some more from about about 30 mins about now..
08:08:53 <gmann> yes, no new one and almost old one are with review comments
08:10:02 <diablo_rojo> I feel like we've mostly caught up with things, but I wanted to see if anyone else noticed there were places we had holes and things weren't being covered.
08:11:05 <diablo_rojo> Maybe we start circling back to the ones that we added other project cores to that still havent gotten attention?
08:11:12 * diablo_rojo is just spitballing
08:11:37 <mattoliverau> yeah, anything that doesn't have any votes might be good candidates for a relook, even if old
08:11:49 <gmann> yea
08:11:56 <mattoliverau> especially if we find there still on first patchset
08:11:56 <diablo_rojo> Simultaneously there are a lot that are just waiting on updates from these new contributors too.
08:11:59 <mattoliverau> that kinda looks bad
08:12:12 <mattoliverau> yeah, I noticed that too
08:12:22 <diablo_rojo> I suppose if we get super desperate we can email the gerrit email about the patch to see if they aren't working on OpenStack anymore.
08:12:26 <mattoliverau> but hopefully there would be a + or - 1 for those
08:12:27 <diablo_rojo> And abandon if they arent.
08:12:51 * diablo_rojo continues to muse aloud
08:13:06 <gmann> i usually post reply to abandon on gerrit but does not work.
08:13:18 <gmann> asking them on email is good idea
08:13:45 <diablo_rojo> gmann, yeah I suppose if its older than x months we can just abandon with comments on the patch.
08:13:54 <gmann> +1
08:14:03 <diablo_rojo> And if its only y months old we can email and check in to see if they need help or have moved on?
08:14:27 <diablo_rojo> What we want to set as x & y as can be up for debate
08:14:34 <gmann> first we message and after week we abandon. that is usually we do in nova and QA
08:14:43 <mattoliverau> I'll try and find the abandon code I had that would keep track and even email if they looked stale.. I got sidetracked with tags this week.
08:14:55 <diablo_rojo> gmann, oh thats a good system
08:15:04 <diablo_rojo> mattoliverau, no worries, that was super helpful
08:15:22 * diablo_rojo hasn't been the most productive in this area lately
08:15:37 <diablo_rojo> I might be juggling a lot right now lol
08:16:00 <mattoliverau> :(
08:16:23 <mattoliverau> whatever you do, don't burn the cadle from both ends for too long. Don't want you to burn out
08:16:45 <diablo_rojo> So what do we want to make the practice? First comment. X weeks/months with no response and email? Y weeks pass after and then we comment again and abandon?
08:17:05 <mattoliverau> yup
08:17:14 <gmann> perfect
08:17:20 <diablo_rojo> mattoliverau, Just tuesday night/wednesday mornings. The rest of the week I go to bed by like 12 :)
08:17:29 <diablo_rojo> So x be 1 month? Or more?
08:17:36 <cmurphy> we don't necessarily have the power to abandon things, only project cores or the owner can do that
08:17:47 <diablo_rojo> And y be like 1 week?
08:17:50 <diablo_rojo> cmurphy, true
08:17:53 <cmurphy> and different projects might have different policies on abandoning things
08:18:02 <diablo_rojo> I guess it only applies to the projects we can touch.
08:18:07 <diablo_rojo> cmurphy, what does keystone do?
08:18:08 <mattoliverau> my swift abandoner did something similar. a -1 with no updates for 4 weeks, then it'll automatically email. Then wait 2 more weeks and add them to a list for a human to review (slow to auto abandon)
08:18:44 <cmurphy> diablo_rojo: if the patch is clearly going no where we abandon after like a year
08:18:57 <cmurphy> we have some around that are older than that because it's possible they could get picked up again
08:18:57 <mattoliverau> that way a core would have to look at the "possibly" abandoned patch.
08:19:22 <diablo_rojo> cmurphy, okay cool so a little more easy going about things.
08:19:28 <diablo_rojo> mattoliverau, makes sense
08:19:40 <diablo_rojo> its interesting to see how different each project handles things :)
08:20:27 * mattoliverau can blow dust off the old code and look at changing it to suite our needs... and laugh at how bad my coding was back then :P
08:20:40 <diablo_rojo> I guess the more important part about this discussion is emailing them and seeing if they need help rather than the abandoning- thats just my need to clean things up coming through again lol
08:21:06 <cmurphy> ++ reaching out is the important part
08:21:23 <mattoliverau> yeah, I agree. if they're new, we don't want to say.. your only patch might be abandoned.. that's kinda not friendly and scary
08:21:35 <diablo_rojo> mattoliverau, agreed
08:21:42 <gmann> yea
08:21:48 <cmurphy> ++
08:22:43 <diablo_rojo> So maybe nevermind the abandoning part but if we haven't seen any activity in a month we should email (and probably post a comment saying we have done for the sake of organization)
08:22:58 <cmurphy> +++
08:23:09 <diablo_rojo> Oh wow an extra '+' :)
08:23:16 <cmurphy> that was an accident
08:23:18 <cmurphy> but i'll stand by it
08:23:33 <diablo_rojo> Dang, and here I thought I had said something that awesome
08:24:03 <diablo_rojo> So new homework then! Go back over the things you've reviewed with no responses and email people :)
08:24:37 <mattoliverau> oh cool, if you want to look at my old bad code.. it's on my github: https://github.com/matthewoliver/swift_abandon_notifier
08:24:41 <diablo_rojo> #action if a new contributor hasn't uploaded a new patchset or posted a reply comment in >= 1 month, send them an email and see if they need help
08:24:51 * diablo_rojo opens tab for tomorrow
08:25:04 <mattoliverau> it doesn't actually abandon, just makes a list of things that need follow up.. ie an email has been sent and still no response
08:25:07 <diablo_rojo> Do we want to come up with some sort of generic template email?
08:25:17 <mattoliverau> yup
08:25:22 <diablo_rojo> mattoliverau, sounds like what we want to do
08:25:41 * diablo_rojo can add that to her todo list for between now and the next meeting
08:25:52 <diablo_rojo> In the meantime, feel free to wing it.
08:26:10 <diablo_rojo> Anything else on this topic?
08:26:26 <gmann> and how we list patch that who emailed, to avoid multiple emails  :)
08:26:53 <mattoliverau> that's what the tool was for :)
08:27:13 <diablo_rojo> action item for you then mattoliverau :)
08:27:15 <mattoliverau> I'll try setting it up and having a play before next week.
08:27:38 <gmann> cool
08:27:46 <diablo_rojo> #action mattoliverau will try to get his abandon_notifier script up and running for next weeks meeting
08:28:19 <diablo_rojo> Oh! and one last thing- my new storyboard contributor hasn't gotten their first patch merged yet to be the new contrib of the month so..we could probably do someone else in the meantime
08:28:23 <diablo_rojo> So..
08:28:24 <mattoliverau> ...and maybe change it's name :)
08:28:29 <diablo_rojo> mattoliverau, that too :)
08:30:01 <diablo_rojo> Next topic?
08:30:01 <mattoliverau> Well I don't have anyone in mind, so yours might just have to be _next_ months contributor of the month :)
08:30:01 <diablo_rojo> Works for me
08:30:01 <mattoliverau> we did say it didn't have to be every month
08:30:02 <diablo_rojo> True
08:30:10 <mattoliverau> but if I see anyone I'll ping y'all
08:30:16 <diablo_rojo> I remember that discussion from last meeting
08:30:20 <diablo_rojo> Okay moving on then.
08:30:25 <diablo_rojo> #topic Ask.o.o
08:30:44 <diablo_rojo> So, no new things that I saw, but it seems we have a lot of new tags we could look at that mattoliverau found
08:30:57 * diablo_rojo is combining standing items with other items
08:31:31 <mattoliverau> that's ok
08:31:37 <gmann> yea no new question there. though i replied nova and qa one which were not related to new contributors
08:31:38 <diablo_rojo> I agree community, development, developer, and gettingstarted could be added to our list
08:31:43 <mattoliverau> I didn't know where to put the list, so added it to the end
08:32:16 <diablo_rojo> mattoliverau, works just fine.
08:32:58 <diablo_rojo> I feel like basics, beginner, newbie and noob (or n00b if you prefer) are all generic enough that we might get a lot of operations-y things in with them
08:33:12 <mattoliverau> yeah
08:33:18 <diablo_rojo> That being said, once we get some operator friends in our awesome group I am 100% cool with adding those as well
08:33:29 <mattoliverau> though if we have to filter with our eyes a little it isn't too bad
08:33:29 <diablo_rojo> I just would be less helpful at responding to those.
08:33:39 <diablo_rojo> mattoliverau, fair point
08:33:52 <mattoliverau> I mean, it wouldn't mean we'd reply to everything that turned up.
08:34:07 <diablo_rojo> True.
08:34:11 <mattoliverau> I picked the tags that might include people looking for help contributing
08:34:28 <mattoliverau> but yeah, some seem too general.
08:34:31 <diablo_rojo> Yeah I can see myself using those if I was new still :)
08:35:02 <diablo_rojo> I also haven't heard back from Jimmy about if there were any he wanted us to add to our list.
08:35:30 <diablo_rojo> I dunno. Thoughts from gmann or cmurphy ?
08:35:32 <mattoliverau> I just went through the list.. found a bunch. Then went and did a search in ask.o.o for each one. Things that came up with nothing.. removed from the list. Things that popped up that _could_ potentually be relevent I kept in. Though your right there is alot of overlap..
08:36:03 <diablo_rojo> mattoliverau, obviously we just need ops-y friends to help us and then we can add them all to the list
08:36:09 <gmann> same, all of them (mentioned on wifi)are good to track
08:36:30 <mattoliverau> I erred on the side of keeping things in, cause there easy to remove.. but not necessarily easy to find again (crazy wall of tags)
08:36:30 * gmann was trying to build single query with all tags but need to check later
08:36:41 <mattoliverau> diablo_rojo: great idea!
08:36:46 <mattoliverau> :P
08:36:50 <diablo_rojo> gmann, yeah we can do that later
08:37:15 <diablo_rojo> mattoliverau, I submitted the forum topic and reserved space if it doesn't get accepted so it will be on the schedule one way or another
08:37:24 <diablo_rojo> That's about all I can do right now.
08:37:46 <diablo_rojo> Once forum topics are chose I plan to tweet up a storm about all my sessions
08:37:47 <mattoliverau> I know, you've done great!
08:38:00 <diablo_rojo> *chosen
08:38:21 <diablo_rojo> I am kind of getting ahead of the agenda..
08:38:29 <diablo_rojo> Sticking to tags for now.
08:38:41 <mattoliverau> I think you've just rolled the rest of the topics into 1 :P
08:39:02 <diablo_rojo> So adding community, development, developer, and gettingstarted
08:39:22 <cmurphy> sounds good
08:39:28 <diablo_rojo> gmann, did you want to make a query for all of them and update the agenda with it?
08:39:47 <gmann> diablo_rojo: yea
08:39:58 <diablo_rojo> Cool thanks :)
08:40:07 <diablo_rojo> Okay so next topic?
08:40:10 <mattoliverau> yup
08:40:11 <gmann> yea
08:40:18 <diablo_rojo> #topic #openstack-101 is no more!
08:40:31 <diablo_rojo> Self explanatory
08:40:35 <gmann> \o/
08:40:45 <diablo_rojo> But thanks to mattoliverau and dmsimard|off for getting that done :)
08:41:06 <gmann> thanks mattoliverau  dmsimard|off
08:41:21 <diablo_rojo> Thank you also for updating the training-guides OUI slides too.
08:41:29 <diablo_rojo> mattoliverau, ^^
08:41:41 <mattoliverau> no worries. I went on an openstack-101 hunt :)
08:41:56 <diablo_rojo> KILL ALL THE 101 MENTIONS
08:42:21 <mattoliverau> and turns out getting an irc channel removed... not too hard. if you have infra's help of course ;)
08:42:23 <diablo_rojo> I thiiiink there is a master list of channels in a wiki somewhere? Might want to find that and update it too.
08:42:34 <diablo_rojo> If there is one and I am not crazy.
08:42:47 <mattoliverau> oh yeah, there could be. good point
08:42:51 <diablo_rojo> mattoliverau, good to know
08:43:15 <diablo_rojo> So much duplicated info. It will be a wonderful day when the contributor guide is the source.
08:43:22 <mattoliverau> +100
08:43:38 <gmann> true
08:43:42 <diablo_rojo> Anywho, next topic!
08:43:47 <diablo_rojo> #topic Forum Planning
08:43:57 <diablo_rojo> So we have the two proposed forum topics
08:44:04 <diablo_rojo> I think we are into voting now or something?
08:44:12 * diablo_rojo can't remember exactly how that works
08:44:31 <gmann> no voting actually but yes we can comment.
08:44:40 <gmann> i think i did for both
08:44:41 <diablo_rojo> I had seen that cdent and gmann had commented on the orgazing base reqs for contribution one
08:44:50 <diablo_rojo> Will have to look at the other.
08:44:58 <diablo_rojo> But yes! please comment and promote :)
08:45:05 <mattoliverau> oh, we can comment. I'll try and remember to do that thing tomorrow
08:45:16 <diablo_rojo> mattoliverau, awesome :)
08:45:36 * diablo_rojo goes to look up when decisions will be made by
08:46:20 <diablo_rojo> Next week ish?
08:46:28 <diablo_rojo> #link https://wiki.openstack.org/wiki/Forum
08:46:34 <diablo_rojo> April 22nd?
08:46:45 <diablo_rojo> Or May 2 for final decisions and scheduling?
08:46:53 <mattoliverau> oh.. ok that's soon
08:47:03 <diablo_rojo> Not sure who is actually on the Forum Selection Committee either
08:47:14 <diablo_rojo> 2 delegates from the Technical Committee
08:47:14 <diablo_rojo> 2 delegates from the User Committee
08:47:14 <diablo_rojo> 2 OpenStack Foundation staff members
08:47:21 <diablo_rojo> But no names
08:47:36 <mattoliverau> cmurphy is a little quiet.. hmm.
08:47:45 <mattoliverau> :P
08:47:46 <diablo_rojo> I can't believe how close we are to the end of April already.
08:47:56 <gmann> :)
08:48:05 <mattoliverau> yeah. isn't the 22nd a Sunday.
08:48:17 <gmann> cmurphy has to play both role :)
08:48:25 <mattoliverau> I guess that's ok. I'd have thought it would be a Friday or something. but 2 extra days is good
08:48:57 <diablo_rojo> #link http://forumtopics.openstack.org/cfp/details/85 Forum Topic on Forming base reqs
08:49:17 <cmurphy> i'm not on the selection committee
08:49:18 <diablo_rojo> #link http://forumtopics.openstack.org/cfp/details/84 Forum topic on getting ops involved and doing a state of the union
08:49:26 <diablo_rojo> ^^ links for commenting on :)
08:49:34 <diablo_rojo> cmurphy, any idea who is?
08:49:42 <cmurphy> I think it's TheJulia and pabelanger
08:49:58 <diablo_rojo> Cool. Good to know :)
08:50:21 <diablo_rojo> I think that was all I had for that topic. Anyone else got anything else?
08:50:29 <diablo_rojo> (10 min left)
08:50:56 <mattoliverau> nope
08:51:03 <gmann> nothing from me
08:51:06 <diablo_rojo> #topic Open Discussion
08:51:21 <diablo_rojo> cmurphy, did you find out if you can come early to Vancouver for OUI?
08:51:40 <diablo_rojo> mattoliverau, I think you have a patch in the contrib guide that has comments on it that needs addressing.
08:51:46 <diablo_rojo> about the ssh keys
08:52:07 <mattoliverau> diablo_rojo: oh cool, I'll take a look
08:52:46 <cmurphy> diablo_rojo: I will be there Sunday so I can probably come in the morning for OUI but I'm not sure if it's that helpful to only come for part of one day
08:52:57 <diablo_rojo> mattoliverau, yeah ianychoi commented but voted 0 so you wouldnt know if you didn't go look at it
08:53:12 <diablo_rojo> cmurphy, we will take all the help we can get :)
08:53:32 <cmurphy> okay then I'll show up :)
08:53:37 <mattoliverau> diablo_rojo: ahh, thanks for the heads up.
08:53:38 <diablo_rojo> Come, hang out (we ususally have breakfast) and then you can sneak out when smcginnis does
08:53:43 <diablo_rojo> mattoliverau, no problem :)
08:54:00 <cmurphy> breakfast ftw
08:54:37 <diablo_rojo> Yeah, we have a sponsor I think so there should be food. If not, mtreinish has a habit of showing up with donuts and things.
08:55:03 <diablo_rojo> Thankfully the gym I go to has a location in the convention center lol
08:55:09 <mattoliverau> oh yeah, the donuts!!
08:55:13 <gmann> or i can bring japanese fruite cake or somehting :)
08:55:28 <gmann> fruit rice cake :)
08:55:29 <diablo_rojo> mattoliverau, you need to send along tim tams
08:55:38 <diablo_rojo> gmann, sounds fancy :)
08:55:41 <mattoliverau> lol, I should.
08:55:45 <gmann> tim tams wow
08:55:50 <diablo_rojo> mattoliverau, yes you should :)
08:55:58 <diablo_rojo> (five min left)
08:56:28 * diablo_rojo should have had that monster closer to 8 rather than 10
08:57:13 <cmurphy> :'D
08:57:21 <diablo_rojo> :D
08:58:05 <diablo_rojo> I think that concludes all the things I wanted to talk about.
08:58:12 <mattoliverau> I think we might be done. diablo_rojo, did you want an early mark and get some sleep?
08:58:19 <diablo_rojo> If there's nothing else from anyone we can call it.
08:58:47 <mattoliverau> call it... do it.. you know you wanna
08:58:52 <diablo_rojo> mattoliverau, if I can- a little wired right now, but I should go to sleep since I have another meeting in like..6 hours.
08:58:52 <gmann> yea
08:59:11 <diablo_rojo> Okay calling it!
08:59:16 <diablo_rojo> Thanks everyone :)
08:59:20 <gmann> thanks :)
08:59:23 <diablo_rojo> #endmeeting