08:01:52 <mattoliverau> #startmeeting fc_sig
08:01:53 <openstack> Meeting started Wed Jun 27 08:01:52 2018 UTC and is due to finish in 60 minutes.  The chair is mattoliverau. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:55 <gmann> fc_sig
08:01:57 <openstack> The meeting name has been set to 'fc_sig'
08:02:17 <mattoliverau> Welcome everyone, and seems I don't need to go ping anyone :)
08:02:25 <diablo_rojo_phon> Off to a good start :)
08:02:43 <mattoliverau> diablo_rojo_phon: is here, but in an airport so I'll press buttons and make mistakes in her stead :P
08:02:59 <diablo_rojo_phon> Much appreciated :)
08:03:21 <mattoliverau> the regulars are here so shall we just start?
08:04:01 <mattoliverau> #link https://wiki.openstack.org/wiki/First_Contact_SIG#Meeting_Agenda Meeting Agenda
08:04:19 <mattoliverau> Lets go then
08:04:21 <mattoliverau> #topic New Contributor Patches
08:04:33 <mattoliverau> So who did their homework?
08:04:55 <mattoliverau> diablo_rojo_phon: you had plenty of plane time, you could have been using gertty ;)
08:04:55 * gmann updated the meeting name info  on wiki
08:05:05 <mattoliverau> gmann: nice work!
08:05:15 * diablo_rojo_phon shifts uneasily and doesn't make eye contact with mattoliverau
08:05:20 <mattoliverau> lol
08:05:34 <gmann> sorry i have not looked on the home work this week
08:05:43 <gmann> not sure if there is any new things.
08:05:58 <ianychoi> Hello :)
08:06:06 <mattoliverau> I had a look, there were a few things, 1 for cinder, so will leave with diablo_rojo_phon :P
08:06:10 <ianychoi> me did it on Wiki page
08:06:17 <mattoliverau> ianychoi: o/ welcome
08:06:26 <ianychoi> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#First_Contact_SIG
08:06:52 <ianychoi> I added brief explanation on first contact sig in cross project liaisons wiki page
08:06:58 <gmann> ianychoi: nice
08:07:06 <mattoliverau> thanks ianychoi
08:07:19 <ianychoi> mattoliverau, gmann: It's my pleasure :)
08:07:34 <diablo_rojo_phon> I'll check it out :)
08:07:38 <mattoliverau> A few of the new contributor patches already had reviews, which is good
08:07:50 <diablo_rojo_phon> Thanks ianychoi !
08:07:56 <gmann> i just pushed the patch to mention firstcontact sig liaison as dedicated duty - https://review.openstack.org/#/c/578306/1
08:07:58 <gmann> #link https://review.openstack.org/#/c/578306/1
08:08:01 <ianychoi> diablo_rojo_phon, you're welcome :)
08:08:41 <mattoliverau> I took the slogging one, as it's kinda swift related. and I tracked down a slogging dev I met at the last PTG, to get him in on the review
08:08:46 <gmann> may be both wiki and PTL page is good to remind PTL about allocating the liaison
08:09:17 <diablo_rojo_phon> Dedication mattoliverau :)
08:09:27 <diablo_rojo_phon> Yeah that would be good gmann
08:09:28 <mattoliverau> if not, they'll find out when we keep annoying them ;)
08:10:09 <mattoliverau> I still have a patch or 2 open in a tab.. so will hopefully finish my homework tomorrow
08:10:38 <mattoliverau> Any else to discuss on the new contributor patches?
08:10:42 <diablo_rojo_phon> Better late than never :)
08:10:48 <diablo_rojo_phon> I don't think so.
08:10:52 <mattoliverau> *anything else
08:10:59 <mattoliverau> cools. let's move on
08:11:13 <gmann> nothing
08:11:25 <mattoliverau> #topic ask.openstack.org questions
08:11:37 * diablo_rojo_phon shifts again
08:11:38 <mattoliverau> This can be quick. I looked and again nothing new.
08:12:09 <mattoliverau> it's good we're looking but so far nothing.
08:12:10 <gmann> yea there is no new query
08:12:29 <diablo_rojo_phon> I forgot to make the etherpad for brainstorming questions to seed it with
08:13:01 <mattoliverau> diablo_rojo_phon: geesh, what have you been doing? travelling around the world in a small metal tube for most of the last few weeks?
08:13:20 <diablo_rojo_phon> Something like that.
08:14:06 <diablo_rojo_phon> I'll be home for a whole week when I go back- it will also be a US holiday but still.
08:14:20 <mattoliverau> lol
08:14:36 <mattoliverau> you need holidays too.
08:15:01 <gmann> US holiday full week ?
08:15:13 <mattoliverau> I'll try and take another look around ask.o.o and see if we can find anything better or even if people are asking new contributor questions there
08:15:51 <diablo_rojo_phon> Not a full week no. A day or two.
08:16:01 <gmann> ok
08:16:07 <diablo_rojo_phon> Sounds good mattoliverau
08:16:24 <diablo_rojo_phon> gmann: it's just annoying cause it's smack in the middle of the week.
08:17:07 <mattoliverau> Unless there's anything else, shall we move on?
08:17:24 <gmann> yeah, we can move next
08:17:27 <ianychoi> +1 :)
08:17:49 <diablo_rojo_phon> We can move on :)
08:18:32 <mattoliverau> oh, we never talked about new contribitor of the week.. should be do that thing or just move on?
08:19:50 <diablo_rojo_phon> Methinks we can move on for now..
08:19:59 <mattoliverau> great :)
08:20:37 <mattoliverau> #topic Reqs for Organisations Contributing to OpenStack
08:21:05 <diablo_rojo_phon> So how's that going? ;)
08:21:44 <mattoliverau> So I'll admit I've failed to submit a patch to the contributor guide.. so my bad. I did think about doing it today, and planned too but got sidetracked with work and support in the swift channel.
08:22:51 <mattoliverau> please start complaining at me, making fun of me, and poking me everyday if I don't do it by next meeting :P
08:23:13 <gmann> :)
08:23:14 <diablo_rojo_phon> That's alright. It would be good to have before the 9th of July so I can show it at the staff offsite.
08:23:35 <diablo_rojo_phon> I can set a due date mattoliverau. Would that help?
08:24:12 <mattoliverau> it might actually :P 9th of july is good. But i'll try and get it up in a few days. it doesn't have to be a large patch just a place holder.
08:25:11 <mattoliverau> cool, so that's on me. let's move on
08:25:28 <diablo_rojo_phon> Sounds good :) Will keep an eye out.
08:26:19 <mattoliverau> #action mattoliverau to push the placeholder patch for the Organisations Contributing to OpenStack doc to the contributor guide
08:26:29 <diablo_rojo_phon> Nice.
08:26:31 <mattoliverau> #topic Project Liaisons
08:26:33 <diablo_rojo_phon> Official now.
08:26:48 <mattoliverau> yup, look at me being or fancy
08:26:55 <mattoliverau> the powers going to me head :P
08:26:56 <diablo_rojo_phon> I also did not send this email yet telling them they are on the hook yet..
08:27:03 <diablo_rojo_phon> Hahaha
08:27:11 <mattoliverau> \o/ we're winning
08:27:20 <diablo_rojo_phon> I always think about using the action command and then I do not.
08:27:24 <diablo_rojo_phon> But should.
08:27:43 <diablo_rojo_phon> I will send this email tomorrow.
08:27:50 <diablo_rojo_phon> Or Friday at the latest.
08:28:24 <mattoliverau> #action diablo_rojo_phon to send the follow up email to tell PTLs they're on the hook for being the FC liaisons
08:28:34 <mattoliverau> ^ now it's not just me :P
08:28:43 <mattoliverau> cool. I'll race you
08:28:51 <diablo_rojo_phon> Oh jeez. Okay.
08:29:02 <diablo_rojo_phon> What's the loser gotta do?
08:29:08 <mattoliverau> action item race
08:29:39 <mattoliverau> no idea, feel shamed, but know we'll still love em :)
08:30:12 <diablo_rojo_phon> Daww
08:30:34 <mattoliverau> If anyone knows any ptl's timezones and they aren't filled in on the list on our wiki page, please make it so :)
08:30:37 <diablo_rojo_phon> On this topic we should review gmann's patch
08:30:43 <diablo_rojo_phon> That's too!
08:30:45 <mattoliverau> oh yeah
08:30:51 <diablo_rojo_phon> *that
08:31:16 <gmann> #link https://review.openstack.org/#/c/578306/1
08:31:37 <mattoliverau> #action everyone to review https://review.openstack.org/#/c/578306
08:31:47 <mattoliverau> now everyone can join in
08:32:00 <gmann> :)
08:32:12 <diablo_rojo_phon> Thanks again for that gmann
08:32:28 <gmann> np!
08:32:28 <mattoliverau> That's all that's on the adjenda so. let's move to open discussion
08:32:36 <mattoliverau> #topic open discussion
08:32:47 <mattoliverau> anything else to bring up or discuss today?
08:33:13 <diablo_rojo_phon> Is there anything we want to submit to the CFP?
08:33:30 <mattoliverau> oh good thinking
08:34:16 <mattoliverau> Shall we attempt to get ops involved again? (and also try and do that thing at the PTG)?
08:34:43 <gmann> nice idea. PTG is good place to get them involve
08:34:47 <diablo_rojo_phon> Definitely already have a day for us at the ptg.
08:34:56 <mattoliverau> nice
08:35:03 <diablo_rojo_phon> The summit thing I can submit forum things once those open.
08:35:17 <diablo_rojo_phon> But for regular presentations the CFP closes the 17th
08:35:24 <mattoliverau> though a reminder that I can't make the PTG as I'
08:35:52 <mattoliverau> I'll be having my second child around then
08:36:26 <diablo_rojo_phon> Boo
08:36:36 <diablo_rojo_phon> We'll have to do a hangout to get you there.
08:36:42 <gmann> also how about submitting a presentation sessions idea also to give overview of FirstContact SIG and how people can take help from us ... how to get new people involve and how new people can get involved
08:36:46 <cmurphy> do we want to talk about the stats gaming problem and how to address it? http://eavesdrop.openstack.org/irclogs/%23openstack-tc/%23openstack-tc.2018-06-26.log.html#t2018-06-26T13:49:11
08:36:53 <mattoliverau> but cmurphy, gmann, diablo_rojo_phon and ianychoi I hope y'all be there and I know you guys will be awesome :)
08:36:59 <diablo_rojo_phon> To clarify: boo on not coming. Congratulations on the second child :)
08:37:15 <mattoliverau> well when she's born, I wont be sleeping again, so timezone wont be an issue :P
08:37:16 <cmurphy> yay babies ^.^
08:37:28 <diablo_rojo_phon> cmurphy: sure
08:37:47 <diablo_rojo_phon> Something we should be educating new contributors on.
08:37:59 <mattoliverau> gmann: that's a good idea.
08:38:06 <diablo_rojo_phon> I think in general we just avoid talking about stackalytics at all.
08:38:21 <diablo_rojo_phon> In OUI at least.
08:39:22 <cmurphy> does the contributor guide have a "how to review" for noobs section?
08:39:48 <cmurphy> maybe we can start looking for these spammy reviews and try to direct people at better guidelines
08:40:08 <gmann> +1
08:41:08 <mattoliverau> we have https://docs.openstack.org/contributors/code-and-documentation/using-gerrit.html#reviewing-changes but it isn't that detailed in guidelines
08:41:28 <mattoliverau> it isn't bad. but maybe not what you mean
08:41:46 <mattoliverau> as in it's how to review, but not "how" to review :)
08:41:59 <cmurphy> yeah, we also have this https://docs.openstack.org/project-team-guide/review-the-openstack-way.html but that was the results of the nitpicking discussion and not so much for noobs
08:42:18 <mattoliverau> yeah
08:42:27 <mattoliverau> I was looking for that link
08:43:29 <mattoliverau> In swift we also have: https://github.com/openstack/swift/blob/master/REVIEW_GUIDELINES.rst
08:44:18 <cmurphy> those are some good guidelines
08:44:38 <cmurphy> they could probably be copied over to the general contributor guide
08:45:24 <mattoliverau> yeah, I was going to mention them in the review the openstack way thread, but came it a little late and the patch landed.
08:45:45 <diablo_rojo_phon> The contributor guide has basic stuff and a link to the thing that Zane wrote.
08:45:56 <diablo_rojo_phon> We can definitely expand and edit where necessary though.
08:45:57 <mattoliverau> some are obviously swift specific but I there are general stuff there too
08:47:11 <gmann> yeah i like to have those(written in swift) in some general place and i can point to those in QA review guidelines also. those are nice as generic
08:47:23 <mattoliverau> but a "the first contact SIG: who are we and what do we do and how to get involved" talk as gmann suggested might be a good submission too, for a community presentation
08:48:25 <mattoliverau> we just put it in the source tree, so devs can't say they haven't seen the file sitting there :P
08:49:07 <diablo_rojo_phon> Could do it as a panel or just a lightning talk.
08:49:30 <diablo_rojo_phon> Lol that's a good tactic.
08:49:37 <mattoliverau> yeah, all of the above. Let's create a etherpad and put down ideas :)
08:49:38 <gmann> panel also sounds good
08:50:51 <mattoliverau> I'll create the etherpad and add it to our wiki page.
08:51:04 <gmann> cool, thanks
08:51:07 <mattoliverau> y'all can help fill it with topics
08:51:15 <diablo_rojo_phon> Thanks mattoliverau!
08:51:18 <diablo_rojo_phon> Yes definitely
08:52:07 <mattoliverau> #action mattoliverau to create etherpad to gather thoughts for summit CFP
08:52:42 <mattoliverau> great, anything else or should be have an early mark and let diablo_rojo_phon go enjoy Seoul?
08:53:10 <diablo_rojo_phon> I think that's all I had..
08:53:22 <gmann> nothing from me
08:53:38 <mattoliverau> anything else cmurphy, ianychoi?
08:53:59 <cmurphy> nope
08:54:55 <mattoliverau> then I'll call it, thanks all for coming, and diablo_rojo_phon go enjoy some korean bbq or a dolsot bibimbap!
08:55:02 <mattoliverau> #endmeeting