07:00:26 <gmann> #startmeeting fc_sig
07:00:27 <openstack> Meeting started Wed Feb 13 07:00:26 2019 UTC and is due to finish in 60 minutes. The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:30 <openstack> The meeting name has been set to 'fc_sig'
07:00:40 <gmann> Ping list: gmann, mattoliverau, cmurphy, tonyb
07:00:44 <diablo_rojo> o/
07:00:47 <cmurphy> heya
07:00:52 <mattoliverau> o/
07:00:56 <tonyb> \o
07:01:59 <gmann> we have full strength today. let's start. i will host meeting today to help diablo_rojo not to awake so late
07:02:25 <gmann> let's go through the home work item
07:02:26 <gmann> #topic New Contributor Patches
07:02:34 <diablo_rojo> Well..not have to think quite as hard
07:02:37 <gmann> #link https://review.openstack.org/#/q/reviewedby:%22Welcome%252C+new+contributor!+(10068)%22+is:open+-project:+openstack-dev/sandbox+AND+-project:openstack-dev/ci-sandbox
07:02:45 <gmann> who all did home work ?
07:02:59 <gmann> i did not find any new patch getting attention
07:03:13 <mattoliverau> I did.. well a quick look anyway
07:03:24 <diablo_rojo> I reviewed efried's patch in the contributor guide repo instead?
07:03:47 <gmann> thanks.
07:03:48 * tonyb did the homework but there wasn't anything I felt I could help with
07:03:53 <gmann> diablo_rojo: that is merged ?
07:03:56 <mattoliverau> there was an openstack client one I delegated ;)
07:04:41 <gmann> mattoliverau: thanks, i saw your reply there.
07:04:57 <gmann> #topic Ask.openstack.org Contribution Questions
07:05:09 <gmann> there is no new question on that.
07:05:25 <gmann> so passing it ?
07:05:47 <mattoliverau> I didn't see one, tho diablo_rojo probably asked some more no doubt :)
07:06:13 <mattoliverau> i'm ok to move on
07:06:28 <gmann> ok
07:06:38 <gmann> #topic Sandbox Bot
07:06:46 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-February/002291.html
07:06:48 <gmann> #link https://review.openstack.org/#/c/636466/1
07:06:51 <gmann> tonyb: your turn
07:07:02 <tonyb> Oh yeah so ...
07:07:07 <diablo_rojo> I did not ask any new one actually.
07:07:20 <tonyb> I sent the rough design to the list and got reasonable feedback
07:07:44 <mattoliverau> nice one tonyb
07:08:04 <tonyb> So now t'all can add 'Bot-Reviewer: Simple' and 'Depends-On: https://review.openstack.org/636466'
07:08:12 <tonyb> like https://review.openstack.org/#/c/636545/
07:08:16 <tonyb> and test out the bot
07:08:24 <tonyb> currently the bot is in 2 halves
07:08:44 <tonyb> one runs in the check pipeline and just logs what it'd do
07:08:56 <mattoliverau> oh nice
07:08:59 <diablo_rojo> WOOHOO!
07:09:00 <tonyb> http://logs.openstack.org/45/636545/2/check/bot-reviewer/8cb4696/job-output.txt.gz#_2019-02-13_05_59_29_760046
07:09:02 <gmann> great
07:09:21 <tonyb> and the second part is runnign on my laptop every 10 mins and actually votes
07:09:35 <tonyb> like https://review.openstack.org/#/c/636545/
07:09:47 <tonyb> look for 'OpenStack bot-reviewer'
07:09:55 <tonyb> currently it's really dumb
07:10:22 <tonyb> it just looks for tagged chnages and replies to PS 1 with 'please publish a new patchset'
07:10:31 <tonyb> and then replies to patchset 2 with +2+W
07:10:53 <tonyb> anything >2 it says 'uum I'm a dumb bot runnign away'
07:11:06 <mattoliverau> lol
07:11:08 <diablo_rojo> Sounds like its most of the way there
07:11:11 <diablo_rojo> Lol
07:11:18 <mattoliverau> great start tho
07:11:33 <diablo_rojo> Yeah. Very good progress.
07:11:37 <tonyb> once we/I play withthe bot a little and tweak it 'til I'm reasonably happy I can more it out of the sandbox repo into project-config
07:12:10 <tonyb> if you want to actually hack on the bot gho for it just bas it on https://review.openstack.org/#/c/636466/
07:12:11 <diablo_rojo> What do you need us to do besides review the patches?
07:12:28 <tonyb> ideas, reviews and light testing
07:12:28 <gmann> tonyb: thanks, nice work. you want more review/testing on sandbox patch or after moving to project-config
07:13:09 * mattoliverau plans to have a play tomorrow :)
07:13:51 <tonyb> go nuts
07:14:03 <gmann> ok, let's review the 636466 and testing, feedback.
07:14:14 <tonyb> I got lots out of it so it was well worth the hours I put in
07:14:52 * diablo_rojo will also send garbage patch tomorrow to play with bot
07:14:59 <gmann> nice, thanks again.
07:15:00 <mattoliverau> that's awesome effort tonyb, thanks!
07:15:12 <gmann> tonyb: anything else on this ?
07:15:12 <tonyb> It doesn't look like the +W is workign as expected
07:15:16 <tonyb> nope
07:15:41 <gmann> tonyb: you mean it does not merge after +W ?
07:15:42 <tonyb> I'm pleased with the progress
07:15:48 <tonyb> gmann: yeah
07:15:57 <gmann> i see
07:16:22 <tonyb> We probably need to think about exactly how we're going to use it in OUI and the contributor guide and teach it more tricks
07:16:22 <gmann> ok, let's check on gerrit. thanks
07:16:30 <gmann> moving next
07:16:33 <gmann> #topic Summit + Forum Planning
07:16:44 <gmann> #link https://etherpad.openstack.org/p/FC_SIG_Denver_forum_topics
07:17:07 <gmann> thanks mattoliverau for creating the etherpad. it is empty so let's put the ideas
07:17:29 <mattoliverau> +1
07:17:37 <gmann> #topic Reqs for Organisations Contributing to OpenStack
07:17:49 <mattoliverau> sandbox bot hacking and brainstorming ;)
07:18:15 <gmann> mattoliverau: your follow up patch is merged, anything else to do in this ?
07:18:33 <gmann> mattoliverau: +1, we can get more ideas for that.
07:18:35 <mattoliverau> Not that I'm aware of, though I haven't really looped back round on it.
07:18:46 <cmurphy> i did https://review.openstack.org/633939 since last meeting
07:19:00 <mattoliverau> I was kinda at sleep school for the baby all weekend + parts of friday and monday, so I'm all over the place this week
07:19:20 <gmann> cmurphy: thanks, that nice.
07:19:24 <gmann> i saw "Will wait for Board of Directors Individual elections to be done before presenting to board"
07:19:36 <gmann> diablo_rojo: ^^ its time for that now ?
07:19:38 <mattoliverau> cmurphy: nice! the power of an action item works
07:19:45 <cmurphy> mattoliverau: ikr
07:20:03 <diablo_rojo> I think the election is done so I just need to push to get on the Agenda
07:20:25 <gmann> thanks
07:20:36 <mattoliverau> diablo_rojo: cool.. sounds like an action item ;)
07:20:36 <diablo_rojo> Ideally not for the one at the summit so I don't have to leave OUI
07:20:53 <diablo_rojo> mattoliverau, yeah...quite possibly
07:21:03 <gmann> #action diablo_rojo to present the organization contributor guide to board
07:21:08 <mattoliverau> \o/
07:21:49 <gmann> anything else on this or move next ?
07:22:49 <diablo_rojo> Nothing else from me
07:23:06 <gmann> #topic Help Wanted List
07:23:10 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-February/002345.html
07:23:45 <gmann> as you all have observed the discussion on help-wanted-list ^^, there are idea of adding the help-wanted list under FC SIG
07:24:00 <gmann> cmurphy: diablo_rojo and myself replied in that.
07:24:52 <gmann> as summary if i am not wrong : diablo_rojo is ok to add under FC SIG, gmann want it under project team , cmurphy : under TC
07:25:16 <gmann> here we can discuss if it is suitable to keep under FC SIG or not
07:25:19 <diablo_rojo> I am fine with it not living with us. It had just sounded like living with the TC wasn't an option anymore and I thought living with us made the most sense.
07:25:20 <mattoliverau> so under all the things
07:26:07 <diablo_rojo> Living with us but written by the projects I guess was what I was thinking
07:26:08 <gmann> diablo_rojo: i agree on not under TC which make me worried of not success again.
07:26:08 <mattoliverau> Depends on how granular the help wanted list will be
07:26:29 <mattoliverau> if it's at the "oh project X need help" then that's one thing
07:26:53 <gmann> on being under FC SIG, i think we will get challenge of not uptodate, help from team on maintaining, mentor mapping etc
07:27:00 <mattoliverau> if its a list of things in each project that projects need help on, then in each project agrigated to somewhere makes sense
07:27:34 <mattoliverau> maybe we manage the agrigation.. ie in the collab guide?
07:27:48 <gmann> mattoliverau: it can be list which need help and mostly it will be from project team side. or some horizontal team where less contributors
07:28:32 <gmann> SIG and pop-up team can be asking to add in this list based on need.
07:28:36 <diablo_rojo> I would agree that it would be challenging to keep projects involved
07:29:01 <mattoliverau> So maybe a help_wanted (or better name) in each developer docs. And then agrigate the list up to collab guide / help wanted.
07:29:21 * mattoliverau is just brainstorming
07:29:54 <mattoliverau> though we'd need a way for cross project or even sigs can get on the list.. so not just dev docs
07:29:57 <mattoliverau> or just projects
07:30:20 <cmurphy> imo the projects who want help and are willing to put up the personhours to do mentoring should apply to be on the list and be approved (by somebody tc or otherwise) the same way we do with the current help wanted list
07:31:29 * mattoliverau wont lie I am ignorant on how the current help_wanted works.
07:31:32 <diablo_rojo> Seems like the format of the psotings just needs to change to be a specific implemention with completion criteria and a mentor
07:31:32 <gmann> additional from current way, it will be mentoring-mapping to that list.
07:31:53 <diablo_rojo> And there needs to be a TC member/champion to beat on the drum
07:32:28 <mattoliverau> does needing a tc champion make it hard to do it outside the tc?
07:32:52 <mattoliverau> or they just want others to manage and then defer to them when the time comes?
07:34:01 <cmurphy> i think that's still part of the question
07:34:40 <mattoliverau> kk
07:35:59 <gmann> yeah, with our FC hat on we can at least conclude that whether the FC a good place to do that or not considering our mission and challenges to do that
07:36:37 <gmann> where it can be otherwise is next question.
07:37:21 <diablo_rojo> I think if the TC doesn't own it, I would vote for it to live here. But if it can stay with the TC I think that makes the most sense for visibility + who should be managing it?
07:38:11 <gmann> ok
07:38:14 <cmurphy> I didn't get the impression from the thread that the TC wasn't willing to still own it, just that it wasn't working in its current form
07:38:29 <mattoliverau> Any ideas on how it's currently used, ie does it tend be a call to arms of existing devs, or does it attract new contributors. I guess it could be a nice carrot for us and new contributors
07:38:49 <mattoliverau> I guess both.
07:38:52 <mattoliverau> ok
07:38:53 <diablo_rojo> Perhaps I misread then :)
07:38:59 <cmurphy> mattoliverau: it's this https://governance.openstack.org/tc/reference/help-most-needed.html
07:39:05 <cmurphy> it's a vague shout in the dark
07:39:11 <diablo_rojo> mattoliverau, I dont think it gets used at all really
07:39:22 <diablo_rojo> Exactly.
07:39:30 <gmann> yeah
07:39:54 <gmann> i am also ok with under TC but with mentor mapping as entry criteria.
07:40:08 <mattoliverau> hmm. then I'd agrue and say it's a great thing to have.. but yes it needs more visibility.. maybe moving it to the contributor guide or the community portal and away from TC pages is step 1. no matther who ends up managing it.
07:40:39 <cmurphy> there's no explicit guidance on what work items need be done, no incentive to join the effort, no criteria for removing an item from the list, and while there's a "sponsor" there's no mentor
07:40:56 <gmann> mattoliverau: but we need owner for that.
07:41:17 <diablo_rojo> I think requiring all of those things would keep the list short without having to cap it.
07:42:04 <gmann> yeah, prioritizing and keep the list short can be challenge but let's see when we have process short out
07:42:23 <diablo_rojo> I also think that there should maybe be a lifespan for each item.
07:42:28 <diablo_rojo> To make sure things don't go stale
07:42:51 <diablo_rojo> If it hasnt been completed in 2 releases or something, it should be removed and have to go through the process again.
07:43:45 <cmurphy> that seems fair
07:44:25 <diablo_rojo> Someone want to summarize this on the thread?
07:44:33 <gmann> https://www.irccloud.com/pastebin/Agc1z0lx/
07:44:54 <gmann> multiline :)
07:45:09 <gmann> is that ok for all ?
07:45:21 <diablo_rojo> Yeah I think so?
07:45:30 <tonyb> gmann: you can just click 'paste as messages' instead of creating a snippet
07:45:46 <gmann> yeah just pressed enter in hurry
07:45:52 <tonyb> gmann: Ahh okay
07:46:51 <cmurphy> thanks gmann
07:46:59 <gmann> i can add the summary of our discussion on ML
07:47:10 <gmann> thanks all.
07:47:17 <gmann> #topic People to Reach Out To
07:47:19 <diablo_rojo> Thanks gmann!
07:47:38 <gmann> has anyone get any reply/success on this ?
07:47:57 <diablo_rojo> No success from me sadly
07:48:15 <gmann> me too.
07:48:49 <mattoliverau> me either
07:48:52 <gmann> one idea is try to catch people (their company active developer) during summit/PTG and talk. but in positive way so that they do not get offended.
07:49:27 <gmann> #action gmann to summaries the "Help- Wanted List" discussion over ML reply.
07:49:49 <mattoliverau> thats true, I real life contributor hunt :)
07:49:56 <mattoliverau> *a
07:50:09 <diablo_rojo> If we can find them in person yeah, chatting directly would be good
07:50:29 <mattoliverau> or if there company has a booth.
07:50:41 <mattoliverau> but positive and nice is the key.
07:50:48 <diablo_rojo> +2
07:50:59 <mattoliverau> esp the china summit
07:51:14 <gmann> nice. let's plan from this summit as start.
07:51:15 <diablo_rojo> Could also invite them to whatever FC SIG sessions we have
07:51:26 <gmann> +1. that can be nice.
07:52:39 <gmann> we can chat about it over summit also, no specific action item on this. ok ?
07:52:49 <mattoliverau> kk
07:52:54 <gmann> #topic open discussion
07:52:54 <diablo_rojo> Okay
07:53:23 <gmann> one thing from me, i mentioned in last meeting also. I will be moving to canada on 20th feb
07:53:31 <diablo_rojo> Everyone got flights/hotels/registration sorted for Denver?
07:53:37 <mattoliverau> oh nice
07:53:41 * tonyb does
07:53:43 <cmurphy> gmann: awesome
07:53:45 <gmann> it should be for long term if things are shorted out for next financial year
07:53:45 <tonyb> gmann: Oh cool!
07:53:56 <tonyb> gmann: which city?
07:53:56 <diablo_rojo> Woohoo! gmann hope all goes well :)
07:53:57 <cmurphy> diablo_rojo: not officially approved yet
07:54:01 <mattoliverau> not yet, still waiting to hear.
07:54:09 * cmurphy hi5 mattoliverau
07:54:12 <gmann> thanks
07:54:23 <mattoliverau> :)
07:54:34 <gmann> tonyb: currently winnipeg (my wife university )
07:54:38 * tonyb thinks about TZ overlap and meeting times
07:54:48 <gmann> plan is for vancouver if all well next financial year
07:54:59 <cmurphy> frustrating thing about the combined summit/ptg is now ptg attendance is tied to cfp acceptance again :(
07:55:23 <diablo_rojo> cmurphy :/
07:55:34 <gmann> yeah
07:55:58 <tonyb> cmurphy: yeah it's all so confusing
07:56:31 <gmann> tonyb: current time will be like 1 AM for me.
07:56:38 <tonyb> gmann: Yeah
07:56:40 * mattoliverau hears alot of crying, he may need to go save his better half soon.
07:56:59 <tonyb> I guess as of March'ish we'll need to move the meeting
07:57:12 <tonyb> which I'm sure will be good for diablo_rojo and cmurphy ;P
07:57:17 <cmurphy> i'll be moving to the US beginning of April so maybe would be good to re-doodle this meeting soonish
07:57:29 <diablo_rojo> Won't need to account for Europe anymore so we can focus on US + AUS
07:57:33 <gmann> cmurphy: +1
07:57:38 <mattoliverau> +1
07:57:49 <tonyb> cool
07:58:08 <mattoliverau> good for me as it'll be out of baby + toddler bed rutuine and craziness :)
07:58:26 <gmann> +1
07:58:47 <gmann> let's wait till april once cmurphy is moved to USA ?
07:58:48 <mattoliverau> only about a minute to go
07:59:09 <gmann> yeah. let's discuss it over next meeting.
07:59:16 <tonyb> okay
07:59:21 <cmurphy> gmann: we could do it sooner, sounds like either way one of us will miss a couple of meetings
07:59:23 <gmann> thanks all for joining. have good day/night.
07:59:42 <gmann> cmurphy: yeah
07:59:47 <mattoliverau> thanks gmann for charing
07:59:49 <gmann> #endmeeting