15:00:59 <ad_rien_> #startmeeting fog-edge-massively-distributed-clouds
15:00:59 <openstack> Meeting started Wed Aug 30 15:00:59 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:03 <openstack> The meeting name has been set to 'fog_edge_massively_distributed_clouds'
15:01:11 <ad_rien_> #chair ad_rien_
15:01:12 <openstack> Current chairs: ad_rien_
15:01:21 <ad_rien_> #topic roll call
15:01:25 <ad_rien_> Hi guys,
15:01:36 <dsantoro> hi
15:01:38 <parus> Hello
15:01:45 <ad_rien_> #chair parus
15:01:46 <openstack> Current chairs: ad_rien_ parus
15:01:57 <kgiusti> o/
15:01:59 <ad_rien_> parus I just added you as chair
15:02:01 <dpertin> hi
15:02:01 <rcherrueau> o/
15:02:03 <ad_rien_> hi kgiusti
15:02:23 <kgiusti> hi
15:02:25 <ad_rien_> let's wait one minute more
15:02:28 <jamemcc> Hi
15:03:12 <ad_rien_> #info agenda
15:03:14 <msimonin1> o/
15:03:33 <ad_rien_> #link https://etherpad.openstack.org/p/massivfbely_distributed_ircmeetings_2017 (line 1059)
15:04:21 <msimonin> o/ (get my nick bacl )
15:04:21 <georgk> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017
15:04:26 <ansmith> o/
15:04:33 <georgk> there was a typo
15:05:37 <ad_rien_> ok so let's start
15:06:33 <ad_rien_> First of all, like probably a few of us, I was on vacations last time so I'm not sure whether there is an important point to discuu
15:06:35 <ad_rien_> discuss
15:07:02 <ad_rien_> please go through the agenda and feel free to add something (I may have forgotten something).
15:07:26 <ad_rien_> #topic announcements
15:07:34 <ad_rien_> From our side,
15:07:54 <parus> Welcome back! Good to have you here.
15:08:10 <ad_rien_> the EnOS presentation has been selected and I just saw that the parus' one too
15:08:12 <ad_rien_> Excellent !
15:08:32 <ad_rien_> Moreover I receive an email regarding our needs for our F2F in Sydney
15:09:02 <ad_rien_> Could you please add your name to see who is planning to attend the summit in Australia
15:09:03 <ad_rien_> ?
15:09:17 <ad_rien_> (see line 1115)
15:09:38 <ad_rien_> from my side it is still not sure but dpertin will replace me in case of
15:10:20 <ad_rien_> the second point is related to Ericsson Sweden that contacted us
15:10:38 <ad_rien_> They will be present at SF and they want to take part to some activities.
15:10:51 <ad_rien_> they cannot attend this meeting but will be present next time
15:11:31 <ad_rien_> and that's all from my side.
15:11:37 <ad_rien_> so the floors is yours
15:11:38 <ad_rien_> ?
15:12:16 <ad_rien_> ok so let's go on
15:12:36 <ad_rien_> #topic previousaction items
15:12:50 <ad_rien_> so who starts ?
15:12:51 <ad_rien_> :D
15:13:09 <ad_rien_> Because I was absent I will be pleased to know a bit more about all those actions
15:13:20 <msimonin> AMQP ?
15:13:39 <kgiusti> yes - msimonin has done great work on the testplan
15:13:41 <ad_rien_> I just want to go through the pending action first ;)
15:13:48 <parus> I had action to dive into details of use case presentation.
15:13:51 <kgiusti> np
15:13:56 <msimonin> hey kgiusti thanks :)
15:14:16 <kgiusti> well deserved!
15:14:18 <parus> There was progress and slides have been updated.  But action is not complete.
15:14:28 <ad_rien_> parus:  will samP announce the next meeting? it would be nice if we can define the agenda in a more collaborative way and announce sometime from our side sometime from yours
15:14:30 <parus> we can talk about it when we get to use cases
15:14:50 <jamemcc> line 1082 - this came from talk that SamP gve about the LCOO Extreme Testing effort
15:15:10 <jamemcc> Sorry - it was in fact earlier today their weekly meeting
15:15:12 <ad_rien_> ok ..
15:15:16 <ad_rien_> my bad
15:15:23 <jamemcc> Next session is to be held in the PTG next week
15:15:27 <ad_rien_> I though he was the parus colleague
15:15:29 <ad_rien_> ok
15:15:33 <parus> no pb.
15:15:49 <ad_rien_> jamemcc:  to work on Control Plane use-case ?
15:16:01 <ad_rien_> jamemcc:  do you have something to share?
15:16:04 <jamemcc> Is anyone else here going to be at PTG?
15:16:22 <ad_rien_> I'm not
15:16:23 <jamemcc> Sorry - I did not work on control plane user stories yet
15:16:41 <ad_rien_> jamemcc:  no problem just to put it in the pedning actions
15:17:15 <ad_rien_> ok I think that's ok
15:17:23 <ad_rien_> other actions have been commented in the pad. thanks
15:17:31 <ad_rien_> so let's move to the next topic in the agenda
15:17:40 <ad_rien_> #topic on-going activities
15:17:48 <kgiusti> AMQP!
15:17:49 <jamemcc> SO the following meeting for Extreme Testing will be before this meeting in 2 weeks. I will get the UTC times and WebEx to join and add it to the agenda. And will work with SamP to announce it in the ML and tag to both LCOO and FEMDC
15:18:02 <ad_rien_> so msimonin kgiusti ansmith the floor is yours
15:18:08 <parus> jamecc: thank you!
15:18:14 <kgiusti> I'll take ombt and driver status
15:18:24 <ad_rien_> jamemcc:  ACK thanks
15:18:30 <kgiusti> ombt - now that msimonin et al have started to define test metrics
15:18:42 <kgiusti> ombt will need a few tweaks (issues recorded in epad)
15:18:54 <kgiusti> to gather the proper metrics
15:19:11 <kgiusti> drivers (non-rabbit): still failing nova-related tests
15:19:30 <kgiusti> due to vhost support.  Fix in progress (see epad 1104)
15:19:59 <kgiusti> and thats pretty much it on those topics.  ansmith msimonin?
15:20:26 <msimonin> Currently we are iterating on a test plan
15:20:35 <msimonin> #link https://review.openstack.org/#/c/491818
15:20:58 <msimonin> kgiusti: helps a lot to formalize it :)
15:21:10 <kgiusti> msimonin: +1
15:21:10 <msimonin> so we are now on the resilience part
15:21:17 <ad_rien_> Thanks guys …. this looks really good
15:21:36 <ad_rien_> I'm just seeing the proposal on gerrit
15:21:38 <msimonin> so there will be a new version soon
15:22:06 <msimonin> The idea after this is to instanciate this test plan using qpidd/rabbit …
15:22:29 <ad_rien_> ok great
15:22:48 <ad_rien_> Is the performance WG taking part to this work?
15:23:02 <ad_rien_> I see only people from FEMDC team?
15:23:15 <kgiusti> still marked work in progress
15:23:30 <msimonin> There might be reviewed by some people
15:23:36 <msimonin> once ready :)
15:23:41 <ad_rien_> ok
15:23:54 <parus> msimonin: I am a little confused with the review linke you shared. What is the link to the latest version of the test plan? I would like to read again.
15:23:58 <ad_rien_> will be nice to see other folks interested by these evaluations
15:24:50 <msimonin> parus: in https://review.openstack.org/#/c/491818 you can see the file modified, if you click on one of them you'll be able to see it
15:25:33 <ad_rien_> anything else regarding AMQP?
15:25:34 <parus> msimonin: Thanks. I will figure it out.
15:25:52 <ad_rien_> Maybe we can add that we found our engineer at Inria
15:26:04 <ad_rien_> that will work on that starting from October
15:26:12 <kgiusti> +1
15:26:27 <msimonin> +1
15:26:33 <ansmith> +1
15:26:43 <ad_rien_> ok so let's go
15:26:50 <ad_rien_> rcherrueau:  news regarding coackroach ?
15:26:58 <rcherrueau> Yep, big news
15:27:02 <ad_rien_> s/…./cockroach
15:27:11 <ad_rien_> please
15:27:13 <rcherrueau> We have a POC of Keystone over CockroachDB
15:27:26 <rcherrueau> #link https://github.com/BeyondTheClouds/openstack-cockroachdb-dev
15:27:50 <ad_rien_> from the agenda I'm seeing in this devstack-based
15:27:57 <ad_rien_> any chance to test it with EnOS ?
15:28:04 <rcherrueau> The github project consist in a VAgrant file that spawns a VM with a CockroachDB and then installs keystone with Devstack
15:28:20 <ad_rien_> ok
15:28:22 <rcherrueau> ad_rien_: Yes, don't worry
15:29:04 <rcherrueau> We first go with devstack because devstack makes things easier when you have to update the code.
15:29:36 <rcherrueau> We have to tweak few things
15:29:49 <rcherrueau> One file in Oslo.db and another one in keystone
15:30:09 <rcherrueau> I don't know if we have the time for details?
15:30:40 <ad_rien_> so first of all thanks guys
15:31:03 <ad_rien_> I should take more vacations because you look to be more efficient when I'm out ;)
15:31:08 <msimonin> LOL
15:31:11 <rcherrueau> :)
15:31:14 <ad_rien_> the work is excellent
15:31:24 <ad_rien_> this is really awesome, in just two months
15:31:27 <ad_rien_> congrats
15:31:44 <ad_rien_> so then some technical questions: what will be the work to be able to test it with EnoS
15:31:56 <ad_rien_> (i.e. switching from devstack to openstack vanilla)
15:32:08 <rcherrueau> Actually, both OpenStack and CockroachDB are well engineered, so it wasn't so difficult
15:33:03 <rcherrueau> My intern already looked into that and it's easy
15:33:04 <msimonin> Maybe we should also gather use cases of using such a distributed backend
15:33:14 <ad_rien_> Is the process of switching from devstack to enos documented ?
15:33:19 <ad_rien_> if not it would be great
15:33:31 <ad_rien_> it would be one more valuable thing you can do with enos
15:33:37 <msimonin> There are multi region deployment that can benefit from it (just a guess)
15:33:44 <ad_rien_> +1 msimonin
15:33:44 <rcherrueau> we just have to containerized our modified keystone and oslo.db and then everything should *almost* work with enos
15:33:57 <ad_rien_> ok let's complete the note in the agenda
15:34:34 <ad_rien_> #action identify possible use-cases for keystone/cockroach DB
15:34:39 <msimonin> (maybe qpid + cockroach will lead to get rid of the cells) not saying it too loud
15:35:03 <ad_rien_> msimonin:  :-P
15:35:11 <kgiusti> msimonin: tell that to the nova folks ;)
15:35:37 <ad_rien_> actually people will continue to use cells to segregate the cluster instead of using the host aggregate capability ;)
15:35:42 <ad_rien_> ok so let's be serious
15:36:01 <ad_rien_> rcherrueau:  anything else?
15:36:41 <rcherrueau> I would add that it's just a POC right now, so everything works (we pass rally tests) but I don't know about performances
15:37:28 <rcherrueau> especially, CockroachDB manage transactions without lock
15:37:34 <ad_rien_> #action evaluate performance impact of cockroach backend
15:38:09 <rcherrueau> this leads to lot of contention in case of concurrency
15:39:00 <ad_rien_> hmmm this point should be clarified
15:39:00 <rcherrueau> In case of conflict, the client has to replay the request
15:39:10 <ad_rien_> It looks to be important
15:39:23 <parus> do we have a plan to expand cockroach to other db (not just keystone)?
15:39:47 <ad_rien_> yes found budgets to hire people
15:39:55 <rcherrueau> So CockroachDB offers mechanism to handle that properly. But implementing these mechanisms in oslo.db would be more difficult
15:39:56 <ad_rien_> or find an organisation that is interested by doing that  ;)
15:40:06 <ad_rien_> s/found/find
15:41:09 <ad_rien_> ok
15:41:10 <ad_rien_> thanks
15:41:16 <ad_rien_> let's move to the third point
15:41:21 <ad_rien_> use-cases
15:41:25 <ad_rien_> parus: ?
15:41:48 <parus> Thanks. As I mentionned before my deck was updated.
15:42:03 <parus> I am hoping for some other eyes to take a look and provide input.
15:42:28 <ad_rien_> I will before the opendev event. you can count on me
15:42:36 <parus> #link https://docs.google.com/presentation/d/1sBczuC2Wu1d_misBmPahLPdvyhOI4QuVy129EHunuUM/edit#slide=id.p
15:42:50 <parus> About way forward.
15:42:54 <ad_rien_> #action ad_rien_ watch the parus updates on use-case slides
15:43:14 <msimonin> parus:  have you looked at the P2P option ?
15:43:25 <parus> P2P?
15:43:31 <msimonin> slide 10
15:43:37 <jamemcc> Seems to me this should be presented at the OPENDEV with request to get more reviewers and collaborators
15:44:15 <jamemcc> I know emphasis on OPENDEV is past use cases and on to solutions but still is good to anchor in use cases.
15:44:49 <parus> msimonin: I looked at the presentation you mentionned. Do you have any contact with these folks that they could provide more details?
15:45:23 <parus> msimonin: at least we should set-up to meet them in Sydney
15:45:51 <msimonin> parus: this would be great :)
15:45:56 <ad_rien_> parus:  these are the guys from Ericsson
15:46:13 <ad_rien_> see line 1082
15:46:25 <parus> ah!
15:46:32 <msimonin> ah!
15:46:36 <ad_rien_> :-)
15:46:41 <ad_rien_> funny meeting today
15:46:47 <ad_rien_> lot of fun
15:46:48 <parus> So we will hear from them next week. It would be great if they could comment before next week.
15:46:59 <parus> (or week after next)
15:47:34 <parus> jamecc: Do you have more details on what to expect at OpenDev? I would be happy to present some of this.
15:48:30 <parus> Who can hook me up? jamecc? ad_rien_?
15:48:57 <parus> The third thing I would like to discuss is how to test some of these use cases.
15:49:07 <jamemcc> I do not.  Where I was thinkinking this was going was that you or Adrien as Chairs would reach out to Foundation staff involved in the event and look for the cross collaboration
15:49:07 <ad_rien_> +1
15:49:55 <ad_rien_> parus:  as mentioned Ericsson folks should take part to our meeting from mid of september
15:49:55 <ildikov> parus: OpenDev is a work event to understand the Edge Computing related use cases and what they demand better and to start to take the next steps towards solutions
15:50:37 <ad_rien_> from what I know they are currently writtng a white paper. I exchanged a couple of emails.
15:50:46 <ildikov> parus: also for connecting the different organizations and people who're looking into addressing these use cases and to encourage collaboration onwards
15:50:54 <ad_rien_> I can send one more and put you in CC parus if you want to
15:51:19 <parus> ad_rien: please do!
15:51:22 <ad_rien_> ok
15:51:28 <ad_rien_> so 10 minutes before the end of the meeting
15:51:40 <parus> I would like to propose  try to text some of the control plane use cases (e.e.g Commissioning of an edge node) and try to make some sequence diagrams
15:51:46 <ad_rien_> parus:  do you want to elaborate a bit more on the third point ?
15:51:55 <ad_rien_> +1 too
15:52:20 <parus> could we use osp_profiler, maybe on the use case from dsantoro and get a trace?
15:52:52 <ad_rien_> if we can run the use-case with enos you can do what you want ;)
15:53:02 <dsantoro> Ok so Let me quickly share status from our side
15:53:09 <ad_rien_> and AFAIK, the use-case is ok with enos
15:53:12 <msimonin> dsantoro: +1 :)
15:53:13 <dsantoro> As specified in the agenda we have updated our slides following ad_rien_ suggestion about i) k8s on top of OS motivation (https://docs.google.com/presentation/d/1FLCjUx1xiQxRcgTG78vg255g6N2RRp8_W0B0Sz0bJH8/edit#slide=id.g2351d4feef_0_0) and ii) better emphasis on the network connection between edge and cloud
15:53:41 <dsantoro> Due to the Holidays period we did not progress too much on the use-case side but thanks to msimonin Daniele Pizzolli (in CC) completed successfully the EnOS installation on our testbed
15:53:51 <dsantoro> I am setting up another testbed
15:54:02 <dsantoro> based on Kubernetes and OpenStack connected with real cameras
15:54:20 <dsantoro> We count to have more information to share and discuss with you by the mid of September
15:54:42 <dsantoro> Currently EnOS is installed but we did not have much time to play with it
15:54:55 <ad_rien_> dsantoro:  just to avoid possible missunderstandings. No one from FBK will attend the opendev event?
15:55:04 <dsantoro> and dancn who is carrying that activity is on holiday this week
15:55:17 <msimonin> dsantoro: let's keep in touch
15:55:19 <dsantoro> I confirm no one unfortunately
15:55:21 <ad_rien_> ok
15:55:30 <ad_rien_> dsantoro:  if you want to visit us, you can ;)
15:55:32 <parus> dsantoro: thanks! this sounds great.
15:55:49 <ad_rien_> I already mentioned  but it is good to remind  ;)
15:55:51 <msimonin> dsantoro: would be nice to know more about your testbeds actually
15:56:25 <parus> I would be happy to participate, if we set-up some sort of a session like that.
15:56:38 <dsantoro> @ad_rien_: thanks we could discuss to plan a visit during next weeks
15:56:39 <ad_rien_> 4 min left
15:56:53 <parus> I yield
15:57:00 <ad_rien_> we should switch to the open discusisons.
15:57:06 <ad_rien_> parus:  nothing important regarding the use-cases ?
15:57:19 <parus> all good for now.
15:57:22 <ad_rien_> can you please add some notes regarding what we discussed in the pad?
15:57:23 <ad_rien_> thanks
15:57:32 <ad_rien_> #topic open discussions
15:57:38 <ad_rien_> regarding the first point.
15:58:05 <ad_rien_> as mentioned I have been in touch with Ericsson folks. We can invite them to make a webconf to present their work.
15:58:21 <ad_rien_> People interested by that please add your name/email line 1130
15:59:03 <ad_rien_> regarding the pending actions, from my side I didn't make any progress
15:59:12 <ad_rien_> but I keep in mind I have too
15:59:22 <ad_rien_> ok
15:59:25 <ad_rien_> 1 min left ?
15:59:38 <ad_rien_> does anyone want to highlight something?
15:59:46 <ad_rien_> if not. Thanks guys for attending the meeting
15:59:50 <dsantoro> @msimonin: Sure let me talk with dancn and we can setup a call maybe next week or the next one to show what we did with our testbeds
16:00:00 <ad_rien_> ok time to end
16:00:02 <ad_rien_> #endmeeting