14:00:29 <ddieterly> #startmeeting freezer
14:00:29 <openstack> Meeting started Thu May 19 14:00:29 2016 UTC and is due to finish in 60 minutes.  The chair is ddieterly. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:32 <openstack> The meeting name has been set to 'freezer'
14:02:25 <ddieterly> hi ice cubes
14:02:29 <yangyapeng> hi
14:02:39 <ddieterly> attendance?
14:02:42 <ddieterly> o/
14:03:00 <yangyapeng> :)
14:04:10 <ddieterly> just us two? wow
14:04:27 <ddieterly> agenda at https://etherpad.openstack.org/p/freezer_meetings
14:04:31 <ddieterly> feel free to add to it
14:05:28 <daemontool> o/
14:05:43 <yangyapeng> haha
14:05:47 <ddieterly> hey daemontool!
14:05:55 <ddieterly> big hugs
14:06:00 <daemontool> hi ddieterly who's the chair?
14:06:07 <ddieterly> i am
14:06:08 <daemontool> ddieterly, only with harms please
14:06:10 <daemontool> haha
14:06:21 <ddieterly> of course
14:06:24 <daemontool> ok
14:06:37 <ddieterly> can we get some items on the agenda?
14:06:41 <daemontool> ok
14:06:47 <daemontool> the url please?
14:07:00 <daemontool> this one right https://etherpad.openstack.org/p/freezer_meetings
14:07:05 <ddieterly> https://etherpad.openstack.org/p/freezer_meetings
14:07:13 <clsacramento> hello
14:07:53 <daemontool> clsacramento, hi
14:08:01 <ddieterly> greetings to all
14:08:15 <clsacramento> daemontool: buon giorno, come stai?
14:08:21 <ddieterly> #topic Tenant resource backup (aka DRaaS)
14:08:21 <szaher> ddieterly:  hi
14:08:39 <ddieterly> hi szaher!
14:09:12 <ddieterly> daemontool take it away, please
14:10:29 <clsacramento> about this Tenant resource backup (aka DRaaS), didn't you find out that there was another project doing it already?
14:10:43 <ddieterly> smaug?
14:10:59 <clsacramento> yes, I think that was it
14:11:02 <daemontool> I'm here
14:11:05 <daemontool> sorry
14:11:22 <daemontool> clsacramento, ola
14:11:22 <daemontool> so
14:11:26 <daemontool> during the summit
14:11:30 <daemontool> the design session
14:11:39 <daemontool> there were more then one person in the room
14:11:41 <daemontool> from different companies
14:11:53 <daemontool> asking for a complete backup of all the tenant resources
14:11:56 <daemontool> such as
14:12:13 <daemontool> vms, volumes, networks config, identity related etc
14:12:19 <daemontool> to be restored
14:12:27 <daemontool> on the same os platform
14:12:31 <daemontool> or on a new one
14:12:38 <daemontool> it is quite interesting
14:12:49 <daemontool> and more and more users are asking for it
14:13:08 <clsacramento> yes, I really like this feature
14:13:20 <clsacramento> It looks like vmware vApp and it is quite nice
14:13:24 <daemontool> yes
14:13:28 <daemontool> clsacramento, exactly
14:13:35 <daemontool> that would make us competitive :)
14:13:48 <daemontool> so I've tried to summarize somethign here
14:13:49 <daemontool> https://blueprints.launchpad.net/freezer/+spec/tenant-backup
14:13:51 <daemontool> let me know
14:13:53 <daemontool> any feedback
14:14:10 <daemontool> so everythhing backed up taken from the API,
14:14:17 <daemontool> such as metadata, glance image, snapshots
14:14:20 <daemontool> volumes etc etc
14:14:37 <szaher> daemontool: Ciao
14:14:57 <szaher> There is a project from Mirantis called Pumphouse they used to do something similar
14:14:57 <szaher> https://github.com/Mirantis/pumphouse
14:15:13 <clsacramento> I would add not only in case of lost, but in case of willing to replicate a lab too, it is very useful for that
14:15:24 <szaher> I don't know why they stopped but they were backing up resources then upgrade the cloud then restore resources again
14:15:45 <szaher> May be we can take a look we might find something useful
14:16:03 <ddieterly> wondering about load on the api's and performance of that kind of approach
14:16:08 <daemontool> let's reuse whatever can be reused of course
14:16:18 <daemontool> yes
14:16:38 <daemontool> ddieterly, that's a good point, I think it depends on how many you execute simultaneously
14:16:48 <daemontool> or in a short time windows
14:17:59 <ddieterly> i think we need more research on pumphouse and smaug
14:19:21 <ddieterly> anyone want to take an action item and report back next week?
14:20:03 <clsacramento> daemontool: I was thinking, it is easier on the same cloud because all images, volumes and vm emephemeral disks are already in there backend storage, we can only duplicate them. If it is to recover on a different cloud we would have to download all of that to some other media and make it available on the other cloud...
14:20:24 <clsacramento> ddieterly: I can do that
14:20:25 <szaher> ddieterly: I don't know if we can only backup mysql database which contains all the required metadata and Openstack will automatically create this resources once we restore the database again and only backup volumes, instances, images and so ?
14:20:42 <szaher> s/this/these/g
14:21:03 <clsacramento> szaher: I dont think backing up the database is the best approach. We should be able to get all the info we need to backup from the APIs
14:21:09 <ddieterly> clsacramento thanks
14:21:25 <ddieterly> #action clsacramento to investigate smaug and pumphouse
14:22:11 <szaher> clsacramento: we need to know about the drawbacks of using this approach when we have a big deployment with hundreds of tenants and resources
14:22:38 <ddieterly> szaher i don't follow your first point
14:23:02 <szaher> ddieterly: the database approach ?
14:23:11 <ddieterly> yes
14:23:39 <clsacramento> szaher: for example: if I insert a flavor in MySQL database, openstack automatically creates it for me?
14:24:17 <szaher> clsacramento: I would say that Openstack stores it's own metadata in mysql database :) and I think yes it will create it automatically
14:24:20 <daemontool> ok
14:24:43 <clsacramento> szaher: I dont think it does, but I'll check this out
14:24:44 <szaher> clsacramento: you can worry about neutron namespaces for example as I am not sure if it will be create automatically or not
14:25:04 <daemontool> we need to get the metadata and data from the API
14:25:08 <szaher> clsacramento: What about when we take the cloud down then up again ?? How Openstack recovers ?
14:25:19 <daemontool> or we'll have tenants executing actions directly to the db
14:25:21 <daemontool> which is not good
14:25:45 <daemontool> let's have a conversation on the freezer chan for this
14:25:50 <daemontool> and move forward with the topics?
14:25:54 <daemontool> :)
14:25:55 <szaher> Guys, What I am saying here let's review both approaches :) what will happen at big scales ?
14:26:01 <daemontool> ok
14:26:04 <ddieterly> daemontool sounds good
14:26:05 <szaher> daemontool: OK
14:26:08 <daemontool> ++
14:26:10 <ddieterly> #topic DAR
14:26:34 <ddieterly> ok, so currently our incremental restores are busticated under certain conditions
14:26:41 <ddieterly> seems to be an issue with TAR
14:26:52 <ddieterly> DAR handles the condition quite well
14:27:10 <ddieterly> could we investigate a DAR engine as szaher has suggested
14:27:11 <daemontool> ddieterly, yes you are right, in my opinion, I'd remove the deps to binaries..
14:27:18 <daemontool> asap
14:27:36 <daemontool> I'd focus on that, rather investing time in contingencies solutions
14:27:46 <clsacramento> sorry, what's DAR?
14:27:49 <ddieterly> not sure what you mean
14:27:55 <daemontool> tar, gzip, dar
14:27:58 <daemontool> are all binaries
14:28:01 <ddieterly> yes
14:28:02 <daemontool> openssl...
14:28:21 <ddieterly> so, you want to implement that functionality directly in freezer instead of using the binaries?
14:28:21 <daemontool> I think we have to work to remove deps to those binaries
14:28:31 <daemontool> yes, there are modules done
14:28:33 <daemontool> that does that
14:28:34 <daemontool> already
14:28:40 <ddieterly> or just let users mix and match which ones to use?
14:28:42 <daemontool> so we'll be more portable
14:29:00 <daemontool> I think if we use the python modules, our life is easier
14:29:03 <ddieterly> what modules?
14:29:04 <daemontool> also for windows
14:29:04 <szaher> reldan and I are working on some sort of refactoring freezer to be pluggable so hopefully we will be able to add engines but we need the refactoring part to be done first
14:29:05 <daemontool> like
14:29:20 <daemontool> bzip, tarfile, crypto.io
14:29:21 <daemontool> and so on
14:29:27 <daemontool> the rsync code
14:29:33 <daemontool> probably the rsync code
14:29:38 <daemontool> can remove tar or dar
14:29:44 <daemontool> by
14:29:49 <daemontool> backing up the data
14:29:51 <ddieterly> so there is a python module that implements rsync directly?
14:29:51 <daemontool> only based on inode
14:29:54 <daemontool> npoe
14:30:06 <daemontool> we need to get completed
14:30:07 <daemontool> this
14:30:08 <daemontool> https://review.openstack.org/#/c/290461/
14:30:12 <daemontool> and we have that
14:30:20 <daemontool> so the difference would be
14:30:30 <daemontool> to backup the whole file if the inode is changed
14:30:36 <daemontool> rather backup block
14:30:45 <daemontool> and the tar approach will be quite the same
14:30:58 <daemontool> so tar, dar openssl
14:30:59 <daemontool> etc
14:31:00 <daemontool> can be removed
14:31:09 <daemontool> but
14:31:14 <daemontool> it is just my opinion
14:31:30 <ddieterly> is this your implementation, or is it an existing well-known python module?
14:32:03 <daemontool> for rsync
14:32:06 <daemontool> any module
14:32:09 <daemontool> does not suits
14:32:14 <daemontool> that's why that implementation
14:32:41 <daemontool> if we finish taht
14:32:49 <daemontool> then we have both inode and block based
14:33:05 <ddieterly> does the rest of the team have an opinion on this?
14:33:23 <ddieterly> i'm still not sure what daemontool tool is saying
14:33:41 <daemontool> ddieterly, tar just check
14:33:46 <daemontool> inode modification
14:33:51 <daemontool> and backup the whole file
14:33:51 <ddieterly> are we going to implement the functionality directly in freezer or is there an existing python module that does what tar/dar do?
14:34:23 <szaher> ddieterly: we need to discuss this before taking a decision
14:34:28 <daemontool> yes
14:34:32 <ddieterly> of course
14:34:39 <daemontool> szaher,  well the engine approach
14:34:44 <daemontool> has been throughtly discussed
14:34:44 <ddieterly> trying to understand what daemontool is saying
14:35:17 <szaher> daemontool: The engine approach Yes and we agreed we will have mutliple engines and the user can choose what is the best one for him
14:35:20 <ddieterly> so, it looks like we could implement another 'engine' that uses dar
14:35:27 <daemontool> ddieterly,  well yes
14:35:28 <ddieterly> or, we could do what daemontool is suggesting
14:35:42 <daemontool> the rsync engine is being implemented
14:35:45 <daemontool> I just do not have time
14:35:48 <daemontool> to finish the restore
14:35:52 <szaher> daemontool: I thought we are going to remove tar and dar totally
14:35:54 <daemontool> but the backup there it's working
14:35:58 <daemontool> szaher, yes
14:36:09 <daemontool> that's what I'm advising for
14:36:12 <ddieterly> well, we don't have dar yet ;-)
14:36:14 <daemontool> haha
14:36:23 <szaher> :D
14:36:39 <daemontool> ddieterly, let's have this discussion later in the freezer chan
14:36:44 <daemontool> ?
14:36:47 <ddieterly> ok
14:36:50 <ddieterly> let's move on
14:36:58 <ddieterly> daemontool is such a task master
14:37:12 <ddieterly> #topic rsync status
14:38:05 <daemontool> ok
14:38:06 <daemontool> so rsync
14:38:09 <daemontool> I need help guys
14:38:16 <daemontool> the restore needs to be done
14:38:25 <daemontool> if anyone is interested let me know
14:38:32 <daemontool> keep in consideration that is a tough bone
14:38:52 <ddieterly> #action let daemontool know if you want to help with rysnc https://review.openstack.org/#/c/290461/
14:39:06 <daemontool> ddieterly, are you interested?
14:39:21 <ddieterly> i am working on hpe hlm most of the time
14:39:21 <daemontool> it is also incredibly inteersting
14:39:23 <ddieterly> :-(
14:39:24 <daemontool> ok
14:39:28 <daemontool> np
14:39:47 <ddieterly> but, i will take a look at it for sure
14:40:16 <daemontool> ty
14:40:20 <ddieterly> next topic?
14:40:39 <daemontool> yes
14:40:50 <ddieterly> #topic ATT architecture meeting
14:41:14 <daemontool> ok we need to decide how do we manage cases where Company wants to contribute
14:41:17 <daemontool> without write code
14:41:20 <ddieterly> this seems like something pierre should be involved with as he is the PTL
14:41:32 <daemontool> like at Architecture level and so on
14:41:36 <daemontool> yes I had a word with Pierre
14:41:37 <daemontool> about this
14:41:46 <daemontool> he asked me to drive it
14:41:54 <ddieterly> well, if they want to contribute w/o writing code, they can submit a bp
14:42:11 <daemontool> we need to have a meeting to explain them what freezer is
14:42:14 <daemontool> what it does etc
14:42:18 <daemontool> I think we should do a video
14:42:24 <daemontool> Freezer Intro Video
14:42:26 <daemontool> something like that
14:42:30 <daemontool> an points new comers to that
14:42:33 <ddieterly> that would be great
14:42:39 <daemontool> m3m0, ?
14:42:40 <daemontool> ping
14:42:47 <daemontool> you are good with videos :)
14:42:52 <ddieterly> he is on holiday
14:42:54 <daemontool> ah ok
14:43:04 <daemontool> m3m0,  and or vannif?
14:43:07 <ddieterly> m3m0 will be back next week
14:43:11 <daemontool> ok
14:43:27 <daemontool> I'll engage ATT for that
14:43:27 <ddieterly> i'm not photogenic
14:43:28 <ddieterly> lol
14:43:39 <daemontool> ddieterly, haha well you need to be videogenic
14:43:51 <daemontool> ok next
14:43:54 <daemontool> ?
14:43:58 <ddieterly> sure
14:44:09 <ddieterly> #topic freezer overview meeting
14:44:13 <ddieterly> what is that?
14:44:21 <daemontool> RH
14:44:24 <daemontool> RH freezer
14:44:27 <daemontool> same as ATT
14:44:30 <ddieterly> oh
14:44:32 <ddieterly> same deal?
14:44:35 <daemontool> yes
14:44:51 <ddieterly> so, are you going to arrange the meetings or is pierre?
14:44:51 <daemontool> so they are evaluating the backup/dr technology
14:44:52 <daemontool> to use
14:44:58 <daemontool> I'm going to do it
14:45:01 <daemontool> have to send an email
14:45:02 <ddieterly> are the meetings in europe or via video chat?
14:45:06 <daemontool> but wanted to wait next week
14:45:12 <daemontool> video
14:45:19 <daemontool> hangout I think
14:45:29 <daemontool> frescof__,  ping
14:45:38 <daemontool> do we have a last freezer presentation?
14:45:44 <daemontool> we could use the summit one?
14:45:54 <daemontool> is that ok do you think?
14:46:00 <szaher> daemontool: fresco is not at his desk
14:46:02 <daemontool> clsacramento, szaher ?
14:46:04 <daemontool> ok
14:46:08 <daemontool> szaher,  ask him please
14:46:10 <ddieterly> i think a video meeting with them going over the slides that arun uses would be good
14:46:15 <clsacramento> sorry, what is RH?
14:46:21 <daemontool> RedHat
14:46:21 <ddieterly> frescof__ is on holiday
14:46:23 <daemontool> ok
14:46:25 <clsacramento> ok
14:46:44 <clsacramento> I was thinking of Human Resources in Portuguese :S
14:46:49 <daemontool> haha
14:47:12 <daemontool> ddieterly, can anyone make a plain openstack preso out of that?
14:47:17 <daemontool> without companies logos?
14:47:20 <ddieterly> #action daemontool will set up meetings
14:47:22 <daemontool> just openstack and freezer logo?
14:47:23 <daemontool> I can do it
14:47:31 <daemontool> ok
14:47:37 <ddieterly> daemontool i think it would be easy to sanitize them and use them
14:47:40 <ddieterly> it is public info
14:48:13 <daemontool> ddieterly,  ok
14:48:27 <daemontool> someone has to do that thought
14:48:31 <ddieterly> daemontool just don't tell anyone ;-)
14:48:34 <daemontool> haha
14:48:34 <daemontool> ok
14:48:47 <ddieterly> next topic?
14:48:48 <daemontool> #action ddieterly sanitize something
14:48:51 <daemontool> lol
14:49:00 <ddieterly> yea, i'm good at that
14:49:12 <ddieterly> especially toilets
14:49:42 <ddieterly> #topic Golang
14:49:57 <ddieterly> did everybody see this? https://review.openstack.org/#/c/290461/
14:50:00 <daemontool> yes
14:50:07 <ddieterly> oops wrong link
14:50:09 <daemontool> ddieterly,  you proposed Java in the mail thread
14:50:09 <daemontool> haha
14:50:22 <ddieterly> https://review.openstack.org/#/c/312267/3
14:50:52 <ddieterly> so, maybe we could benifit from Go in freezer?
14:50:58 <daemontool> ddieterly,  I think so
14:50:59 <daemontool> yes
14:51:03 <daemontool> but
14:51:05 <ddieterly> awesome
14:51:07 <daemontool> last year
14:51:14 <daemontool> I've tried freezer executing
14:51:17 <daemontool> actions
14:51:20 <daemontool> under pypy
14:51:25 <daemontool> and it was really fast
14:51:58 <ddieterly> so we should look for ways to incorporate Go in places to optimize performance
14:52:36 <ddieterly> i can't tell if this passed or not
14:52:40 <ddieterly> does anyone know?
14:53:03 <daemontool> ddieterly,  I don't know
14:53:10 <szaher> I guess the workflow is not +1
14:53:14 <daemontool> I think there are taks we perform
14:53:20 <daemontool> intensive
14:53:20 <ddieterly> is anyone on freezer opposed to using go?
14:53:23 <daemontool> for rsync
14:53:24 <daemontool> math
14:53:29 <daemontool> I'm in favor
14:53:36 <daemontool> just wonder if we really need it and where
14:53:43 <szaher> daemontool: +1
14:54:30 <daemontool> ok
14:54:33 <daemontool> all good anyway
14:54:36 <daemontool> for me
14:54:43 <ddieterly> #startvote Should we allow Go in Freezer when it makes sense?
14:54:44 <openstack> Begin voting on: Should we allow Go in Freezer when it makes sense? Valid vote options are Yes, No.
14:54:45 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:54:48 <daemontool> a part the fact tha tI do not know Go
14:54:55 <clsacramento> from the last comment on the bp, not sure if approved
14:54:59 <ddieterly> #vote yes
14:55:05 <daemontool> #vote yes
14:55:10 <clsacramento> #vote yes
14:55:27 <daemontool> using new IRC features lol
14:55:32 <szaher> #vote yes
14:55:42 <ddieterly> i've always wanted to use that!
14:55:44 <ddieterly> haha
14:55:57 <ddieterly> #showvote
14:56:12 <ddieterly> #endvote
14:56:12 <szaher> I would say yes if we really need it badly
14:56:13 <openstack> Voted on "Should we allow Go in Freezer when it makes sense?" Results are
14:56:42 <ddieterly> #showvote
14:57:09 <daemontool> ddieterly,  ok, I'm glad you are enjoying it
14:57:12 <ddieterly> ok, so the vote results are logged in the meeting minutes
14:57:15 * daemontool hug ddieterly  lol
14:57:35 <ddieterly> ok, any other items in the time remaining?
14:57:44 <daemontool> I think we are good
14:57:49 <daemontool> not from me
14:57:51 <ddieterly> hpe folks have a standup in a couple of mins
14:58:11 <szaher> ah guys the upgrade to falcon middleware is merged so you can submit changes to freezer-api
14:58:24 <ddieterly> szaher cool
14:58:26 <szaher> and If you have a change upstream please, submit a recheck
14:58:32 <ddieterly> daemontool hugs back to you
14:58:33 <daemontool> szaher,  brilliant
14:58:46 <daemontool> ddieterly,  not from the back please, that doesn't look good
14:58:48 <daemontool> lol
14:59:20 <ddieterly> daemontool ok, you can stop the double entendre please
14:59:39 <daemontool> thanks all
14:59:42 <ddieterly> ciao everybody!
14:59:53 <szaher> ciao ciao :)
14:59:56 <clsacramento> daemontool: a presto!
15:00:01 <ddieterly> #endmeeting