14:00:08 <m3m0> #startmeeting freezer
14:00:10 <openstack> Meeting started Thu Jul 14 14:00:08 2016 UTC and is due to finish in 60 minutes.  The chair is m3m0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <openstack> The meeting name has been set to 'freezer'
14:00:21 <yangyapeng> hello
14:00:24 <m3m0> hello everyone, who is here for the freezer meeting?
14:00:30 <domhnallw> o/
14:00:36 <yangyapeng> hello m3m0
14:00:52 <m3m0> yangyapeng: hi, could you add the pending reviews that you have in here please? https://etherpad.openstack.org/p/freezer_meetings
14:01:06 <timothyb89> hello all
14:01:10 <thatsdone> o/
14:01:20 <yangyapeng> OK
14:01:48 <m3m0> let's give 3 more minutes for people to join, is that ok?
14:01:57 <ddieterly> o/
14:02:43 <daemontool> o/
14:04:24 <slashme> o/
14:04:50 <m3m0> #topic  Freezer mascot : https://etherpad.openstack.org/p/freezer_mascot
14:05:01 <m3m0> slashme: would you like to comment on this?
14:05:10 <slashme> Yes
14:05:42 <slashme> The OpenStack foundation is going to create mascot (logos) for each OpenStack project
14:05:58 <slashme> We need to provide some suggestion on what we would like it to be
14:06:07 <daemontool> I did it :)
14:06:16 <slashme> It can be an animal or something natural
14:06:17 <daemontool> ++ for the idea
14:06:54 <slashme> They will review our suggestions and we will vote on our favourite afterwards
14:07:32 <slashme> Please heads to that etherpad to give your opinion
14:07:37 <slashme> https://etherpad.openstack.org/p/freezer_mascot
14:08:05 <slashme> Don't forget to add your name in the participants list (not in the menu) so we can track vote
14:08:12 <domhnallw> One of the rules is that it can't be man-made... does an ice cube count as man-made?
14:08:15 <ddieterly> what the heck is a 'floe'
14:08:25 <domhnallw> I big block of floating ice
14:08:31 <domhnallw> s/I/A/g
14:09:17 <slashme> We will propose multiple ideas and we will see what feedback we get
14:09:46 <domhnallw> Either way it's something with not a whole pile of recognizability - if anything you'll look at it and think "iceberg" or just "ice".
14:09:48 <slashme> I know we already have a logo, but I also think it is good to get some uniformisation of the OpenStack branf
14:09:49 <m3m0> #action, update https://etherpad.openstack.org/p/freezer_mascot with your suggestion and name
14:10:37 <m3m0> #topic Midcycle meetup tomorrow : https://etherpad.openstack.org/p/freezer_midcycle_meetup_newton.
14:11:13 <domhnallw> Is there anyone who isn't already on the list who thinks they can attend, either physically or (more likely) virtually?
14:12:57 <timothyb89> I will be around in the morning at least (Colorado time)
14:13:49 <domhnallw> You're seven hours behind, right?
14:13:56 <domhnallw> It's 08:13 there?
14:14:41 <timothyb89> Right, yup
14:15:04 <domhnallw> You'll catch the tail end so.
14:15:20 <m3m0> slashme what time it starts tomorrow?
14:15:24 <timothyb89> I will try to match ddieterly's schedule tomorrow, at any rate
14:15:29 <domhnallw> 10AM on the etherpad.
14:15:38 <domhnallw> That's 3AM Colorado time :(
14:15:48 <timothyb89> indeed it is :/
14:16:02 <m3m0> domhnallw: thanks
14:16:22 <slashme> It will be starting at 10AM our time. We will keep the most important subjects for our afternoon so you can attend
14:16:53 <domhnallw> So we have people at -07:00, +01:00 and +02:00 that I know about. At that rate, around this time of day seems to be the best overlap.
14:17:30 <domhnallw> ^^^ all times relative to Irish time as it's the venue.
14:17:39 <slashme> Is it okay if I put most important subjects from 15:00 GMT+1 to 17:00 GMT+1
14:17:49 <slashme> ?
14:17:54 <daemontool> yes
14:17:56 <domhnallw> I think that only makes sense.
14:19:36 <m3m0> ok, is there anything that we should discuss about this?
14:19:55 <m3m0> if not can we move forward?
14:20:14 <domhnallw> Unless figuring out which issues is a priority is something slashme needs help with?
14:20:25 <domhnallw> s/is/are
14:20:43 <slashme> I think we are okay to move forward
14:21:14 <m3m0> #topic Nova and cinder backups review
14:21:51 <m3m0> ok, we've been having issues with users reporting nova and cinder backups are not working
14:22:14 <m3m0> this relates a bit with backup of vm's but let's go step by step
14:22:27 <m3m0> has anyone been working on nova or cinder lately/
14:22:30 <m3m0> ?
14:22:38 <ddieterly> m3m0 what users?
14:23:23 <daemontool> ddieterly, does that makes any difference? the point is that cinder and nova backups does not work
14:23:54 <daemontool> athinkingmeat if I remembe rwell is one of the users
14:24:01 <ddieterly> yes, it does make a difference. if it is hpe people, then we should have internal bugs filed.
14:24:01 <daemontool> or somethind like that
14:24:02 <EinstCrazy_> ping yangyapeng iceyao liudan
14:24:02 <yangyapeng> backup or restore ?
14:24:11 <daemontool> ddieterly, well then please discuss that
14:24:14 <daemontool> internally in hpe
14:24:19 <ddieterly> we also need to know what release
14:24:29 <m3m0> yangyapeng: backup
14:24:37 <ddieterly> we also need to know if it is just one user or many
14:24:47 <ddieterly> all this info helps us understand the issue
14:25:04 <daemontool> the issue is the cinder and nova backups are not working :)
14:25:19 <daemontool> so we are also doing tests in the lab for freezer
14:25:28 <daemontool> setting up the infrastructure
14:25:39 <ddieterly> what lab?
14:25:40 <daemontool> so we could also verify next week
14:25:52 <daemontool> a lab in bangalore
14:25:56 <daemontool> does that make any difference_
14:25:57 <daemontool> ?
14:25:59 <yangyapeng> now I foucs on cindernative backup ,  I should test nova and cinder
14:26:21 <ddieterly> yes, it gives us context to the issue
14:26:40 <daemontool> ok, a lab in bangalore :)
14:26:45 <ddieterly> is there a launchpad bug filed for these issues?
14:26:49 <m3m0> the situation here is, freezer has been advertised as a backup and restore as a service, which in really is not that, so in order to make that happen we need 2 thins: multitenancy support and nova-cinder backups working
14:27:16 <EinstCrazy_> but, our patches about them are hardly to get  review
14:27:25 <m3m0> my question here is, who else has priorities on this issues that would like to work on it?
14:27:46 <m3m0> EinstCrazy_: could you please add them here? https://etherpad.openstack.org/p/freezer_meetings
14:28:05 <m3m0> tomorrow we will dedicated time for this, and working on a better way to review patches
14:28:33 <daemontool> m3m0,  I think the features are there for baas
14:28:40 <yangyapeng> best idea review patch soon
14:28:40 <m3m0> not all of them
14:28:46 <daemontool> I agree
14:28:55 <domhnallw> Also, please mark your reviews with your name so that we know who's who (the name-colour association disappears when you leave Etherpad)
14:29:06 <daemontool> but the feedback is as far as I can understand, what we have does not work now
14:29:18 <m3m0> nova, cinder, horizon
14:29:21 <EinstCrazy_> but etherpad only works one time a week
14:29:41 <m3m0> EinstCrazy_: you don't have access to etherpad?
14:29:59 <domhnallw> I think the meaning is that people are only looking at it once a week, around now :)
14:30:27 <m3m0> yes yes, I agree with you, so I would like to propose a new way for this
14:30:43 <m3m0> * for doing this *
14:31:25 <m3m0> I'll share that next week, I don't have any idea right now :P
14:31:36 <m3m0> but definitely we need to change something
14:32:14 <domhnallw> I don't think a lot of the people who are down in the OpenStack wiki as being "core team" are really looking at freezer right now, that might be part of the problem.
14:33:00 <m3m0> that's something we can discuss
14:33:05 <domhnallw> Yup.
14:33:08 <m3m0> slashme ^^
14:33:47 <slashme> We are going to do some cleaning in the core team in the next few weeks.
14:33:49 <m3m0> where is the etherpad for tomorrow? can someone provide me the link?
14:34:00 <domhnallw> https://etherpad.openstack.org/p/freezer_midcycle_meetup_newton
14:34:00 <slashme> https://etherpad.openstack.org/p/freezer_midcycle_meetup_newton
14:34:05 <domhnallw> snap :P
14:34:36 <slashme> Grrrrr
14:34:39 <slashme> ;)
14:35:37 <m3m0> ok, we will discuss tomorrow cinder and nova with more depth
14:35:39 <m3m0> is that ok?
14:35:49 <domhnallw> Yup.
14:36:02 <m3m0> which I think this summarize the next topic
14:36:08 <m3m0> #Backup as a Service
14:36:12 <m3m0> #topic Backup as a Service
14:36:27 <m3m0> this is priority for the community
14:36:51 <slashme> And for many customers
14:37:03 <m3m0> but so far, there not that many people working on this, would someone like to work on it?
14:37:31 <ddieterly> m3m0 for the record what does that entail?
14:37:39 <domhnallw> ^^^ this
14:38:04 <m3m0> the ability to create backups and restore of machines at tenant level
14:38:40 <m3m0> so we can delegate the backups to the admin or any user of a tenant, rather than just backup of the infra
14:38:44 <daemontool> EinstCrazy_, yangyapeng  are working on it
14:39:02 <daemontool> ddieterly, backup tenants data and metadata
14:39:12 <ddieterly> thanks
14:39:22 <m3m0> perfect, I'll find the patches and prioritize the reviews and testing
14:39:28 <slashme> We also need the integration of oslo policy
14:39:39 <slashme> szaher has been working on it
14:39:59 <slashme> This will allow freezer objects to be treated as common openstack objects
14:40:25 <slashme> Like an admin of a tenant can access all backups made in that tenant
14:40:36 <slashme> Right now everithing is only user based
14:41:44 <m3m0> daemontool: could you help me re-review this? https://review.openstack.org/#/c/238969/4 :P
14:42:28 <m3m0> ok, can we move forward?
14:43:09 <m3m0> #topic  Horizon status
14:43:52 <m3m0> this repo has been forgotten for a while now :P does anyone with django exprience want to contribute
14:43:55 <m3m0> ?
14:44:06 <timothyb89> that's potentially something I could look into
14:44:18 <m3m0> the focus should be made in how to deploy it better
14:44:23 <daemontool> m3m0,  yes
14:44:25 <domhnallw> Ditto. I used to do some Pylons/Pyramid stuff back in the day, so Django shouldn't be rocket science.
14:44:26 <m3m0> timothyb89: that could be really great
14:44:42 <slashme> Very good news :)
14:45:09 <daemontool> m3m0,  cheeky monkey >)
14:45:16 <m3m0> right now most of the issues are at the deployment level and some minor while catching errors and providing bad error messages
14:45:42 <timothyb89> are issues with the ui filed at bugs.launchpad.net/freezer or does it have its own tracker somewhere?
14:46:03 <m3m0> right now is on the same, but does it make sense to split it?
14:46:25 <timothyb89> I don't have an opinion, just making sure I know where to look :)
14:47:05 <slashme> One tracker per project
14:47:13 <domhnallw> Where's the repo for the web ui?
14:47:14 <slashme> Not per component
14:47:35 <slashme> https://git.openstack.org/cgit/openstack/freezer-web-ui
14:48:16 <domhnallw> Thanks slashme
14:48:16 <m3m0> BTW
14:48:26 <m3m0> https://review.openstack.org/#/q/project:openstack/freezer-api++status:open
14:48:26 <m3m0> https://review.openstack.org/#/q/project:openstack/freezer++status:open
14:48:27 <m3m0> https://review.openstack.org/#/q/project:openstack/python-freezerclient++status:open
14:48:27 <m3m0> https://review.openstack.org/#/q/project:openstack/freezer-web-ui+status:open
14:48:29 <m3m0> boom
14:48:52 <m3m0> domhnallw: github.com/openstack/freezer-web-ui
14:48:56 <m3m0> as well
14:49:20 <m3m0> if you would like to contribute to the ui, let me know I can provide help for it
14:49:21 <domhnallw> Cheers, must have mistyped that when I tried it :)
14:49:31 <domhnallw> Okay.
14:49:36 <m3m0> can we move forward?
14:50:03 <m3m0> #topic Newton beta2 release
14:50:17 <slashme> Milestone 2 for the Newton release cycle was yesterday.
14:50:17 <slashme> As so, we release freezer v3.0.0 beta2
14:50:17 <slashme> Corresponding packages for freezer, freezer-api and freezer-web-ui have been uploaded to PyPI
14:50:33 <m3m0> what about python-freezerclient?
14:50:43 <slashme> It has another release schedule
14:50:50 <slashme> Independant
14:51:03 <slashme> We will release it very soon
14:51:22 <m3m0> ok, 'cause that is blocking us to move to that library
14:51:40 <m3m0> is there anything else you would like to share about this topic?
14:51:49 <domhnallw> m3m0, Is there something I can read about that?
14:52:02 <m3m0> what exactly?
14:52:29 <domhnallw> What's blocking what?
14:52:49 <domhnallw> What it is about the client that's problematic.
14:52:59 <m3m0> python-freezerclient should be added to the global-requirements in order to add it to the scheduler and ui
14:53:07 <m3m0> we need to install it from pip
14:53:34 <domhnallw> Okay.
14:53:37 <domhnallw> Thanks.
14:53:49 <m3m0> #topic Freezer talks in Barcelona
14:54:03 <m3m0> who's going to see meesi?
14:54:17 <slashme> As far as I know, two talks hve been submited :
14:54:27 <slashme> Freezer Bootcamp / Presenters: Deklan, Arun and myself.
14:54:28 <slashme> Freezer: What's new? Plugins and Deduplication! / Presenters: Guillermo and myself.
14:54:41 <slashme> Anyone else submited a talk ?
14:55:56 <m3m0> apparently no one else
14:56:05 <domhnallw> Nope.
14:56:13 <domhnallw> How long before you know if you've gotten approval?
14:56:15 <m3m0> ok, we cover all the topics, does anyone has anything to say?
14:56:29 <m3m0> first we need to vote for them :)
14:56:51 <m3m0> as soon as the voting is open I'll send the link :)
14:57:10 <m3m0> ok I think we can close the meeting
14:57:14 <m3m0> thanks all
14:57:17 <slashme> Thank you m3m0
14:57:17 <domhnallw> Thanks.
14:57:28 <m3m0> #endmeeting