14:01:55 <m3m0> #startmeeting freezer
14:01:57 <openstack> Meeting started Thu Aug 11 14:01:55 2016 UTC and is due to finish in 60 minutes.  The chair is m3m0. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:00 <openstack> The meeting name has been set to 'freezer'
14:02:08 <yangyape_> hello
14:02:13 <timothyb89> hello all
14:02:14 <szaher> Hey m3m0
14:02:20 <szaher> timothyb89: Hi Tim
14:02:21 <ddieterly> hell
14:02:23 <ddieterly> o
14:02:33 <szaher> ddieterly: Hey Deklan
14:02:36 <ddieterly> hi
14:02:38 <szaher> are you back ?
14:02:41 <ddieterly> yes
14:02:47 <domhnallw> o/
14:04:37 <m3m0> ok let's start
14:04:39 <daemontool> ok
14:05:00 <m3m0> #topic propose yangyapeng as core
14:05:10 <daemontool> +1
14:05:27 <ddieterly> +1
14:05:30 <daemontool> yangyape_, is always on the first line, giving support
14:05:35 <daemontool> providing information
14:05:37 <daemontool> contributing
14:05:38 <m3m0> IMHO this should be done soon but we need to wait until slashme comes back from holidays
14:05:38 <daemontool> reviewing
14:05:39 <szaher> +1 :)
14:05:55 <daemontool> ok
14:06:03 <m3m0> I think he is the one with superpowers to promote someone
14:06:08 <daemontool> ok
14:06:31 <m3m0> yangyapeng: are you here?
14:06:32 <yangyape_> thank you  very much  :)
14:06:43 * domhnallw is picturing slashme with a cape... it's not working.
14:06:43 <yangyape_> yeah
14:06:46 <m3m0> yangyape_: you deserve it :)
14:06:58 <yangyape_> thank you thank you
14:07:23 <m3m0> we just need to wait for the PTL to come back and send an email to the mailing list
14:07:39 <daemontool> ok
14:07:46 <daemontool> haha
14:07:47 <daemontool> good
14:07:49 <m3m0> it's a vote, subscribe to the openstack dev mailing list
14:07:50 <daemontool> next?
14:07:53 <m3m0> yes
14:08:21 <m3m0> #topic  BaaS status
14:08:46 <daemontool> is there any baas feature that is currently being implemented?
14:08:57 <m3m0> this is in the process to be merge
14:08:58 <m3m0> https://review.openstack.org/#/c/335274/
14:09:09 <m3m0> this will allow us to have backup as a service
14:09:35 <m3m0> and with the work on cinder and nova that the team at china has been doing we should be good to go
14:09:46 <daemontool> brilliant
14:10:03 <daemontool> ok
14:10:22 <m3m0> so, as always documenation improvements needs to be made to promote this
14:10:29 <daemontool> yes
14:10:33 <m3m0> #action improve docs for BaaS
14:11:28 <m3m0> who wants to take ownership of this?
14:11:36 <daemontool> I think the first doc
14:11:41 <daemontool> version should be probably written
14:11:49 <daemontool> by who provide the feature
14:11:52 <daemontool> then we can improve
14:12:02 <domhnallw> Makes a lot of sense.
14:12:15 <m3m0> szaher: you are on now :)
14:12:30 <szaher> :)
14:13:39 <m3m0> then can we move forward? or is there anything else here?
14:15:04 <m3m0> I'll take that as a yes
14:15:13 <m3m0> #topic  agent refactoring
14:15:27 <daemontool> engine refactoring_
14:15:28 <daemontool> ?
14:15:35 <szaher> Yes
14:15:37 <daemontool> so I can work 1 week per month
14:15:42 <m3m0> the plug in layers
14:15:42 <daemontool> anyone is working on this_
14:15:43 <daemontool> ?
14:16:11 <szaher> Eldar initiated a patch for this and I am following up
14:16:26 <daemontool> ok
14:16:34 <daemontool> let me know :)
14:16:37 <daemontool> I remember
14:16:37 <szaher> daemontool: Take a look here https://review.openstack.org/#/c/319182/
14:16:44 <daemontool> there's also a review
14:17:05 <szaher> it has been their since May
14:17:42 <szaher> To make things clear THIS WILL BREAK BACKWARD COMPATIBILITY
14:17:45 <daemontool> for metadata
14:17:49 <daemontool> ah ok
14:18:27 <ddieterly> szaher are we planning on creating an upgrade script to migrate data?
14:18:33 <szaher> #info freezer agent refactoring is going to break backward compatibility #link https://review.openstack.org/#/c/319182/
14:18:52 <szaher> ddieterly: Not yet as we didn't merge this patch
14:20:07 <ddieterly> i'm wondering about hos 5.0 which is based on newton and supports being upgraded from hos 4.0
14:20:21 <m3m0> is it possible to enable s3 as a storage backend?
14:20:39 <m3m0> (unrelated question)
14:20:40 <daemontool> 2 customers asked me about that
14:20:52 <szaher> when we complete the refactoring we can add this as an storage backend
14:24:19 <m3m0> any more updates on this topic?
14:24:36 <daemontool> not sure
14:24:45 <daemontool> I think the refactoring
14:24:49 <daemontool> is done for
14:25:00 <daemontool> engine, back end and snapshots?
14:25:12 <daemontool> eash one is probably independent_
14:25:14 <daemontool> ?
14:25:16 <m3m0> yes, basically every aspect of the agent
14:26:02 <m3m0> eash?
14:26:44 <m3m0> oooook I think I misunderstood the question
14:26:49 <daemontool> yes I think it is delivered by multiple
14:26:57 <daemontool> reviews right_
14:26:59 <daemontool> ?
14:27:03 <m3m0> szaher should know more about this
14:27:13 <m3m0> status and reviews for it
14:28:11 <m3m0> mmmm no?
14:28:28 <m3m0> let's move this topic for next week then
14:29:01 <m3m0> moving forward
14:29:04 <m3m0> #topic Lab testing results (to be provided next week in a etherpad)
14:29:09 <m3m0> what is this about?
14:30:18 <domhnallw> Am guessing this is Ericsson?
14:30:33 <daemontool> I'll be sharing this
14:30:35 <daemontool> next week
14:30:42 <daemontool> there are few issues
14:31:01 <daemontool> when executing backup and the job/ations
14:31:03 <daemontool> from the web ui
14:31:07 <daemontool> syncronization
14:31:08 <daemontool> et
14:31:08 <daemontool> c
14:31:24 <daemontool> it will be available in therpad as soon as I can publish it
14:32:10 <m3m0> daemontool: cool, thanks, are they people at ericsson interested in taking this?
14:32:15 <m3m0> I mean the fixes?
14:32:31 <daemontool> I don-t know
14:32:34 <daemontool> because
14:32:38 <daemontool> we have to do a demo
14:32:44 <daemontool> according the demo outcome
14:32:50 <daemontool> it will be decided
14:33:02 <daemontool> if resources will be allocated or not
14:34:03 <daemontool> so I don't know
14:34:19 <daemontool> hopefully yes
14:34:30 <daemontool> anyway I can work on Freezer 1 week per month
14:34:37 <daemontool> so let me know
14:34:43 <daemontool> what is needed and I'll do it
14:35:04 <m3m0> that's cool :) talk with slashme to get the priorities, he should be back soon
14:35:59 <daemontool> ok
14:36:01 <daemontool> :)
14:36:37 <m3m0> but for horizon, we should agree on how to approach new bugs, it's been a while since that repo got new commits
14:36:58 <daemontool> yes
14:37:36 <m3m0> ok, can we move forward?
14:38:42 <m3m0> #topic  logs type in ES
14:39:07 <m3m0> we need to store the logs of the backups as well as the metadata to improve the BaaS solution
14:40:17 <daemontool> yes
14:40:57 <daemontool> is that related to upstream?
14:41:22 <m3m0> yes, if we do this it will improve a lot the ui
14:41:42 <daemontool> ah ok
14:41:52 <m3m0> fro horizon we can know exactly what happened in a job, rather can getting the logs from the machine one each time
14:41:58 <daemontool> ah ok
14:41:59 <daemontool> got it
14:42:00 <daemontool> yes
14:42:22 <m3m0> should be easy to implement
14:42:40 <m3m0> but someone else needs to take ownership of this
14:42:58 <daemontool> I can take a look at it
14:43:11 <daemontool> but
14:43:16 <daemontool> I'm not sure I entirely got
14:43:26 <daemontool> do you mind m3m0 write something in etherpad
14:43:29 <daemontool> or launchpad
14:43:31 <m3m0> sure :)
14:43:33 <m3m0> I can do that
14:43:38 <daemontool> and I'll implement it?
14:43:42 <daemontool> ok thanks :)
14:44:05 <m3m0> thanks to you :)
14:44:11 <m3m0> is there anyting else pending?
14:44:29 <daemontool> it's all from me
14:44:41 <ddieterly> nothing from me
14:44:54 <szaher> I am OK :)
14:45:07 <m3m0> ok, we have 15 min left, we can close it early
14:45:20 <yangyape_> sure
14:45:22 <ddieterly> ok
14:45:24 <m3m0> thanks everyone and stay pending on #openstack-freezer channel
14:45:33 <domhnallw> Cheers.
14:45:36 <ddieterly> ciao
14:45:37 <m3m0> #endmeeting