14:00:31 <szaher> #startmeeting freezer
14:00:36 <openstack> Meeting started Thu Mar 16 14:00:31 2017 UTC and is due to finish in 60 minutes.  The chair is szaher. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:39 <openstack> The meeting name has been set to 'freezer'
14:01:01 <yangyapeng> hello szaher
14:01:05 <szaher> Hello everyone
14:01:08 <jvarlamova__> hi
14:01:13 <szaher> hello szaher
14:01:23 <raliev> hey everyone :)
14:01:23 <yangyapeng> hello jvarlamova__ :)ha-ha
14:01:28 <szaher> sorry :) I wasn't saying hi to myself :)
14:01:34 <szaher> Hi yangyapeng
14:01:58 <szaher> Please check the topics https://etherpad.openstack.org/p/freezer_meetings and add whatever topics you want to discuss
14:03:52 <szaher> raliev daemontool vnogin anyone is around ?
14:04:13 <raliev> szaher, yep, I'm here
14:04:51 <szaher> raliev: Cool!
14:04:55 <szaher> So Let's start guys
14:05:06 <szaher> #topic freezer-web-ui add interval
14:05:35 <yangyapeng> ping allen
14:05:36 <szaher> Please Let's group reviews at the end of the meeting
14:05:50 <szaher> Guys, we need more presence in the review :) we need to review more
14:06:10 <yangyapeng> agree it,
14:07:00 <yangyapeng> about this patch, i have a test, looks good.
14:07:16 <szaher> https://review.openstack.org/#/q/project:openstack/freezer+status:open
14:07:17 <szaher> https://review.openstack.org/#/q/project:openstack/freezer-api+status:open
14:07:17 <szaher> https://review.openstack.org/#/q/project:openstack/python-freezerclient+status:open
14:07:17 <szaher> https://review.openstack.org/#/q/project:openstack/freezer-dr+status:open
14:07:18 <szaher> https://review.openstack.org/#/q/project:openstack/freezer-specs+status:open
14:07:30 <szaher> you can add these links to your review board here https://review.openstack.org/#/settings/preferences
14:07:51 <szaher> #topic Specs deadline
14:08:23 <szaher> anyone wants to add specs to Pike the specs deadline is 17th March
14:09:09 <szaher> Also we need to merge existing specs if you agree with it https://review.openstack.org/#/q/project:openstack/freezer-specs+status:open
14:10:09 <szaher> not sure if we should move these ones to Pike directory or we leave them in Ocata
14:10:20 <szaher> I will be creating Pike directory today
14:11:21 <szaher> anyone want to add anything to specs topic or even specs repo ?
14:12:17 <szaher> Ok, Let's move on
14:12:34 <szaher> #topic Boston Summit brainstorming
14:13:04 <szaher> raliev jvarlamova__ yangyapeng anyone is going to attend Boston summit ?
14:13:52 <yangyapeng> i have no plan. raliev  jvarlamova__?
14:14:18 <raliev> unfortunately, nope
14:14:22 <jvarlamova__> no
14:15:09 <szaher> np, anyway it would be nice if you can share the ideas that you would like to discuss with the community in this etherpad #link https://etherpad.openstack.org/p/BOS-Freezer-brainstorming
14:16:25 <raliev> ok, will think about possible topics
14:16:38 <szaher> raliev jvarlamova__ where are you guys located ?
14:16:55 <raliev> szaher, Saratov, Russia
14:17:06 <jvarlamova__> szaher: Saratov
14:17:34 <szaher> Nice :) Let's hope we can get a summit in Russia
14:17:56 <yangyapeng> raliev: jvarlamova__  Shanghai, China :)
14:18:15 <raliev> may be :)
14:18:28 <szaher> yangyapeng: China would be great as well :)
14:18:37 <szaher> #topic Tenant Backups
14:19:40 <szaher> jvarlamova__: Did you test your fix for nova backups ?
14:19:57 <jvarlamova__> szaher: yes:)
14:20:40 <szaher> jvarlamova__: I was trying your patch for tenant backups today and it didn't work at all
14:20:41 <jvarlamova__> szaher: did you find any bugs?
14:20:59 <szaher> Also freezer master wasn't able to take nova backups
14:21:11 <szaher> It says Yes the backup is taken but the data size is zero
14:21:34 <szaher> Restore reports Yes and the instance reporting an error No bootable device
14:21:53 <jvarlamova__> szaher:  and what about backup/restore of single instance?
14:22:20 <szaher> jvarlamova__: Well, that was about the single instance backup
14:22:45 <szaher> jvarlamova__: Tenant backups was creating directories with the instances IDs and data file is zero size
14:23:04 <szaher> and the restore hangs after restoring the first instance
14:24:27 <jvarlamova__> szaher: so, looks like the problem is in nova engine?
14:25:32 <szaher> jvarlamova__: Yes, I think freezer fails to upload data to the right location and I think this causes problems. It's very strict to paths so when you change the path it might fail to backup/restore
14:26:43 <jvarlamova__> szaher: Actually when you take a snapshot of vm, it may have zero size, it's ok. So we may have  zero size files in nova backup container.
14:27:53 <jvarlamova__> szaher: but I'll take a look and test it once again
14:27:57 <szaher> jvarlamova__: I've been discussing this with Glance guys in the PTG this should be a bug in nova (according to our discussion), but I was busy (lazy enough) so I didn't file it upstream
14:28:13 <yangyapeng> if nova boot from volume, take snapshot it have a zero size in glance
14:28:37 <szaher> jvarlamova__: The zero size should happen only if you have the instance booted from volume ( this what happens to me)
14:28:50 <yangyapeng> szaher: yes
14:28:54 <szaher> yangyapeng: +1
14:29:20 <szaher> jvarlamova__: In my case I created 3 Cirros instances booted from normal image and the there failed to backup
14:29:25 <szaher> and restore
14:30:44 <jvarlamova__> sziher: actually when I create instance from image and take a snapshot, it has 0 size.
14:31:12 <yangyapeng> jvarlamova__: ?  what is  nova backend?
14:31:37 <yangyapeng> ceph?
14:33:07 <szaher> jvarlamova__: Ok Cool
14:33:07 <jvarlamova__> i believe it's swift
14:34:41 <szaher> jvarlamova__: It happened with me on local storage as well
14:35:39 <yangyapeng> nova cinder glance backend is ceph for me.
14:36:17 <jvarlamova__> szaher: so if you take snapshot manually, it isn't 0 size, but you have zero size files in nova backup container?
14:36:40 <jvarlamova__> szaher: i'll try to reproduce it
14:36:50 <jvarlamova__> szaher: thank you for testing!
14:37:02 <szaher> jvarlamova__: Let's talk about it on freezer room
14:37:10 <jvarlamova__> ok
14:37:22 <szaher> #topic Docs
14:37:47 <szaher> Anyone want to help me building installation guide at least https://review.openstack.org/#/c/445952/ ?
14:38:58 <szaher> api-ref I think we can leave it for a while after we move to v2
14:39:13 <szaher> at least please take a look at this one https://review.openstack.org/#/c/445952/
14:42:18 <szaher> Ok it seems to be I'm the only one working on it though, anyway It would be nice to take a look at least :)
14:42:23 <szaher> #topic Pike Goals
14:42:49 <szaher> we have two goals
14:43:20 <szaher> fully support python 3.5 https://governance.openstack.org/tc/goals/pike/python35.html
14:44:11 <szaher> anyone would like to have the ownership of getting this goal done yangyapeng: raliev: ?
14:45:04 <szaher> it shouldn't be a too much to do as we have an upstream gate to takecare of it, but just make sure we follow everything written here https://governance.openstack.org/tc/goals/pike/python35.html
14:45:23 <szaher> raliev: yangyapeng  anyone ?
14:45:42 <raliev> szaher, I can take this point, but only after implementing cinder os-brick backup
14:45:56 <raliev> because i'm working on it now
14:46:19 <szaher> raliev: Thanks! :)
14:46:41 <szaher> second point is Control Plane API endpoints deployment via WSGI
14:48:19 <szaher> Well, to some extent we are following this but we need a couple of more patches
14:48:42 <szaher> anyone wants to takecare of this one ? If not I can take of it
14:49:10 <yangyapeng> szaher: hello, sorry, have a negligence, me too to update it
14:49:32 <yangyapeng> https://governance.openstack.org/tc/goals/pike/python35.html
14:49:56 <szaher> yangyapeng: I think raliev: will takecare of it, you can coordinate with him if you want :)
14:50:26 <szaher> for the WSGI goal I will takecare of it :) If you want to do anything around it you're more than welcome :)
14:50:51 <szaher> #action raliev will takecare of Pike Goal Fully Support Python 3.5
14:51:05 <raliev> szaher, okay :)
14:51:07 <szaher> #action szaher will takecare of Pike Goal Control Plane API endpoints deployment via WSGI
14:51:19 <yangyapeng> :)
14:51:42 <szaher> yangyapeng: Do you want to work with me on this one https://review.openstack.org/#/c/445952/ ?
14:52:06 <yangyapeng> ok
14:52:13 <szaher> yangyapeng: Thank You! :)
14:52:29 <szaher> #topic resource availability
14:53:03 <szaher> How much are you guys available to work on Freezer, raliev jvarlamova__ yangyapeng ?
14:54:36 <raliev> szaher, freezer is my first priority assignment till the end of Q1, don't know for sure plans for Q2
14:55:18 <szaher> raliev: When Q1 ends :) ?
14:55:32 <raliev> March, 31 :)
14:55:43 <szaher> raliev: Ok
14:55:58 <szaher> jvarlamova__: ?
14:56:01 <szaher> yangyapeng: ?
14:56:14 <yangyapeng> szaher: I have about a quarter of the time
14:56:17 <raliev> anyway, I'll proceed contribute into freezer :)
14:56:32 <szaher> raliev: Nice!, Thanks :)
14:56:49 <szaher> anyway we're running out of time
14:57:05 <raliev> but if it will by my first priority, i'll spend more time on it :)
14:57:27 <jvarlamova__> szaher: I'll work on freezer in this quarter, not sure about the next quarter
14:57:30 <yangyapeng> We are promoting freezer in State Grid of china,
14:57:40 <szaher> Please guys try to support yangyapeng on this one Freezer-resource (integration with heat) https://review.openstack.org/#/c/443426/
14:57:51 <szaher> yangyapeng: Thanks!
14:57:56 <szaher> jvarlamova__: Ok, Thanks! :)
14:58:10 <yangyapeng> i add the templates about freezer, but it have a jenkins -1
14:58:26 <szaher> yangyapeng: I will take a look
14:58:36 <yangyapeng> szaher: thanks
14:58:38 <szaher> Thank you guys for attending the meeting today :)
14:58:52 <szaher> anyone to add anything ?
14:58:57 <raliev> thanks everyone :)
14:59:15 <jvarlamova__> thank you:)
14:59:18 <yangyapeng> :) thank you
14:59:54 <szaher> Cool!, for you to know tomorrow we will be Off in Ireland and I think US :)
15:00:25 <szaher> so Have a good weekend and chat to you soon :)
15:00:33 <bswartz> st patrick's day isn't a federal holiday in the US
15:00:52 <szaher> bswartz: oh, didn't know that :)
15:01:01 <szaher> It's a holiday in Ireland
15:01:04 <szaher> sorry need to go
15:01:06 <szaher> Thanks guys
15:01:07 <szaher> #endmeeting