14:00:10 <szaher> #startmeeting freezer
14:00:11 <openstack> Meeting started Thu Apr 20 14:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is szaher. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'freezer'
14:00:22 <slashme> Hi  szaher
14:00:22 <szaher> Hello guys
14:00:33 <yangyapeng> Hi szaher
14:00:36 <jiaopengju> hi
14:00:55 <szaher> Please take a look at the meeting agenda for today https://etherpad.openstack.org/p/freezer_meetings
14:01:48 <yangyapeng> jiaopengju: I see some common in freezer  admin action  patch
14:02:12 <szaher> #topic blueprints and bugs filtering and handling
14:02:35 <szaher> #link https://launchpad.net/freezer
14:03:02 <szaher> guys, we have a lot of blueprints, bugs are open and they're not scope to a certain release or milestone
14:03:20 <vnogin> hi guys
14:03:28 <yangyapeng> Define the priority ?
14:03:30 <yangyapeng> szaher:
14:03:51 <szaher> I need your help to comment on them and review them with me so we can remove what's obsolete and define it's priority
14:03:58 <yangyapeng> I found some bugs, it have been fixed.
14:04:17 <szaher> yangyapeng: Yes + we need to know what's really bug and what's a user issue or miss configuration or whatever
14:04:34 <szaher> yangyapeng: comment on them and I will close it
14:05:06 <szaher> also please, we need to have a clear commit message with the bug # in it or which blueprint
14:05:21 <szaher> this will make things easier to trace and handle later on
14:05:29 <vnogin> +
14:05:43 <yangyapeng> we should add commit message  Close-Bugs: #xxxx
14:06:00 <szaher> for people who doesn't know how to write a good commit message take a look here https://wiki.openstack.org/wiki/GitCommitMessages
14:07:38 <szaher> slashme, m3m0, yangyapeng, daemontool, raliev, szaher all core members please don't merge any patch without a bug # or blueprint in the commit message
14:07:51 <szaher> Thank You!
14:08:10 <szaher> #topic kolla-ansible  (freezer)
14:08:29 <szaher> yangyapeng: Do you want to integrate freezer with kolla ?
14:08:36 <vnogin> szaher: -1 for all patches without it from my side :))
14:08:45 <raliev> hey guys :)
14:08:49 <szaher> vnogin: Thanks
14:08:50 <yangyapeng> no  , we  have 2 core member in kolla
14:08:55 <szaher> raliev: hello
14:09:16 <yangyapeng> but i should push it to finally integrate freezer with kolla
14:09:29 <yangyapeng> but it have some question,
14:09:43 <szaher> so you're going to submit a patch to integrate freezer with kolla ?
14:09:45 <szaher> what question ?
14:10:23 <yangyapeng> 1. freezer-scheduler start manual, if we should other methods
14:11:02 <yangyapeng> 2、kolla need to do some demo usage after freezer install.
14:11:08 <szaher> yangyapeng: what do you mean by start manual ?
14:11:49 <yangyapeng> szaher: now, we start freezer-scheduler by manual
14:12:00 <slashme> For the demo: https://github.com/sl4shme/venvs/tree/master/examples
14:12:58 <szaher> yangyapeng: there is a config option in freezer-scheduler called no_daemon you can try to set this to true it's shouldn't be running in  the bg anymore
14:12:59 <yangyapeng> OK. demo it is nice
14:13:11 <szaher> yangyapeng: did that answer your question ?
14:13:18 <yangyapeng> szaher: oh oh, thank you
14:13:27 <szaher> yangyapeng: Cool!
14:13:45 <szaher> Please keep us updated with your progress with kolla integration :)
14:13:50 <yangyapeng> ok
14:13:51 <szaher> yangyapeng: Thanks :)
14:14:14 <szaher> anyone want to add anything ?
14:14:39 <szaher> #topic Freezer to join OpenStack ansible
14:15:32 <yangyapeng> Good idea, write a ansible-playbook ?
14:15:33 <szaher> vnogin: Do you wanna lead the efforts on this topic ?
14:16:20 <vnogin> szaher: yep, however I'm not sure how much I'll have for this activity
14:16:23 <szaher> we are going to open a repo https://github.com/openstack/openstack-ansible-os_freezer  like other projects where we can write ansible playbooks for freezer
14:17:11 <szaher> take  https://github.com/openstack/openstack-ansible-os_glance
14:17:14 <yangyapeng> we could write some sample moudle in anisble first.
14:17:18 <vnogin> szaher: anyway, we should do it
14:17:19 <szaher> take a look at this one
14:17:34 <szaher> vnogin: I will try to put some effort on that as well
14:17:45 <szaher> I will be working with you don't worry :)
14:17:52 <vnogin> szaher: cool :)
14:18:10 <slashme> I'm okay to work on this :)
14:18:22 <vnogin> szaher: slashme nice team :)
14:18:25 <szaher> slashme: vnogin: Nice !
14:18:49 <szaher> cool so actions
14:19:05 <szaher> #action szaher will open openstack-ansible-os_freezer repo for freezer ansible code
14:19:42 <szaher> anything to add ? anyone ?
14:20:06 <szaher> #topic Trello board for freezer
14:20:32 <szaher> I've created a trello board for freezer so we can share some ideas
14:20:45 <szaher> #link https://trello.com/b/0ob58uWt/freezer  you can find it here
14:21:03 <szaher> you can comment on tickets or create new ones
14:21:20 <szaher> finally i will be creating blueprints from those tickets
14:21:32 <vnogin> awesome
14:21:43 <jiaopengju> nice
14:21:58 <szaher> Thanks :)
14:22:18 <szaher> #topic Freezer documentation
14:22:40 <szaher> daemontool: ping
14:23:18 <szaher> daemontool: Ananya didn't contact me to let her know what do we need for freezer
14:23:36 <szaher> vnogin: Do you know anything about Ananya ?
14:24:03 <jiaopengju> As a beginner of freezer, I was confused by the documentation sometimes.
14:24:09 <vnogin> szaher: nope :(
14:24:19 <szaher> jiaopengju: we're trying to solve this :)
14:24:26 <vnogin> jiaopengju: everybody is confused
14:24:30 <jiaopengju> thanks
14:24:43 <jiaopengju> the documentation is not match with the code
14:25:11 <szaher> just to let you know guys. TC will add a new badge to certify projects install-guide and docs
14:25:30 <szaher> so for now we won't get that badge as we don't have any installation guides!
14:26:16 <szaher> I hope we can get the install-guide and developer docs live this release, that will be a big addition to freezer
14:26:32 <vnogin> szaher: 100% agree
14:26:39 <yangyapeng> agree
14:26:41 <jiaopengju> +1
14:26:49 <slashme> +1
14:28:26 <szaher> I hope we can get Ananya to work on that soon :)
14:28:58 <szaher> anyway, I'm going to skip some topics as daemontool seems to be busy and not in the meeting today
14:29:18 <szaher> is mnaser: and m3m0: around ?
14:29:55 <szaher> seems to be no :(
14:30:29 <szaher> #topic Centos gate job update
14:30:51 <szaher> I've create a gate job to test freezer on centos
14:31:43 <szaher> the gate job appeared in the ci but it's always failing
14:32:31 <szaher> I will try to work on fixing it soon, but till now it seem to be devstack problem
14:32:40 <szaher> I will keep you posted on the progress :)
14:33:26 <szaher> #topic heat integration
14:33:52 <szaher> yangyapeng: did you take a look recently at this https://review.openstack.org/#/c/443426/
14:34:23 <szaher> we need to assign this spec to someone to work on it
14:34:32 <yangyapeng> szaher: yeah
14:34:45 <szaher> I think there is a couple of issues as well
14:34:48 <yangyapeng> szaher:  assign  to ?
14:35:08 <szaher> yangyapeng: not sure who is going to work on that at the moment, do you have room for it ?
14:35:59 <yangyapeng> szaher: i can do it , but It may be after 2 weeks
14:36:26 <szaher> yangyapeng: no problem just adjust the milestone to be pike-rc1
14:36:36 <yangyapeng> szaher: OK
14:36:45 <szaher> Thanks!
14:37:28 <yangyapeng> szaher: :)
14:39:15 <szaher> move on ?
14:39:23 <yangyapeng> szaher: next topic
14:39:31 <szaher> #topic oslo.db patch
14:40:03 <szaher> vnogin: Did you see Dima :) ?
14:40:12 <jiaopengju> yangyapeng: what's your meaning of "I see some common in freezer  admin action  patch", do you mean these two patches? https://review.openstack.org/#/c/455495/ and https://review.openstack.org/#/c/458412/
14:40:22 <vnogin> szaher: I can ping him by slack :)
14:40:41 <szaher> vnogin: nice
14:40:50 <szaher> we need to have a bit discussion about this patch
14:41:08 <szaher> I don't know if I should comment on this patch now or I should wait
14:41:26 <yangyapeng> jiaopengju: no, https://review.openstack.org/#/c/458379/ this patch, this patch need more review -1, i should update it
14:41:50 <jiaopengju> got it
14:41:59 <vnogin> as far as I know this patch should be reviewed. However I see some problems with passing our gates :(
14:43:46 <yangyapeng> vnogin: i guess your tox test ,it is ok, i have the some question
14:43:57 <yangyapeng> same
14:45:37 <szaher> vnogin: I can some problems with the patch
14:45:57 <szaher> so I wanted to have a discussion with him first before I comment or review
14:46:19 <szaher> for example till now there is oslo.db in requirements.txt :)
14:46:39 <szaher> I need to update the gate job to use mysql instead of elasticsearch or add one more gate job
14:47:20 <vnogin> szaher: he hasn't replied me in slack
14:47:45 <vnogin> however I think we can ping him tomorrow in irc freezer room
14:48:45 <szaher> vnogin: Ok seems Ok to me
14:49:03 <szaher> vnogin: Thanks !
14:49:12 <vnogin> cool, however I'll try to ping him after the meeting again
14:49:16 <szaher> #topic reviews
14:50:00 <yangyapeng> szaher: https://review.openstack.org/#/c/458379/  please review it, need more than -1
14:50:03 <szaher> there are few reviews available upstream so we need to get these patches reviewd
14:50:13 <szaher> for now take a look at this one #link https://review.openstack.org/#/c/458379/
14:53:45 <vnogin> ok
14:53:51 <szaher> anyone wants to add anything before we go :) ?
14:53:56 <szaher> #topic Open discussion :)
14:54:18 <szaher> anyone wants to discuss anything or any topic ?
14:54:46 <szaher> vnogin: ?
14:54:48 <szaher> yangyapeng: ?
14:54:51 <szaher> raliev ?
14:54:56 <szaher> slashme: ?
14:54:57 <szaher> m3m0 ?
14:55:05 <szaher> jiaopengju:  ?
14:55:19 <vnogin> install guide has been discussed already :)
14:55:31 <vnogin> however I want to mention that we REALLY need it :)
14:55:49 <jiaopengju> +1
14:55:51 <szaher> vnogin: I will try to do some efforts around it as well :)
14:56:07 <szaher> vnogin: I totally agree with you :)
14:56:07 <vnogin> szaher: thank you so much :)
14:56:28 <szaher> I hope to get Ananya back soon so she can help a lot :)
14:56:35 <vnogin> me too :)
14:56:56 <szaher> anyway let's continue in freezer room as we're running out of time :)
14:57:00 <szaher> Thanks Guys :)
14:57:08 <yangyapeng> thank you szaher
14:57:15 <slashme> Thank you szaher
14:57:30 <jiaopengju> thank you szaher
14:58:01 <szaher> #endmeeting