14:00:19 <szaher> #startmeeting freezer
14:00:19 <openstack> Meeting started Thu May 25 14:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is szaher. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:22 <openstack> The meeting name has been set to 'freezer'
14:00:46 <szaher> Hello everyone
14:00:50 <jiaopengju> hi
14:00:56 <szaher> Let's wait 5 minutes for everyone to join
14:01:01 <szaher> jiaopengju: hi :)
14:01:18 <szaher> Please find the meeting agenda here #link https://etherpad.openstack.org/p/freezer_meetings
14:02:12 <vnogin> hi guys )
14:02:21 <szaher> vnogin: Hi Vitaliy
14:02:23 <Yangyapeng> szaher hi
14:02:34 <vnogin> szaher: hi Saad :)
14:02:34 <szaher> Yangyapeng: Hey :) How are you ?
14:03:00 <Yangyapeng> szaher  Often have a business trip recently :(
14:03:17 <szaher> Yangyapeng: Are you back again to China ?
14:03:24 <Yangyapeng> vnogin Congratulations  :)
14:03:39 <vnogin> Yangyapeng: thanks a lot :)))
14:04:11 <szaher> Guys please add topics to the agenda https://etherpad.openstack.org/p/freezer_meetings
14:06:04 <Yangyapeng> szaher yeah
14:09:49 <szaher> Ok let's start ?
14:09:56 <vnogin> +
14:10:11 <jiaopengju> ok
14:10:34 <szaher> #topic reviews
14:10:56 <szaher> We need more people to test features till we develop tempest tests for these features
14:11:12 <slashme> Especialy Nova and Cinder backups
14:11:20 <szaher> for example nova backups, I'm working on a tempest test for nova backups at the moment so we can merge things fast
14:11:21 <szaher> er
14:11:25 <slashme> And rsync engine
14:11:28 <szaher> slashme: +1
14:12:19 <vnogin> cool
14:12:21 <szaher> anyone willing to test those features as well ?
14:12:27 <raliev> hey guys :)
14:12:35 <szaher> I won't last long as I'm working on the tempest tests for them
14:12:41 <szaher> raliev: Hey Ruslan :)
14:13:10 <jiaopengju> I'am testing the nova and cinder backups
14:13:16 <szaher> we're talking about tempest tests for features that are important and doesn't have tempest tests
14:13:46 <szaher> jiaopengju: Yes, I can see but you're submitting some patches as well so we need someone else to test it as well
14:14:38 <jiaopengju> szaher: it is really need
14:14:56 <szaher> raliev: Can you develop some tempest tests for rsync ? so we make sure it's always working ;) ?
14:15:05 <szaher> Also Cinder os-brick engine ?
14:15:57 <raliev> as far as I remember, I created some tests for rsync engine
14:16:09 <raliev> but there is need to check
14:16:17 <raliev> as well as for os-brick
14:16:45 <szaher> raliev: I don't think those were tempest tests
14:17:07 <raliev> szaher, probably you're right :)
14:17:38 <szaher> raliev: so will you get the time to develop some tests ?
14:18:25 <raliev> I think yes
14:18:38 <szaher> raliev: Thanks :)
14:18:48 <szaher> so hopefully this will speedup things as well
14:18:54 <raliev> are you modified it a bit already?
14:19:00 <raliev> I mean tempest tests
14:19:04 <raliev> in general
14:19:07 <szaher> m3m0 is working now on the new UI and moving freezerclient freezer schedule to api v2
14:19:52 <szaher> raliev: I'm working on a patch to create instance and back it up using tempest so hopefully we can reuse the code for different use cases
14:20:09 <szaher> https://review.openstack.org/#/c/467692/
14:20:18 <szaher> sorry wrong one :(
14:20:28 <szaher> https://review.openstack.org/#/c/466763/
14:22:11 <szaher> hopefully that will help for nova and we can try it with cinder as well
14:23:11 <szaher> the thing is there are some patches are waiting upstream for someone to test it but it's only me testing patches offline when I get the time to do so, otherwise things might be broken
14:24:35 <Yangyapeng> indeed
14:24:56 <szaher> so I hope to get people to test those patches with me :)
14:25:38 <szaher> Also please It doesn't matter if you're a core or not, we need as many people as we can to review the code and +1 or -1
14:26:10 <szaher> you'll find all links under code review https://etherpad.openstack.org/p/freezer_usefull_links
14:26:20 <szaher> Ok, let's Move on ?
14:26:25 <jiaopengju> ok
14:27:05 <szaher> #topic ceph support
14:27:43 <szaher> jiaopengju: There is ceph support in freezer using rados gateway which simulates swift api
14:28:09 <szaher> jiaopengju: do you want to support swift in a different way ?
14:28:47 <jiaopengju> I means that do we have plan to support s3?
14:29:48 <szaher> Well, if it's s3 that fine :)
14:29:55 <szaher> It should be easy to do so
14:30:25 <szaher> the storage part in freezer is plugable so you should be able to add driver but It might need some integration with the config opts
14:31:10 <jiaopengju> ok, I would like to try. Because we use ceph object storage in our public or private cloud
14:32:18 <szaher> jiaopengju: If you have rados gateway ceph should work with swift driver without any problems
14:33:24 <jiaopengju> szaher: yes, but maybe we must integrate with keystone
14:34:05 <jiaopengju> In our cloud environment, ceph object storage is a relatively independent part
14:34:24 <szaher> jiaopengju: Ok :) so that is a different story :)
14:35:17 <szaher> jiaopengju: but as I've told you, you can build an s3 driver to upload your backups to s3
14:35:42 <jiaopengju> szaher: thanks, I will try it
14:36:13 <szaher> jiaopengju: If you need anyhelp let me know
14:36:21 <jiaopengju> ok
14:36:21 <szaher> may be i will be able to help :)
14:36:27 <jiaopengju> thanks a log
14:36:30 <jiaopengju> log
14:36:31 <jiaopengju> lot
14:36:37 <vnogin> :)
14:37:01 <szaher> anyone wants to add anything ?
14:37:28 <szaher> move on ?
14:37:32 <vnogin> +
14:37:37 <jiaopengju> +1
14:37:39 <szaher> #topic move tempest test to separate repo
14:37:43 <vnogin> For instance: http://lists.openstack.org/pipermail/openstack-dev/2016-April/091425.html and https://docs.openstack.org/developer/tempest/plugin.html#standalone-plugin-vs-in-repo-plugin
14:37:46 <szaher> move tempest test to separate repo (instance https://review.openstack.org/#/q/project:openstack/ironic-tempest-plugin ) (vnogin)
14:39:05 <szaher> Let's vote please use +1 pr -1
14:39:07 <szaher> +1
14:39:13 <szaher> Let's create a repo
14:39:15 <vnogin> +1
14:39:18 <Yangyapeng> +1
14:39:23 <jiaopengju> +1
14:40:15 <slashme> +1
14:40:23 <szaher> Ok, Looks like we gonna create it :)
14:40:41 <szaher> #agreed Create freezer standalone tempest repo
14:41:19 <szaher> anyone wants to add anything ?
14:41:39 <szaher> #topic #General Discussion
14:42:08 <szaher> https://review.openstack.org/#/c/466826/
14:42:33 <szaher> I've submitted for Pike goal python3.5 and I've done some patches to do it in different repos
14:42:50 <szaher> I will be working soon on the other goal uwsgi
14:44:49 <szaher> anyone wants to discuss anything please raise and let's discuss it
14:45:08 <jiaopengju> Currently, restore nova feature is broken
14:45:24 <jiaopengju> so I submit this patch: https://review.openstack.org/#/c/467917/
14:47:33 <szaher> jiaopengju: I'll take a look
14:47:46 <jiaopengju> szaher: thanks
14:48:34 <szaher> jiaopengju: Yea, I knew this one as python-novaclient 7.1 contains the networks object and after that the networks object got removed
14:48:51 <jiaopengju> yes
14:48:52 <szaher> if you do pip freeze on your env you'll find novaclient 8.x
14:48:59 <szaher> which breaks this one :)
14:49:21 <szaher> so I knew it before but I was busy with other stuff
14:49:24 <szaher> jiaopengju: Thanks :)
14:49:35 <szaher> jiaopengju: approved :)
14:49:46 <jiaopengju> szaher: thanks
14:50:35 <szaher> anything else ?
14:50:41 <szaher> vnogin ?
14:51:06 <szaher> by the way, Is dima gonna be back soon or should I work on oslo.db or find someone to work on it ?
14:51:42 <szaher> raliev: are you going to be working on something in a short term period ?
14:52:34 <raliev> yep
14:52:40 <szaher> great
14:52:43 <szaher> Thanks :)
14:53:20 <szaher> anyone wants to add anything or should we close ?
14:54:00 <szaher> Ok, Thanks a lot
14:54:01 <szaher> #endmeeting