16:00:55 <xarses> #startmeeting fuel
16:00:55 <openstack> Meeting started Thu Jul 23 16:00:55 2015 UTC and is due to finish in 60 minutes.  The chair is xarses. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:55 <xarses> #chair xarses
16:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:59 <openstack> The meeting name has been set to 'fuel'
16:01:00 <openstack> Current chairs: xarses
16:01:07 <mwhahaha> ahoy
16:01:08 <xarses> Todays Agenda:
16:01:08 <xarses> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:01:08 <xarses> Who's here?
16:01:10 <bookwar> hi
16:01:10 <vkramskikh> hi
16:01:10 <ikalnitsky> \o/
16:01:13 <IvanKliuk> hi
16:01:13 <jaranovich> hi
16:01:19 <maximov> hi
16:01:22 <kpimenova> hi
16:01:25 <MorAle> o/
16:01:30 <xenolog13> hi
16:01:32 <akislitsky> hi
16:01:32 <tatyana> hi
16:01:36 <evgenyl> hi
16:01:40 <xarses> #topic Auto-abandon and current status with code reviews (mihgen)
16:01:40 <warpc__> hi
16:01:43 <rvyalov> hi
16:01:45 <agordeev> hi
16:01:47 <igorbelikov> hi
16:02:12 <mattymo_> hi
16:02:30 <xarses> mike's not here, lets circle back
16:02:40 <xarses> #topic The status of fuel-upgrade code and upgrading of the Fuel Master node to 7.0 (ogelbukh)
16:02:42 <rmoe> hi
16:03:49 <alex_didenko> 0/
16:04:03 <ikalnitsky> alex_didenko: o/
16:04:13 <mihgen> sorry folks I'm late. I wanted to say about upgrades & FFE request - we need to get Nailgun cores to reply on ogelbukh email in openstack-dev
16:04:18 <mihgen> risks needs to be estimated
16:04:32 <kozhukalov> ogelbukh, please let's call it fuel-octane to avoid confusing with fuel-upgrade which is master node upgrade
16:04:52 <salmon_> hi
16:04:54 <mihgen> and if we have any suggestions on how to mitigate risks - please propose those.
16:05:09 <alexz> o/
16:05:16 <xarses> ok, lets star over here, ogelbukh is not responing
16:05:25 <xarses> mike lets start with auto-abandon
16:05:32 <mihgen> xarses: sure
16:05:43 <xarses> #topic Auto-abandon and current status with code reviews (mihgen)
16:06:22 <mihgen> folks I looked at date, and for all reviews we have recently (in last weeks) - we are doing very, very good job with reviews, providing prompt feedback
16:06:23 <ogelbukh> hi
16:06:43 <mihgen> though at the same time, most of reviews come from cores, which means they are getting over loaded
16:06:57 <mihgen> so that means that we need to have other developers reviewing more
16:07:11 <mihgen> I'll come up with more detailed data separately.
16:07:27 <mihgen> Now, regardarding stackalytics stats. They are in terrible shape still
16:07:46 <mihgen> as we still didn't clean up all stalled reviews which sit there for months
16:07:56 <mihgen> (at least as per yesterday's investigations)
16:08:24 <mihgen> So do you guys agree that we looked into it, and now just need to enable auto-abandon?
16:08:36 <mihgen> for everything which hangs for over a month?
16:08:36 <ogelbukh> I guess mostly all things that sit for months are outdated and irrelevant
16:08:56 <evgenyl> +1 for enabling auto-abandon
16:08:58 <mattymo_> +1
16:09:02 <warpc__> +1
16:09:03 <ikalnitsky> +1
16:09:06 <xarses> mihgen: +1 to enable -1 for 1moth
16:09:07 <akasatkin> agree. but there are exceptions like specs.
16:09:13 <xarses> lets start with 2 mo for now
16:09:25 <xenolog13> +1 for auto-abandon for requests with at least one "-1"
16:09:25 <ogelbukh> +1 fwiw
16:09:26 <xarses> and asses what is still in 1-2 moth old and why
16:09:29 <evgenyl> xarses: what is the reason for 2 month?
16:09:33 <mihgen> akasatkin: we need to provide feedback there then?
16:09:36 <evgenyl> xarses: I think 1 month should be just fine.
16:09:44 <ogelbukh> I don't think the specs are exception
16:09:47 <xarses> items with -1,-2 because of FF
16:09:52 <akasatkin> mihgen: yep, right
16:10:02 <xarses> dev wont touch them untill release most likely
16:10:34 <mihgen> So folks but simple comment in there would reset the time, right?
16:10:41 <xarses> Would it?
16:11:03 <ogelbukh> well, it's not that difficult to activate something abandoned
16:11:07 <mihgen> #link http://stackalytics.com/report/reviews/fuel-group/open
16:11:09 <evgenyl> As far as I know commenting works fine.
16:11:42 <mihgen> yep. So according to comment from Neutron team I think, you can always make it back
16:11:48 <ogelbukh> when it's time to look into it again
16:11:49 <mihgen> we talk more
16:12:17 <ogelbukh> loooks like we're all in agreement here :)
16:12:40 <mihgen> so guys I think we just need to move forward with this. I can't get real numbers without doing this, and I really want real numbers as I still hear complaints that Fuel team doesn't do good job on code review
16:13:03 <mihgen> ok. bookwar - how can we enable it?
16:13:07 <mihgen> auto-abandon?
16:13:19 <mihgen> anyone from devops team ?
16:13:32 <bookwar> i don't think we can enable it on gerrit, we should just write script which does it
16:13:48 <mihgen> we need to figure out how other teams do it
16:13:59 <maximov> https://github.com/openstack/neutron/blob/master/tools/abandon_old_reviews.sh
16:14:00 <mihgen> I think there should be something in infra..
16:14:02 <maximov> for example
16:14:04 <ogelbukh> or rather reuse one out of existing ones
16:14:34 <mihgen> can we have it as an action item for devops team?
16:14:40 <xarses> ok, can we move this along, the schedule is full
16:14:42 <mihgen> to run it this week
16:14:53 <mihgen> and then enable it periodically?
16:14:54 <xarses> bookwar: can I assign it to you?
16:15:06 <bookwar> xarses: no, on teran
16:15:09 <xarses> ok
16:15:22 <xarses> lets move on, and write the results to the ML
16:15:23 <mihgen> thanks guys, sorry it took long
16:15:35 <xarses> #topic Features requiring FF exception (mihgen)
16:15:50 <mihgen> it has two subtopics, let's go into them
16:16:02 <xarses> #topic Cluster Upgrade FF exception request (ogelbukh)
16:16:18 <ogelbukh> I formally requested FFE for cluster upgrade nailgun API extensions
16:16:27 <mihgen> python team - we need to respond on it
16:16:37 <mihgen> major things we have to consider is how risky changes are
16:16:43 <mihgen> can they introduce regressions
16:16:43 <ogelbukh> the patches are being actively worked on
16:16:57 <mihgen> and how much effort would it take from cores to review / test / land
16:16:58 <evgenyl> mihgen: ogelbukh I will provide my thoughts about it in ML
16:17:18 <ogelbukh> they are mostly separated from core functionality
16:17:21 <mihgen> so we'd understand if it will lead to slip of the release dates or not.
16:17:34 <mihgen> As for essential features we pretty much need to give exception
16:17:53 <mihgen> ogelbukh: ok thanks
16:18:05 <mihgen> other exception? xarses ?
16:18:22 <xarses> #topic     (FFE) Separate services from controller status (matt) <- Discuss gray area of plugin development
16:19:22 <mihgen> mattymo: ?
16:19:23 <xarses> mattymo^^
16:19:38 <mattymo_> hi sorry
16:19:41 <mattymo_> nick is messed up
16:19:50 <xarses> #action teran will enable script to abandon stale commits over 1 moth and run it every once and a while
16:19:56 <xarses> happens
16:20:11 <mattymo_> so Andrew Maksimov asked me to bring this up in FFE section because it's a gray area
16:20:18 <mattymo_> All core features to fuel-library are merged. All dependent features (network templates, VIP as plugin, role as plugin) are also merged.
16:20:28 <mattymo_> There are 3 plugins that demonstrate this feature's capability: https://github.com/mattymo/detach-database https://github.com/mattymo/detach-keystone https://github.com/mattymo/detach-rabbitmq
16:20:29 <mattymo_> The plan is to publish these plugins, but they are not part of fuel.
16:20:53 <xarses> The whole point of plugins is that they don't have to conform to our release schedule
16:20:59 <xarses> so I think this is a no-brainer
16:21:01 <mattymo_> the catch is they're not 100% ready. database and rabbitmq seem okay so far, but haven't been very extensively tested yet. keystone is a couple days from ready
16:21:10 <xarses> if its 100% a plugin, then you don't need FFE
16:21:24 <xarses> if you need something in fuel's core still then we need to discuss that
16:21:30 <mattymo_> the reason they're behind is because on Monday my dependent features became ready, and I just haven't finished refactoring the plugins and removing workarounds
16:21:46 <mihgen> yeah, though you need to ensure they are good for release time, along with good documentation
16:21:49 <mattymo_> I just want a verbal okay that these plugins don't impact FFE for delivery of this feature, which is, in fact, done
16:22:11 <xarses> mattymo: so, will we end up with something into fuel core as a result of not using the work arounds?
16:22:26 <mattymo_> xarses, I'm sorry, I don't understand you
16:22:32 <mihgen> in my opinion they don't directly impact, however we have to understand that success of the feature is when it's documented and people can take these plugins and use
16:22:57 <mihgen> xarses: nope mattymo just need to polish plugins
16:22:59 <xarses> as part of un-winding the workarounds, do you see any issues that might cause you to need to make new changes to fuel?
16:23:07 <ogelbukh> guys, did you think about moving integrated db/amqp/keystone into plugins instead?
16:23:14 <mattymo_> xarses, I found some neat bugs, but no show stoppers yet
16:23:28 <ogelbukh> and have core working with some abstract external entities of them
16:23:30 <xarses> ok, so then you are in the clear as your plugin is not a fuel feature any longer
16:23:32 <alex_didenko> fuel core allows you to separate components already, but don't provide any UI for it - this is job for plugins
16:23:33 <mattymo_> so far it looks like our features are implemented correctly
16:23:33 <ogelbukh> ok, not keystone
16:23:53 <mattymo_> ogelbukh, we've enabled the _capability_ of a plugin devel to do this. You can just view the plugins and see how it's done with hiera
16:24:16 <ogelbukh> k good
16:24:21 <mihgen> ok so it's clear I think - I'm worried that instead of working on bugs, you'll need to spend time on plugins polishing
16:24:36 <mihgen> When can you finish with it and switch to bugs?
16:24:40 <mattymo_> mihgen, it's just a couple more days for keystone. and the rest is bugs time for sure
16:25:18 <mihgen> ok good thanks
16:25:25 <mihgen> we need you on bugs asap..
16:25:28 <xarses> ok, so lets wrap this one, I'll write a ML about the feature state of plugins
16:25:32 <mattymo_> bugs need me to be on them
16:25:35 <mihgen> you are the most active bug squasher  )
16:25:47 <mihgen> let's move on thanks mattymo_
16:25:50 <xarses> #topic (FFE) flexible networking (akasatkin)
16:26:00 <akasatkin> We have one CR which is on review still:
16:26:00 <akasatkin> https://review.openstack.org/#/c/204321/
16:26:00 <akasatkin> It is CLI support for API for creation/removal of networks.
16:26:00 <akasatkin> Other stuff is merged. Including 2 patches were landed today.
16:26:16 <xarses> #action xarses will write ML about plugins not being features, and their exemption from FF
16:26:41 <mihgen> sounds like almost excellent
16:26:53 <mihgen> if it's only CLI, then it should not be very big deal... I hope
16:27:04 <mihgen> akasatkin: right
16:27:06 <mihgen> ?
16:27:07 <akasatkin> I hope we can merge it tomorrow.
16:27:22 <mihgen> rmoe: it's -1ed by CI..., are you on it?
16:27:30 <akasatkin> It requires unit tests and testing.
16:27:36 <rmoe> yeah, I'll fix it up today
16:27:39 <xarses> should we grant FF on the 2 CR's or the whole feature?
16:27:54 <mihgen> only for patch, why 2?
16:28:00 <xarses> I thought there where 2
16:28:09 <xarses> oh, 2 where landed
16:28:09 <xarses> ok
16:28:13 <akasatkin> We've landed other stuff today..
16:28:17 <mihgen> Only for CLI for flexible networking, I'd expect everyone else to focus on bugs right away
16:28:22 <xarses> been busy =)
16:28:41 <mihgen> we are in terrible situation with bugs, that's why I don't want us to derail on anything else now..
16:28:49 <xarses> python-fuelclient cores?
16:28:50 <akasatkin> Okey.
16:28:59 <mihgen> same here - we need other python cores to reply in openstack-dev
16:29:22 <mihgen> about risks, etc. It seems like it's not risky at all to me, as it doesn't touch any core pieces
16:29:35 <mihgen> ikalnitsky: will you reply.. ? ^^
16:30:00 <mihgen> xarses: moving on..?
16:30:06 <xarses> yep
16:30:10 <xarses> #topic The status of fuel-upgrade code and upgrading of the Fuel Master node to 7.0 (ogelbukh)
16:31:47 <xarses> seems ogelbukh is missing
16:31:49 <ogelbukh> just wanted to clarify the status of the upgrade tarball and scripts
16:31:51 <xarses> nvm
16:32:26 <mihgen> I have related question about bootstrap on ubuntu & upgrades..
16:32:28 <kozhukalov> currently upgrade scripts are located in new repo
16:32:36 <kozhukalov> stackforge/fuel-upgrade
16:32:52 <kozhukalov> i am working on getting rid of tarball
16:33:26 <kozhukalov> i need to modify script itself to make sure it works
16:33:35 <kozhukalov> without tarball
16:33:41 <mihgen> kozhukalov: you want to make a package instead?
16:33:48 <kozhukalov> yes,
16:33:53 <kozhukalov> rpm package
16:33:59 <mihgen> kozhukalov: how much it will take?
16:34:17 <kozhukalov> without venv and without rpm and deb mirrors inside
16:34:34 <kozhukalov> mihgen, hard to say, probably another week
16:34:40 <mihgen> I'm asking as we are in a pretty shaky situation with bugs and we need to focus on stabilization and bugs at first
16:35:14 <mihgen> so if there are anything related to your area of expertise I'd say I'd love to see some progress in bugs..
16:35:23 <kozhukalov> we've been  always in such situation
16:36:00 <kozhukalov> so i hope to deal with tarball with minimum affection on our whole process
16:36:39 <mihgen> ok I'll follow up on this separately let's move on
16:36:42 <kozhukalov> mihgen, sure, i am trying to help with review
16:37:00 <xarses> #topic Separate services from controller status (mattymo)
16:38:30 <mihgen> mattymo_: ^^
16:38:45 <mihgen> xarses: let's move on
16:39:27 <xarses> #topic The status of node labels feature (jaranovich)
16:39:33 <jaranovich> the feature includes 3 requests, 2 of them are already merged (spec and ui part). The latest one is the CLI changes https://review.openstack.org/#/c/204524/
16:39:37 <jaranovich> This request is on review, its author is fixing comments and we are going to merge it asap. Today we showed a demo on this request. The base node labels flow in cli was approved, the gaps are discussed. So, the question is about fixing some comments and collecting +1s
16:40:17 <xarses> jaranovich: is there any risk for this not being merged today?
16:40:41 <mihgen> guys this is +390, -35
16:40:41 <jaranovich> i think yes
16:40:42 <mihgen> no reviews
16:40:50 <mihgen> I don't see a way for it
16:40:52 <jaranovich> there were +1s
16:41:03 <jaranovich> but the only one -1 and we are working on it
16:41:03 <xarses> jaranovich: should we get FFE for this?
16:41:08 <vkramskikh> there were decent review activity during today
16:41:12 <mihgen> -1 from SMEs
16:41:22 <mihgen> guys you'd need email in openstack-dev with FFE then
16:41:24 <mihgen> I don't like it
16:41:37 <xarses> its all fuelclient
16:41:42 <xarses> so it might be ok for FFE
16:41:44 <mihgen> it's not an essential feature, and we already requesting exception for flexible nets
16:41:45 <jaranovich> ok, i'll write to openstack-dev
16:41:47 <xarses> but we should request it
16:41:49 <mihgen> in same area
16:42:06 <xarses> jaranovich: any other risks?
16:42:13 <mihgen> so before we are done with flexible networking I won't even work on this one
16:42:15 <vkramskikh> yep, UI and backend parts are merged, I don't think we should postpone thes feature because of fuelclient
16:42:24 <vkramskikh> we'll request FFE
16:42:26 <jaranovich> no, the base flow of cli commands was accepted on the demo. we need just +1s
16:42:32 <ikalnitsky> it's a patch to fuel2. i think there's a minimal risk that it breaks something
16:42:44 <mihgen> there should be clear focus for everyone: essentials at first, and keep bugs in manageable state
16:42:51 <xarses> ok, moving on then
16:43:03 <mihgen> yep..
16:43:05 <xarses> #topic     Bugs status & focus for the team (mihgen)
16:43:49 <mihgen> so folks I mined data
16:43:57 <mihgen> and we still keep our bugs # growing
16:44:16 <mihgen> we are above the guideline for sure to converge by HCF
16:44:23 <mihgen> which is 3rd of September
16:44:54 <mihgen> so guys I urge you to switch to bugs right after you are done with feature work
16:45:10 <mihgen> we can't work on other features just yet if we want to hit release dates
16:45:36 <mihgen> I'll be tracking it and will present data next meeting
16:45:46 <mihgen> any comments?
16:46:16 <mihgen> xarses: let's move on..
16:46:22 <xarses> #topic fuel-devops 2.9.10 released (bookwar)
16:47:20 <bookwar> just an announcement
16:47:28 <bookwar> so fuel-devops has been released today
16:47:34 <bookwar> and we plan to switch to it
16:47:38 <mihgen> any page with new features / bug fixes?
16:47:39 <xarses> now with virtualbox?
16:47:51 <mihgen> bookwar: when do we plan to switch?
16:47:55 <mihgen> I hope before SCF ;)
16:47:57 <bookwar> fuel-qa requirements has not been updates yet, so fuel-qa is still working with 2.9.9
16:48:03 <mihgen> and not these few hot days
16:48:28 <bookwar> but as soon as we switch everyone will need to update local copy
16:48:37 <bookwar> because tests will become incompatible
16:49:10 <mihgen> looks like we'd need more details for dev teams?
16:49:28 <bookwar> qa team requested to switch today, but it looks like we should wait for FF, so we delaying the switch for weekend or next week
16:49:29 <mihgen> action item for QA? Who has been working on new fuel-devops..?
16:49:47 <mihgen> bookwar: +1 for not doing it in the next couple of days
16:50:11 <mihgen> anyone from QA?
16:50:31 <bookwar> we should probably ask dtyzhnenko to send the announce to openstack-dev
16:50:48 <mihgen> #action maximov ask QA to email everyone about new fuel-devops
16:50:57 <mihgen> I'll do it this way ) ^^
16:51:00 <mihgen> xarses: moving on?
16:51:02 <bookwar> so that's it from me :)
16:51:07 <xarses> #topic (?) update iso build process(rpm\deb\repositories\nailgun pinning\IBP) (azvyagintsev)
16:51:08 <mihgen> thanks bookwar  for raising this
16:52:45 <xarses> azvyagintsev is not here, moving on
16:52:55 <xarses> #topic Enable deployment through Packer and Vagrant, and/or publish vagrant boxes and Vagrantfiles for "standard" deployments locally (crimi)
16:53:25 <mihgen> crimi seems to be not here too
16:53:46 <xarses> #topic is it ok to split fuel-web git repo after FF? (kozhukalov)
16:54:03 <kozhukalov> ok, guys, i am working on this
16:54:17 <kozhukalov> and i should know if it is ok
16:54:34 <mihgen> I don't really like to work on this after FF. As I said, we are in bad situations with bugs
16:54:37 <mihgen> we need this
16:54:42 <kozhukalov> my opinion here is it is the most suitable time for this
16:54:52 <mihgen> and we would ideally do it before FF
16:55:16 <mihgen> now it would need not only your time, but also devops, and other developers to review / test
16:55:22 <mihgen> QA
16:55:29 <kozhukalov> mihgen, we are in bad with bugs because we never invest enough time to improve our development processes
16:55:30 <salmon_> splitting ans setting up CI may take even week
16:55:37 <mihgen> and all of those have not planned for it
16:55:38 <salmon_> *and
16:55:47 <mihgen> kozhukalov: then it means we have to do better planning
16:55:57 <mihgen> but once we are committed, we are committed
16:56:06 <mihgen> we need to meet deadlines
16:56:15 <mihgen> no slip this release
16:56:48 <kozhukalov> just question who managed to notice that fuel-upgrade in new repo since the beginning of this week?
16:56:55 <kozhukalov> or fuel-agent?
16:57:02 <kozhukalov> nothing broken
16:57:16 <kozhukalov> developers are not blocked
16:57:42 <alex_didenko> the only problem is re-submitting patches, I've noticed few
16:57:52 <mihgen> I provide my POV. You increase risk of delivery in time
16:58:01 <mihgen> Goal is to deliever quality code in time
16:58:09 <mihgen> you are working on orthogonal now
16:58:20 <mihgen> even though from best ideas, which we need
16:58:28 <mihgen> but it's just not the right timing for it
16:58:47 <kozhukalov> ok, when the right time for this?
16:58:48 <mihgen> alex_didenko's team trying their best with bugs, dedicated team, and bugs ## still grows
16:59:06 <kozhukalov> we will never have enough time and stable enough code to do this
16:59:07 <mihgen> kozhukalov: after we get better with bugs situation, and in next release timeframe
16:59:17 <mihgen> plan for it
16:59:28 <mihgen> it has to be agreed way before FF
16:59:37 <mihgen> this simply was not in the scope
16:59:41 <kozhukalov> let's discuss this p2p later, ok?
16:59:56 <mihgen> small changes are ok to be done without planning, but before FF
16:59:58 <mihgen> sure
17:00:17 <mihgen> looks like other topics should go to openstack-dev..
17:00:23 <mihgen> xarses: let's close ..
17:00:25 <mihgen> thanks guys
17:00:26 <xarses> yep
17:00:27 <xarses> thanks
17:00:30 <xarses> #endmeeting