16:00:54 <xarses> #startmeeting fuel
16:00:56 <openstack> Meeting started Thu Jul 30 16:00:54 2015 UTC and is due to finish in 60 minutes.  The chair is xarses. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:56 <xarses> #chair xarses
16:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:59 <xarses> Todays Agenda:
16:01:00 <openstack> The meeting name has been set to 'fuel'
16:01:00 <xarses> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:01:01 <openstack> Current chairs: xarses
16:01:02 <xarses> Who's here?
16:01:05 <mwhahaha> hi
16:01:05 <angdraug> o/
16:01:06 <Tatyanka_Leontov> hi
16:01:06 <amaksimov> hi
16:01:07 <IvanKliuk> Hello!
16:01:10 <akislitsky> рш
16:01:12 <akislitsky> hi
16:01:37 <ikalnitsky> o/
16:01:38 <vkramskikh> hi
16:01:39 <xenolog13> \~/
16:01:56 <mihgen> hi
16:02:13 <xarses> #topic Exceptions and status (xarses)
16:02:16 <dpyzhov> hi
16:02:29 <xarses> So I wanted to get an update on the FF's that are done
16:02:43 <mattymo_> hey - sorry I'm late
16:02:48 <sbog> Hi guys
16:02:51 <warpc__> hi!
16:03:22 <xarses> FFE for bug/1475759 ceph generators - was split into bug and feature, feature was moved to 8.0
16:03:36 <xarses> FF Exception request for Fernet tokens support was declined
16:03:53 <xarses> sorry
16:03:59 <xarses> FFE for bug/1475759 ceph generators is a feature, and moved to 8
16:04:06 <dilyin> hi
16:04:16 <xarses> FF Exception for LP-1464656 fix (update ceph PG calculation algorithm)  - was split
16:04:34 <xarses> FF Exception request for Deploy nova-compute (VCDriver) feature - was split
16:04:52 <xarses> for the ones that where approved, what is their current merge status?
16:05:00 <ogelbukh> 0/
16:05:08 <xarses> FF Exception request for Custom node attributes feature - is merged
16:05:16 <xarses> FF Exception request for Templates for Networking feature
16:05:25 <xarses> ^ akasatkin ?
16:05:29 <xarses> everything is in?
16:05:38 <akasatkin> All code is in master.
16:05:38 <akasatkin> We've got working demployments with custom networks and templates.
16:05:38 <akasatkin> But there are some bugs which need to be fixed.
16:05:38 <akasatkin> And we need to land some fixes into master to get all stuff to work properly.
16:06:05 <xarses> FF Exception request for Env Upgrade feature, was approved. Has everything landed?
16:06:18 <akasatkin> So, it is OK, we work on bugs
16:07:07 <ogelbukh> xarses: not yet
16:07:24 <xarses> ogelbukh: any blockers? what's your eta?
16:07:26 <ogelbukh> one patch out of 4 is merged, 1 is close to merge, 2 more are still in dev
16:08:08 <ogelbukh> no particular blockers, just not enough eng resource
16:08:27 <mihgen> ogelbukh: any specific area where you need help?
16:08:27 <ogelbukh> expect to be ready to merge all by tomorrow
16:09:10 <ogelbukh> just prompt responses from reviewers
16:09:23 <xarses> sounds good
16:09:29 <xarses> FF Exception request for Deploy nova-compute (VCDriver) feature
16:09:29 <ogelbukh> and I'm actually quite impressed by it
16:09:51 <ogelbukh> everything goes pretty quick
16:09:56 <xarses> was approved in part, has that part landed?
16:11:40 <mihgen> holser bogdando aglarendil alex_didenko one of you could land only ^^
16:11:57 <xarses> thanks mihgen
16:12:45 <xarses> ok, I will ask for a follow up on the ML
16:12:51 <sgolovatiuk> mihgen: VCDriver was landed
16:13:00 <sgolovatiuk> the rest is still in progress
16:13:17 <mihgen> sgolovatiuk: sorry I'm still looking for holser, you changed your nick
16:13:30 <mihgen> what is "the rest"?
16:13:32 <sgolovatiuk> I'll change it back
16:13:33 <sgolovatiuk> sorry
16:14:17 <xarses> any other feature freeze related items to raise / talk about?
16:15:07 <xarses> ok moving on
16:15:10 <xarses> #topic Overall bugs situation (mihgen)
16:15:23 <mihgen> guys we are in a challenging situation
16:15:24 <mihgen> #link http://postimg.org/image/z81emkhop/
16:15:41 <mihgen> this is grap for all bugs in fuel, start date is about when we started the release, end date is HCF
16:15:48 <mihgen> #link http://postimg.org/image/46ca5sglj/
16:15:54 <mihgen> this one for critical & high only
16:16:32 <mihgen> of course, we just refocused to bugs from features, but still. Let's ensure that we are totally committed to work on bugs now
16:16:38 <mihgen> Also, we need to focus on most important
16:16:44 <sgolovatiuk> mihgen: We made Bug Squashing Day today
16:16:50 <sgolovatiuk> with aglarendil and bogdando
16:16:56 <aglarendil> and alex_didenko
16:17:04 <mihgen> that's why let's continue to collect bugs to be moved to 8.0
16:17:22 <vkramskikh> I heard guys want to deal with mediums - they are travelling from release to release. we (UI team) also try to squash as much mediums as possible before SCF
16:17:25 <mihgen> and once leads agrees, those can be moved.
16:17:57 <aglarendil> I suggest other teams (non-Fuel Library) also do triaging of their bugs and add corresponding non-release tags and set correct priorities
16:17:58 <mihgen> vkramskikh: focus now should be on unblocking extensive testing
16:18:06 <mihgen> #link https://bugs.launchpad.net/fuel/+bug/1479090
16:18:07 <openstack> Launchpad bug 1479090 in Fuel for OpenStack "API locks up during serialization, Number of nodes to serialize impacts lockup time" [Critical,Confirmed] - Assigned to Sylwester Brzeczkowski (sbrzeczkowski)
16:18:07 <uvirtbot> Launchpad bug 1479090 in fuel "API locks up during serialization, Number of nodes to serialize impacts lockup time" [Critical,Confirmed]
16:18:09 <uvirtbot> Launchpad bug 1479090 in fuel "API locks up during serialization, Number of nodes to serialize impacts lockup time" [Critical,Confirmed] https://launchpad.net/bugs/1479090
16:18:32 <mihgen> this one, for example, blocks >=50nodes install. So we need to fix it quickly
16:18:59 <mihgen> we might want to move many mediums / lows to 8.0 but pick some of those if we can later
16:19:18 <mihgen> aglarendil: thank you for triaging session today
16:19:27 <mihgen> xarses: let's move to the aglarendil's update on triaging
16:19:28 <aglarendil> I can provide some details
16:19:39 <angdraug> vkramskikh: you can only work on mediums if there's no high & critical bugs that you can fix, even now, before SCF
16:20:17 <xarses> vkramskikh: we now have new criteria for UX defects for high and critical
16:20:42 <mihgen> angdraug: vkramskikh or you can't take high/critical... if you don't have subject matter expertise to work in there..
16:20:43 <xarses> We might want to assess if medium is actually high with UX criteria
16:20:58 <xarses> but if its been moved from release to release, its probably not urgent
16:21:06 <xarses> moving to the sub topic
16:21:14 <xarses> #topic Fuel Library bugs triaging results (aglarendil)
16:21:27 <aglarendil> so far we did triaging for Fuel Library bugs today for C/H/M bugs with core reviewers:
16:21:40 <aglarendil> sgolovatiuk, alex_didenko and bogdando
16:21:56 <aglarendil> brief results for bugs that were somehow changed are here:
16:22:04 <aglarendil> #link https://etherpad.mirantis.net/p/7.0-fuellib-bugs-triage
16:22:19 <aglarendil> oops, sorry, I will copy it to public location
16:22:22 <aglarendil> after the meeting
16:22:53 <aglarendil> so far, we  added non-release tags and marked some old bugs as incomplete ones
16:22:57 <aglarendil> as they were too old
16:23:05 <mihgen> #link https://etherpad.openstack.org/p/7.0-fuellib-bugs-triage
16:23:07 <mihgen> I just did
16:23:31 <aglarendil> and could have been fixed by upstream merges or HA improvements or other features
16:23:40 <aglarendil> also, we deduplicated some of them and decreased priorites of the bugs
16:23:52 <aglarendil> and pushed them
16:23:57 <aglarendil> to 8.0
16:24:07 <mihgen> list contains all bugs you guys processed?
16:24:18 <aglarendil> please read this document and provide your objections if any
16:24:19 <mihgen> or only those which you have questions / need feedback?
16:24:27 <aglarendil> nope, only those that we changed somehow
16:24:43 <aglarendil> others we just did not touch saying "it is valid"
16:25:05 <mihgen> ok. Thanks. I actually checked a few, and milestone was still 7.0
16:25:16 <mihgen> so you wanted to get feedback first if any, and then move?
16:25:26 <mihgen> if there are no concerns?
16:25:31 <aglarendil> mihgen: we did not move all of them
16:25:41 <aglarendil> some of them were marked as wishlist
16:25:50 <aglarendil> some of them were marked as low priority and won't fix
16:26:03 <xarses> wow, you guys where busy
16:26:06 <aglarendil> we will surely go over wishlist bugs and attach them to corresponding blueprints
16:26:14 <mihgen> ok understand now.
16:26:24 <aglarendil> we wanna get feedback and revert our actions if needed
16:26:29 <aglarendil> leaning to lazy consensus here
16:26:48 <mihgen> thanks aglarendil & team - great work, thank you for collecting all them in etherpad so other can review
16:27:33 <mihgen> xarses: moving on?
16:27:37 <xarses> yep
16:27:41 <xarses> #topic Change SCF date (mihgen)
16:28:11 <mihgen> question here guys is the following. We want to reach HCF date. and I don't see us converging to it yet
16:28:32 <mihgen> If we move SCF date 1 week earlier, would it allow us to focus on critical / highs more?
16:28:51 <mihgen> and as such to be sure in hitting HCF date?
16:29:17 <ikalnitsky> mihgen i thought we're fixing high/critical now, and we have no time for medium bugs at all
16:29:31 <ikalnitsky> i mean our "medium" bugs usually just move to next release
16:29:54 <ikalnitsky> due to lack of time, so i don't think it change something
16:30:15 <mihgen> let's get some data if it's the case
16:30:43 <mwhahaha> moving the scf date doesn't really change what we're supposed to be working on other than disrupting if there are any pending reviews for medium bugs out there
16:30:56 <xarses> mwhahaha: +1
16:31:08 <mwhahaha> rather than being able to close bugs we are preventing us from doing so by artificial dates
16:31:23 <xarses> i think 1) discourage working on medium bugs
16:31:26 <angdraug> pending reviews still require attention on review test & merge and introduce risk of regression
16:31:34 <angdraug> that attention is better spent on high priority bugs
16:31:59 <xarses> 2) Re-triage medium bugs against UX criteria to see if they deserve high
16:31:59 <mwhahaha> while i wait for a bug to reproduce, i can work on other things
16:32:18 <mwhahaha> just because it's high/crit doesn't mean i don't have time for a minor fix
16:32:19 <amaksimov> +1 to move HCF week. it will send clear message that gates for medium bugs will be closed soon
16:32:20 <angdraug> yes, but other things should be other high priority bugs
16:32:32 <mwhahaha> we don't have that many bugs
16:32:36 <xarses> 3) There should only be a small set of medium bugs that people want to work on
16:32:37 <amaksimov> and we will have better focus on CRIT/HIGH
16:32:37 <xenolog13> +1 to move
16:33:04 <angdraug> also see my point about medium review increasing unnecessary risk of regressions
16:33:25 <mihgen> #link http://lp-reports.vm.mirantis.net/reports/custom_report?milestone=7.0&status=Fix%20Committed&status=Fix%20Released&importance=Medium&importance=Low&importance=Wishlist&fix_committed_from=2015-07-01&fix_committed_to=2015-09-03&assignee=fuel-python&assignee=fuel-qa&assignee=fuel-provisioning&assignee=fuel-ui&assignee=fuel-library&assignee=fuel-astute
16:33:35 <mihgen> sorry for internal link I hope it will be open soon
16:33:50 <mihgen> but it's 125 medium / low fixed over July
16:34:10 <xarses> mihgen: ya, I was about to say, I thought we where open sourcing that
16:34:33 <mihgen> xarses: I thought too, authz in there, I don't know why it can't be deployed public
16:34:42 <angdraug> mihgen: ran the same report, got even bigger numbers
16:34:46 <mihgen> so guys still there are many being closed
16:34:56 <mihgen> that's good from one hand
16:35:00 <nurla> mihgen: if we will move SCF, it can affect some criteria for it - test cases/CI readiness
16:35:23 <mihgen> from another - this time might could be spent on high/critical
16:35:33 <mihgen> nurla: it's SCF, not HCF, why CI is affected at all?
16:35:37 <xarses> nurla: I don't think any tests should be blocked for code that is already in master
16:35:38 <mihgen> what about test cases?
16:35:53 <xarses> regardless of the bug priority
16:36:03 <nurla> we have to implement jobs for test before SCF actually
16:36:11 <angdraug> 268 medium and lower bugs w/o customer-found tag fixed in fuel since july 1 based on the incoming/outgoing report
16:36:16 <mihgen> so I think we can still land medium and low for couple more weeks, but the focus should stay around high and critical
16:36:29 <angdraug> 87 of those in the last week
16:36:53 <mihgen> angdraug: In Fuel LP project? As my data was about dev teams
16:36:58 <mihgen> not including qa / infra
16:36:58 <angdraug> yes
16:37:20 <xarses> mihgen: should we vote then or move to the ML
16:37:37 <mihgen> xarses: let's vote
16:38:11 <angdraug> 223 excluding docs and infra
16:38:19 <angdraug> 76 last week
16:38:47 <xarses> #startvote move SCF closer 1 week? Yes, No
16:38:48 <openstack> Begin voting on: move SCF closer 1 week? Valid vote options are Yes, No.
16:38:49 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:39:09 <xarses> #vote yes
16:39:10 <mwhahaha> #vote no
16:39:13 <mihgen> #vote yes
16:39:16 <angdraug> #vote yes
16:39:17 <xarses> I don't like it, but I see the need
16:39:17 <prmtl> #vote yes
16:39:19 <vkramskikh> #vote yes
16:39:40 <evgenyl> #vote yes
16:39:44 <IvanKliuk> irc://fuel-irc.mirantis.com:7777/#vote yes
16:39:44 <xenolog13> #vote yes
16:39:45 <mattymo_> #vote yes
16:39:46 <warpc__> #vote yes
16:39:48 <akislitsky> #vote yes
16:39:51 <dpyzhov> #vote yes
16:39:56 <amaksimov> #vote yes
16:40:05 <IvanKliuk> #vote yes
16:40:05 <alex_didenko> #vote yes
16:40:06 <openstack> IvanKliuk:  yes is not a valid option. Valid options are Yes, No.
16:40:29 <akasatkin> #vote yes
16:40:34 <mihgen> IvanKliuk: you need to re-try, as there was a wrong message pasted before yes
16:40:42 <mihgen> oh you did, sorry
16:40:44 <nurla> are you really sure that we haven't some critical in medium issues?
16:40:51 <IvanKliuk> #vote Yes
16:41:00 <amaksimov> #vote Yes
16:41:14 <xarses> nurla: we should check them for the new criteria in UX, but in general they wont be
16:41:14 <mihgen> nurla: we are not, and there is another procedure to move bugs to another release
16:41:22 <mihgen> where we would ask your team to approve it
16:41:38 <xarses> ok, looks like we cant go the otherway, so I'll end it
16:41:42 <xarses> #endvote
16:41:43 <openstack> Voted on "move SCF closer 1 week?" Results are
16:41:44 <openstack> Yes (15): warpc__, xarses, angdraug, mattymo_, xenolog13, vkramskikh, dpyzhov, akislitsky, evgenyl, IvanKliuk, akasatkin, amaksimov, prmtl, alex_didenko, mihgen
16:41:45 <openstack> No (1): mwhahaha
16:41:49 <mihgen> so of course if there is anything critical, it must not go to 8.0
16:42:14 <xarses> Ok, so we will move SCF closer by 1 week
16:42:17 <xarses> moving on?
16:42:31 <xarses> #topic Bugs stalled in "in progress" state: http://bit.ly/1Iu6RsH (mihgen)
16:42:32 <mihgen> sorry mwhahaha. It's about focus now..
16:42:44 <mihgen> #link http://bit.ly/1Iu6RsH
16:42:48 <mwhahaha> that's fine
16:42:52 <mihgen> fokls I came across
16:43:01 <mihgen> and it's ton of bugs stalled actually
16:43:13 <mihgen> And I started to dig in thinking why
16:43:30 <mihgen> the reason can be lp-reports
16:44:01 <mihgen> where we look only for particular teams of our interest. But if someone unaffiliated with the team takes a bug
16:44:08 <mihgen> it's being shown in Uknown bugs
16:44:09 <xarses> So how should we attempt to address it?
16:44:14 <alex_didenko> it's related with review queues, as I remember this week we've got lower review activity and thus growing amount of in progress bugs
16:44:31 <mihgen> angdraug: btw whole your fuel-infra is unkown now I believe ...
16:44:54 <angdraug> shouldn't be, it now has a team in lp-reports
16:45:12 <mihgen> xarses: to address queues, we've got to check SLAs and poke people around, so I'd like to ask leads to ensure that it's the case
16:45:31 <mihgen> for unknown, I'd like someone to take an action item and clean it up
16:45:35 <xarses> there are alot of in-progress high and even a critical
16:45:41 <xarses> seems wrong...
16:45:59 <xarses> i'd expect to see a good amount of medium / low
16:46:07 <mwhahaha> a bunch of these bugs are in a weird state if you compare the comments vs status, https://bugs.launchpad.net/fuel/+bug/1430376 In progress but was updated to won't fix according to the comments
16:46:08 <openstack> Launchpad bug 1430376 in Fuel for OpenStack 7.0.x "Duplicate server parameter in dnsmasq.template.erb" [Low,In progress] - Assigned to Bartlomiej Piotrowski (bpiotrowski)
16:46:10 <uvirtbot> Launchpad bug 1430376 in fuel/7.0.x "Duplicate server parameter in dnsmasq.template.erb" [Low,In progress]
16:46:11 <uvirtbot> Launchpad bug 1430376 in fuel/7.0.x "Duplicate server parameter in dnsmasq.template.erb" [Low,In progress] https://launchpad.net/bugs/1430376
16:46:40 <angdraug> mwhahaha: LP doesn't always show status updates in comments, check activity history
16:46:43 <mihgen> #link https://bugs.launchpad.net/fuel/+bug/1430376/+activity
16:46:47 <mihgen> that's where you look for it
16:47:17 <mwhahaha> yea that's not confusing
16:47:26 <mihgen> #link http://lp-reports.vm.mirantis.net/reports/custom_report?milestone=7.0&assignee=unknown
16:47:39 <mihgen> 154 unknown bugs in the internal tool we use
16:47:49 <mihgen> so those are getting lost quickly if we filter by teams
16:48:11 <mihgen> angdraug: mos-infra is actually in there
16:48:26 <xarses> #action mihgen to follow up on lp-reports.vm.mirantis.net still being closed
16:48:37 <mihgen> xarses: thanks I will
16:48:48 <mihgen> is sbanka here?
16:49:14 <mihgen> alex_didenko: can you please follow up with teams and ask them to fill their people in corresponding groups?
16:49:22 <xarses> mihgen: can we move along so we can get the three other topics?
16:49:22 <mihgen> in order to clean it up?
16:49:54 <mihgen> xarses: moving on
16:49:57 <alex_didenko> mihgen: ok
16:50:01 <xarses> #topic librarian wiki & patches (mwhahaha)
16:50:07 <mihgen> alex_didenko: thanks!
16:50:07 <mwhahaha> I sent out a note yesterday to openstack-dev about the wiki page with an explanation of the librarian work and workflows.  Please  take some time to read the thread and the wiki page and provide feedback.
16:50:07 <mwhahaha> #link https://wiki.openstack.org/wiki/Fuel/Library_and_Upstream_Modules
16:50:08 <mwhahaha> The reviews have been updated and are passing CI as well.
16:50:09 <mwhahaha> #link https://review.openstack.org/#/q/status:open+project:stackforge/fuel-library+branch:master+topic:bp/fuel-puppet-librarian,n,z
16:51:03 <mihgen> what do we want to land from those?
16:51:03 <mwhahaha> comments/concerns/etc?
16:51:06 <xarses> So are we going to have a victim, erm... first module?
16:51:11 <mwhahaha> stdlib
16:51:12 <mwhahaha> :D
16:51:22 <xarses> cinder was dropped?
16:51:28 <mwhahaha> oh it's there
16:51:40 <mihgen> we need to test in custom iso if we want to land it
16:51:41 <mwhahaha> but if you look at the ordering of the patches, stdlib is the first
16:51:55 <mihgen> and ensure that people can figure out later where the code is coming from
16:52:22 <mihgen> Also, our upgrade tarball should take the right code
16:52:39 <angdraug> kozhukalov_: ^
16:52:40 <xarses> mihgen: nurla can we designate 1 or 2 QA to be trained by mwhahaha so there are no gaps?
16:52:50 <mihgen> sgolovatiuk: any objections?
16:53:02 <mihgen> xarses: 1 should be over than enough
16:53:24 <angdraug> can we land it today? tomorrow?
16:53:36 <xarses> I'd like to see it landed today
16:53:38 <mihgen> sgolovatiuk: alex_didenko Looks like you'd need to look into it guys, and let's socialize it
16:53:51 <xarses> the longer we wait, the less likely it's to happen
16:53:55 <mihgen> if we want to merge, then let's do carefully
16:54:15 <xarses> so what do we need to do before merge to be sure we are ok?
16:54:25 <xarses> test custom iso? how BVT? Swarm?
16:54:33 <mihgen> there is a discussion in ML let's continue there and move to another topic
16:54:38 <mihgen> custom ISO should be enough
16:54:40 <mwhahaha> so you have to pick the modules you want to start with
16:54:44 <mihgen> plus what I mentioned
16:55:05 <mwhahaha> the CI shows that it's still functioning even without core peices like stdlib
16:55:05 <xarses> moving on
16:55:06 <mihgen> While merging, I'd start with one and then see
16:55:06 <alex_didenko> we can use 'diff -r' :)
16:55:17 <angdraug> all we need is to confirm that puppet code in fuel-library rpm remains exactly the same as before merge, no?
16:55:29 <angdraug> alex_didenko: +1
16:55:32 <alex_didenko> and compare /etc/puppet/modules from old library and from new one (with librarian)
16:55:45 <mwhahaha> i did that as part of the migration of each module
16:55:52 <mwhahaha> which is where you see some have upgraded versions
16:56:04 <mwhahaha> so this is something you do during the migration from our repo to librarian
16:56:12 <alex_didenko> ok, nice
16:56:14 <mwhahaha> so i'd be happy to talk to someone about it and go do some diffs
16:56:18 <mihgen> grep -r won't work for people on the hook to support
16:56:20 <angdraug> ok, lets move on, unless there are objections on ML we'll land it today
16:56:21 <mwhahaha> but this is why i picked the modules out there
16:56:24 <mihgen> it has to be easy
16:56:25 <xarses> #topic Ceph-related bug fixes (mihgen)
16:56:31 <mihgen> #link https://review.openstack.org/#/c/204814/
16:56:40 <mihgen> I've heard that we don't pay enough attention to this one
16:56:54 <mihgen> just wanted to know what's up in there
16:57:17 <mihgen> looks like we need ceph SMEs to review this one, so xarses please take a look
16:57:25 <xarses> yep
16:57:35 <alex_didenko> ok, as far as I know a bugfix contains of two parts - fuel-web and library
16:57:43 <xarses> alex_didenko: correct
16:57:45 <alex_didenko> and fuel-web has some backwards compatibility
16:57:52 <evgenyl> Ryan and Andrew are the main persons who should review patch.
16:58:03 <mihgen> #link https://review.openstack.org/#/c/204811/
16:58:06 <alex_didenko> so we should merge it first, update CI iso and only then merge library part
16:58:06 <evgenyl> Also I've added fuel-cores, because there were no any
16:58:07 <mihgen> this is library part
16:59:04 <mwhahaha> these commits needs more details as to what is being done
16:59:16 <mihgen> is koder here?
16:59:19 <mwhahaha> these commit messages don't provide enough info on what/why it's changing and what is needed
16:59:20 <xarses> mattymo: sorry, won't get to you please raise on the ML
16:59:51 <mwhahaha> i looked at the commits but since i don't know what is supposed to be there, I don't feel comfortable +1'ing them (at least the python one)
17:00:04 <mihgen> ok let's review it guys then and leave comments
17:00:05 <xarses> mwhahaha: there is a BP that explains it
17:00:13 <mwhahaha> which is not linked to
17:00:15 <mwhahaha> in the commit message
17:00:16 <mihgen> So I think we would need to ask for clarifications then
17:00:17 <xarses> but ya, it needs to be linked
17:00:20 <angdraug> time
17:00:21 <mihgen> if it's not clear
17:00:27 <xarses> #endmeeting