16:00:35 <xarses> #startmeeting fuel
16:00:35 <xarses> #chair xarses
16:00:35 <openstack> Meeting started Thu Oct  1 16:00:35 2015 UTC and is due to finish in 60 minutes.  The chair is xarses. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:35 <xarses> Todays Agenda:
16:00:35 <xarses> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:00:35 <xarses> Who's here?
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:39 <openstack> The meeting name has been set to 'fuel'
16:00:40 <openstack> Current chairs: xarses
16:00:41 <mwhahaha> hi
16:00:48 <angdraug> o/
16:00:50 <rmoe> hi
16:00:52 <mihgen> hi
16:01:13 <jkirnosova_> hi
16:02:18 <xarses> #topic action items from last week
16:02:24 <xarses> mihgen to find bug about missing neutron options found by scale
16:02:32 <mihgen> sorry folks, I spent some time and was unable to find that bug.. Let's just pay attention when we sync something with upstream, that we don't lose our settings which we made based on testing
16:03:13 <mihgen> that's it on this topic..
16:03:19 <xarses> thanks
16:03:29 <xarses> #topic MAINTAINERS: let's go ahead and extend the list (mihgen)
16:04:08 <mihgen> it's pity that we don't have many ppl today .. most are busy with another meeting ( anyway..
16:04:13 <mihgen> First patch is merged to fuel-web:
16:04:18 <mihgen> #link https://review.openstack.org/#/c/225457/
16:04:25 <mihgen> I call everyone to create this file in every repo, and fill it in by next IRC meeting. We need to move on with our code review improvements, and this is one of the steps.
16:04:37 <mihgen> Then, maintainers will need to review code first before asking cores to review.
16:04:38 <mihgen> I'll use http://lists.openstack.org/pipermail/openstack-dev/2015-September/075008.html as a source on who is core in which repo, and assign an action item for the first core from each repo to create MAINTAINERS file for that repo.
16:04:51 <mihgen> If you folks see that someone is on vacation, etc. - please pick it up as being another core / maintainer of the repo. Let's get it all done by next IRC meeting, so we can go repo by repo and ensure that files are there.
16:05:22 <mihgen> angdraug: do you agree here.. .?
16:05:29 <evgenyl> mihgen: do we have some template for that?
16:05:42 <mihgen> let's use patch which I've shared as template
16:05:45 <evgenyl> mihgen: sorry, i see.
16:06:17 <ashtokolov> mihgen sorry I didn't catch. How we can add maintainers now?
16:06:36 <mihgen> just go ahead and propose patch to that file in fuel-web
16:06:42 <mihgen> or just add in other repos
16:06:47 <ashtokolov> ok
16:06:54 <mihgen> or do you mean how you identify particular people?
16:07:12 <ashtokolov> I think bulat can be a maintainer of fuel-createmirror
16:07:29 <mattymo_> ashtokolov, that's not on a stackforge/fuel-* repo
16:07:50 <mihgen> mattymo: fuel-createmirror is there
16:07:54 <mattymo_> mihgen, who is maintainer of nailgun? Who is maintainer of specs? I know your goal is to mark a maintainer for everything... but there's only a few areas where it's black and white
16:07:56 <mihgen> well then you propose him
16:08:17 <mihgen> mattymo_: there can be few maintainers
16:08:29 <mihgen> let's bring gray areas to discussion and decide
16:08:43 <mattymo_> mihgen, https://github.com/stackforge/fuel-createmirror ? no... it's https://review.fuel-infra.org/#/admin/projects/packages/centos6/fuel-createmirror
16:08:46 <mihgen> it's actually ideal situation when there a few maintainers
16:08:54 <ashtokolov> mattymo_ I think it should be on a stackforge/fuel-* repo anyway
16:08:55 <mwhahaha> https://github.com/stackforge/fuel-mirror
16:09:07 <angdraug> mihgen: +1 on MAINTAINERS
16:09:24 <mwhahaha> it has already been moved to fuel-mirror
16:09:27 <mattymo_> mihgen, we should have an etherpad, all top level dirs for all our main repos, and we should fill it out
16:09:36 <mattymo_> rather than inviting random 1-20 people to create reviews
16:09:54 <mihgen> mattymo_: I don't want to invite random
16:09:56 <mihgen> cores!
16:10:10 <mihgen> they must know whom to propose to maintainers
16:10:21 <mihgen> they merge other people's code
16:10:23 <mattymo_> mwhahaha, you're core. you should know all :)
16:10:57 <angdraug> mattymo_: -1
16:11:19 <mihgen> mattymo_: so I don't know why we'd have etherpad
16:11:30 <mihgen> if core of particular repo can just go ahead and propose patch
16:11:32 <angdraug> all cores combined will definitely know all maintainers
16:11:35 <mihgen> then get people review it
16:11:42 <mihgen> including future maintainers
16:11:52 <angdraug> doesn't mean a single core would know everything
16:11:53 <mihgen> so it should go with approve
16:12:41 <mihgen> mattymo_: do you have any particular thing it mind why it may not work.. ?
16:13:07 <mattymo_> mihgen, because your patch sat for a week without much involvement from cores. I'm seeing a bystander effect
16:13:23 <mattymo_> "EVERYONE do this" results in nobody does anything
16:13:33 <mattymo_> anyway, move on
16:13:49 <mihgen> mattymo_: I'll assign first core of each repo, as I said.. did you read my messages above?)))
16:13:55 <mihgen> one guy per repo
16:14:01 <angdraug> lets give out some actions
16:14:01 <mihgen> who will be responsible to make it done
16:14:48 <mihgen> xarses: you can give an action item for me to assign first core to create/fill in MAINTAINERS file for the repo core reviewer is responsible for
16:15:02 <mattymo_> "<mihgen> I call everyone to create this file in every repo" != first core of each
16:15:30 <xarses> assign the first core?
16:15:56 <mihgen> mattymo_: sorry. I fixed myself in next sentence:
16:15:58 <mihgen> "I'll use http://lists.openstack.org/pipermail/openstack-dev/2015-September/075008.html as a source on who is core in which repo, and assign an action item for the first core from each repo to create MAINTAINERS file for that repo."
16:16:42 <xarses> #action mihgen will task a core from each repo to start the first version of the MAINTAINERS file
16:16:48 <xarses> moving on then?
16:17:05 <angdraug> yes please
16:17:08 <xarses> #topic team structure policy: can we get more +2 and merge it.. ? (mihgen)
16:17:19 <mihgen> #link https://review.openstack.org/#/c/225376/
16:17:37 <mihgen> angdraug, you are as an acting PTL, in my opinion should make a decision if we need to wait some more time / ask particular cores to +1, and finally merge it. This doc is ~2 weeks around, so I'd assume that we can move on with mergin...
16:18:33 <xarses> +1
16:19:25 <mihgen> angdraug: ^^ ?
16:19:26 <angdraug> the deadline to merge it is 8th
16:19:38 <angdraug> so we still have a few days
16:20:00 <angdraug> I don't want to have some last-minute -1's so lets agree that the last day to provide feedback is 5th
16:20:03 <mihgen> did we mention it in openstack-dev ML .. ?
16:20:09 <angdraug> oh yes
16:20:14 <mihgen> oh sorry then
16:20:18 <mihgen> I didn't notice
16:20:36 <angdraug> #link http://lists.openstack.org/pipermail/openstack-dev/2015-September/074984.html
16:20:39 <mihgen> ok, so I hope everyone had a chance to read already
16:20:59 <mihgen> then let's move on..
16:21:25 <angdraug> yes
16:21:26 <xarses> #topic clean up in core reviewers group: http://lists.openstack.org/pipermail/openstack-dev/2015-September/075008.html (mihgen)
16:22:07 <mihgen> so folks it's been 10 days since I proposed it
16:22:15 <mihgen> I think we can go ahead with it
16:22:24 <mihgen> any objections?
16:22:33 <angdraug> mihgen: what do you think about keeping me on fuel-docs-core?
16:22:46 <mihgen> I'd task fuel-infra team to make it happen
16:23:03 <angdraug> :)
16:23:14 <mihgen> angdraug: you are #19 there, so sorry..
16:23:31 <mihgen> if you go back to review stats, other cores will re-propose you?)
16:23:52 <mihgen> #link http://stackalytics.com/report/contribution/fuel-docs/180
16:24:01 <xarses> action on angdraug then?
16:24:07 <angdraug> no thanks
16:24:23 <mihgen> xarses: yes, on angdraug to execute as he is leading fuel-infra
16:24:37 <angdraug> no thanks on going back up in review stats, that is
16:24:46 <angdraug> yes on action for fuel-infra
16:24:57 <xarses> #action angdraug will task fuel-infra team to update core groups
16:25:15 <angdraug> fuel-docs team does come to me for help occasionally, but I'm not likely to be able to do enough reviews there to keep up with the top 10
16:26:11 <angdraug> moving on?
16:26:21 <xarses> #topic announcement! 7.0!
16:26:38 <angdraug> what's there to say? 7.0 is out!
16:26:47 <xarses> I'd like to take a moment to thank every one for their work on 7.0, it went out the door
16:26:52 <mihgen> links shared?
16:26:56 <xarses> due to every one's hard work
16:26:58 <angdraug> #link http://lists.openstack.org/pipermail/openstack-dev/2015-October/075932.html
16:26:58 <xarses> https://www.fuel-infra.org/
16:27:09 <xarses> #link https://www.fuel-infra.org/
16:27:19 <mihgen> yes. This should be the best release we had ever in terms of quality
16:27:46 <xarses> hopefully it works when you install it this time (j/k)
16:27:50 <xarses> =)
16:28:01 <angdraug> not just quality
16:28:27 <angdraug> we managed to 1) improve quality; 2) reduce time between releases; 3) integrate new OpenStack release; 4) add a whole bunch of cool features!
16:28:41 <mihgen> 8)
16:28:51 <bookwar> 5) and do it in time
16:29:19 <angdraug> bookwar: that's (2) :p
16:29:34 <angdraug> but yes, great job everyone!
16:29:47 <mihgen> thanks folks. Let's keep it up!
16:29:50 <xarses> #topic open discuss
16:30:03 <xarses> thats it for the scheduled topics, if any one has anything to raise
16:30:10 <xarses> otherwise we can close early
16:30:12 <angdraug> IBerezovskiy: around?
16:30:17 <mattymo_> xarses have we decided about Q^A questions for PTL?
16:30:19 <IBerezovskiy> angdraug, yep
16:30:21 <mattymo_> Q&A*
16:30:28 <angdraug> I was wondering if we should talk again about librarian
16:30:49 <xarses> mattymo_: you can propose some =)
16:31:08 <xarses> also when should we schedule that, next meeting?
16:31:47 <IBerezovskiy> angdraug, mwhahaha have sent email yesterday about our meeting results and provided detailed description of new workflow for puppet modules
16:32:54 <angdraug> it was a private mail though, so worth reiterating here
16:33:07 <angdraug> mwhahaha: you were going to update the wiki page on librarian, right?
16:33:10 <mwhahaha> yes
16:33:22 <mwhahaha> it is on my list of things to do to provide more details on the wiki
16:33:32 <angdraug> #link https://wiki.openstack.org/wiki/Fuel/Library_and_Upstream_Modules
16:33:46 <mwhahaha> the email was just adding more details on things already provided in that page
16:34:05 <mwhahaha> additionally there were concerns around the puppetfile and people merging items that bypass fuel-library core review
16:34:15 <angdraug> one thing in particular that still worries me is setting the expectation on what is and is not ok to merge into fuel-infra clones of upstream modules
16:34:25 <mwhahaha> I've created a script to validate Puppetfiles based on our policy around upstream modules. The goal is to turn this into a jenkins job so we do not accidentally merge changes that do not follow our guidelines around upstream modules.
16:34:25 <mwhahaha> #link https://review.openstack.org/#/c/229605/
16:34:46 <mwhahaha> We'll need to figure out a list of things that are OK to merge on fuel-infra and what is not
16:34:52 <mwhahaha> and that should be put in the wiki as well
16:34:57 <angdraug> yup
16:35:12 <mwhahaha> I'll try to come up with a starting point when i update the wiki and send an email
16:36:12 <angdraug> thanks
16:36:45 <angdraug> anything else?
16:36:49 <rmoe> I have something
16:37:00 <angdraug> rmoe: go for it :)
16:37:05 <rmoe> I'd like to give a short update on some work I've been doing with network templates
16:37:17 <rmoe> One of the things I've been working on recently has been using network
16:37:17 <rmoe> templates to deploy environments with only two networks, one for admin traffic and one
16:37:17 <rmoe> for all OpenStack traffic. I've also created a template to use a single interface for
16:37:17 <rmoe> everything, admin + OpenStack.
16:37:17 <rmoe> There are preliminary instructions for configuring these templates here: https://review.openstack.org/#/c/229948
16:37:18 <rmoe> It requires applying a few patches to 7.0 environments but all but one of the required changes
16:37:20 <rmoe> have been merged so 8.0 ISOs require less effort.
16:37:22 <rmoe> HA works fine and all OpenStack components appear to work correctly. The only thing I haven't tested
16:37:25 <rmoe> yet is Ceph. Hopefully this serves as a good example of how flexible network templates
16:37:27 <rmoe> are.
16:37:41 <rmoe> this came from frequent requests from customers (and potential customers) for this kind of network configuration
16:38:30 <angdraug> funny that originally the idea of network templates came from the need to _add_ more networks :)
16:38:55 <mihgen> rmoe: cool
16:38:58 <holser> Hi
16:38:59 <angdraug> it's pretty cool that you've made it to scale in both directions
16:39:04 <aglarendil> cool
16:39:11 <mihgen> let's complete it and merge template someone
16:39:17 <mihgen> so people can easily reuse it!
16:39:45 <xarses> rmoe, can we make it so these templates are part of our CI coverage?
16:39:45 <aglarendil> but there is even more demand on one interface for compute node
16:39:55 <angdraug> if it needs code from 8.0 does it mean we can't merge this documentation to fuel-docs stable/7.0?
16:40:06 <rmoe> it works in 7.0 but it's not easy
16:40:18 <rmoe> not as easy as 8.0 will be
16:40:34 <mihgen> we may want to document it in stable/7.0, and provide instructions what patches to apply if needed
16:40:38 <rmoe> there were some important changes that didn't make 7.0 (like the ability to update network groups with the cli)
16:40:46 <mihgen> or just better - document it in development guide
16:41:14 <mihgen> rmoe: that particular one should be targeted to 7.0-updates in my opinion
16:41:20 <rmoe> I agree
16:41:39 <mihgen> can you please ensure it target that milestone and it's clearly explained why it's important... ?
16:41:52 <rmoe> yes, I'll do that
16:42:32 <mihgen> thanks
16:42:55 <xarses> anything else?
16:43:56 <xarses> ok, thanks every one
16:44:04 <xarses> #endmeeting