16:00:23 <xarses> #startmeeting fuel
16:00:23 <xarses> #chair xarses
16:00:23 <xarses> Todays Agenda:
16:00:23 <xarses> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:00:23 <xarses> Who's here?
16:00:27 <maximov> hi
16:00:29 <openstack> Meeting started Thu Oct  8 16:00:23 2015 UTC and is due to finish in 60 minutes.  The chair is xarses. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <angdraug> \o
16:00:29 <ashtokolov> o/
16:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:32 <mkwiek> hi
16:00:33 <mihgen> hi
16:00:33 <openstack> The meeting name has been set to 'fuel'
16:00:35 <openstack> Current chairs: xarses
16:00:39 <rmoe> yo
16:00:42 <yottatsa> hi
16:00:45 <mwhahaha> hi
16:01:06 <xarses> #topic Action Items from last week
16:01:19 <xarses> mihgen will task a core from each repo to start the first version of the MAINTAINERS file
16:01:27 <mihgen> #link https://review.openstack.org/#/q/topic:maintainers,n,z
16:01:40 <mihgen> looks like good progress
16:01:53 <xarses> yea, nice
16:01:55 <mihgen> thank you guys. Let's push it forward to be fully done by next IRC meeting
16:01:59 <dpyzhov> hi
16:02:02 <xarses> angdraug will task fuel-infra team to update core groups
16:02:07 <mihgen> I suggest to check in details next time
16:02:09 <angdraug> #link http://lists.openstack.org/pipermail/openstack-dev/2015-October/076390.html
16:02:17 <mihgen> angdraug: is script ready?
16:02:20 <angdraug> mostly done, except parts waiting for openstack-infra
16:02:24 <prmtl> hey
16:02:27 <akislitsky> hi
16:02:33 <evgenyl> hi
16:02:35 <mihgen> to automatically add reviewers based on maintainers files?
16:02:44 <angdraug> mihgen: no
16:02:52 <mihgen> ETA?..
16:02:56 <angdraug> bug #?
16:03:07 <mihgen> will need to find.. don't remember
16:03:17 <angdraug> lets take it offline then
16:03:21 <mihgen> ok
16:03:42 <mihgen> thanks for getting core groups to the good shape
16:04:07 <mihgen> xarses: moving.?
16:04:14 <xarses> #topic premature backport cherry-picks considered harmful (mattymo)
16:04:23 <xarses> #link http://lists.openstack.org/pipermail/openstack-dev/2015-October/076066.html
16:05:01 <angdraug> everyone, please have a good look at this thread and our bugfix backporting policy
16:05:23 <xarses> yep
16:05:25 <mihgen> I skimmed through
16:05:32 <angdraug> cherry-picking a commit to a stable branch before it is merged to master creates noise and extra work for reviewers
16:05:36 <mihgen> I agree with mattymo and you guys
16:05:59 <mihgen> so I think we should go ahead and update our engineering process
16:06:11 <mihgen> and don't create backport before code is merged into master..
16:06:18 <xarses> I through that was our process
16:06:19 <angdraug> mihgen: our engineering process definition already reflects that, we just need to get better at following it :)
16:06:36 <angdraug> #link https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Backport_bugfixes_to_stable_release_series
16:06:51 <angdraug> note the word in bold :)
16:06:59 <mihgen> oh then it's call for cores to reflect that in comments when someone creates backport earlier than needed..
16:07:27 <maximov> usually it happened when we need to deliver on time,  before important milestone
16:07:52 <angdraug> maximov: premature optimization is root of all evil (D. Knuth)
16:08:15 <maximov> if we strictly followed this rule, I don't think we would have released 7.0 on time
16:08:33 <mihgen> maximov: why so.. ?
16:08:37 <mwhahaha> ci takes hours
16:08:38 <mihgen> how is it related?
16:08:54 <maximov> it is related because when you finish with master
16:09:02 <maximov> usually it takes 2 days
16:09:11 <maximov> you would need to repeat this process for stable
16:09:16 <angdraug> no
16:09:28 <angdraug> you don't have to repeat the review process for stable
16:09:31 <xarses> it should not take 2 days to backport to stable
16:09:36 <angdraug> you're supposed to merge exactly what went into master
16:09:53 <angdraug> core reviewer can cherry-pick as soon as they've voted workflow+1
16:10:06 <angdraug> all you have to do is wait for CI, which is 2-4 hours
16:10:29 <maximov> ok, who will do cherry picks? core or author of bugfix ?
16:10:32 <angdraug> compared to 48h average on master, that's 8% overhead
16:10:56 <angdraug> core
16:11:00 <angdraug> see above link
16:11:16 <maximov> ok, if core then ok
16:11:18 <angdraug> "When you approve a bugfix commit for master branch... For all series where backport should exist and doesn't, create a backport review request yourself"
16:11:27 <evgenyl> I don't think that core should do that. Author should know if it requires backporting and solve conflicts.
16:11:31 <mihgen> folks let's analyze it deeply. maximov - if you or someone else has concerns, let's bring it up in email thread then
16:11:44 <mihgen> I thought it's resolved in ML..
16:11:53 <angdraug> there was a strong consensus on openstack-dev
16:11:59 <xarses> mihgen: +
16:12:13 <maximov> see comments from evgenyl  above
16:12:15 <xarses> it sounds like we need more discussion on the ML
16:12:23 <mihgen> so questions like who should backport it - we need to reflect in email thread
16:12:31 <angdraug> I have a big meta concern about this
16:12:48 <angdraug> the thread on ML was a week ago
16:12:48 <mihgen> I suggest to move on to highlight other updates..
16:13:16 <xarses> lets keep moving
16:13:16 <angdraug> ok lets move on
16:13:21 <xarses> #topic OpenStack Infra jobs enabled in non-voting mode https://review.openstack.org/#/c/228204/. Status for repos reorg (mihgen, kozhukalov)
16:13:35 <mihgen> enabled for almost all of the repos. Now we've got to fix our repos structure, introduce tox.ini, etc.
16:13:41 <mihgen> In fuel-agent repo I believe once we merge https://review.openstack.org/#/c/203005/, we can switch jobs to voting and remove Fuel CI from there. What about docs job there.. how can we fix it?
16:13:51 <mihgen> What is the status for other repos folks? What / whom do we need to fix it in the other repos?
16:14:40 <kozhukalov> I am working on this
16:14:41 <mihgen> mkwiek: any eta on when your patch can be landed?
16:15:10 <prmtl> mihgen: this patch is waiting for bvt to pass, but here is apparently some lag there
16:15:11 <kozhukalov> aah no, it is not what i meant
16:15:32 <mihgen> kozhukalov: provide update on fuel-web repo pls
16:16:00 <kozhukalov> there are no patches on review yet, but I am working on this
16:16:09 <mkwiek> kozhukalov: yeah, I am waiting for bvt to pass
16:16:27 <kozhukalov> next week infra is going to move all the projects from stackforge to openstack
16:16:28 <ikalnitsky> kozhukalov: what about 4 databases we use to speed-up unit tests? i mean fuel-web
16:16:31 <mkwiek> there were some strange failures before, if they happen again I may need some assistance, but I will let you know
16:16:31 <mihgen> kozhukalov: any eta / specific plan how to appoach it?
16:16:38 <ikalnitsky> does openstack infra support this?
16:16:42 <kozhukalov> http://lists.openstack.org/pipermail/openstack-dev/2015-August/072140.html
16:17:24 <kozhukalov> they said that they will continue to create new repos for existent stackforge projects to prevent namespace splitting
16:17:48 <kozhukalov> but i don't think it is a good idea to do this before the migration
16:17:58 <kozhukalov> i mean once this migration is done
16:18:12 <angdraug> +1
16:18:17 <kozhukalov> i'll send a set of patches to create new projects
16:18:21 <kozhukalov> in openstack
16:18:30 <mihgen> is it only about creating new repos?
16:18:40 <mihgen> what about repo restructure, tox, etc.
16:18:42 <angdraug> openstack-infra is not likely to review any infra commits before 17th
16:18:48 <kozhukalov> including shotgun , network-checker, fuelmenu,
16:18:52 <mihgen> is there any specific plan for it?
16:18:58 <angdraug> ...that are not related to stackforge->openstack ns migration
16:19:22 <kozhukalov> first we need to create all necessary files that we need for fuel-ci
16:19:30 <kozhukalov> i mean test interface
16:19:34 <kozhukalov> run_tests.sh
16:20:18 <kozhukalov> and then we need to announce code freeze and extract  corresponding directories
16:20:41 <kozhukalov> it is exactly the same as we did for fuel-agent for example
16:20:56 <kozhukalov> I have kind of checklist
16:20:57 <xarses> kozhukalov: can you prepare a mail on the ML so we can move along?
16:21:07 <kozhukalov> the most complicated case is fuel-ui
16:21:16 <prmtl> kozhukalov: Igor already asked this question: what about 4 databases we use to speed-up unit tests in nailgun?
16:21:34 <prmtl> how we will tackle this?
16:21:36 <kozhukalov> we need to modify our testing approach cuz it requires nailgun for testing
16:22:02 <mihgen> kozhukalov: we may need your checklist for other folks, so that we move quick and easy
16:22:07 <kozhukalov> xarses: sure, i'll send a separate e-mail for every subproject
16:22:12 <mihgen> Do we have people who plan to work on it for other repos.. fuel-main, fuel-ostf, etc. ?
16:22:30 <kozhukalov> mihgen: it will in ML, like it was for fuel-agent
16:22:30 <ikalnitsky> prmtl: it seems we're ignored. :/
16:22:34 <prmtl> ikalnitsky: :/
16:23:07 <xarses> #action kozhukalov will update ML with plain to separate each sub-project in fuel-web
16:23:16 <kozhukalov> prmtl: 4 databases?
16:23:25 <xarses> ikalnitsky: prmtl please bring it up on the ML, we need to move along
16:23:37 <prmtl> xarses: ok
16:23:39 <xarses> #topic code review backlog status: http://bit.ly/1G4Xsn9 (mihgen)
16:23:51 <mihgen> These are patchsets which are 5+ days without feedback.
16:23:59 <mihgen> Majority of them are in fuel-specs. What would be the best approach here folks?
16:24:05 <mihgen> I think that we need to just take action items for core reviewers of corresponding repos to deal with it.
16:24:13 <mihgen> For fuel-specs, I'd say it should be PTL - who would find experts and assign them to review.
16:24:37 <angdraug> this reminds me: all, please update your fuel review inbox links if you're using Firefox 41 or later
16:25:22 <xarses> mihgen: that seems good. angdraug ?
16:25:25 <angdraug> +1
16:25:37 <mihgen> we just need to ensure that cores delegate review work to maintainers
16:25:51 <mihgen> and PTL to some of the subject matter experts to review fuel-specs
16:26:15 <aglarendil> mihgen: the approach is to wait for core reviewers to get back from PTO or Sick Leave
16:26:37 <mihgen> I want to highlight that queue was 4x longer actually couple of days ago. So I'd like to thank everyone for dealing with it
16:26:58 <xarses> #action angdraug will update fuel-specs reviews to assign SME's to review
16:27:08 <mihgen> aglarendil: I'm not sure that so many are on sick leave/vacation..
16:27:32 <angdraug> no feedback means even non-cores didn't vote
16:27:36 <mihgen> maximov: can you please take an action item to deal with it and assign cores to figure out particular patchsets.. ?
16:27:45 <maximov> ok mihgen
16:27:50 <mihgen> thank you...
16:28:10 <xarses> moving then
16:28:12 <xarses> #topic Status on IPv6 in tenant networks research (veremin)
16:28:27 <mihgen> yottatsa: ^^^
16:28:41 <yottatsa> I've done some research about IPv6 status on OpenStack Liberty
16:28:45 <xarses> #action maximov will look over stale review queue and ensure that cores are assigned to them
16:29:00 <yottatsa> and put some thought on etherpad https://etherpad.openstack.org/p/tenant-ipv6
16:29:27 <mihgen> woops it doesn't work with DVR?
16:29:28 <yottatsa> shortly: IPv6 is working is provider networks with external routers just fine
16:29:47 <yottatsa> DVR didn't yet support IPv6
16:30:28 <xarses> and VRRP?
16:30:29 <yottatsa> As for tenant networks, there is good news that we can implement it with few patches
16:30:32 <mihgen> what about fuel changes needed to enable what is supported?
16:30:47 <mihgen> yottatsa: that would be awesome
16:30:49 <yottatsa> Didn't test for VRRP, will ask Sergey Vasilenko
16:31:17 <yottatsa> There is no changes will be needed in fuel except tseting AFAIK
16:31:27 <xenolog13> It should be additionally tested after
16:31:51 <xenolog13> support of VRRP was be implemented for IPv4
16:32:14 <yottatsa> SNAT and Floating IP is not working with IPv6, will need to implement
16:32:29 <yottatsa> also, there some cases with radvd, will need some support from fuel and neutron
16:32:29 <mihgen> yottatsa: ok let's think about how it has to be tested, I mean what already works
16:32:52 <mihgen> and we need to collect list of things which should be fixed in openstack and pass to neutron team to deal with..
16:32:58 <mihgen> thank you for research yottatsa
16:33:12 <yottatsa> mihgen, I'll finish my ressearch on testing today and put it to report
16:33:21 <mihgen> cool, thanks
16:33:25 <haleyb> i'm just a lurker, but IPv6 has no plans on doing SNAT or floating IPv6 in neutron
16:33:55 <yottatsa> haleyb, AFAIK there is no blueprints for it
16:34:12 <xarses> haleyb: is that because it's not needed? or its not planned
16:34:27 <haleyb> yottatsa: well, the neutron team has decided against doing it, not needed if tenants are using global addresses
16:34:31 <yottatsa> haleyb, but I believe it very neat feature
16:34:53 <yottatsa> haleyb, thank you for information.
16:35:06 <xarses> haleyb: thanks
16:35:18 <mihgen> looks like yottatsa you'd need to articulate why it's needed to neutron team)
16:35:34 <haleyb> feel free to corner the neutron cores and plead your case
16:36:08 <mihgen> xarses: moving on.. ?
16:36:12 <xarses> yep
16:36:13 <xarses> #topic Enhancements Team Status (ashtokolov)
16:36:25 <ashtokolov> Enhancements status briefly:
16:36:37 <ashtokolov> Inbox - 62, In progress - 12, On review - 20, QA - 17, Done - 2
16:36:46 <ashtokolov> and 12 to be sorted with Product Management
16:37:00 <ashtokolov> One of our story «Rewrite fuel-createmirror» takes more than 5 man-days
16:37:08 <mihgen> looks like a good progress, thanks for driving this!
16:37:16 <ashtokolov> Bulat could you provide a status of this story?
16:37:17 <mihgen> yeah that's gonna be exception one :(
16:37:27 <angdraug> that would be our next agenda item
16:37:28 <mihgen> it's in agenda
16:37:28 <xarses> we have topic for create mirror just next
16:37:44 <angdraug> moving?
16:37:46 <mihgen> ashtokolov: those 17 in qa - those are implemented?
16:37:49 <bgaifullin> the proof of concept will be provided to QA
16:37:53 <mihgen> or in review?
16:38:04 <ashtokolov> mihgen: yes, Fix committed
16:38:23 <mihgen> that's cool. we will finally get rid of many gaps..
16:38:37 <mihgen> thanks ashtokolov, no more questions from my side.
16:38:39 <xarses> #topic Status on fuel-createmirror.(bgaifullin)
16:38:56 <bgaifullin> the proof of concept was provided to QA -team.
16:39:09 <bgaifullin> they are testing it now.
16:39:19 <mihgen> where can we look at code..?
16:39:29 <bgaifullin> on review
16:39:48 <mihgen> https://review.openstack.org/#/c/231535/ ?
16:40:08 <bgaifullin> https://review.openstack.org/#/c/231535/
16:40:24 <angdraug> #link https://review.openstack.org/#/c/231535/
16:40:28 <angdraug> 3 times does the charm :)
16:40:39 <mihgen> ok thanks. do you get reviewers.. ?
16:41:01 <bgaifullin> I need to prepare specification before, and a change interfaces little bit.
16:41:09 <mihgen> ok thanks bgaifullin
16:41:32 <mihgen> xarses: moving on.. ?
16:41:37 <xarses> #topic UI team status (vkramskikh)
16:41:45 <vkramskikh> Hi, this week we've fixed 11 bugs, and have 56 bugs left. There is only 1 high bug (which is in progress), and others are mediums and lower. We also have quite a few low-hanging-fruit bugs which we can fix quickly. We'll continue to fix the bugs.
16:41:48 <vkramskikh> that's it :)
16:42:04 <mihgen> vkramskikh: hey any plans for multi-rack?
16:42:10 <mihgen> other advanced networking pieces?
16:42:39 <vkramskikh> mihgen: multirack is one of 8.0 features, but currently we're working only on bugs
16:42:52 <vkramskikh> yes we plan to deliver multirack in UI in 8.0
16:43:00 <yottatsa> mihgen, I've got initial info from xenolog13 about multirack, and I'm still in progress
16:43:27 <mihgen> yottatsa: in progress of what in terms of multirack...?
16:43:44 <angdraug> vkramskikh: I asked rvyalov to create a spec for the changes in js deps packaging that asilenkov is working on
16:43:52 <mihgen> vkramskikh: sound good. thanks. Do you know if http://demo.fuel-infra.org:8000/ is compressed now.. ?
16:44:00 <angdraug> please review when it's available
16:44:08 <yottatsa> mihgen: trying to fit IPv6 deployment in multirack case
16:44:18 <angdraug> I'd like to make sure that this time we don't leave it in a state where it can block your team again
16:44:21 <vkramskikh> mihgen: nope, development UI is still used
16:44:27 <mihgen> yottatsa: oh ok. thanks.
16:44:51 <xarses> #topic Bugfix team status (dpyzhov)
16:44:55 <vkramskikh> angdraug: thanks a lot
16:45:01 <dpyzhov> Hi again
16:45:05 <mihgen> angdraug: please prioritize the work for demo instance if possible.. it's likea a face of Fuel
16:45:13 <dpyzhov> Here is our current stats. I’ll show it in format “total (UI / python / librar)"
16:45:13 <dpyzhov> Critical and high bugs: 49 (1/26/22). Last week it was 48 (2/31/15)
16:45:15 <dpyzhov> Medium, low and wishlist bugs: 252 (64/125/63). Last week it was 241 (72/119/50)
16:45:15 <dpyzhov> Features tracked as bug reports: 134. Last week it was 133.
16:45:15 <dpyzhov> Technical debt bugs: 88. Last week it was 72.
16:45:15 <openstack> bug 252 in gnome-system-tools (Ubuntu) "Remove absolute reference from icon .desktop file " [Low,Fix released] https://launchpad.net/bugs/252 - Assigned to Sebastien Bacher (seb128)
16:45:37 <bgaifullin> #left
16:45:42 <dpyzhov> We had some really tricky bugs and it affected our velocity
16:46:01 <dpyzhov> Now they seem to be nailed down
16:46:12 <dpyzhov> So I hope that we will be better next week
16:46:18 <xarses> dpyzhov: but its good to get them done
16:46:21 <dpyzhov> I’ve walked through our tech-debt bugs and shared my proposals in openstack-dev list last week.
16:46:21 <dpyzhov> I haven’t got any objections so looks like we cool here.
16:46:21 <dpyzhov> We have several tech-debt bugs in High priority and we should fix them.
16:46:21 <dpyzhov> All other tech-debt bugs can be postponed or fixed in a background without any priority.
16:46:37 <dpyzhov> Right now we are focused on maintenance update for 7.0. Fixes for most of bugs are in progress and about 10 bugs are not touched yet.
16:46:52 <mihgen> dpyzhov: thanks. Looks like it's good progress overall!
16:47:04 <dpyzhov> 2 bugs for MU1 are on review
16:47:08 <mihgen> dpyzhov: what about "features"
16:47:14 <mihgen> is those are enhancements?
16:47:22 <dpyzhov> Yest
16:47:25 <mihgen> it doesn't seem to be in sync with report from ashtokolov
16:47:36 <dpyzhov> feature-bugs are ehnancement bugs
16:47:48 <dpyzhov> I've just provided some stats
16:48:08 <dpyzhov> well, it doesn't look good for me
16:48:14 <mihgen> ashtokolov: can you please check why numbers are different..?
16:48:17 <dpyzhov> Because numbers are almost the same
16:48:36 <dpyzhov> looks like we are like Alisa, running as fast as we can in order to be on the same place
16:48:59 <dpyzhov> feature bugs also include bugs tied to blueprints
16:49:09 <dpyzhov> that are not in ashtokolov area
16:49:19 <dpyzhov> sorry for misleading
16:49:50 <dpyzhov> Also I’ve created new bug tag ‘regression-8.0’ for bugs that were introduced in 8.0 release.
16:49:51 <mihgen> oh I misinterpreted some numbers .. I see it almost doesn't move now..
16:50:08 <mihgen> ok let's take it offline.. we need to figure out what to do here
16:50:14 <dpyzhov> yep
16:50:33 <mihgen> xarses: moving on?
16:50:35 <xarses> #topic Multirack status (alex_didenko)
16:50:45 <mihgen> let's try to fit 3 topics in 10min
16:50:49 <alex_didenko> We're working on this list of bugs https://goo.gl/wzIGl5 - when High bugs are resolved we should have a working multi-rack deployment with static routes.
16:50:49 <alex_didenko> We have a fix/solution for the most of bugs, some of them are on review already.
16:50:51 <alex_didenko> The only bug without solution/fix is https://bugs.launchpad.net/fuel/+bug/1502842, but I think we'll have a solution for it on the next week.
16:50:51 <alex_didenko> Our main goal right now is to upload all the patches to gerrit, build custom ISO and test it on both standard and multirack topologies.
16:50:51 <openstack> Launchpad bug 1502842 in Fuel for OpenStack 8.0.x "Need to re-configure routing after we add a new nodegroup (rack)" [High,Triaged] - Assigned to Aleksey Kasatkin (alekseyk-ru)
16:51:09 <dpyzhov> we are focused on mu1. You can see our status here: https://etherpad.openstack.org/p/fuel-python-7-0-mu1-bugs https://etherpad.openstack.org/p/fuel-library-7-0-mu1-bugs
16:51:17 <alex_didenko> multirack done, next :)
16:51:29 <mihgen> alex_didenko: wait, is it all static routes?
16:51:37 <alex_didenko> yep
16:51:44 <mihgen> how do we do HA in multirack here?
16:51:53 <mihgen> can you place controller per rack?
16:52:08 <alex_didenko> nope, controllers should be in the same L3 segment
16:52:13 <xenolog13> no, it's impossible now
16:52:21 <xarses> mihgen: no, not with out separating l3-agent and haproxy/vip
16:52:44 <mihgen> ok.. I'll sync offline with you xarses in the office then..
16:52:55 <mihgen> yottatsa: did you discuss it with xenolog13 in the office?
16:53:18 <mihgen> in general, how you did it before and how we are doing it .. we need fresh feedback on things
16:53:43 <mihgen> alex_didenko: do we have a design spec for multirack.. ?
16:53:53 <alex_didenko> well, besicaly we're imporving and fixing nodegroups, so there's nothing new
16:54:02 <mihgen> ok..
16:54:06 <alex_didenko> but we do have a spec for it
16:54:21 <xenolog13> spec started, attached to the task
16:54:26 <alex_didenko> https://review.openstack.org/230943
16:54:27 <mihgen> can you find please and share with yottatsa - I want him to review it
16:54:30 <yottatsa> mihgen, I've discussed it, but I'm still think on it in connection with IPv6 routers
16:54:53 <mihgen> ok, thanks. xarses - let's move on.. if no more questions here..
16:54:55 <xarses> #topic last call for votes for PTL (angdraug)
16:54:58 <angdraug> just wanted to remind everyone that the PTL vote closes in a few hours (23:59 UTC), please vote now if you haven't already
16:55:01 <yottatsa> alex_didenko, got the spec
16:55:17 <angdraug> next topic please :)
16:55:19 <xenolog13> Spec for dynamic multi-rack will be here: https://review.openstack.org/#/c/195640/
16:55:36 <xarses> #topic Networking configuration as a service (rmoe)
16:55:46 <mihgen> yottatsa: this one is more important to review (dymamic routes) ^^
16:55:56 <rmoe> I'm currently working on separating network configuration from nailgun into a standalone service that is not nailgun-specific.
16:55:56 <rmoe> I'm building a PoC to figure out the data structures and API. I'm also researching os-net-config as a way
16:55:56 <rmoe> to realize the host network configurations stored in this new service. As soon as I'm done with the PoC I'll take
16:55:56 <rmoe> what I've learned and put it all into a spec.
16:56:25 <rmoe> spec should be up by the next meeting here
16:56:31 <angdraug> rmoe: do you have a scratch repo with the code up on github?
16:56:51 <rmoe> everything I'm doing will be on github by the end of today
16:57:01 <mihgen> thanks rmoe. Do you solely work on this or whom do you sync up with on this matter.. ?
16:57:19 <xarses> cool, can you post it to the ML when it's ready?
16:57:21 <rmoe> right now just me, but once we're past this initial poc
16:57:37 <rmoe> vova will be helping with the design
16:57:54 <mihgen> which vova.. aglarendil ?
16:57:57 <rmoe> yes
16:58:26 <mihgen> cool. and I assume akasatkin, xenolog13 will be in sync as well here..?
16:58:40 <rmoe> I hope so, i would definitely rely on their input as we get further along
16:58:49 <mihgen> thanks rmoe
16:58:53 <xarses> 1 min
16:59:04 <aglarendil> yo
16:59:07 <angdraug> open discussion?
16:59:13 <mihgen> we just fit agenda yo
16:59:19 <angdraug> jk
16:59:24 <aglarendil> sorry hurried a little bit
16:59:24 <xarses> thanks everyone, if you have something to raise, please do in the ML
16:59:45 <xarses> #endmeeting