15:59:43 <kozhukalov_> #startmeeting Fuel
15:59:43 <openstack> Meeting started Thu Oct 22 15:59:43 2015 UTC and is due to finish in 60 minutes.  The chair is kozhukalov_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:46 <openstack> The meeting name has been set to 'fuel'
15:59:50 <kozhukalov_> hi guys
15:59:57 <kozhukalov_> agenda as usual
16:00:06 <mihgen> hi
16:00:08 <akislitsky_> hi
16:00:08 <maximov> hi
16:00:12 <kozhukalov_> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:00:23 <mwhahaha> hi
16:00:41 <ikalnitsky> o/
16:00:41 <angdraug> o/
16:00:45 <ashtokolov> hi
16:01:14 <kozhukalov_> #topic Action Items from last meeting:
16:01:19 <salmon_> hi
16:01:24 <kozhukalov_> angdraug will update fuel-specs reviews to assign SME's to review https://etherpad.openstack.org/p/fuel-blueprints-8.0
16:01:36 <kozhukalov_> ashtokolov will generate raw input from need-bp bugs for PM to review
16:01:43 <kozhukalov_> angdraug will update spec template to remove osci impact as its duplicate of infra https://review.openstack.org/235666
16:01:44 <aglarendil> \o/
16:01:51 <dpyzhov> hi
16:01:52 <kozhukalov_> ogelbukh will raise with liberty version schema and how to change that in fuel to ML
16:01:54 <vkramskikh> hi
16:01:59 <kozhukalov_> ashtokolov angdraug will update ML about status and direction of openstack infra gate jobs
16:02:22 <angdraug> spec template update to fix up infra impact is on review and could use some +2s:
16:02:22 <angdraug> #link https://review.openstack.org/235666
16:02:22 <kozhukalov_> could you guys please give status on these action items?
16:02:38 <angdraug> no progress on assigning spec reviewers yet
16:02:57 <ashtokolov> done, we scheduled a meeting with Dmitriy Novakovskiy.
16:03:06 <yottatsa> hi
16:04:00 <kozhukalov_> how about ML on gating?
16:04:04 <bgaifullin> Hi
16:04:12 <sbog_> hi all
16:04:16 <angdraug> will send that today
16:04:29 <kozhukalov_> angdraug, great, thanks
16:04:52 <angdraug> already have a draft, might need to change it if https://review.openstack.org/236068 finally lands
16:05:16 <kozhukalov_> ogelbukh, what about liberty versioning?
16:05:44 <angdraug> #link http://lists.openstack.org/pipermail/openstack-dev/2015-October/077135.html
16:06:06 <angdraug> ^ is the thread about liberty versioning that ogelbukh started
16:06:13 <kozhukalov_> ok, guys, thanks for your actions
16:06:23 <kozhukalov_> let's go through agenda
16:06:36 <kozhukalov_> #topic rename stable/x.x branch to updates/x.x on GA to simplify gerrit ACLs for maintenance (angdraug)
16:06:39 <angdraug> ACLs in openstack gerrit for fuel repositories currently have this bit of ugliness:
16:06:39 <angdraug> #link https://github.com/openstack-infra/project-config/blob/master/gerrit/acls/openstack/fuel-web.config#L8-L14
16:06:39 <angdraug> this could be replaced with "refs/heads/stable/*"
16:06:39 <angdraug> except we can't limit merges to stable branch until after GA
16:06:39 <angdraug> what we can do is rename the branch when we hand it over to fuel-stable-core so that the pattern starts to match
16:06:41 <angdraug> for example, create proposed/* branch on SCF, rename it to stable/* on RTM
16:06:56 <angdraug> or rename stable/* to updates/*
16:07:03 <angdraug> thoughts?
16:07:16 <angdraug> anyone from fuel-stable-core around to comment?
16:08:01 <angdraug> heh, no objections :p
16:08:15 <mihgen> I'm not from fuel-stable-core, but I think we should do same branch naming as in openstack and extend it only if necessary. Here it would mean to have stable/* at SCF
16:08:16 <dpyzhov> I'm trying to understand the question )
16:08:33 <kozhukalov_> i think branch deletion is quite expensive in terms of current infra implementation
16:08:36 <mihgen> and potentially rename it to updates/*
16:08:51 <angdraug> mihgen: other openstack projects don't restrict merge rights to stable branches
16:09:12 <mihgen> when we hand it over to special team to work on providing updates in channels
16:09:21 <angdraug> kozhukalov_: branch deletion is not necessary, you just create a new branch with new name at the same head
16:09:45 <bookwar1> the naming is not that important as the dates and milestones. Creating branch at SCF - have we already agreed on that?
16:09:54 <angdraug> yes
16:10:10 <kozhukalov_> angdraug, , but it would lead us to unused branches, right?
16:10:25 <bookwar1> so at SCF - we get stable branch and couple of days before RTM we rename those
16:11:05 <ikalnitsky> guys, how openstack solves this issue? i see that they do use stable core group?
16:11:07 <ikalnitsky> #link https://github.com/openstack-infra/project-config/blob/master/gerrit/acls/openstack/nova.config#L7-L12
16:11:19 <angdraug> kozhukalov_: unused -> frozen, but yes
16:12:39 <kozhukalov_> probably we can allow merging into upstream stable branches and then we can downstream fuel projects into fuel-infra.org and there we can have restrictions
16:13:03 <angdraug> ikalnitsky: good point. but openstack has a much shorter gap between branching stable and the release
16:13:07 <kozhukalov_> then only those changes in upstream that are approved by stable team will be downstreamed
16:13:26 <angdraug> also, nova-stable-maint is a half of nova-core, so it's not as much of a bottleneck as fuel-stable-core
16:13:35 <mihgen> kozhukalov_: yes, I agree - it will actually depend on where we want to have maintainance team to do it - upstream or downstream
16:14:01 <mihgen> where they want*
16:14:30 <mihgen> angdraug: I'd suggest to give it another thought and suggest solution in openstack-dev..
16:14:38 <mihgen> and move on now - many items in the agenda..
16:14:51 <angdraug> ok
16:15:09 <kozhukalov_> ok, i think we need to think of this for a while, probably ML is a good place to discuss this
16:15:20 <angdraug> we have until December to think about it
16:15:28 <kozhukalov_> #topic can we do upgrade 7.0 release -> 8.0 master? upgrade tarball status? (mihgen)
16:15:37 <mihgen> #link https://bugs.launchpad.net/fuel/+bug/1506810
16:15:37 <openstack> Launchpad bug 1506810 in Fuel for OpenStack "Cannot find running container with name "fuel-core-8.0-postgres"" [High,Triaged] - Assigned to Fuel Python Team (fuel-python)
16:15:47 <mihgen> this bug blocks quite a several tests
16:16:01 <mihgen> so I wanted to draw an attention that we need to fix this sooner than later
16:16:14 <mihgen> and I have question on how our work is going with getting rid of tarball
16:16:22 <mihgen> which might be unrelated to this bug at all
16:16:46 <kozhukalov_> removal of upgrade tarball is planned for this and next iterations
16:16:59 <ikalnitsky> mihgen: regarding bug you've mentioned - i've triaged it
16:17:14 <mihgen> kozhukalov_: so when to expect that it's gonna go away.. ?
16:17:23 <ikalnitsky> and i want to notice once more - we'll continue catch this sort of bugs until we remove puppet run from inside containers
16:17:32 <mihgen> ikalnitsky: thanks. according to QA, it affects 13 test cases
16:17:41 <kozhukalov_> mihgen, likely beginning of December
16:17:45 <ikalnitsky> we can go on with one more hack
16:18:15 <mihgen> can we have one more hack closing this bug and track work on removing puppet run from containers as a separate thing .. ?
16:18:39 <mihgen> I actually thought that mattymo has been working on it for quite a while
16:19:22 <ikalnitsky> afaik , he didn't work on it
16:19:29 <ikalnitsky> yes, i'll prepare a patch tomorrow
16:19:39 <kozhukalov_> is it possible to get rid of using docker at all? perhaps this q sounds silly, but still. do we still really need docker on the master node?
16:19:44 <mihgen> oh.. ok, thanks ikalnitsky.
16:20:02 <mihgen> kozhukalov_: in my pov - we don't need it there
16:20:03 <kozhukalov_> ok, moving on, ikalnitsky thanks
16:20:20 <mihgen> I'm not sure how easy it would be to get rid of it there though )
16:20:32 <kozhukalov_> #topic code review backlog status: http://bit.ly/1Kp8BzM (mihgen)
16:20:52 <mihgen> so it's mostly specs still. angdraug - we need to act
16:21:25 <aglarendil> library has a WIP commit, btw, so no worries
16:21:55 <mihgen> also, devops, ostf, astute, nailgun-agent, main - so pretty much from each repo by 1-2 patches..
16:21:57 <kozhukalov_> and some fuel-main requests there
16:22:28 <mihgen> can you folks take a look pls. this one sits from 2nd of october: https://review.openstack.org/#/c/229570/
16:22:36 <mihgen> let's find someone to take it
16:22:46 <mihgen> anyone from devops maintainers?
16:23:10 <mihgen> dtyzhnenko
16:23:12 <angdraug> we need to improve fuel-qa attendance of this meeting :(
16:23:34 <mihgen> angdraug: I can follow up with them about it
16:23:46 <mihgen> next is ostf
16:23:59 <dpyzhov> as I see ostf is about tests
16:24:09 <dpyzhov> so it for qa
16:24:25 <mihgen> so no one too.
16:24:37 <mihgen> ok action item on me to follow up with them
16:24:39 <mihgen> #link https://github.com/openstack/fuel-ostf/blob/master/MAINTAINERS
16:24:39 <angdraug> mihgen: please update your dashboard link, it doesn't work in current Firefox
16:25:02 <mihgen> you'd need to help me, it perfectly works on chrome ;)
16:25:09 <kozhukalov_> #action mihgen will poke QA people to review fuel-devops and fuel-ostf
16:25:15 <mihgen> kozhukalov_: thanks. let's move on..
16:25:22 <angdraug> just re-run the script
16:25:33 <kozhukalov_> #topic Multirack status (alex_didenko)
16:25:45 <alex_didenko> We've built custom 8.0-liberty ISO with some multi-rack patches (items 1 and 6 of https://review.openstack.org/230943 spec) and it has passed BVT.
16:25:45 <alex_didenko> We've also tested it on a virtual multi-rack lab (computes in default nodegroup, controllers in nodegroup2, cinder nodes in nodegroup3, floating IP range from nodegroup2), deployment went fine without any hacks, everything was configured via API/CLI. It also has passed OSTF. Manual tests with VMs and floating IPs were fine as well.
16:25:45 <alex_didenko> So at the moment items 3 and 6 from our spec are merged, item 1 is megred partially (astute patch merged, fuel-library and fuel-main in progress) and we're working on other items of the spec.
16:27:04 <mihgen> thanks alex_didenko, what about UI part of this .. ?
16:27:19 <vkramskikh> we started this work today
16:27:29 <vkramskikh> I'll tell you more in my status update
16:27:33 <mihgen> thanks
16:28:25 <kozhukalov_> #topic Bugs status and area tags (dpyzhov) http://lists.openstack.org/pipermail/openstack-dev/2015-October/077736.html
16:28:25 <alex_didenko> that's it from my side
16:28:43 <dpyzhov> I've shared current numbers in e-mail
16:29:01 <dpyzhov> In short - we are walking around same numbers
16:29:26 <mihgen> I saw email. thank you for sharing. what about bugs like net-verify support for multirack?
16:29:27 <dpyzhov> we still getting a lot of reports
16:29:33 <mihgen> are those in your bucket of bugs?
16:29:47 <dpyzhov> Yes, I guess. But I didn't see any
16:30:05 <dpyzhov> alex_didenko: could you get the list of multirack bugs?
16:30:27 <mihgen> dpyzhov: let's take it off this meeting, but I think in general we need feature-based taxonomy
16:30:49 <mihgen> so that we can easily differentiate what happened agaisnt production features released before
16:30:53 <mihgen> vs experimental
16:31:05 <mihgen> vs what are implementing now, like multirack
16:31:22 <dpyzhov> We need to split bugs in several piles somehow
16:31:22 <alex_didenko> dpyzhov I have a huge link with LP filter, I can send it to you
16:31:33 <dpyzhov> And feature-based doesn't look really good for me
16:31:41 <dpyzhov> let's take it offline
16:31:45 <alex_didenko> ok
16:31:51 <mihgen> kk
16:32:00 <kozhukalov_> moving on
16:32:02 <dpyzhov> Also I've shared links
16:32:09 <dpyzhov> for new area tags
16:32:32 <kozhukalov_> #topic UI team status (vkramskikh)
16:32:37 <dpyzhov> And I'd be happy to hear any feedback about new way of assignment bugs
16:32:37 <vkramskikh> Hi, this week we fixed 12 bugs (though we had 10 incoming bugs - most of them are result of fixing High bugs with extracting the remaining part as a Medium bug or a defects which are known but not filed). We will continue to work on bugs this iteration, but we'll be focused on implementing new features.
16:32:37 <vkramskikh> During the current iteration whe plan to implement the following blueprints: https://blueprints.launchpad.net/fuel/+spec/node-groups-network-tab https://blueprints.launchpad.net/fuel/+spec/node-groups-in-sorters-and-filters https://blueprints.launchpad.net/fuel/+spec/segment-settings-tab-logically https://blueprints.launchpad.net/fuel/+spec/support-separate-provisioning-and-deployment-in-ui https://blueprints.launchpad.net/fuel
16:32:38 <vkramskikh> /+spec/support-baremetal-network-in-ui
16:32:39 <vkramskikh> We also would like to deliver https://blueprints.launchpad.net/fuel/+spec/webpack - it is ready to be merged, but we're blocked by build team - they're still unable to provide package with JS library for this request (today is 1 month since initial request)
16:32:43 <vkramskikh> Any questions?
16:33:09 <kozhukalov_> dpyzhov, sorry for interrupting
16:34:01 <mihgen> will those cover multi-rack fully?
16:34:28 <vkramskikh> we'll also have view-all-nodes blueprint which is scheduled for 3rd iteration
16:34:43 <vkramskikh> after implementing it, multirack will be covered fully
16:35:03 <mihgen> any risks associated.. ?
16:35:25 <vkramskikh> don't see any yet, maybe we'll discover something during the implementation
16:35:29 <mihgen> what if it happens that we move network manager to a separate service?
16:35:44 <vkramskikh> I don't think it will affect UI significantly
16:35:51 <mihgen> thanks. anyone from build team to clarify on js lib.. ?
16:36:23 <angdraug> asilenkov: ^
16:36:31 <kozhukalov_> afaik, asilenkov has almost done this
16:36:48 <vkramskikh> well, we need this to be done by this evening or it will be postponed
16:37:06 <vkramskikh> it's to risky to merge it tomorrow - on the next week I'm on vacation
16:38:04 <angdraug> understood. moving on?
16:38:09 <vkramskikh> yes
16:38:32 <kozhukalov_> #topic Upgrade team status (ogelbukh)
16:39:02 <kozhukalov_> ogelbukh, around?
16:39:54 <kozhukalov_> ok, let's move on and then will ask him again
16:40:04 <kozhukalov_> #topic Enhancements Team Status (ashtokolov)
16:40:13 <ashtokolov> hi folks
16:40:22 <ashtokolov> Enhancements weekly status:
16:40:35 <ashtokolov> Inbox - 65(was 66), In progress - 13(was 15), On review - 23(was 19), QA - 18(was 17), Done - 10(was 6)
16:40:43 <ashtokolov> and 11(was 8) to be sorted with Product Management
16:40:52 <ashtokolov> Total: 139 (was 133) and Fix committed+Fix released = 28 (was 23)
16:41:15 <ashtokolov> Also we are close to finish fuel-createmirror refactoring
16:41:33 <ashtokolov> We are going to make a demo next week
16:41:54 <ashtokolov> Any questions?
16:41:56 <kozhukalov_> ashtokolov, about fuel-createmirror not really close, review is at the beginning :-)
16:42:16 <ogelbukh> o/
16:42:37 <kozhukalov_> ok, ashtokolov thanks, moving on?
16:42:51 <kozhukalov_> #topic Upgrade team status (ogelbukh)
16:42:56 <mihgen> thanks ashtokolov
16:43:30 <kozhukalov_> ogelbukh, here?
16:43:45 <ogelbukh> so we have 1 bug fix in verification, otherwise we're good to publish version for upgrade to 7.0
16:44:08 <ogelbukh> another thing we're working on is upgrade to centos7-based Master
16:44:09 <akasatkin> please review a critical: https://review.openstack.org/#/c/238602/
16:44:26 <akasatkin> sorry
16:44:31 <akasatkin> wrong chat
16:44:42 <ogelbukh> akasatkin: np
16:45:08 <kozhukalov_> ok, thanks
16:45:12 <ogelbukh> there are 2 potential paths: using centos-upgrade-tool and migrate nailgun db and settings
16:45:12 <kozhukalov_> moving on
16:45:31 <ogelbukh> we're evaluating and will choose path based on ETA
16:45:40 <ogelbukh> ok, let's move on
16:45:55 <kozhukalov_> #topic openstack/fuel-menu openstack/network-checker openstack/shotgun are now separate projects (kozhukalov)
16:46:20 <kozhukalov_> fyi, those 3 projects are now at their separate repos
16:46:39 <kozhukalov_> all patches need to be backported to these new repos
16:46:55 <kozhukalov_> I will give update in ML
16:47:19 <kozhukalov_> but still I fix some adjacent things
16:47:38 <kozhukalov_> here are my notes on this https://etherpad.openstack.org/p/fuel-move-repos
16:47:48 <mihgen> it's cool to see that all of this happening :)
16:48:11 <kozhukalov_> yes, but it takes a lot of my attention
16:48:11 <angdraug> are ^^^ repos going to have unit tests at the gate?
16:48:25 <kozhukalov_> angdraug, sure
16:48:45 <kozhukalov_> they are green now for two of these repos
16:49:00 <kozhukalov_> need to fix network-checker tests
16:49:01 <angdraug> nice
16:49:08 <kozhukalov_> and yet another thing
16:49:38 <kozhukalov_> I am still waiting for ci team to review my patches to fuel-ci
16:49:47 <angdraug> links?
16:49:50 <angdraug> bookwar1: ^
16:50:03 <kozhukalov_> I asked them several times
16:50:12 <kozhukalov_> https://review.fuel-infra.org/12865
16:50:20 <bookwar1> kozhukalov merged couple of hours ago i think
16:50:21 <kozhukalov_> https://review.fuel-infra.org/12872
16:50:23 <bookwar1> let's check
16:50:34 <kozhukalov_> https://review.fuel-infra.org/12923
16:50:46 <angdraug> all merged
16:51:12 <kozhukalov_> ohh, great, thanks a lot bookwar1
16:51:20 <kozhukalov_> moving on
16:51:44 <kozhukalov_> #topic Integration of Fuel-repos with openstack-ci (ashtokolov) (aka gating)
16:51:52 <ashtokolov> Folks, you know we are working on enabling openstack-gates for Fuel-* repos.
16:52:01 <ashtokolov> Status: 12 fuel-repos are green (was 3) and 3 - wip. And we are close to enable voting mode for pep8 and python27 gates (review openstack-infra)
16:52:21 <ashtokolov> +2 new green from kozhukalov
16:52:24 <ashtokolov> +1 wip
16:52:32 <ashtokolov> #link https://review.openstack.org/#/c/236068/
16:52:39 <ashtokolov> Thank you so much to kozhukalov warpc akislitsky mwhahaha
16:53:07 <angdraug> thanks all for your hard work on this!
16:53:16 <kozhukalov_> thank you so much ashtokolov
16:53:18 <mihgen> this is aweome progress folks.
16:53:28 <angdraug> this is the biggest remaining blocker of our big tent application
16:54:03 <kozhukalov_> moving on?
16:54:15 <angdraug> yes please
16:54:20 <kozhukalov_> #topic Progress on IPv6 in Fuel (veremin)
16:54:23 <yottatsa> I’ve updated spec proposal on IPv6 in Fuel https://review.openstack.org/#/c/216787/ and it’s open for review. I’m in progress to introduce corresponding blueprints.
16:54:33 <yottatsa> #link https://review.openstack.org/#/c/216787/
16:54:38 <yottatsa> OpenStack is almost ready to implement IPv6 on scale, except some UX flaws in Horizon and design issues in Neutron. I’ll do my best to work it out on summit.
16:54:38 <yottatsa> I propose three stages: on stage zero we’re documenting IPv6 provider networks and work out tests integration tests on IPv6.
16:54:38 <yottatsa> On first stage we have to implement IPv6-enabled tenant networks and public interfaces. This mainly requires huge reworking in Nailgun and less patching in fuel-library and OCF. akasatkin has said that changes in Nailgun would take at least 3 weeks.
16:54:38 <yottatsa> Second stage is about support IPv6 networks for every part of reference architecture. It’s mainly requires verify all the components for IPv6-compliance, and sync up with multirack, so it would be nice if xenolog13 will review it too.
16:55:33 <angdraug> teran: please review infra impact section of the spec ^
16:55:36 <yottatsa> I'm still in progress to scope test and patch work in fuel
16:56:35 <kozhukalov_> #action teran will review IPv6 proposal on how it is gonna impact infra https://review.openstack.org/#/c/216787/
16:56:42 <mihgen> yottatsa: thanks! I suggest to patch Fuel to support what is currently supported in openstack
16:57:00 <mihgen> and work with upstream neutron team to make necessary changes in neutron in mitaka
16:57:27 <mihgen> other opinions? aglarendil ?
16:57:43 <yottatsa> I've contacted with scollins from MOS Neutron and work on it on summut
16:58:12 <kozhukalov_> ok, guys, 3 minutes
16:58:34 <angdraug> open discussion?
16:58:43 <kozhukalov_> we still have Config data processing system discussion (ogelbukh) topic in open discussion
16:59:00 <kozhukalov_> but i think we need to move to #fuel-dev
16:59:19 <mihgen> would need to defer to next week perhaps..
16:59:25 <kozhukalov_> thank you for attending
16:59:26 <angdraug> +1 for defer to next week
16:59:28 <kozhukalov_> closing
16:59:38 <kozhukalov_> #endmeeting