16:01:38 <kozhukalov> #startmeeting Fuel
16:01:38 <aglarendil> \o
16:01:39 <openstack> Meeting started Thu Nov  5 16:01:38 2015 UTC and is due to finish in 60 minutes.  The chair is kozhukalov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:43 <openstack> The meeting name has been set to 'fuel'
16:01:43 <kozhukalov> hey guys
16:01:44 <mihgen> hi
16:01:45 <yottatsa> \o
16:01:46 <aglarendil> \o/
16:01:46 <mwhahaha> hola
16:01:47 <dpyzhov> hi
16:01:49 <ogelbukh> hi
16:01:50 <kozhukalov> agenda as usual
16:01:51 <angdraug> o/
16:01:53 <dklenov> hi
16:01:54 <aglarendil> o/
16:01:58 <kozhukalov> #link https://etherpad.openstack.org/p/fuel-weekly-meeting-agenda
16:01:58 <ashtokolov> hi
16:01:58 <aglarendil> \o
16:02:19 <rmoe> hi
16:02:22 <kozhukalov> #topic action items from last meeting
16:02:32 <kozhukalov> xarses will look for additional reviewers to assign to https://review.openstack.org/#/q/status:open+branch:master+topic:bp/dynamic-dnsmasq,n,z work, python reviews are stalled
16:02:46 <kozhukalov> looks like done
16:02:49 <angdraug> xarses is not around (on vacation this and next week)
16:03:03 <kozhukalov> mihgen will poke QA people to review fuel-devops and fuel-ostf (from 2w ago)
16:03:11 <mihgen> yep I did
16:03:15 <mihgen> though I didn't check result
16:03:23 <kozhukalov> teran will review IPv6 proposal on how it is gonna impact infra https://review.openstack.org/#/c/216787/ (from 2w ago)
16:03:26 <mihgen> we'll take a look at stalled reviews this week too
16:03:43 <teran> kozhukalov: If you looked on that review teran was made it 2 weeks ago
16:04:15 <kozhukalov> yes those items from the meeting that was held 2 w ago
16:04:41 <angdraug> teran: infra impact in the spec is still way too thin
16:04:46 <kozhukalov> ok, let's go through our actual agenda
16:04:57 <evgenyl> hi
16:05:00 <yottatsa> I'll update this spec today with new details about vxlan over ipv6
16:05:19 <kozhukalov> #topic Enhancements Team Status (ashtokolov)
16:05:23 <kozhukalov> yottatsa: nice
16:05:26 <ashtokolov> hi
16:05:34 <ashtokolov> Enhancements weekly status: Inbox - 65(was 65), In progress - 12(was 14)
16:05:42 <ashtokolov> On review - 25(was 23), QA - 17(was 16), Done - 16(was 14)
16:05:49 <ashtokolov> and 13(was 14) to be sorted with Product Management
16:06:03 <ashtokolov> So Total: 148 (was 146) and Fix committed+Fix released = 33 (was 30)
16:06:33 <mihgen> can you share major things you are working on?
16:07:12 <ashtokolov> sure
16:07:40 <kozhukalov> mihgen: as far as i know one of the main activities is re-implementing fuel-createmirror in python
16:07:45 <ashtokolov> #link https://bugs.launchpad.net/fuel/+bug/1493520
16:07:45 <openstack> Launchpad bug 1493520 in Fuel for OpenStack "OpenStack is down after filling the root filesystem" [High,Fix committed] - Assigned to Alex Schultz (alex-schultz)
16:08:17 <ashtokolov> this feature request was one of the most interesting
16:08:33 <ashtokolov> we found a set of small bugs in rabbitmq
16:09:09 <ashtokolov> also we are working on OVS support
16:09:12 <mihgen> now it's over?
16:09:29 <mihgen> #link http://bit.ly/1MKIifc
16:09:42 <mihgen> would it be right link to look at all in progress?
16:09:48 <kozhukalov> ashtokolov:  what about shotgun? have you managed to invent the right way how to deploy it and use (taking into account docker related stuff)?
16:10:03 <mihgen> including those which are on review. I filtered using "feature" tag, "in progress" status
16:10:21 <ashtokolov> #link https://trello.com/b/JlWmptJN/enhancements-team
16:10:32 <ashtokolov> please find find our activities here
16:10:53 <ashtokolov> kozhukalov we have 2 ideas:
16:10:57 <kozhukalov> wow, what a nice board
16:11:33 <ashtokolov> shotgun can work with logs on master node like on a remote host
16:11:58 <ashtokolov> but the best one is to use "cp -rs"
16:12:36 <kozhukalov> but cp -rs requires shotgun to be installed and run on the host? right?
16:12:37 <ashtokolov> and we are going to check is it master node to prevent make copy of all log files
16:12:39 <mihgen> thanks for sharing trello
16:13:09 <ashtokolov> we need to use  "cp -rs" anyway
16:13:25 <ashtokolov> because we are going to use templates for diag.snapshot
16:13:57 <ashtokolov> in this case we need a place to store files before zip it
16:14:06 <angdraug> time folks
16:14:21 <kozhukalov> yes,
16:14:25 <kozhukalov> ashtokolov: thanks
16:14:29 <kozhukalov> moving on
16:14:31 <ashtokolov> I can provide additional info next meeting!
16:14:42 <ashtokolov> sorry for slow typing:)
16:14:44 <kozhukalov> #topic Telco Team Status (dklenov)
16:14:46 <angdraug> ashtokolov: ML
16:14:53 <dklenov> hi folks
16:15:02 <ashtokolov> angdraug ok
16:15:10 <dklenov> Fuel Telco team is actively working on Ubuntu bootstrap feature. The following activities are in progress:
16:15:10 <dklenov> 1. Spec was finalized and merged.
16:15:10 <dklenov> 2. Bootstrap creation script enhancements - adding list of installed packages, customization root FS and defining kernel params. Change is on review.
16:15:10 <dklenov> 3. Fuel menu is being changed. Commits are on review.
16:15:25 <mattymo> Thanks for the fuelmenu refactoring patches!
16:15:35 <dklenov> np
16:15:52 <angdraug> speaking of fuelmenu...
16:16:10 <angdraug> https://www.openstack.org/summit/tokyo-2015/videos/presentation/mirantis-openstack-7-0-vs-rhel-osp7
16:16:39 <angdraug> there was some good constructive criticism of it in the linked session in Tokyo
16:16:43 <kozhukalov> angdraug: thanks for the link
16:16:48 <mihgen> dklenov: does ubuntu bootstrap already works? what is the plan for automated testing there?
16:17:29 <angdraug> main problem reported with fuelmenu was that you have to save changes separately on each tab
16:17:30 <dklenov> angdraug: will take a look at this video
16:17:35 <mihgen> fuelmenu was mentioned at some other openstack deployment tools comparison session too..
16:17:37 <angdraug> apparently it keeps tripping people up
16:18:12 <dklenov> we will analyse what is said here, although it might be another feature which is not in scope of ubuntu bootstrap
16:18:35 <mihgen> dklenov: definitely not - please focus on ubuntu bootstrap ))
16:18:39 <angdraug> definitely not in scope of that, just wondering if the refactorings you're doing could make it easier to keep changes state between tabs
16:19:01 <kozhukalov> any other q on this topic?
16:19:12 <angdraug> interface naming?
16:19:28 <dklenov> mihgen: fresh version is partially working and on review. Automated tests are planned for 3rd iteration
16:19:29 <angdraug> what's the state of persistent nic naming?
16:19:59 <dklenov> persistent naming is being implemented by mos-linux team
16:20:14 <dklenov> it is highly desirable, but still not a must for ubuntu bootstrap
16:20:44 <angdraug> do you have an alternative solution to nic reordering on reboot?
16:20:56 <dklenov> no
16:21:03 <kozhukalov> as far as i remember it was quite critical
16:21:14 <angdraug> kozhukalov: yup
16:21:19 <mihgen> dklenov: in terms of UX, can I use centos to start as defaul, but then change my mind and switch to ubuntu when fuel master is already installed ?
16:21:43 <dklenov> we do not think that it is worth to implement partial solutions different from biosdevnames
16:22:11 <dklenov> they are all not easy and will not give all required functionality
16:22:17 <kozhukalov> ok, guys, moving on?
16:22:29 <kozhukalov> still many other topics
16:22:41 <angdraug> biosdevname is exactly what I wasking about
16:22:42 <dklenov> mihgen: no, ubuntu will be default bootstrap
16:23:04 <kozhukalov> maybe we need action to find out what is the status of this persistent naming
16:23:19 <kozhukalov> dklenov: will you figure out this?
16:23:30 <dklenov> sure
16:23:33 <mihgen> dklenov: angdraug: I think we should a way to choose bootstrap image at any time
16:23:40 <dklenov> in general it is what i said above -  is being implemented by mos-linux team
16:23:41 <mihgen> should have a way *
16:23:58 <kozhukalov> #action dklenov will figure out the current status of persistent interface naming (ubuntu bootstrap)
16:24:05 <dklenov> mihgen: true
16:24:17 <kozhukalov> #topic UI team status (vkramskikh)
16:24:17 <dklenov> there will be bootstrap management tool
16:24:17 <angdraug> mihgen: yes, at least at the CLI level
16:24:23 <vkramskikh> Hi, we continue our work on the new features and all of them are in green state, excluding these two which are in yellow state:
16:24:23 <vkramskikh> - https://blueprints.launchpad.net/fuel/+spec/node-groups-network-tab - the change is quite big and it's likely we won't be able to merge it to master with a proper quality, so we'll probably postpone it to the next iteration
16:24:23 <vkramskikh> - https://blueprints.launchpad.net/fuel/+spec/webpack - we're still blocked by the build team
16:24:24 <vkramskikh> And also there is one story code for which is already merged: https://blueprints.launchpad.net/fuel/+spec/node-groups-in-sorters-and-filters
16:24:26 <vkramskikh> Any questions?
16:24:34 <dklenov> you can find it in the spec https://review.openstack.org/#/c/229063/50/specs/8.0/dynamically-build-bootstrap.rst
16:24:56 <angdraug> asilenkov: rvyalov: can you share the status on js dependencies package?
16:26:09 <rvyalov> we prepare design document for this feature. and we have chnge request with new js module
16:26:32 <vkramskikh> when can we expect it to be merged?
16:26:34 <rvyalov> @asilenkov can provide more information about status of package
16:26:41 <angdraug> #link https://review.openstack.org/241202
16:26:50 <angdraug> spec draft ^ is still very much incomplete
16:27:12 <angdraug> vkramskikh: please make sure that the spec contains enough information for you to accept the package
16:27:13 <rvyalov> @vkramskikh as i know during this week
16:27:43 <rvyalov> yes, @vkramskikh please review this design document
16:27:48 <vkramskikh> sure
16:28:14 <angdraug> I don't want us to end up with another temporary solution that we'd have to revisit again in the next release
16:28:14 <kozhukalov> #action vkramskikh will review the spec https://review.openstack.org/241202 to make sure everything is clear and it is enough info
16:28:20 <angdraug> moving on?
16:28:35 <kozhukalov> #topic Upgrade team status (ogelbukh)
16:29:17 <kozhukalov> ogelbukh: around?
16:29:38 <ogelbukh> we're developing single-cluster upgrade by this spec: https://review.openstack.org/#/c/224302/
16:30:14 <ogelbukh> current plan is to finish API part by the end of iteration and continue with specific deployment tasks and partition preservation in iteration 3
16:30:37 <angdraug> 2 specs in 1 commit?
16:31:05 <ogelbukh> angdraug: they are tightly connected to each other
16:31:06 <kozhukalov> yes, a little bit too many
16:31:17 <ogelbukh> but I can split if necessary
16:31:32 <kozhukalov> everyone, please help to review this (including me)
16:31:40 <angdraug> if they strongly depend on each other, should be combined instead
16:31:59 <angdraug> if it's two separate but related pieces of work, should be 2 blueprints, 2 specs, 2 commits
16:32:03 <kozhukalov> 1 spec - 1 epic
16:32:11 <kozhukalov> moving on?
16:32:14 <ogelbukh> okay, understood
16:32:22 <ogelbukh> let's move on
16:32:36 <kozhukalov> #topic fuel-specs reviews https://etherpad.openstack.org/p/fuel-blueprints-8.0 (angdraug)
16:32:45 <angdraug> I went through stuck specs reviews and added reviewers as listed in:
16:32:45 <angdraug> #link https://etherpad.openstack.org/p/fuel-blueprints-8.0
16:32:45 <angdraug> SergK asheplyakov mattymo asilenkov agordeev brain461: please have a look and review the specs you're listed against
16:33:20 <angdraug> vkramskikh's specs all got merged before I got to them, nice work!
16:33:33 <angdraug> questions, moving on?
16:33:53 <kozhukalov> no q
16:34:10 <kozhukalov> #topic UI for templated networking and Ironic https://review.openstack.org/225619 https://review.openstack.org/240184 https://review.openstack.org/229879 (angdraug)
16:34:15 <angdraug> I'd like to see more opinions on what to do with the spec for UI for templated networking:
16:34:16 <angdraug> #link https://review.openstack.org/225619
16:34:16 <angdraug> it was originally created as part of Ironic integration in Fuel 7.0
16:34:16 <angdraug> now there's a separate Ironic UI blueprint:
16:34:16 <angdraug> #link https://review.openstack.org/240184
16:34:16 <angdraug> and a very lively discussion of UI in the early patchsets in the fuel-web commit:
16:34:18 <angdraug> #link https://review.openstack.org/229879
16:34:20 <angdraug> pshchelo is of opinion that the old spec draft can be abandoned
16:34:22 <angdraug> any objections? is it fully superceded by other outstanding specs?
16:35:20 <mihgen> can author abandon it?
16:35:44 <angdraug> mihgen: yes, if we decide that there's no value in keeping it
16:36:38 <angdraug> the question is, is there any value left in that spec?
16:36:49 <angdraug> vkramskikh: ^
16:37:16 <vkramskikh> I don't think so, AFAIC proper UI for templated networking is the advanced networking blueprint
16:37:36 <angdraug> ok, then we can abandon
16:37:41 <angdraug> thanks!
16:38:01 <kozhukalov> moving on then
16:38:16 <kozhukalov> #topic code review backlog status: http://bit.ly/1Kp8BzM. Status of https://bugs.launchpad.net/fuel/+bug/1497655 ? (mihgen)
16:38:17 <openstack> Launchpad bug 1497655 in Fuel for OpenStack "Add reviewers automatically based on MAINTAINERS data" [High,Confirmed] - Assigned to Fuel DevOps (fuel-devops)
16:38:53 <mihgen> I just want to highlight review backlog. Not that scary, though a few have no move for over a couple of weeks
16:39:00 <mihgen> fuel-main, fuel-ostf repos
16:39:22 <mihgen> #link https://review.openstack.org/#/c/232099/
16:39:28 <mihgen> #link https://review.openstack.org/#/c/233431/
16:39:35 <mihgen> #link https://review.openstack.org/#/c/191759/
16:39:37 <mihgen> in particular
16:40:06 <kozhukalov> mihgen: thanks for bringing this up, I'll review all fuel-main
16:40:08 <angdraug> monester_laptor: can you comment on https://bugs.launchpad.net/fuel/+bug/1497655 ?
16:40:08 <openstack> Launchpad bug 1497655 in Fuel for OpenStack "Add reviewers automatically based on MAINTAINERS data" [High,Confirmed] - Assigned to Fuel DevOps (fuel-devops)
16:40:13 <mihgen> can we give action items perhaps?
16:40:34 <mihgen> nurla: can you please take a fuel-ostf one.. ?
16:40:42 <mihgen> I don't see tatyana here
16:40:42 <kozhukalov> #action kozhukalov will review all requests in fuel-main
16:41:17 <monester_laptor> angdraug: I was working on script before vacation
16:41:18 <mihgen> ashtokolov: https://review.openstack.org/#/c/236350/ - this is about fuel-mirror, I suppose your team?
16:41:20 <kozhukalov> #action nurla will poke tatyana or someone else to review all requests in fuel-ostf
16:41:31 <mihgen> monester_laptor: any ETA?
16:41:41 <monester_laptor> next week
16:41:43 <mihgen> on script? We really need it...
16:42:02 <mihgen> ok thanks - let's check status at next IRC meeting then
16:42:13 <angdraug> kozhukalov: action for monester_laptor please
16:42:20 <monester_laptor> mihgen ok
16:43:19 <kozhukalov> #action monester_laptor will make sure that people from MAINTAINERS are added as reviewers automatically
16:43:31 <kozhukalov> is it correct
16:43:36 <kozhukalov> ?
16:43:56 <mihgen> yep
16:43:59 <kozhukalov> moving on?
16:44:09 <mihgen> I added as a first topic for next week
16:44:23 <kozhukalov> #topic Multirack status (alex_didenko)
16:44:36 <alex_didenko> All the comments in our spec review https://review.openstack.org/230943 have been addressed, so it's ready for reviews and merge.
16:44:36 <alex_didenko> We've merged almost all patches required for automatic DHCP/PXE re-configuration on admin network changes. Only 2 patches for nailgun left.
16:44:36 <alex_didenko> https://blueprints.launchpad.net/fuel/+spec/allow-any-vip is going to take more time than we assumed initially. During this feature implementation it was decided to introduce new API handler for VIPs which would require some additional work/time. Please see this ML thread for details http://lists.openstack.org/pipermail/openstack-dev/2015-November/078165.html
16:44:36 <alex_didenko> Our QA engineers are working on tests, some pacthes are on review already. They have also created QA related BPs and linked them to https://blueprints.launchpad.net/fuel/+spec/l3-multiple-racks, you can see those BPs in section "Testing, QA" of our spec.
16:45:26 <alex_didenko> done :)
16:46:51 <mihgen> thanks
16:47:06 <kozhukalov> alex_didenko: nice, thanks
16:47:19 <kozhukalov> open discussion?
16:47:36 <mihgen> for update. I have a q about allow-any-vip, but I'll read email first
16:48:15 <kozhukalov> #topic open discussion
16:48:18 <mihgen> if we started open discussion, I have a question to mwhahaha about fuel deploying community packages
16:48:51 <mwhahaha> What's up?
16:48:54 <mihgen> what are we currently with this, do you have list of to-do items to make it happen?
16:49:07 <mihgen> what needs to be done / how?
16:49:22 <mwhahaha> At the moment I'm currently trying to get fuel-library working with the upstream manifests to make sure we can actually deploy using those
16:49:41 <mwhahaha> at the moment it's deploying the fuel master but we have a few issues with some of the OSTF tests
16:50:10 <mwhahaha> once we can leverage the upstream modules and pass OSTF, i plan on trying to switch out to use the community packages to see what needs to be modified to support that
16:50:27 <mwhahaha> along the same lines zigo has started the work with the upstream to be able to leverage debian packages on top of ubuntu
16:50:37 <mihgen> excellent
16:50:43 <mattymo> I have a topic after mwhahaha is ready
16:50:48 <mwhahaha> specifically, https://review.openstack.org/#/c/241615/
16:51:02 <mwhahaha> (that's all i've got at the moment)
16:51:03 <mihgen> mwhahaha: any eta on this work, even roughly.. ?
16:51:19 <mwhahaha> hopefully i can get something together next week
16:51:44 <mwhahaha> it all depends on what landmines i run into when i swap packages
16:52:16 <mihgen> would be awesome to have this done in a nearest future, thanks
16:52:25 <mwhahaha> my current work for the upstream modules themselves is https://review.openstack.org/#/c/240325/
16:53:29 <mihgen> mattymo had topic.. ?
16:53:31 <mattymo> I want to see what the general feeling is on scale-down with regards to purging non-critical entries. That is entries in /etc/hosts, in nova-manage service list, as a start. We don't have any metadata in /etc/astute.yaml on nodes about nodes that are deleted, and I think we should avoid purging _every_ entry not in nodes hash indiscriminately (potential conflict with plugins)
16:54:15 <mattymo> so should we include a hash in astute.yaml for node info for deleted nodes? what's the best approach?
16:54:49 <angdraug> I think we should follow the general openstack policy of not purging data on deleted entities
16:55:11 <mattymo> I don't think that's a real policy, but more of a side effect
16:55:20 <mattymo> angdraug, can you quote anything about this alleged policy?
16:57:26 <kozhukalov> probably we continue this discussion about alleged policy somewhere else
16:57:31 <kozhukalov> 3 minutes
16:57:37 <kozhukalov> any other q?
16:57:42 <angdraug> mattymo: I've seen it many times on ML, not sure if it's formalized, I'll look it up
16:57:55 <kozhukalov> angdraug: could you please share the status of https://review.openstack.org/#/c/199232/? are there any news?
16:58:18 <angdraug> it's on agenda for TC meeting next Tuesday
16:58:36 <angdraug> this week, TC meeting didn't have quorum so it was postponed
16:58:48 <kozhukalov> this week i only saw couple of line in irc meeting log
16:59:00 <kozhukalov> ok, thanks
16:59:10 <kozhukalov> waiting for good news )
16:59:13 <kozhukalov> time
16:59:28 <kozhukalov> closing meeting, thanks everyone for attending
16:59:34 <kozhukalov> #endmeeting